{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,3]],"date-time":"2026-10-03T11:51:23Z","timestamp":1791028283640,"version":"4.1.0"},"publisher-location":"Berlin, Heidelberg","reference-count":10,"publisher":"Springer Berlin Heidelberg","isbn-type":[{"value":"9783540441793","type":"print"},{"value":"9783540457480","type":"electronic"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2002]]},"DOI":"10.1007\/3-540-45748-8_15","type":"book-chapter","created":{"date-parts":[[2007,10,9]],"date-time":"2007-10-09T08:29:16Z","timestamp":1191918556000},"page":"155-165","source":"Crossref","is-referenced-by-count":81,"title":["Serving DNS Using a Peer-to-Peer Lookup Service"],"prefix":"10.1007","author":[{"given":"Russ","family":"Cox","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Athicha","family":"Muthitacharoen","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Robert T.","family":"Morris","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"297","published-online":{"date-parts":[[2002,10,10]]},"reference":[{"key":"15_CR1","unstructured":"Paul Albitz and Cricket Liu. DNS and BIND. O\u2019Reilly & Associates, 1998."},{"key":"15_CR2","doi-asserted-by":"crossref","unstructured":"T. Brisco. DNS support for load balancing. RFC 1794, April 1995.","DOI":"10.17487\/rfc1794"},{"key":"15_CR3","doi-asserted-by":"crossref","unstructured":"Frank Dabek, M. Frans Kaashoek, David Karger, Robert Morris, and Ion Stoica. Wide-area cooperative storage with CFS. In Proceedings of the 18th ACM Symposium on Operating Systems Principles (SOSP\u2019 01), Chateau Lake Louise, Banff, Canada, October 2001.","DOI":"10.1145\/502034.502054"},{"key":"15_CR4","doi-asserted-by":"crossref","unstructured":"P. Danzig, K. Obraczka, and A. Kumar. An analysis of wide-area name server traffic: A study of the internet domain name system. In Proc ACM SIGCOMM, pages 281\u2013292, Baltimore, MD, August 1992.","DOI":"10.1145\/144179.144301"},{"key":"15_CR5","doi-asserted-by":"crossref","unstructured":"D. Eastlake. Domain name system security extensions. RFC 2535, March 1999.","DOI":"10.17487\/rfc2535"},{"key":"15_CR6","doi-asserted-by":"crossref","unstructured":"Jaeyeon Jung, Emil Sit, Hari Balakrishnan, and Robert Morris. Dns performance and the effectiveness of caching. In Proceedings of the ACM SIGCOMM Internet Measurement Workshop\u2019 01, San Francisco, California, November 2001.","DOI":"10.1145\/505202.505223"},{"key":"15_CR7","unstructured":"R. Mahajan. How Akamai works. http:\/\/www.cs.washington.edu\/homes\/ratul\/akamai.html ."},{"key":"15_CR8","doi-asserted-by":"crossref","unstructured":"P. Mockapetris. Domain names \u2014 concepts and facilities. RFC 1034, November 1987.","DOI":"10.17487\/rfc1034"},{"key":"15_CR9","doi-asserted-by":"crossref","unstructured":"P. Mockapetris and K. Dunlap. Development of the Domain Name System. In Proc. ACM SIGCOMM, Stanford, CA, 1988.","DOI":"10.1145\/52324.52338"},{"key":"15_CR10","doi-asserted-by":"crossref","unstructured":"Ion Stoica, Robert Morris, David Karger, M. Frans Kaashoek, and Hari Balakrishnan. Chord: A scalable peer-to-peer lookup service for internet applications. In Proc. ACM SIGCOMM, San Diego, 2001.","DOI":"10.1145\/383059.383071"}],"container-title":["Lecture Notes in Computer Science","Peer-to-Peer Systems"],"original-title":[],"link":[{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/3-540-45748-8_15","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2019,5,3]],"date-time":"2019-05-03T12:49:58Z","timestamp":1556887798000},"score":1,"resource":{"primary":{"URL":"http:\/\/link.springer.com\/10.1007\/3-540-45748-8_15"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2002]]},"ISBN":["9783540441793","9783540457480"],"references-count":10,"URL":"https:\/\/doi.org\/10.1007\/3-540-45748-8_15","relation":{},"ISSN":["0302-9743"],"issn-type":[{"value":"0302-9743","type":"print"}],"subject":[],"published":{"date-parts":[[2002]]}}}