{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,10,13]],"date-time":"2025-10-13T08:59:55Z","timestamp":1760345995145,"version":"3.33.0"},"publisher-location":"Berlin, Heidelberg","reference-count":10,"publisher":"Springer Berlin Heidelberg","isbn-type":[{"type":"print","value":"9783540441793"},{"type":"electronic","value":"9783540457480"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2002]]},"DOI":"10.1007\/3-540-45748-8_20","type":"book-chapter","created":{"date-parts":[[2007,10,9]],"date-time":"2007-10-09T12:29:16Z","timestamp":1191932956000},"page":"214-224","source":"Crossref","is-referenced-by-count":7,"title":["Exploring the Design Space of Distributed and Peer-to-Peer Systems: Comparing the Web, TRIAD, and Chord\/CFS"],"prefix":"10.1007","author":[{"given":"Stefan","family":"Saroiu","sequence":"first","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"P. Krishna","family":"Gummadi","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Steven D.","family":"Gribble","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"297","published-online":{"date-parts":[[2002,10,10]]},"reference":[{"key":"20_CR1","doi-asserted-by":"crossref","unstructured":"Tim Berners-Lee, Larry Masinter, and Mark McCahill. RFC 1738-Uniform Resource Locators (URL), December 1994.","DOI":"10.17487\/rfc1738"},{"key":"20_CR2","doi-asserted-by":"crossref","unstructured":"Frank Dabek, M. Frans Kaashoek, David Karger, Robert Morris, and Ion Stoica. Wide-area cooperative storage with CFS. In Proceedings of the 18th ACM Symposium on Operating Systems Principles (SOSP 2001), Lake Louise, AB, Canada, October 2001.","DOI":"10.1145\/502034.502054"},{"key":"20_CR3","unstructured":"Peter Druschel and Antony Rowstron. Storage management and caching in PAST, a large-scale, persistent peer-to-peer storage utility. In Proceedings of the 18th ACM Symposium on Operating Systems Principles (SOSP 2001), Lake Louise, AB, Canada, October 2001."},{"key":"20_CR4","doi-asserted-by":"crossref","unstructured":"Roy Fielding. RFC 1808-R elative Uniform Resource Locators, June 1995.","DOI":"10.17487\/rfc1808"},{"key":"20_CR5","unstructured":"Mark Gritter and David R. Cheriton. An Architecture for Content Routing Support in the Internet. In Proceedings of the 3rd Usenix Symposium on Internet Technologies and Systems (USITS), San Francisco, CA, USA, March 2001."},{"key":"20_CR6","doi-asserted-by":"crossref","unstructured":"Sylvia Ratnasamy, Paul Francis, Mark Handley, Richard Karp, and Scott Shenker. A Scalable Content-Addressable Network. In Proceedings of the ACM SIGCOMM 2001 Technical Conference, San Diego, CA, USA, August 2001.","DOI":"10.1145\/383059.383072"},{"key":"20_CR7","doi-asserted-by":"crossref","unstructured":"Jerome Saltzer. RFC 1498-On the Naming and Binding of Network Destinations, August 1993.","DOI":"10.17487\/rfc1498"},{"key":"20_CR8","doi-asserted-by":"crossref","unstructured":"Stefan Saroiu, P. Krishna Gummadi, and Steven D. Gribble. A Measurement Study of Peer-to-Peer File Sharing Systems. In Proceedings of the Multimedia Computing and Networking Conference (MMCN), San Jose, CA, USA, January 2002.","DOI":"10.1117\/12.449977"},{"key":"20_CR9","unstructured":"John F. Shoch. Inter-Network Naming, Addressing, and Routing. In Proceedings of IEEE COMPCON, pages 72\u201379, Washington, DC, USA, December 1978. Also in K. Thurber (ed.), Tutorial: Distributed Processor Communication Architecture, IEEE Publ. #EHO 152-9, 1979, pp. 280\u2013287."},{"key":"20_CR10","unstructured":"Ben Y. Zhao, John Kubiatowicz, and Anthony D. Joseph. Tapestry: An Infrastructure for Fault-Resilient Wide-Area Location and Routing. Technical Report UCB\/\/CSD-01-1141, University of California at Berkeley Technical Report, April 2001."}],"container-title":["Lecture Notes in Computer Science","Peer-to-Peer Systems"],"original-title":[],"link":[{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/3-540-45748-8_20","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,1,21]],"date-time":"2025-01-21T13:41:51Z","timestamp":1737466911000},"score":1,"resource":{"primary":{"URL":"http:\/\/link.springer.com\/10.1007\/3-540-45748-8_20"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2002]]},"ISBN":["9783540441793","9783540457480"],"references-count":10,"URL":"https:\/\/doi.org\/10.1007\/3-540-45748-8_20","relation":{},"ISSN":["0302-9743"],"issn-type":[{"type":"print","value":"0302-9743"}],"subject":[],"published":{"date-parts":[[2002]]}}}