{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,12,13]],"date-time":"2025-12-13T09:55:16Z","timestamp":1765619716546,"version":"3.40.4"},"publisher-location":"Cham","reference-count":30,"publisher":"Springer Nature Switzerland","isbn-type":[{"value":"9783031893490","type":"print"},{"value":"9783031893506","type":"electronic"}],"license":[{"start":{"date-parts":[[2025,1,1]],"date-time":"2025-01-01T00:00:00Z","timestamp":1735689600000},"content-version":"tdm","delay-in-days":0,"URL":"https:\/\/www.springernature.com\/gp\/researchers\/text-and-data-mining"},{"start":{"date-parts":[[2025,1,1]],"date-time":"2025-01-01T00:00:00Z","timestamp":1735689600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.springernature.com\/gp\/researchers\/text-and-data-mining"}],"content-domain":{"domain":["link.springer.com"],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2025]]},"DOI":"10.1007\/978-3-031-89350-6_22","type":"book-chapter","created":{"date-parts":[[2025,4,25]],"date-time":"2025-04-25T12:09:16Z","timestamp":1745582956000},"page":"365-381","update-policy":"https:\/\/doi.org\/10.1007\/springer_crossmark_policy","source":"Crossref","is-referenced-by-count":1,"title":["Preventing WebRTC IP Address Leaks"],"prefix":"10.1007","author":[{"ORCID":"https:\/\/orcid.org\/0000-0002-3277-8533","authenticated-orcid":false,"given":"Guillaume","family":"Nibert","sequence":"first","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-0948-7172","authenticated-orcid":false,"given":"S\u00e9bastien","family":"Tixeuil","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Baptiste","family":"Polv\u00e9","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Nana J. Bakalafoua","family":"M\u2019boussi","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Xuan Son","family":"Nguyen","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"297","published-online":{"date-parts":[[2025,4,16]]},"reference":[{"issue":"13s","key":"22_CR1","doi-asserted-by":"publisher","first-page":"1","DOI":"10.1145\/3579162","volume":"55","author":"H Abbas","year":"2023","unstructured":"Abbas, H., et al.: Security assessment and evaluation of VPNs: a comprehensive survey. ACM Comput. Surv. 55(13s), 1\u201347 (2023). https:\/\/doi.org\/10.1145\/3579162","journal-title":"ACM Comput. Surv."},{"key":"22_CR2","doi-asserted-by":"publisher","unstructured":"Al-Fannah, N.M.: One leak will sink a ship: WebRTC IP address leaks. In: 2017 International Carnahan Conference on Security Technology (ICCST), pp.\u00a01\u20135. IEEE, Madrid, Spain (2017). https:\/\/doi.org\/10.1109\/CCST.2017.8167801","DOI":"10.1109\/CCST.2017.8167801"},{"key":"22_CR3","unstructured":"banbot: How to disable digital signature verification in Firefox add-ons (in Russian). https:\/\/forum.mozilla-russia.org\/viewtopic.php?id=70326 (2016). Accessed 12 July 2024"},{"key":"22_CR4","doi-asserted-by":"publisher","unstructured":"Englehardt, S., Narayanan, A.: Online tracking: A 1-million-site measurement and analysis. In: Proceedings of the 2016 ACM SIGSAC Conference on Computer and Communications Security, pp. 1388\u20131401. Association for Computing Machinery, Vienna, Austria (2016). https:\/\/doi.org\/10.1145\/2976749.2978313","DOI":"10.1145\/2976749.2978313"},{"key":"22_CR5","unstructured":"Fablet, Y., Uberti, J., Borst, J.D., Wang, Q.: Using multicast DNS to protect privacy when exposing ICE candidates. Internet Draft draft-ietf-mmusic-mdns-ice-candidates-03, Internet Engineering Task Force (2021). https:\/\/datatracker.ietf.org\/doc\/draft-ietf-mmusic-mdns-ice-candidates\/03\/. Accessed 12 July 2024"},{"issue":"5","key":"22_CR6","doi-asserted-by":"publisher","first-page":"92","DOI":"10.3390\/fi12050092","volume":"12","author":"A Fakis","year":"2020","unstructured":"Fakis, A., Karopoulos, G., Kambourakis, G.: Neither denied nor exposed: fixing WebRTC privacy leaks. Fut. Internet 12(5), 92 (2020). https:\/\/doi.org\/10.3390\/fi12050092","journal-title":"Fut. Internet"},{"key":"22_CR7","doi-asserted-by":"publisher","unstructured":"Felter, W., Ferreira, A., Rajamony, R., Rubio, J.: An updated performance comparison of virtual machines and Linux containers. In: 2015 IEEE International Symposium on Performance Analysis of Systems and Software (ISPASS), pp. 171\u2013172 (2015). https:\/\/doi.org\/10.1109\/ISPASS.2015.7095802","DOI":"10.1109\/ISPASS.2015.7095802"},{"key":"22_CR8","doi-asserted-by":"publisher","unstructured":"Gont, F.: A method for generating semantically opaque interface identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC). Request for Comments RFC 7217, Internet Engineering Task Force (2014). https:\/\/doi.org\/10.17487\/RFC7217","DOI":"10.17487\/RFC7217"},{"key":"22_CR9","unstructured":"Haberman, B., Hinden, B.: Unique Local IPv6 Unicast Addresses. Request for Comments RFC 4193, Internet Engineering Task Force (2005)"},{"key":"22_CR10","doi-asserted-by":"publisher","unstructured":"Hazhirpasand, M., Ghafari, M.: One leak is enough to expose them all. In: Payer, M., Rashid, A., Such, J.M. (eds.) Engineering Secure Software and Systems, pp. 61\u201376. Lecture Notes in Computer Science, Springer International Publishing, Cham (2018). https:\/\/doi.org\/10.1007\/978-3-319-94496-8_5","DOI":"10.1007\/978-3-319-94496-8_5"},{"key":"22_CR11","doi-asserted-by":"publisher","unstructured":"Hosoi, R., Saito, T., Ishikawa, T., Miyata, D., Chen, Y.: A browser scanner: collecting intranet information. In: 2016 19th International Conference on Network-Based Information Systems (NBiS), pp. 140\u2013145. IEEE, Ostrava, Czech Republic (2016). https:\/\/doi.org\/10.1109\/NBiS.2016.10","DOI":"10.1109\/NBiS.2016.10"},{"key":"22_CR12","unstructured":"Jakobsson, C.: Peer-to-peer communication in web browsers using WebRTC A detailed overview of WebRTC and what security and network concerns exists. Bachelor\u2019s thesis, Ume \u0227 University (2015). http:\/\/urn.kb.se\/resolve?urn=urn:nbn:se:umu:diva-108372. Accessed 12 July 2024"},{"key":"22_CR13","doi-asserted-by":"publisher","unstructured":"Ker\u00e4nen, A., Holmberg, C., Rosenberg, J.: Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal. Request for Comments RFC 8445, Internet Engineering Task Force (2018). https:\/\/doi.org\/10.17487\/RFC8445","DOI":"10.17487\/RFC8445"},{"key":"22_CR14","doi-asserted-by":"publisher","unstructured":"Khan, M.T., DeBlasio, J., Voelker, G.M., Snoeren, A.C., Kanich, C., Vallina-Rodriguez, N.: An empirical analysis of the commercial VPN ecosystem. In: Proceedings of the Internet Measurement Conference 2018, IMC \u201918, pp. 443\u2013456. Association for Computing Machinery, New York, NY, USA (2018). https:\/\/doi.org\/10.1145\/3278532.3278570","DOI":"10.1145\/3278532.3278570"},{"issue":"2","key":"22_CR15","doi-asserted-by":"publisher","first-page":"1","DOI":"10.1145\/3386040","volume":"14","author":"P Laperdrix","year":"2020","unstructured":"Laperdrix, P., Bielova, N., Baudry, B., Avoine, G.: Browser fingerprinting: a survey. ACM Trans. Web 14(2), 1\u201333 (2020). https:\/\/doi.org\/10.1145\/3386040","journal-title":"ACM Trans. Web"},{"key":"22_CR16","doi-asserted-by":"publisher","unstructured":"Liu, X., Liu, Q., Wang, X., Jia, Z.: Fingerprinting web browser for tracing anonymous web attackers. In: 2016 IEEE First International Conference on Data Science in Cyberspace (DSC), pp. 222\u2013229. IEEE, Changsha, China (2016). https:\/\/doi.org\/10.1109\/DSC.2016.78","DOI":"10.1109\/DSC.2016.78"},{"key":"22_CR17","unstructured":"Mozilla: addrs.c (2024). https:\/\/hg.mozilla.org\/releases\/mozilla-release\/file\/FIREFOX_125_0_3_RELEASE\/dom\/media\/webrtc\/transport\/third_party\/nICEr\/src\/stun\/addrs.c#l66. Accessed 12 July 2024"},{"key":"22_CR18","unstructured":"Mozilla Wiki: Media\/WebRTC\/Privacy. https:\/\/wiki.mozilla.org\/Media\/WebRTC\/Privacy (2020). Accessed 12 July 2024"},{"key":"22_CR19","doi-asserted-by":"publisher","unstructured":"Narten, T., Jinmei, T., Thomson, S.: IPv6 Stateless Address Autoconfiguration. Request for Comments RFC 4862, Internet Engineering Task Force (2007). https:\/\/doi.org\/10.17487\/RFC4862","DOI":"10.17487\/RFC4862"},{"issue":"1","key":"22_CR20","doi-asserted-by":"publisher","first-page":"77","DOI":"10.1515\/popets-2015-0006","volume":"2015","author":"VC Perta","year":"2015","unstructured":"Perta, V.C., Barbera, M., Tyson, G., Haddadi, H., Mei, A.: A glance through the VPN looking glass: IPv6 leakage and DNS hijacking in commercial VPN clients. PoPETs 2015(1), 77\u201391 (2015). https:\/\/doi.org\/10.1515\/popets-2015-0006","journal-title":"PoPETs"},{"key":"22_CR21","doi-asserted-by":"publisher","unstructured":"Ramesh, R., Evdokimov, L., Xue, D., Ensafi, R.: VPNalyzer: systematic investigation of the VPN ecosystem. In: Proceedings 2022 Network and Distributed System Security Symposium. Internet Society, San Diego, CA, USA (2022). https:\/\/doi.org\/10.14722\/ndss.2022.24285","DOI":"10.14722\/ndss.2022.24285"},{"key":"22_CR22","doi-asserted-by":"publisher","unstructured":"Reiter, A., Marsalek, A.: WebRTC: your privacy is at risk. In: Proceedings of the Symposium on Applied Computing, SAC \u201917, pp. 664\u2013669. Association for Computing Machinery, New York, NY, USA (2017). https:\/\/doi.org\/10.1145\/3019612.3019844","DOI":"10.1145\/3019612.3019844"},{"key":"22_CR23","doi-asserted-by":"publisher","unstructured":"Revyakina, E.: Development of a secure video chat based on the WebRTC standard for video conferencing. In: E3S Web of Conferences, vol. 389, p. 07017 (2023). https:\/\/doi.org\/10.1051\/e3sconf\/202338907017","DOI":"10.1051\/e3sconf\/202338907017"},{"key":"22_CR24","unstructured":"richard: Enable webrtc for base-browser (#41021) $$\\cdot $$ Issues $$\\cdot $$ The Tor Project \/ Applications \/ Tor Browser $$\\cdot $$ GitLab (2022). https:\/\/gitlab.torproject.org\/tpo\/applications\/tor-browser\/-\/issues\/41021. Accessed 12 July 2024"},{"key":"22_CR25","unstructured":"Roesler, D.: STUN IP Address requests for WebRTC (2015). https:\/\/github.com\/diafygi\/webrtc-ips. Accessed 12 July 2024"},{"key":"22_CR26","unstructured":"StatCounter: Desktop browser Market Share Worldwide. https:\/\/gs.statcounter.com\/browser-market-share\/desktop\/worldwide (2024). Accessed 12 July 2024"},{"key":"22_CR27","doi-asserted-by":"publisher","unstructured":"Takasu, K., Saito, T., Yamada, T., Ishikawa, T.: A survey of hardware features in modern browsers: 2015 edition. In: 2015 9th International Conference on Innovative Mobile and Internet Services in Ubiquitous Computing, pp. 520\u2013524. IEEE, Santa Catarina, Brazil (2015). https:\/\/doi.org\/10.1109\/IMIS.2015.72","DOI":"10.1109\/IMIS.2015.72"},{"key":"22_CR28","unstructured":"The Chromium Project: network.cc (2024). https:\/\/webrtc.googlesource.com\/src.git\/+\/refs\/branch-heads\/6478\/rtc_base\/network.cc#620. Accessed 12 July 2024"},{"key":"22_CR29","doi-asserted-by":"publisher","unstructured":"Uberti, J.: WebRTC IP Address Handling Requirements. Request for Comments RFC 8828, Internet Engineering Task Force (2021). https:\/\/doi.org\/10.17487\/RFC8828","DOI":"10.17487\/RFC8828"},{"key":"22_CR30","unstructured":"Uberti, J., Borst, J.D., Wang, Q., Fablet, Y.: WebRTC IP Address Handling Extensions for Multicast DNS. Internet Draft draft-uberti-ip-handling-ex-mdns-00, Internet Engineering Task Force (2018). https:\/\/datatracker.ietf.org\/doc\/draft-uberti-ip-handling-ex-mdns\/00\/. Accessed 12 July 2024"}],"container-title":["Lecture Notes in Computer Science","Risks and Security of Internet and Systems"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/link.springer.com\/content\/pdf\/10.1007\/978-3-031-89350-6_22","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,4,25]],"date-time":"2025-04-25T12:09:30Z","timestamp":1745582970000},"score":1,"resource":{"primary":{"URL":"https:\/\/link.springer.com\/10.1007\/978-3-031-89350-6_22"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2025]]},"ISBN":["9783031893490","9783031893506"],"references-count":30,"URL":"https:\/\/doi.org\/10.1007\/978-3-031-89350-6_22","relation":{},"ISSN":["0302-9743","1611-3349"],"issn-type":[{"value":"0302-9743","type":"print"},{"value":"1611-3349","type":"electronic"}],"subject":[],"published":{"date-parts":[[2025]]},"assertion":[{"value":"16 April 2025","order":1,"name":"first_online","label":"First Online","group":{"name":"ChapterHistory","label":"Chapter History"}},{"value":"The authors declare no conflicts of interest.","order":1,"name":"Ethics","group":{"name":"EthicsHeading","label":"Disclosure of Interests"}},{"value":"CRiSIS","order":1,"name":"conference_acronym","label":"Conference Acronym","group":{"name":"ConferenceInfo","label":"Conference Information"}},{"value":"International Conference on Risks and Security of Internet and Systems","order":2,"name":"conference_name","label":"Conference Name","group":{"name":"ConferenceInfo","label":"Conference Information"}},{"value":"Aix-en-Provence","order":3,"name":"conference_city","label":"Conference City","group":{"name":"ConferenceInfo","label":"Conference Information"}},{"value":"France","order":4,"name":"conference_country","label":"Conference Country","group":{"name":"ConferenceInfo","label":"Conference Information"}},{"value":"2024","order":5,"name":"conference_year","label":"Conference Year","group":{"name":"ConferenceInfo","label":"Conference Information"}},{"value":"26 November 2024","order":7,"name":"conference_start_date","label":"Conference Start Date","group":{"name":"ConferenceInfo","label":"Conference Information"}},{"value":"28 November 2024","order":8,"name":"conference_end_date","label":"Conference End Date","group":{"name":"ConferenceInfo","label":"Conference Information"}},{"value":"crisis2024","order":10,"name":"conference_id","label":"Conference ID","group":{"name":"ConferenceInfo","label":"Conference Information"}}]}}