{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,11,11]],"date-time":"2026-11-11T07:59:33Z","timestamp":1794383973031,"version":"4.9.0"},"publisher-location":"Berlin, Heidelberg","reference-count":19,"publisher":"Springer Berlin Heidelberg","isbn-type":[{"value":"9783540662389","type":"print"},{"value":"9783540485070","type":"electronic"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[1999]]},"DOI":"10.1007\/978-3-540-48507-0_1","type":"book-chapter","created":{"date-parts":[[2011,1,7]],"date-time":"2011-01-07T23:26:27Z","timestamp":1294442787000},"page":"1-12","source":"Crossref","is-referenced-by-count":1,"title":["The Architecture of ALIEN"],"prefix":"10.1007","author":[{"given":"D. Scott","family":"Alexander","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Jonathan M.","family":"Smith","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"297","reference":[{"key":"1_CR1","doi-asserted-by":"crossref","unstructured":"Tennenhouse, D.L., Smith, J.M., Sincoskie, W.D., Wetherall, D.J., Minden, G.J.: A survey of active network research. IEEE Communications Magazine (January 1997)","DOI":"10.1109\/35.568214"},{"key":"1_CR2","unstructured":"Scott Alexander, D.: ALIEN: A Generalized Computing Model of Active Networks. PhD thesis, University of Pennsylvania, Philadelphia (December 1998)"},{"key":"1_CR3","unstructured":"Knabe, F.C.: Language Support for Mobile Agents. PhD thesis, CMU (December 1995)"},{"key":"1_CR4","unstructured":"Leroy, X.: The Caml Special Light System (Release 1.10). INRIA, France (November 1995)"},{"key":"1_CR5","unstructured":"Milner, R., Tofte, M., Harper, R.: The Definition of Standard ML. MIT Press, Cambridge"},{"key":"1_CR6","doi-asserted-by":"crossref","unstructured":"Sites, R.L., Witek, R.T.: Alpha AXP Architecture Reference Manual, 2nd edn. Digital Press (1995)","DOI":"10.1016\/B978-1-4831-8403-6.50018-5"},{"key":"1_CR7","volume-title":"Pentium Processor System Architecture","author":"D. Anderson","year":"1995","unstructured":"Anderson, D., Shanley, T.: Pentium Processor System Architecture, 2nd edn. Addison Wesley, Reading (1995)","edition":"2"},{"key":"1_CR8","doi-asserted-by":"crossref","unstructured":"Rivest, R.: The MD5 message-digest algorithm. RFC 1321 (April 1992)","DOI":"10.17487\/rfc1321"},{"key":"1_CR9","first-page":"436","volume-title":"Applied Cryptography","author":"B. Schneier","year":"1996","unstructured":"Schneier, B.: Applied Cryptography, 2nd edn., pp. 436\u2013441. Wiley, Chichester (1996)","edition":"2"},{"key":"1_CR10","doi-asserted-by":"crossref","unstructured":"Rouaix, F.: A web navigator with applets in Caml. In: Fifth WWW Conf. (May 1996)","DOI":"10.1016\/0169-7552(96)00032-3"},{"key":"1_CR11","unstructured":"Arnold, K., Gosling, J.: The Java Programming Language. Sun Microsystems. Java Series (1996) ISBN 0-201-63455-4"},{"key":"1_CR12","doi-asserted-by":"crossref","unstructured":"Hicks, M., Kakkar, P., Moore, J.T., Gunter, C.A., Nettles, S.: PLAN: A packet language for active networks. In: Proceedings of the International Conference on Function Programming, ICFP (September 1998)","DOI":"10.1145\/289423.289431"},{"key":"1_CR13","unstructured":"Yemini, Y., da Silva, S.: Towards programmable networks. In: IFIP\/IEEE Intl. Workshop on Distributed Systems: Operations and Management (October 1996)"},{"issue":"3","key":"1_CR14","doi-asserted-by":"publisher","first-page":"37","DOI":"10.1109\/65.690960","volume":"12","author":"D. Scott Alexander","year":"1998","unstructured":"Scott Alexander, D., Arbaugh, W.A., Keromytis, A.D., Smith, J.M.: A secure active network architecture: Realization in SwitchWare. IEEE Network\u00a012(3), 37\u201345 (1998) (issue on Active and Programmable Networks)","journal-title":"IEEE Network"},{"key":"1_CR15","doi-asserted-by":"crossref","unstructured":"Postel, J.: INTERNET protocol. Internet RFC 791 (1981)","DOI":"10.17487\/rfc0791"},{"key":"1_CR16","doi-asserted-by":"crossref","unstructured":"Postel, J.: User datagram protocol. Internet RFC 768 (1980)","DOI":"10.17487\/rfc0768"},{"key":"1_CR17","doi-asserted-by":"crossref","unstructured":"Sollins, K.R.: The TFTP protocol (revision 2). Internet RFC 1350 (1992)","DOI":"10.17487\/rfc1350"},{"key":"1_CR18","doi-asserted-by":"crossref","unstructured":"Alexander, D.S., Shaw, M., Nettles, S.M., Smith, J.M.: Active bridging. In: Proc. 1997 ACM SIGCOMM Conference (September 1997)","DOI":"10.1145\/263105.263149"},{"key":"1_CR19","unstructured":"Scott Alexander, D., Braden, B., Gunter, C.A., Jackson, A.W., Keromytis, A.D., Minden, G.J., Wetherall, D.: Active network encapsulation protocol (ANEP) (August 1997), http:\/\/www.cis.upenn.edu\/~angelos\/ANEP.txt.gz"}],"container-title":["Lecture Notes in Computer Science","Active Networks"],"original-title":[],"link":[{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/978-3-540-48507-0_1","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2019,6,7]],"date-time":"2019-06-07T14:06:28Z","timestamp":1559916388000},"score":1,"resource":{"primary":{"URL":"http:\/\/link.springer.com\/10.1007\/978-3-540-48507-0_1"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[1999]]},"ISBN":["9783540662389","9783540485070"],"references-count":19,"URL":"https:\/\/doi.org\/10.1007\/978-3-540-48507-0_1","relation":{"is-part-of":[{"id-type":"doi","id":"https:\/\/doi.org\/10.1007\/b72204","asserted-by":"object"}]},"ISSN":["0302-9743","1611-3349"],"issn-type":[{"value":"0302-9743","type":"print"},{"value":"1611-3349","type":"electronic"}],"subject":[],"published":{"date-parts":[[1999]]}}}