{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,27]],"date-time":"2026-10-27T18:32:47Z","timestamp":1793125967611,"version":"4.5.0"},"publisher-location":"Berlin, Heidelberg","reference-count":20,"publisher":"Springer Berlin Heidelberg","isbn-type":[{"value":"9783540693888","type":"print"},{"value":"9783540693895","type":"electronic"}],"license":[{"start":{"date-parts":[[2008,1,1]],"date-time":"2008-01-01T00:00:00Z","timestamp":1199145600000},"content-version":"tdm","delay-in-days":0,"URL":"https:\/\/www.springernature.com\/gp\/researchers\/text-and-data-mining"},{"start":{"date-parts":[[2008,1,1]],"date-time":"2008-01-01T00:00:00Z","timestamp":1199145600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.springernature.com\/gp\/researchers\/text-and-data-mining"}],"content-domain":{"domain":["link.springer.com"],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2008]]},"DOI":"10.1007\/978-3-540-69389-5_57","type":"book-chapter","created":{"date-parts":[[2008,7,31]],"date-time":"2008-07-31T06:39:18Z","timestamp":1217486358000},"page":"501-509","update-policy":"https:\/\/doi.org\/10.1007\/springer_crossmark_policy","source":"Crossref","is-referenced-by-count":5,"title":["Resource Discovery Based on VIRGO P2P Distributed DNS Framework"],"prefix":"10.1007","author":[{"given":"Lican","family":"Huang","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"297","reference":[{"issue":"12","key":"57_CR1","doi-asserted-by":"publisher","first-page":"1583","DOI":"10.1002\/cpe.1203","volume":"19","author":"L. Huang","year":"2007","unstructured":"Huang, L., Akram, A., Allan, R.J., Walker, D.W., Rana, O.F., Huang, Y.: A Workflow Portal Supporting Multi-Language Interoperation and Optimisation. Journal Concurrency and Computation: Practice and Experience\u00a019(12), 1583\u20131595 (2007)","journal-title":"Journal Concurrency and Computation: Practice and Experience"},{"issue":"4","key":"57_CR2","doi-asserted-by":"crossref","first-page":"235","DOI":"10.1155\/2007\/281741","volume":"15","author":"D.W. Walker","year":"2007","unstructured":"Walker, D.W., Huang, L., Rana, O.F., Huang, Y.: Dynamic Service Selection in Workflows Using Performance Data. Journal of Scientific Programming\u00a015(4), 235\u2013247 (2007)","journal-title":"Journal of Scientific Programming"},{"key":"57_CR3","series-title":"Lecture Notes in Computer Science","doi-asserted-by":"publisher","first-page":"228","DOI":"10.1007\/978-3-540-72588-6_40","volume-title":"Computational Science \u2013 ICCS 2007","author":"L. Huang","year":"2007","unstructured":"Huang, L.: Framework for Workflow Parallel Execution in Grid Environment. In: Shi, Y., van Albada, G.D., Dongarra, J., Sloot, P.M.A. (eds.) ICCS 2007. LNCS, vol.\u00a04489, pp. 228\u2013235. Springer, Heidelberg (2007)"},{"key":"57_CR4","first-page":"627","volume-title":"3rd IEEE International Conference on e-Science and Grid Computing","author":"L. Huang","year":"2007","unstructured":"Huang, L.: Production Rule Based Selection Decision for Dynamic Flexible Workflow. In: 3rd IEEE International Conference on e-Science and Grid Computing, pp. 627\u2013632. IEEE Press, New York (2007)"},{"key":"57_CR5","series-title":"Lecture Notes in Computer Science","doi-asserted-by":"publisher","first-page":"51","DOI":"10.1007\/3-540-45644-9_6","volume-title":"Grid Computing - GRID 2001","author":"I. Foster","year":"2001","unstructured":"Foster, I., Iamnitchi, A.: On Fully Decentralized Resource Discovery in Grid Environments. In: Lee, C.A. (ed.) GRID 2001. LNCS, vol.\u00a02242, pp. 51\u201362. Springer, Heidelberg (2001)"},{"key":"57_CR6","series-title":"Lecture Notes in Computer Science","doi-asserted-by":"publisher","first-page":"46","DOI":"10.1007\/3-540-44702-4_4","volume-title":"Designing Privacy Enhancing Technologies","author":"I. Clarke","year":"2001","unstructured":"Clarke, I., Sandberg, O., Wiley, B., Theodore, W., Hong, T.W.: Freenet: A distributed anonymous information storage and retrieval system. In: Federrath, H. (ed.) Designing Privacy Enhancing Technologies. LNCS, vol.\u00a02009, pp. 46\u201366. Springer, Heidelberg (2001)"},{"key":"57_CR7","first-page":"149","volume-title":"2001 conference on Applications, technologies, architectures, and protocols for computer communications","author":"I. Stoica","year":"2001","unstructured":"Stoica, I., Morris, R., Karger, D., Kaashoek, F.M., Balakrishnan, H.: Chord: a scalable peer-to-peer lookup service for internet applications. In: 2001 conference on Applications, technologies, architectures, and protocols for computer communications, pp. 149\u2013160. ACM Press, New York (2001)"},{"issue":"3","key":"57_CR8","doi-asserted-by":"publisher","first-page":"329","DOI":"10.1177\/1094342003173001","volume":"17","author":"L. Huang","year":"2003","unstructured":"Huang, L., Wu, Z., Pan, Y.: Virtual and Dynamic Hierarchical Architecture for e-Science Grid. International Journal of High Performance Computing Applications\u00a017(3), 329\u2013347 (2003)","journal-title":"International Journal of High Performance Computing Applications"},{"key":"57_CR9","series-title":"Lecture Notes in Computer Science","doi-asserted-by":"publisher","first-page":"911","DOI":"10.1007\/11508380_93","volume-title":"Advances in Grid Computing - EGC 2005","author":"L. Huang","year":"2005","unstructured":"Huang, L.: VIRGO: Virtual Hierarchical Overlay Network for Scalable Grid Computing. In: Sloot, P.M.A., Hoekstra, A.G., Priol, T., Reinefeld, A., Bubak, M. (eds.) EGC 2005. LNCS, vol.\u00a03470, pp. 911\u2013921. Springer, Heidelberg (2005)"},{"key":"57_CR10","doi-asserted-by":"publisher","first-page":"492","DOI":"10.2481\/dsj.6.S492","volume":"6","author":"L. Huang","year":"2007","unstructured":"Huang, L.: A P2P service discovery strategy based on content catalogues. Data Science Journal\u00a06, S492\u2013S499 (2007)","journal-title":"Data Science Journal"},{"key":"57_CR11","series-title":"Lecture Notes in Computer Science","doi-asserted-by":"publisher","first-page":"840","DOI":"10.1007\/11508380_86","volume-title":"Advances in Grid Computing - EGC 2005","author":"M. Giordano","year":"2005","unstructured":"Giordano, M.: DNS-Based Discovery System in Service Oriented Programming. In: Sloot, P.M.A., Hoekstra, A.G., Priol, T., Reinefeld, A., Bubak, M. (eds.) EGC 2005. LNCS, vol.\u00a03470, pp. 840\u2013850. Springer, Heidelberg (2005)"},{"key":"57_CR12","doi-asserted-by":"crossref","unstructured":"Mockapetris, P.: DOMAIN NAMES - IMPLEMENTATION AND SPECIFICATION. Specification, RFC1035 (1987), \n                      http:\/\/www.ietf.org\/rfc\/rfc1035.txt","DOI":"10.17487\/rfc1035"},{"key":"57_CR13","unstructured":"Huang, L.:Distributed Universal Resource Name Resolution based on Distributed DNS(Internet Draft) (2008), \n                      http:\/\/www.tools.ietf.org\/html\/draft-licanhuang-dnsop-urnresolution-01"},{"key":"57_CR14","unstructured":"Huang, L.: Distributed DNS Implementation in IpV6 (Internet Draft) (2007), \n                      http:\/\/tools.ietf.org\/id\/draft-licanhuang-dnsop-distributeddns-02.txt"},{"key":"57_CR15","doi-asserted-by":"crossref","unstructured":"Berners-Lee, T. , Fielding, R., Irvine, U.C., Masinter, L.: Uniform Resource Identifiers (URI): Generic Syntax, RFC 2396 (1998), \n                      http:\/\/www.ietf.org\/rfc\/rfc2396.txt","DOI":"10.17487\/rfc2396"},{"key":"57_CR16","doi-asserted-by":"crossref","unstructured":"Berners-Lee, T. , Masinter, L. , McCahill, M.: Uniform Resource Locators (URL), RFC 1738 (1994), \n                      http:\/\/www.faqs.org\/rfcs\/rfc1738","DOI":"10.17487\/rfc1738"},{"key":"57_CR17","doi-asserted-by":"crossref","unstructured":"Daigle, L., Gulik, D. v., Iannella, R., Faltstrom, P.: URN Namespace Definition Mechanisms, RFC 2611 (1999), \n                      http:\/\/www.ietf.org\/rfc\/rfc2611.txt","DOI":"10.17487\/rfc2611"},{"key":"57_CR18","unstructured":"Wong, S.C., Tan, V., Fang, W., Miles, S., Moreau, L.: Grimoires: Grid Registry with Metadata Oriented Interface: Robustness, Efficiency, Security. IEEE Distributed Systems Online\u00a06(10) (2005)"},{"key":"57_CR19","unstructured":"VIRGO: HomePage of VIRGO, \n                      http:\/\/virgo.sourceforge.net\/"},{"key":"57_CR20","unstructured":"DNSjava: HomePage of DNSjava, \n                      http:\/\/www.dnsjava.org\/"}],"container-title":["Lecture Notes in Computer Science","Computational Science \u2013 ICCS 2008"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/link.springer.com\/content\/pdf\/10.1007\/978-3-540-69389-5_57","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2024,5,9]],"date-time":"2024-05-09T06:46:35Z","timestamp":1715237195000},"score":1,"resource":{"primary":{"URL":"https:\/\/link.springer.com\/10.1007\/978-3-540-69389-5_57"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2008]]},"ISBN":["9783540693888","9783540693895"],"references-count":20,"URL":"https:\/\/doi.org\/10.1007\/978-3-540-69389-5_57","relation":{},"ISSN":["0302-9743","1611-3349"],"issn-type":[{"value":"0302-9743","type":"print"},{"value":"1611-3349","type":"electronic"}],"subject":[],"published":{"date-parts":[[2008]]},"assertion":[{"value":"This content has been made available to all.","name":"free","label":"Free to read"}]}}