{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,9,26]],"date-time":"2026-09-26T23:03:38Z","timestamp":1790463818752,"version":"4.1.0"},"publisher-location":"Berlin, Heidelberg","reference-count":22,"publisher":"Springer Berlin Heidelberg","isbn-type":[{"value":"9783642104329","type":"print"},{"value":"9783642104336","type":"electronic"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2009]]},"DOI":"10.1007\/978-3-642-10433-6_12","type":"book-chapter","created":{"date-parts":[[2009,11,23]],"date-time":"2009-11-23T03:20:51Z","timestamp":1258946451000},"page":"174-188","source":"Crossref","is-referenced-by-count":24,"title":["DepenDNS: Dependable Mechanism against DNS Cache Poisoning"],"prefix":"10.1007","author":[{"given":"Hung-Min","family":"Sun","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Wen-Hsuan","family":"Chang","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Shih-Ying","family":"Chang","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Yue-Hsun","family":"Lin","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"297","reference":[{"key":"12_CR1","doi-asserted-by":"publisher","first-page":"335","DOI":"10.1109\/ARES.2007.139","volume-title":"ARES 2007: Proceedings of The Second International Conference on Availability, Reliability and Security","author":"S. Ariyapperuma","year":"2007","unstructured":"Ariyapperuma, S., Mitchell, C.J.: Security vulnerabilities in dns and dnssec. In: ARES 2007: Proceedings of The Second International Conference on Availability, Reliability and Security, pp. 335\u2013342. IEEE Computer Society, Los Alamitos (2007)"},{"key":"12_CR2","doi-asserted-by":"crossref","unstructured":"Chatzis, N.: Motivation for behaviour-based dns security: A taxonomy of dns-related internet threats. In: International Conference on Emerging Security Information, Systems, and Technologies. SecureWare 2007, pp. 36\u201341 (October 2007)","DOI":"10.1109\/SECUREWARE.2007.4385307"},{"key":"12_CR3","doi-asserted-by":"crossref","unstructured":"Ollmann, G.: The phishing guide. Next Generation Security Software Ltd. (2004)","DOI":"10.1016\/S1353-4858(04)00050-9"},{"issue":"6","key":"12_CR4","doi-asserted-by":"publisher","first-page":"44","DOI":"10.1145\/1247001.1247004","volume":"50","author":"A. Friedlander","year":"2007","unstructured":"Friedlander, A., Mankin, A., Maughan, W., Crocker, S.: DNSSEC: a protocol toward securing the internet infrastructure. Communications of the ACM\u00a050(6), 44\u201350 (2007)","journal-title":"Communications of the ACM"},{"key":"12_CR5","doi-asserted-by":"crossref","unstructured":"Eastlake, D.: Secret key establishment for DNS (TKEY RR). RFC 2930 (September 2000)","DOI":"10.17487\/rfc2930"},{"key":"12_CR6","doi-asserted-by":"crossref","unstructured":"Vixie, P., Gudmundsson, O., Eastlake, D., Wellington, B.: Secret key transaction authentication for DNS (TSIG). RFC 2845 (May 2000)","DOI":"10.17487\/rfc2845"},{"issue":"12","key":"12_CR7","doi-asserted-by":"publisher","first-page":"2238","DOI":"10.1016\/j.comcom.2006.03.004","volume":"29","author":"R. Oppliger","year":"2006","unstructured":"Oppliger, R., Hauser, R., Basin, D.: SSL\/TLS session-aware user authentication\u2013Or how to effectively thwart the man-in-the-middle. Computer Communications\u00a029(12), 2238\u20132246 (2006)","journal-title":"Computer Communications"},{"key":"12_CR8","doi-asserted-by":"crossref","unstructured":"Ju, Y.W., Song, K.H., Lee, E.J., Shin, Y.T.: Cache poisoning detection method for improving security of recursive DNS. In: The 9th International Conference on Advanced Communication Technology, vol.\u00a03, pp. 1961\u20131965 (2007)","DOI":"10.1109\/ICACT.2007.358755"},{"key":"12_CR9","doi-asserted-by":"publisher","first-page":"23","DOI":"10.1145\/1179576.1179582","volume-title":"VizSEC 2006: Proceedings of the 3rd international workshop on Visualization for computer security","author":"P. Ren","year":"2006","unstructured":"Ren, P., Kristoff, J., Gooch, B.: Visualizing DNS traffic. In: VizSEC 2006: Proceedings of the 3rd international workshop on Visualization for computer security, pp. 23\u201330. ACM, New York (2006)"},{"key":"12_CR10","unstructured":"Zdrnja, B.: Security Monitoring of DNS traffic. CompSci780 project, University of Auckland (May 2006)"},{"key":"12_CR11","unstructured":"Roolvink, S.: Detecting attacks involving dns servers: a netflow data based approach (December 2008), http:\/\/essay.utwente.nl\/58497\/"},{"key":"12_CR12","doi-asserted-by":"crossref","unstructured":"Yuan, L., Kant, K., Mohapatra, P., Chuah, C.N.: Dox: A peer-to-peer antidote for DNS cache poisoning attacks. In: ICC 2006: Proceedings of the International Conference on Communications, vol.\u00a05, pp. 2345\u20132350 (2006)","DOI":"10.1109\/ICC.2006.255120"},{"key":"12_CR13","doi-asserted-by":"publisher","first-page":"211","DOI":"10.1145\/1455770.1455798","volume-title":"CCS 2008: Proceedings of the 15th ACM conference on Computer and communications security","author":"D. Dagon","year":"2008","unstructured":"Dagon, D., Antonakakis, M., Vixie, P., Jinmei, T., Lee, W.: Increased dns forgery resistance through 0x20-bit encoding: security via leet queries. In: CCS 2008: Proceedings of the 15th ACM conference on Computer and communications security, pp. 211\u2013222. ACM, New York (2008)"},{"key":"12_CR14","first-page":"3","volume-title":"WORLDS 2006: Proceedings of the 3rd conference on USENIX Workshop on Real, Large Distributed Systems","author":"L. Poole","year":"2006","unstructured":"Poole, L., Pai, V.S.: Confidns: leveraging scale and history to improve dns security. In: WORLDS 2006: Proceedings of the 3rd conference on USENIX Workshop on Real, Large Distributed Systems, p. 3. USENIX Association, Berkeley (2006)"},{"key":"12_CR15","unstructured":"Park, K., Pai, V., Peterson, L., Wang, Z.: CoDNS: improving DNS performance and reliability via cooperative lookups. In: OSDI: Proceedings of the 6th USENIX Symposium on Operating Systems Design and Implementation, USENIX Association Berkeley, CA, USA, pp. 14\u201314 (2004)"},{"key":"12_CR16","doi-asserted-by":"crossref","unstructured":"Brisco, T.: DNS support for load balancing. RFC 1794 (April 1995)","DOI":"10.17487\/rfc1794"},{"issue":"3","key":"12_CR17","doi-asserted-by":"publisher","first-page":"28","DOI":"10.1109\/4236.769420","volume":"3","author":"V. Cardellini","year":"1999","unstructured":"Cardellini, V., Colajanni, M., Yu, P.: Dynamic load balancing on web-server systems. Internet Computing, IEEE\u00a03(3), 28\u201339 (1999)","journal-title":"Internet Computing, IEEE"},{"key":"12_CR18","doi-asserted-by":"crossref","unstructured":"Hong, Y., No, J., Kim, S.: Dns-based load balancing in distributed web-server systems. In: SEUS 2006\/WCCIA 2006: Proceedings of the Fourth International Workshop on Software Technologies for Future Embedded and Ubiquitous Systems and the 2006 Second International Workshop on Collaborative Computing, Integration, and Assurance, vol.\u00a04 (April 2006)","DOI":"10.1109\/SEUS-WCCIA.2006.23"},{"key":"12_CR19","doi-asserted-by":"publisher","first-page":"189","DOI":"10.1145\/1455770.1455796","volume-title":"CCS 2008: Proceedings of the 15th ACM conference on Computer and communications security","author":"H. Ballani","year":"2008","unstructured":"Ballani, H., Francis, P.: Mitigating DNS dos attacks. In: CCS 2008: Proceedings of the 15th ACM conference on Computer and communications security, pp. 189\u2013198. ACM, New York (2008)"},{"key":"12_CR20","doi-asserted-by":"crossref","unstructured":"Ylonen, T., Lonvick, C.: Rfc 4251: The secure shell (ssh) protocol architecture (January 2006), http:\/\/www.ietf.org\/rfc\/rfc4251.txt","DOI":"10.17487\/rfc4251"},{"key":"12_CR21","doi-asserted-by":"crossref","unstructured":"Rescorla, E.: Http over TLS (May 2000)","DOI":"10.17487\/rfc2818"},{"key":"12_CR22","unstructured":"Wendlandt, D., Andersen, D., Perrig, A.: Perspectives: improving SSH-style host authentication with multi-path probing. In: USENIX 2008 Annual Technical Conference on Annual Technical Conference table of contents, USENIX Association Berkeley, CA, USA, pp. 321\u2013334 (2008)"}],"container-title":["Lecture Notes in Computer Science","Cryptology and Network Security"],"original-title":[],"link":[{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/978-3-642-10433-6_12.pdf","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2023,5,27]],"date-time":"2023-05-27T16:53:52Z","timestamp":1685206432000},"score":1,"resource":{"primary":{"URL":"http:\/\/link.springer.com\/10.1007\/978-3-642-10433-6_12"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2009]]},"ISBN":["9783642104329","9783642104336"],"references-count":22,"URL":"https:\/\/doi.org\/10.1007\/978-3-642-10433-6_12","relation":{},"ISSN":["0302-9743","1611-3349"],"issn-type":[{"value":"0302-9743","type":"print"},{"value":"1611-3349","type":"electronic"}],"subject":[],"published":{"date-parts":[[2009]]}}}