{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,9,24]],"date-time":"2026-09-24T10:29:25Z","timestamp":1790245765555,"version":"4.1.0"},"reference-count":34,"publisher":"Springer Science and Business Media LLC","issue":"1","license":[{"start":{"date-parts":[[2016,1,22]],"date-time":"2016-01-22T00:00:00Z","timestamp":1453420800000},"content-version":"tdm","delay-in-days":0,"URL":"http:\/\/www.springer.com\/tdm"}],"funder":[{"name":"Ministry of Science, Technology and Innovation (MOSTI), Malaysia","award":["01-02-11-SF0202"],"award-info":[{"award-number":["01-02-11-SF0202"]}]},{"DOI":"10.13039\/501100002671","name":"Universiti Tunku Abdul Rahman","doi-asserted-by":"publisher","award":["IPSR\/RMC\/UTARRF\/2012-C2\/L04"],"award-info":[{"award-number":["IPSR\/RMC\/UTARRF\/2012-C2\/L04"]}],"id":[{"id":"10.13039\/501100002671","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["link.springer.com"],"crossmark-restriction":false},"short-container-title":["Cluster Comput"],"published-print":{"date-parts":[[2016,3]]},"DOI":"10.1007\/s10586-016-0536-2","type":"journal-article","created":{"date-parts":[[2016,1,22]],"date-time":"2016-01-22T13:31:54Z","timestamp":1453469514000},"page":"335-347","update-policy":"https:\/\/doi.org\/10.1007\/springer_crossmark_policy","source":"Crossref","is-referenced-by-count":29,"title":["Fast implementation of block ciphers and PRNGs in Maxwell GPU architecture"],"prefix":"10.1007","volume":"19","author":[{"ORCID":"https:\/\/orcid.org\/0000-0003-4659-8979","authenticated-orcid":false,"given":"Wai-Kong","family":"Lee","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Hon-Sang","family":"Cheong","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Raphael C.-W.","family":"Phan","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Bok-Min","family":"Goi","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"297","published-online":{"date-parts":[[2016,1,22]]},"reference":[{"issue":"2","key":"536_CR1","first-page":"255270","volume":"17","author":"W Cao","year":"2014","unstructured":"Cao, W., Xu, C., Wang, Z., Yao, L., Liu, H.: CPU\/GPU computing for a multi-block structured grid based high-order flow solver on a large heterogeneous system. J. Clust. Comput. 17(2), 255270 (2014)","journal-title":"J. Clust. Comput."},{"issue":"1","key":"536_CR2","doi-asserted-by":"crossref","first-page":"333","DOI":"10.1007\/s10586-014-0392-x","volume":"18","author":"MS Islam","year":"2015","unstructured":"Islam, M.S., Kim, C., Kim, J.: A GPU-based (8, 4) Hamming decoder for secure transmission of watermarked medical images. J. Clus. Comput. 18(1), 333\u2013341 (2015)","journal-title":"J. Clus. Comput."},{"key":"536_CR3","doi-asserted-by":"crossref","first-page":"40","DOI":"10.1016\/j.jpdc.2014.09.016","volume":"75","author":"M Chopkowski","year":"2015","unstructured":"Chopkowski, M., Walkowiak, R.: A general purpose lossless data compression method for GPU. J. Parallel Distrib. Comput. 75, 40\u201352 (2015)","journal-title":"J. Parallel Distrib. Comput."},{"key":"536_CR4","unstructured":"Osa, G.L.: Fast implementation of two hash algorithm on NVidia CUDA GPU. Master thesis, Norwegian University of Science and Technology (2009)"},{"key":"536_CR5","unstructured":"Bos, J.W., Osvik, D.A., Stefan, D.: Fast implementations of AES on various platforms. In: Software Performance Enhancement for Encryption and Decryption and Cryptographic Compilers (SPEED-CC), pp. 19\u201334 (2009)"},{"key":"536_CR6","doi-asserted-by":"crossref","unstructured":"Hu, G., Ma, J., Huang, B.: High throughput implementation of MD5 algorithm on GPU. In: IEEE Proceedings of the 4th International Conference on Ubiquitous Information Technologies & Applications, pp. 1\u20135 (2009)","DOI":"10.1109\/ICUT.2009.5405734"},{"key":"536_CR7","doi-asserted-by":"crossref","first-page":"152","DOI":"10.1016\/j.jpdc.2014.09.001","volume":"75","author":"SC Seo","year":"2015","unstructured":"Seo, S.C., Kim, T.H., Hong, S.K.: Accelerating elliptic curve scalar multiplication over GF( $$2^m$$ 2 m )on graphic hardware. J. Parallel Distrib. Comput. 75, 152\u2013167 (2015)","journal-title":"J. Parallel Distrib. Comput."},{"key":"536_CR8","unstructured":"National Institute of Standards and Technology (NIST): FIPS-197: advanced encryption standard. http:\/\/www.itl.nist.gov\/fipspubs\/ (2001). Accessed 1 Sept 2015"},{"key":"536_CR9","doi-asserted-by":"crossref","unstructured":"Adams, C.: The CAST-128 Encryption Algorithm. RFC 2144 (Informational) (1997)","DOI":"10.17487\/rfc2144"},{"key":"536_CR10","doi-asserted-by":"crossref","unstructured":"Lee, H.J., Lee, S.J., Yoon, J.H., Cheon, D.H., Lee, J.I., Korea Information Security Agency: The SEED encryption algorithm. The Internet Engineering Task Force RFC 4269 [online database]. http:\/\/www.ietf.org\/rfc\/rfc4269.txt (2005). Accessed 18 May 2015","DOI":"10.17487\/rfc4269"},{"key":"536_CR11","unstructured":"Aoki, K., Ichikawa, T., Kanda, M., Matsui, M., Moriai, S., Nakajima, J., Tokita, T.: Specifications of Camellia a 128-bit block cipher. http:\/\/info.isl.ntt.co.jp\/crypt\/eng\/camellia\/dl\/01espec (2001). Accessed 6 May 2015"},{"key":"536_CR12","unstructured":"Lai, X., Massey, J.L.: A proposal for a new block encryption standard. In: EUROCRYPT 1990, pp. 389404 (1990)"},{"key":"536_CR13","doi-asserted-by":"crossref","unstructured":"Schneier, B.: Description of a new variable-length key, 64-bit block cipher (Blowfish). In Fast Software Encryption, Cambridge Security Workshop Proceedings, pp. 191204. Springer (1993)","DOI":"10.1007\/3-540-58108-1_24"},{"key":"536_CR14","unstructured":"Ferguson, N., Lucks, S., Schneier, B., Whiting, D., Bellare, M., Kohno, T., Callas, J., Walker, J.: The Skein Hash Function Family, a SHA-3 candidate (2009)"},{"key":"536_CR15","unstructured":"Transport Layer Security (TLS) Protocol Version 1.2, RFC 5246, 2008"},{"key":"536_CR16","unstructured":"The Secure Sockets Layer (SSL) Protocol Version 3.0, RFC 6101 (1996)"},{"key":"536_CR17","doi-asserted-by":"crossref","first-page":"611","DOI":"10.1016\/j.cpc.2015.06.016","volume":"196","author":"M Leetmaa","year":"2015","unstructured":"Leetmaa, M., Skorodumova, N.V.: KMCLib 1.1: extended random number support and technical updates to the KMCLib general framework for kinetic Monte-Carlo simulations. Comput. Phys. Commun. 196, 611\u2013613 (2015)","journal-title":"Comput. Phys. Commun."},{"key":"536_CR18","unstructured":"NIST Statistical Test Suite: A Statistical Test Suite for Random and Pseudorandom Number Generators for Cryptographic Applications. In: SP800-22, Revision 1a (2010)"},{"key":"536_CR19","doi-asserted-by":"crossref","unstructured":"LEcuyer, P., Simard, R.: TestU01: a C library for empirical testing of random number generators. ACM Trans. Math. Softw. 33, 22 (2007)","DOI":"10.1145\/1268776.1268777"},{"key":"536_CR20","unstructured":"CUDA C Programming Guide V7.0. NVIDIA Corporation. http:\/\/docs.nvidia.com\/cuda\/cuda-c-programming-guide\/index.html (2015). Accessed 26 June 2015"},{"key":"536_CR21","unstructured":"Dworkin, M.: Recommendation for block cipher mode of operations. http:\/\/csrc.nist.gov\/publications\/nistpubs\/800-38a\/sp800-38a (2001). Accessed 2 June 2015"},{"key":"536_CR22","doi-asserted-by":"crossref","unstructured":"Biagio, A.D., Barenghi, A., Agosta, G., Pelosi, G.: Design of a parallel AES for graphics hardware using the CUDA framework. In: IEEE International Symposium on Parallel and Distributed Processing, pp. 1\u20138 (2009)","DOI":"10.1109\/IPDPS.2009.5161242"},{"key":"536_CR23","unstructured":"Mei, C., Jiang, H., Jenness, J.: CUDA-based AES parallelization with fine-tuned GPU memory utilization. In: IEEE International Symposium on Parallel and Distributed Processing, Workshops and Ph.D. Forum (IPDPSW) (2010)"},{"key":"536_CR24","doi-asserted-by":"crossref","unstructured":"Bos, J.W., Osvik, D.A., Stefan, D., Canright, D.: Fast software AES encryption. In: Proceedings of the 17th International Conference on Fast Software Encryption (2010)","DOI":"10.1007\/978-3-642-13858-4_5"},{"key":"536_CR25","doi-asserted-by":"crossref","unstructured":"Tran, N.P., Lee, M., Hong, S., Lee, S.J.: Parallel execution of AES-CTR algorithm using extended block size. In: IEEE 14th International Conference on Computational Science and Engineering (2011)","DOI":"10.1109\/CSE.2011.43"},{"issue":"2","key":"536_CR26","doi-asserted-by":"crossref","first-page":"251","DOI":"10.15803\/ijnc.2.2_251","volume":"2","author":"N Nishikawa","year":"2012","unstructured":"Nishikawa, N., Iwai, K., Kurokawa, T.: High-performance symmetric block ciphers on multicore CPU and GPUs. Int. J. Netw. Comput. 2(2), 251\u2013268 (2012)","journal-title":"Int. J. Netw. Comput."},{"key":"536_CR27","doi-asserted-by":"crossref","unstructured":"Gilger, J., Barnickel, J., Meyer, U.: GPU-acceleration of block ciphers in the OpenSSL cryptographic library. In: Proceedings of the 15th International Conference on Information Security, pp. 338\u2013353, Springer (2012)","DOI":"10.1007\/978-3-642-33383-5_21"},{"issue":"1","key":"536_CR28","doi-asserted-by":"crossref","first-page":"159","DOI":"10.3745\/JIPS.2012.8.1.159","volume":"8","author":"S Lee","year":"2012","unstructured":"Lee, S., Kim, D., Yi, J., Ro, W.W.: An efficient block cipher implementation on many-core graphics processing unit. J. Inf. Process. Syst. 8(1), 159\u2013174 (2012)","journal-title":"J. Inf. Process. Syst."},{"key":"536_CR29","doi-asserted-by":"crossref","unstructured":"Li, Q., Zhong, C., Zhao, K., Mei, X., Chu, X.: Implementation and analysis of AES encryption on GPU. In: IEEE 14th International Conference on High Performance Computing and Communications, pp. 843\u2013848 (2012)","DOI":"10.1109\/HPCC.2012.119"},{"key":"536_CR30","doi-asserted-by":"crossref","unstructured":"Zola, W., Bona, L.C.E.: Parallel speculative encryption of multiple AES contexts on GPUs. In: IEEE International Conference on Innovative Parallel Programming, pp. 1\u20139 (2012)","DOI":"10.1109\/InPar.2012.6339611"},{"issue":"6","key":"536_CR31","doi-asserted-by":"crossref","first-page":"1506","DOI":"10.1587\/transinf.E97.D.1506","volume":"E97\u2013D","author":"N Nishikawa","year":"2014","unstructured":"Nishikawa, N., Iwai, K., Tanaka, H., Kurokawa, T.: Throughput and power efficiency evaluations of block ciphers on Kepler and GCN GPUs using micro-benchmark analysis. IEICE Trans. Inf. Syst. E97\u2013D(6), 1506\u20131515 (2014)","journal-title":"IEICE Trans. Inf. Syst."},{"key":"536_CR32","unstructured":"Mukherjee, R., Rehman, M.S., Kothapalli, K., Narayanan, P.J., Srinathan, K.: Fast, scalable, and secure encryption on the GPU. http:\/\/researchweb.iiit.ac.in\/~rishabh_m\/gpu_crypto (2011). Accessed 2 Aug 2015"},{"key":"536_CR33","doi-asserted-by":"crossref","unstructured":"Salmon, J.K., Moraes, M.A., Dror, R.O., Shaw, D.E.: Parallel random numbers: as easy as 1, 2, 3. In: Proceedings of International Conference for High Performance Computing, Networking, Storage and Analysis, pp 1\u201312 (2011)","DOI":"10.1145\/2063384.2063405"},{"key":"536_CR34","unstructured":"Tuning CUDA Applications for Kepler V7.0. NVIDIA Corporation. http:\/\/docs.nvidia.com\/cuda\/kepler-tuning-guide\/#axzz3wKHPco4y (2015). Accessed 21 May 2015"}],"container-title":["Cluster Computing"],"original-title":[],"language":"en","link":[{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/s10586-016-0536-2.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"text-mining"},{"URL":"http:\/\/link.springer.com\/article\/10.1007\/s10586-016-0536-2\/fulltext.html","content-type":"text\/html","content-version":"vor","intended-application":"text-mining"},{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/s10586-016-0536-2","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,1]],"date-time":"2025-06-01T06:23:27Z","timestamp":1748759007000},"score":1,"resource":{"primary":{"URL":"http:\/\/link.springer.com\/10.1007\/s10586-016-0536-2"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2016,1,22]]},"references-count":34,"journal-issue":{"issue":"1","published-print":{"date-parts":[[2016,3]]}},"alternative-id":["536"],"URL":"https:\/\/doi.org\/10.1007\/s10586-016-0536-2","relation":{},"ISSN":["1386-7857","1573-7543"],"issn-type":[{"value":"1386-7857","type":"print"},{"value":"1573-7543","type":"electronic"}],"subject":[],"published":{"date-parts":[[2016,1,22]]}}}