{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,4,29]],"date-time":"2026-04-29T05:13:57Z","timestamp":1777439637605,"version":"3.51.4"},"reference-count":39,"publisher":"Springer Science and Business Media LLC","issue":"3","license":[{"start":{"date-parts":[[2021,11,11]],"date-time":"2021-11-11T00:00:00Z","timestamp":1636588800000},"content-version":"tdm","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0"},{"start":{"date-parts":[[2021,11,11]],"date-time":"2021-11-11T00:00:00Z","timestamp":1636588800000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0"}],"funder":[{"DOI":"10.13039\/100013443","name":"Swedish Institute","doi-asserted-by":"publisher","id":[{"id":"10.13039\/100013443","id-type":"DOI","asserted-by":"publisher"}]},{"DOI":"10.13039\/501100003252","name":"Lund University","doi-asserted-by":"crossref","id":[{"id":"10.13039\/501100003252","id-type":"DOI","asserted-by":"crossref"}]}],"content-domain":{"domain":["link.springer.com"],"crossmark-restriction":false},"short-container-title":["Cluster Comput"],"published-print":{"date-parts":[[2022,6]]},"abstract":"<jats:title>Abstract<\/jats:title><jats:p>Distributed e-Infrastructure is a key component of modern BIG Science. Service discovery in e-Science environments, such as Worldwide LHC Computing Grid (WLCG), is a crucial functionality that relies on service registry. In this paper we re-formulate the requirements for the service endpoint registry based on our more than 10 years experience with many systems designed or used within the WLCG e-Infrastructure. To satisfy those requirements the paper proposes a novel idea to use the existing well-established Domain Name System (DNS) infrastructure together with a suitable data model as a service endpoint registry. The presented ARC Hierarchical Endpoints Registry (ARCHERY) system consists of a minimalistic data model representing services and their endpoints within e-Infrastructures, a rendering of the data model embedded into DNS-records, a lightweight software layer for DNS-record management and client-side data discovery. Our approach for the ARCHERY registry required minimal software development and inherits all the benefits of one of the most reliable distributed information discovery source of the internet, the DNS infrastructure. In particular, deployment, management and operation of ARCHERY is fully relying on DNS. Results of ARCHERY deployment use-cases are provided together with performance analysis.<\/jats:p>","DOI":"10.1007\/s10586-021-03455-5","type":"journal-article","created":{"date-parts":[[2021,11,11]],"date-time":"2021-11-11T21:02:26Z","timestamp":1636664546000},"page":"1645-1664","update-policy":"https:\/\/doi.org\/10.1007\/springer_crossmark_policy","source":"Crossref","is-referenced-by-count":3,"title":["DNS-embedded service endpoint registry for distributed e-Infrastructures"],"prefix":"10.1007","volume":"25","author":[{"ORCID":"https:\/\/orcid.org\/0000-0002-1667-1357","authenticated-orcid":false,"given":"Andrii","family":"Salnikov","sequence":"first","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Bal\u00e1zs","family":"K\u00f3nya","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"297","published-online":{"date-parts":[[2021,11,11]]},"reference":[{"key":"3455_CR1","unstructured":"Andrzejak, A., Xu, Z.: Scalable, efficient range queries for grid information services. In: Second International Conference on Peer-to-Peer Computing, 2002 (P2P 2002). Proceedings, pp. 33\u201340. IEEE (2002)"},{"key":"3455_CR2","doi-asserted-by":"publisher","first-page":"032001","DOI":"10.1088\/1742-6596\/513\/3\/032001","volume":"513","author":"A Anisenkov","year":"2014","unstructured":"Anisenkov, A., Di Girolamo, A., Klimentov, A., Oleynik, D., Petrosyan, A., Collaboration, A., et al.: AGIS: the ATLAS grid information system. J. Phys. Conf. Ser. 513, 032001 (2014)","journal-title":"J. Phys. Conf. Ser."},{"key":"3455_CR3","doi-asserted-by":"crossref","unstructured":"Arends, R., Austein, R., Larson, M., Massey, D., Rose, S.: DNS Security Introduction and Requirements. RFC 4033. IETF (2005). http:\/\/tools.ietf.org\/rfc\/rfc4033.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc4033"},{"key":"3455_CR4","doi-asserted-by":"crossref","unstructured":"Bellis, R.: DNS Transport over TCP\u2014Implementation Requirements. RFC 5966. IETF (2010). http:\/\/tools.ietf.org\/rfc\/rfc5966.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc5966"},{"key":"3455_CR5","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-23157-5","volume-title":"From the Web to the Grid and Beyond: Computing Paradigms Driven by High-Energy Physics","author":"R Brun","year":"2012","unstructured":"Brun, R., Carminati, F., Carminati, G.G.: From the Web to the Grid and Beyond: Computing Paradigms Driven by High-Energy Physics. Springer, Berlin (2012)"},{"key":"3455_CR6","unstructured":"CERN: The WLCG REsource, Balance and Usage (REBUS). https:\/\/wlcg-rebus.cern.ch\/apps\/topology\/. Accessed 13 Oct 2021"},{"key":"3455_CR7","unstructured":"CERN: Top-BDII. http:\/\/gridinfo.web.cern.ch\/introduction. Accessed 13 Oct 2021"},{"key":"3455_CR8","doi-asserted-by":"crossref","unstructured":"Cheshire, S., Krochmal, M.: DNS-Based Service Discovery. RFC 6763. IETF (2013). http:\/\/tools.ietf.org\/rfc\/rfc6763.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc6763"},{"key":"3455_CR9","doi-asserted-by":"crossref","unstructured":"Crocker, D., Hansen, T., Kucherawy, M.: Domain Keys Identified Mail (DKIM) Signatures. RFC 6376. IETF (2011). http:\/\/tools.ietf.org\/rfc\/rfc6376.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc6376"},{"key":"3455_CR10","unstructured":"Czajkowski, K., Fitzgerald, S., Foster, I., Kesselman, C.: Grid information services for distributed resource sharing. In: 10th IEEE International Symposium on High Performance Distributed Computing, 2001. Proceedings, pp. 181\u2013194. IEEE (2001)"},{"key":"3455_CR11","doi-asserted-by":"crossref","unstructured":"Damas, J., Graff, M., Vixie, P.: Extension Mechanisms for DNS (EDNS(0)). RFC 6891. IETF (2013). http:\/\/tools.ietf.org\/rfc\/rfc6891.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc6891"},{"key":"3455_CR12","unstructured":"Dyer, S.P.: The Hesiod name server. In: USENIX Winter, pp. 183\u2013189 (1988)"},{"key":"3455_CR13","unstructured":"EGI service provided by STFC: Grid Configuration Database (GOCDB). https:\/\/goc.egi.eu\/. Accessed 13 Oct 2021"},{"issue":"2","key":"3455_CR14","doi-asserted-by":"publisher","first-page":"219","DOI":"10.1016\/j.future.2006.05.008","volume":"23","author":"M Ellert","year":"2007","unstructured":"Ellert, M., Gr\u00f8nager, M., Konstantinov, A., Konya, B., Lindemann, J., Livenson, I., Nielsen, J., Niinim\u00e4ki, M., Smirnova, O., W\u00e4\u00e4n\u00e4nen, A.: Advanced resource connector middleware for lightweight computational grids. Future Gen. Comput. Syst. 23(2), 219\u2013240 (2007). https:\/\/doi.org\/10.1016\/j.future.2006.05.008","journal-title":"Future Gen. Comput. Syst."},{"issue":"1","key":"3455_CR15","doi-asserted-by":"publisher","first-page":"29","DOI":"10.1007\/s10723-013-9284-1","volume":"12","author":"L Field","year":"2014","unstructured":"Field, L., Memon, S., M\u00e1rton, I., Szigeti, G.: The EMI Registry: discovering services in a federated world. J. Grid Comput. 12(1), 29\u201340 (2014). https:\/\/doi.org\/10.1007\/s10723-013-9284-1","journal-title":"J. Grid Comput."},{"key":"3455_CR16","doi-asserted-by":"crossref","unstructured":"Gulbrandsen, A., Vixie, P., Esibov, L.: A DNS RR for Specifying the Location of Services (DNS SRV). RFC 2782. IETF (2000). http:\/\/tools.ietf.org\/rfc\/rfc2782.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc2782"},{"key":"3455_CR17","doi-asserted-by":"crossref","unstructured":"Hoffman, P.E., Sullivan, A., Fujiwara, K.: DNS Terminology. RFC 8499. IETF (2019). http:\/\/tools.ietf.org\/rfc\/rfc8499.txt. Accessed 13 Oct 2021","DOI":"10.17487\/RFC8499"},{"key":"3455_CR18","unstructured":"ICANN Research: TLD DNSSEC Report. ICANN Research (2018). http:\/\/stats.research.icann.org\/dns\/tld_report\/. Accessed 13 Oct 2021"},{"key":"3455_CR19","unstructured":"Internet Assigned Numbers Authority: Root Servers. https:\/\/www.iana.org\/domains\/root\/servers. Accessed 13 Oct 2021"},{"key":"3455_CR20","unstructured":"Internet Systems Consortium: DNS RFCs. https:\/\/www.isc.org\/community\/rfcs\/dns\/. Accessed 13 Oct 2021"},{"key":"3455_CR21","unstructured":"Internet Systems Consortium, Inc., et al.: ISC BIND. Internet Systems Consortium, Inc. (2005)"},{"key":"3455_CR22","doi-asserted-by":"crossref","unstructured":"Kitterman, S.: Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1. RFC 7208. IETF (2014). http:\/\/tools.ietf.org\/rfc\/rfc7208.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc7208"},{"key":"3455_CR23","doi-asserted-by":"crossref","unstructured":"Kranzlm\u00fcller, D., de Lucas, J.M., \u00d6ster, P.: The European Grid Initiative (EGI). In: Remote Instrumentation and Virtual Laboratories, pp. 61\u201366. Springer, New York (2010)","DOI":"10.1007\/978-1-4419-5597-5_6"},{"key":"3455_CR24","doi-asserted-by":"crossref","unstructured":"Lottor, M.: Domain Administrators Operations Guide. RFC 1033. IETF (1987). http:\/\/tools.ietf.org\/rfc\/rfc1033.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc1033"},{"issue":"2","key":"3455_CR25","doi-asserted-by":"publisher","first-page":"1483","DOI":"10.1007\/s10586-019-03016-x","volume":"23","author":"DP Mahato","year":"2020","unstructured":"Mahato, D.P., Sandhu, J.K., Singh, N.P., Kaushal, V.: On scheduling transaction in grid computing using cuckoo search-ant colony optimization considering load. Clust. Comput. 23(2), 1483\u20131504 (2020). https:\/\/doi.org\/10.1007\/s10586-019-03016-x","journal-title":"Clust. Comput."},{"key":"3455_CR26","doi-asserted-by":"publisher","first-page":"062021","DOI":"10.1088\/1742-6596\/219\/6\/062021","volume":"219","author":"G Mathieu","year":"2010","unstructured":"Mathieu, G., Richards, A., Gordon, J., Novales, C.D.C., Colclough, P., Viljoen, M.: GOCDB, a topology repository for a worldwide grid infrastructure. J. Phys. Conf. Ser. 219, 062021 (2010)","journal-title":"J. Phys. Conf. Ser."},{"key":"3455_CR27","unstructured":"MIT Kerberos Consortium: MIT Kerberos Documentation: Realm Configuration Decisions. https:\/\/web.mit.edu\/kerberos\/. Accessed 13 Oct 2021"},{"key":"3455_CR28","doi-asserted-by":"crossref","unstructured":"Mockapetris, P.: Domain Names\u2014Concepts and Facilities. RFC 1034. IETF (1987). (http:\/\/tools.ietf.org\/rfc\/rfc1034.txt).Accessed 13 Oct 2021","DOI":"10.17487\/rfc1034"},{"key":"3455_CR29","doi-asserted-by":"crossref","unstructured":"Mockapetris, P.: Domain Names\u2014Implementation and Specification. RFC 1035. IETF (1987). (http:\/\/tools.ietf.org\/rfc\/rfc1035.txt). Accessed 13 Oct 2021","DOI":"10.17487\/rfc1035"},{"key":"3455_CR30","doi-asserted-by":"publisher","first-page":"052028","DOI":"10.1088\/1742-6596\/119\/5\/052028","volume":"119","author":"R Pordes","year":"2008","unstructured":"Pordes, R., Petravick, D., Kramer, B., Olson, D., Livny, M., Roy, A., Avery, P., Blackburn, K., Wenaus, T., W\u00fcrthwein, F., et al.: The Open Science Grid status and architecture. J. Phys. Conf. Ser. 119, 052028 (2008)","journal-title":"J. Phys. Conf. Ser."},{"key":"3455_CR31","doi-asserted-by":"crossref","unstructured":"Puppin, D., Moncelli, S., Baraglia, R., Tonellotto, N., Silvestri, F.: A grid information service based on peer-to-peer. In: European Conference on Parallel Processing, pp. 454\u2013464. Springer (2005)","DOI":"10.1007\/11549468_52"},{"key":"3455_CR32","doi-asserted-by":"crossref","unstructured":"Rose, S., Wijngaards, W.: DNAME Redirection in the DNS. RFC 6672. IETF (2012). http:\/\/tools.ietf.org\/rfc\/rfc6672.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc6672"},{"key":"3455_CR33","doi-asserted-by":"crossref","unstructured":"Salnikov, A., Sliusar, I., Sudakov, O., Savytskyi, O., Kornelyuk, A.: MolDynGrid Virtual Laboratory as a part of Ukrainian academic grid infrastructure. In: IEEE International Workshop on Intelligent Data Acquisition and Advanced Computing Systems: Technology and Applications, 2009. IDAACS 2009, pp. 237\u2013240. IEEE (2009)","DOI":"10.1109\/IDAACS.2009.5342989"},{"key":"3455_CR34","unstructured":"Smirnova, O.: The Grid Monitor. http:\/\/www.nordugrid.org\/documents\/monitor.pdf. Accessed 13 Oct 2021"},{"key":"3455_CR35","unstructured":"Stichting NLnet Labs: Unbound. https:\/\/nlnetlabs.nl\/projects\/unbound\/about\/. Accessed 13 Oct 2021"},{"key":"3455_CR36","unstructured":"Swedish Institute: The Visby Programme. https:\/\/si.se\/en\/apply\/visby-programme\/. Accessed 13 Oct 2021"},{"key":"3455_CR37","doi-asserted-by":"publisher","unstructured":"van der Toorn, O., van Rijswijk-Deij, R., Fiebig, T., Lindorfer, M., Sperotto, A.: TXTing 101: finding security issues in the long tail of DNS TXT records. In: 2020 IEEE European Symposium on Security and Privacy Workshops (EuroS PW), pp. 544\u2013549 (2020). https:\/\/doi.org\/10.1109\/EuroSPW51379.2020.00080","DOI":"10.1109\/EuroSPW51379.2020.00080"},{"key":"3455_CR38","doi-asserted-by":"crossref","unstructured":"Vixie, P., Gudmundsson, O., Eastlake III, D., Wellington, B.: Secret Key Transaction Authentication for DNS (TSIG). RFC 2845. IETF (2000). http:\/\/tools.ietf.org\/rfc\/rfc2845.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc2845"},{"key":"3455_CR39","doi-asserted-by":"crossref","unstructured":"Vixie, P., Thomson, S., Rekhter, Y., Bound, J.: Dynamic Updates in the Domain Name System (DNS UPDATE). RFC 2136. IETF (1997). http:\/\/tools.ietf.org\/rfc\/rfc2136.txt. Accessed 13 Oct 2021","DOI":"10.17487\/rfc2136"}],"container-title":["Cluster Computing"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/link.springer.com\/content\/pdf\/10.1007\/s10586-021-03455-5.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/link.springer.com\/article\/10.1007\/s10586-021-03455-5\/fulltext.html","content-type":"text\/html","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/link.springer.com\/content\/pdf\/10.1007\/s10586-021-03455-5.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2022,5,17]],"date-time":"2022-05-17T18:51:18Z","timestamp":1652813478000},"score":1,"resource":{"primary":{"URL":"https:\/\/link.springer.com\/10.1007\/s10586-021-03455-5"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2021,11,11]]},"references-count":39,"journal-issue":{"issue":"3","published-print":{"date-parts":[[2022,6]]}},"alternative-id":["3455"],"URL":"https:\/\/doi.org\/10.1007\/s10586-021-03455-5","relation":{},"ISSN":["1386-7857","1573-7543"],"issn-type":[{"value":"1386-7857","type":"print"},{"value":"1573-7543","type":"electronic"}],"subject":[],"published":{"date-parts":[[2021,11,11]]},"assertion":[{"value":"26 November 2020","order":1,"name":"received","label":"Received","group":{"name":"ArticleHistory","label":"Article History"}},{"value":"13 October 2021","order":2,"name":"revised","label":"Revised","group":{"name":"ArticleHistory","label":"Article History"}},{"value":"19 October 2021","order":3,"name":"accepted","label":"Accepted","group":{"name":"ArticleHistory","label":"Article History"}},{"value":"11 November 2021","order":4,"name":"first_online","label":"First Online","group":{"name":"ArticleHistory","label":"Article History"}}]}}