{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,9,29]],"date-time":"2026-09-29T17:21:37Z","timestamp":1790702497257,"version":"4.1.0"},"reference-count":39,"publisher":"Springer Science and Business Media LLC","issue":"3","license":[{"start":{"date-parts":[[2021,4,30]],"date-time":"2021-04-30T00:00:00Z","timestamp":1619740800000},"content-version":"tdm","delay-in-days":0,"URL":"https:\/\/www.springer.com\/tdm"},{"start":{"date-parts":[[2021,4,30]],"date-time":"2021-04-30T00:00:00Z","timestamp":1619740800000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.springer.com\/tdm"}],"content-domain":{"domain":["link.springer.com"],"crossmark-restriction":false},"short-container-title":["J Netw Syst Manage"],"published-print":{"date-parts":[[2021,7]]},"DOI":"10.1007\/s10922-021-09603-x","type":"journal-article","created":{"date-parts":[[2021,5,3]],"date-time":"2021-05-03T08:24:38Z","timestamp":1620030278000},"update-policy":"https:\/\/doi.org\/10.1007\/springer_crossmark_policy","source":"Crossref","is-referenced-by-count":45,"title":["Deep Reinforcement Learning Based Active Queue Management for IoT Networks"],"prefix":"10.1007","volume":"29","author":[{"given":"Minsu","family":"Kim","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Muhammad","family":"Jaseemuddin","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-6646-6052","authenticated-orcid":false,"given":"Alagan","family":"Anpalagan","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"297","published-online":{"date-parts":[[2021,4,30]]},"reference":[{"key":"9603_CR1","unstructured":"ns-3. https:\/\/www.nsnam.org\/. Accessed 06 Feb 2021"},{"key":"9603_CR2","unstructured":"tiny-dnn. https:\/\/github.com\/tiny-dnn\/tiny-dnn. Accessed 06 Feb 2021"},{"key":"9603_CR3","doi-asserted-by":"publisher","first-page":"2070","DOI":"10.1109\/JIOT.2017.2666269","volume":"4","author":"HAA Al-Kashoash","year":"2017","unstructured":"Al-Kashoash, H.A.A., Amer, H.M., Mihaylova, L., et al.: Optimization-based hybrid congestion alleviation for 6LoWPAN networks. IEEE Internet Things J. 4, 2070\u20132081 (2017)","journal-title":"IEEE Internet Things J."},{"key":"9603_CR4","unstructured":"Amar, Y., Haddadi, H., Mortier, R., et\u00a0al.: An Analysis of Home IoT Network Traffic and Behaviour. In: arXiv preprint arXiv:1803.05368 (2018)"},{"key":"9603_CR5","doi-asserted-by":"crossref","unstructured":"Baker, F., Fairhurst, G.: IETF Recommendations Regarding Active Queue Management. In: Internet Engineering Task Force (IETF), RFC 7567 (2015)","DOI":"10.17487\/RFC7567"},{"key":"9603_CR6","doi-asserted-by":"crossref","unstructured":"Bhandari, S., Sharma, S.K., Wang, X.: Latency Minimization in Wireless IoT Using Prioritized Channel Access and Data Aggregation. In: GLOBECOM 2017\u20142017 IEEE Global Communications Conference (2017)","DOI":"10.1109\/GLOCOM.2017.8255038"},{"key":"9603_CR7","doi-asserted-by":"crossref","unstructured":"Bisoy, S.K., Pandey, P.K., Pati, B.: Design of an active queue management technique based on neural networks for congestion control. In: 2017 IEEE International Conference on Advanced Networks and Telecommunications Systems (ANTS) (2017)","DOI":"10.1109\/ANTS.2017.8384104"},{"key":"9603_CR8","doi-asserted-by":"crossref","unstructured":"Bouacida, N., Shihada, B.: Practical and Dynamic Buffer Sizing using LearnQueue. IEEE Transactions on Mobile Computing (2018)","DOI":"10.1109\/TMC.2018.2868670"},{"key":"9603_CR9","doi-asserted-by":"crossref","unstructured":"Chen, X., Zhang, H., Wu, C., et\u00a0al.: Optimized Computation Offloading Performance in Virtual Edge Computing Systems via Deep Reinforcement Learning. IEEE Internet of Things Journal (2018)","DOI":"10.1109\/JIOT.2018.2876279"},{"key":"9603_CR10","doi-asserted-by":"crossref","unstructured":"Chinchali, S., Hu, P., Chu, T., et\u00a0al.: Cellular Network Traffic Scheduling With Deep Reinforcement Learning. In: Thirty-Second AAAI Conference on Artificial Intelligence (2018)","DOI":"10.1609\/aaai.v32i1.11339"},{"key":"9603_CR11","doi-asserted-by":"publisher","first-page":"397","DOI":"10.1109\/90.251892","volume":"1","author":"S Floyd","year":"1993","unstructured":"Floyd, S., Jacobson, V.: Random early detection gateways for congestion avoidance. IEEE\/ACM Trans. Netw. 1, 397\u2013413 (1993)","journal-title":"IEEE\/ACM Trans. Netw."},{"key":"9603_CR12","unstructured":"Gartner: Gartner says a typical family home could contain more than 500 smart devices by 2022 (2014)"},{"key":"9603_CR13","first-page":"249","volume":"9","author":"X Glorot","year":"2010","unstructured":"Glorot, X., Bengio, Y.: Understanding the difficulty of training deep feedforward neural networks. Proc. Thirteen. Int. Conf. Artif. Intell. Stat. 9, 249\u2013256 (2010)","journal-title":"Proc. Thirteen. Int. Conf. Artif. Intell. Stat."},{"key":"9603_CR14","doi-asserted-by":"publisher","first-page":"64","DOI":"10.1145\/1400097.1400105","volume":"42","author":"S Ha","year":"2008","unstructured":"Ha, S., Rhee, I., Xu, L.: CUBIC: a new TCP-friendly high-speed TCP variant. ACM SIGOPS Oper. Syst. Rev. 42, 64\u201374 (2008)","journal-title":"ACM SIGOPS Oper. Syst. Rev."},{"key":"9603_CR15","doi-asserted-by":"crossref","unstructured":"Hoeiland-Joergensen, T., McKenney, P., Taht, D., et\u00a0al.: The Flow Queue CoDel Packet Scheduler and Active Queue Management Algorithm. In: Internet Engineering Task Force (IETF), RFC 8290 (2018)","DOI":"10.17487\/RFC8290"},{"key":"9603_CR16","first-page":"1169","volume":"19","author":"SYL Huang","year":"2018","unstructured":"Huang, S.Y.L., Feng, C.: QRED: a Q-Learning-based active queue management scheme. J. Internet Technol. 19, 1169\u20131178 (2018)","journal-title":"J. Internet Technol."},{"key":"9603_CR17","unstructured":"IDC: Worldwide Internet of Things Forecast Update, 2017\u20132021. In: Document US43304017, IDC (2018)"},{"key":"9603_CR18","doi-asserted-by":"publisher","first-page":"1084","DOI":"10.1049\/el.2019.1146","volume":"55","author":"W Jin","year":"2019","unstructured":"Jin, W., Gu, R., Ji, Y., et al.: Dynamic traffic aware active queue management using deep reinforcement learning. Electron. Lett. 55, 1084\u20131086 (2019)","journal-title":"Electron. Lett."},{"key":"9603_CR19","unstructured":"Kingma, D.P., Ba, J.: Adam: A Method for Stochastic Optimization. In: arXiv preprint arXiv:1412.6980v9 (2017)"},{"key":"9603_CR20","doi-asserted-by":"publisher","first-page":"1399","DOI":"10.1109\/JIOT.2017.2722683","volume":"4","author":"J Kua","year":"2017","unstructured":"Kua, J., Nguyen, S.H., Armitage, G., et al.: Using active queue management to assist IoT application flows in home broadband networks. IEEE Internet Things J. 4, 1399\u20131407 (2017)","journal-title":"IEEE Internet Things J."},{"key":"9603_CR21","unstructured":"Kuhn, N., Natarajan, P., Khademi, N., et\u00a0al.: Characterization Guidelines for Active Queue Management (AQM). In: Internet Engineering Task Force (IETF), RFC 7928 (2016)"},{"key":"9603_CR22","doi-asserted-by":"publisher","first-page":"1125","DOI":"10.1109\/JIOT.2017.2683200","volume":"4","author":"J Lin","year":"2017","unstructured":"Lin, J., Yu, W., Zhang, N., et al.: A survey on Internet of Things: Architecture, Enabling technologies, security and privacy, and applications. IEEE Internet Things J. 4, 1125\u20131142 (2017)","journal-title":"IEEE Internet Things J."},{"key":"9603_CR23","unstructured":"Luong, N.C., et\u00a0al.: Applications of Deep Reinforcement Learning in Communications and Networking: A Survey. In: arXiv preprint arXiv:1810.07862 (2018)"},{"key":"9603_CR24","doi-asserted-by":"crossref","unstructured":"Mathis, M., Dukkipati, N., Cheng, Y.: Proportional Rate Reduction for TCP. In: Internet Engineering Task Force (IETF), RFC 6937 (2013)","DOI":"10.17487\/rfc6937"},{"key":"9603_CR25","doi-asserted-by":"crossref","unstructured":"Mnih, V., et\u00a0al.: Human-level control through deep reinforcement learning. Nature pp. 529\u2013533 (2015)","DOI":"10.1038\/nature14236"},{"key":"9603_CR26","doi-asserted-by":"publisher","first-page":"1826","DOI":"10.1109\/COMST.2018.2814571","volume":"20","author":"M Mukherjee","year":"2018","unstructured":"Mukherjee, M., Shu, L., Wang, D.: Survey of fog computing: fundamental, network applications, and research challenges. IEEE Commun. Surv. Tutor. 20, 1826\u20131857 (2018)","journal-title":"IEEE Commun. Surv. Tutor."},{"key":"9603_CR27","doi-asserted-by":"publisher","first-page":"42","DOI":"10.1145\/2209249.2209264","volume":"55","author":"K Nichols","year":"2012","unstructured":"Nichols, K., Jacobson, V.: Controlling queue delay. Commun. ACM 55, 42\u201350 (2012)","journal-title":"Commun. ACM"},{"key":"9603_CR28","doi-asserted-by":"crossref","unstructured":"Pan, R., Natarajan, P., Piglione, C., et\u00a0al.: PIE: A lightweight control scheme to address the bufferbloat problem. In: 2013 IEEE 14th International Conference on High Performance Switching and Routing (HPSR) (2013)","DOI":"10.1109\/HPSR.2013.6602305"},{"key":"9603_CR29","doi-asserted-by":"crossref","unstructured":"Sivanathan, A., Sherratt, D., Gharakheili, H.H., et\u00a0al.: Characterizing and classifying IoT traffic in smart cities and campuses. In: 2017 IEEE Conference on Computer Communications Workshops (INFOCOM WKSHPS) (2017)","DOI":"10.1109\/INFCOMW.2017.8116438"},{"key":"9603_CR30","unstructured":"Sungur, A.: Tcp: random early detection (red) mechanism for congestion control. Master\u2019s thesis, Rochester Institute of Technology (2015)"},{"key":"9603_CR31","volume-title":"Reinforcement Learning: An Introduction","author":"RS Sutton","year":"2018","unstructured":"Sutton, R.S., Barto, A.G.: Reinforcement Learning: An Introduction, 2nd edn. MIT Press, Cambridge (2018)","edition":"2"},{"key":"9603_CR32","doi-asserted-by":"crossref","unstructured":"Vucevic, N., Perez-Romero, J., Sallent, O., et\u00a0al.: Reinforcement Learning for Active Queue Management in Mobile All-IP Networks. In: 2007 IEEE 18th International Symposium on Personal, Indoor and Mobile Radio Communications (2007)","DOI":"10.1109\/PIMRC.2007.4394713"},{"key":"9603_CR33","doi-asserted-by":"crossref","unstructured":"Watkins, C.J.C.H., Dayan, P.: Q-learning. Machine Learning pp. 279\u2013292 (1992)","DOI":"10.1023\/A:1022676722315"},{"key":"9603_CR34","doi-asserted-by":"crossref","unstructured":"Xu, Z., Tang, J., Meng, J., et\u00a0al.: Experience-driven Networking: A Deep Reinforcement Learning based Approach. In: IEEE INFOCOM 2018\u2014IEEE Conference on Computer Communications (2018)","DOI":"10.1109\/INFOCOM.2018.8485853"},{"key":"9603_CR35","doi-asserted-by":"publisher","first-page":"998","DOI":"10.1109\/JIOT.2017.2788802","volume":"5","author":"A Yousefpour","year":"2018","unstructured":"Yousefpour, A., Ishigaki, G., Gour, R., et al.: On reducing IoT service delay via fog offloading. IEEE Internet Things J. 5, 998\u20131010 (2018)","journal-title":"IEEE Internet Things J."},{"key":"9603_CR36","doi-asserted-by":"publisher","first-page":"4228","DOI":"10.1109\/JIOT.2018.2875599","volume":"6","author":"Y Zhang","year":"2018","unstructured":"Zhang, Y., Feng, B., Quan, W., et al.: Theoretical analysis on edge computation offloading policies for IoT devices. IEEE Internet Things J. 6, 4228\u20134241 (2018)","journal-title":"IEEE Internet Things J."},{"key":"9603_CR37","doi-asserted-by":"publisher","first-page":"1334","DOI":"10.1109\/JIOT.2018.2811808","volume":"5","author":"L Zhao","year":"2018","unstructured":"Zhao, L., Sun, W., Shi, Y., et al.: Optimal placement of cloudlets for access delay minimization in SDN-based internet of things networks. IEEE Internet Things J. 5, 1334\u20131344 (2018)","journal-title":"IEEE Internet Things J."},{"key":"9603_CR38","doi-asserted-by":"publisher","first-page":"1169","DOI":"10.1109\/JIOT.2018.2808280","volume":"5","author":"S Zhao","year":"2018","unstructured":"Zhao, S., Yang, Y., Shao, Z., et al.: FEMOS: fog-enabled multitier operations scheduling in dynamic wireless networks. IEEE Internet Things J. 5, 1169\u20131183 (2018)","journal-title":"IEEE Internet Things J."},{"key":"9603_CR39","doi-asserted-by":"publisher","first-page":"496","DOI":"10.1109\/JIOT.2016.2577630","volume":"4","author":"X Zheng","year":"2016","unstructured":"Zheng, X., Cai, Z., Li, J., et al.: Scheduling flows with multiple service frequency constraints. IEEE Internet Things J. 4, 496\u2013504 (2016)","journal-title":"IEEE Internet Things J."}],"container-title":["Journal of Network and Systems Management"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/link.springer.com\/content\/pdf\/10.1007\/s10922-021-09603-x.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/link.springer.com\/article\/10.1007\/s10922-021-09603-x\/fulltext.html","content-type":"text\/html","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/link.springer.com\/content\/pdf\/10.1007\/s10922-021-09603-x.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2022,12,26]],"date-time":"2022-12-26T06:11:32Z","timestamp":1672035092000},"score":1,"resource":{"primary":{"URL":"https:\/\/link.springer.com\/10.1007\/s10922-021-09603-x"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2021,4,30]]},"references-count":39,"journal-issue":{"issue":"3","published-print":{"date-parts":[[2021,7]]}},"alternative-id":["9603"],"URL":"https:\/\/doi.org\/10.1007\/s10922-021-09603-x","relation":{},"ISSN":["1064-7570","1573-7705"],"issn-type":[{"value":"1064-7570","type":"print"},{"value":"1573-7705","type":"electronic"}],"subject":[],"published":{"date-parts":[[2021,4,30]]},"assertion":[{"value":"18 September 2020","order":1,"name":"received","label":"Received","group":{"name":"ArticleHistory","label":"Article History"}},{"value":"10 February 2021","order":2,"name":"revised","label":"Revised","group":{"name":"ArticleHistory","label":"Article History"}},{"value":"9 April 2021","order":3,"name":"accepted","label":"Accepted","group":{"name":"ArticleHistory","label":"Article History"}},{"value":"30 April 2021","order":4,"name":"first_online","label":"First Online","group":{"name":"ArticleHistory","label":"Article History"}}],"article-number":"34"}}