{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,4]],"date-time":"2026-10-04T17:40:05Z","timestamp":1791135605160,"version":"4.1.0"},"reference-count":44,"publisher":"Springer Science and Business Media LLC","issue":"3","license":[{"start":{"date-parts":[[2013,6,12]],"date-time":"2013-06-12T00:00:00Z","timestamp":1370995200000},"content-version":"tdm","delay-in-days":0,"URL":"http:\/\/www.springer.com\/tdm"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":["Wireless Pers Commun"],"published-print":{"date-parts":[[2013,12]]},"DOI":"10.1007\/s11277-013-1250-5","type":"journal-article","created":{"date-parts":[[2013,6,11]],"date-time":"2013-06-11T11:28:53Z","timestamp":1370950133000},"page":"1089-1116","source":"Crossref","is-referenced-by-count":45,"title":["IPv6 Multicast Forwarding in RPL-Based Wireless Sensor Networks"],"prefix":"10.1007","volume":"73","author":[{"given":"George","family":"Oikonomou","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Iain","family":"Phillips","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Theo","family":"Tryfonas","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"297","published-online":{"date-parts":[[2013,6,12]]},"reference":[{"key":"1250_CR1","doi-asserted-by":"crossref","unstructured":"Hui, J. W., & Culler, D. E. (2008). IP is dead, long live IP for wireless sensor networks. In Proceedings of the 6th ACM conference on Embedded network sensor systems (SenSys\u201908) (pp. 15\u201328).","DOI":"10.1145\/1460412.1460415"},{"key":"1250_CR2","unstructured":"Montenegro, G., Kushalnagar, N., Hui, J. W., & Culler, D. E. (2007). Transmission of IPv6 packets over IEEE 802.15.4 networks. RFC 4944."},{"key":"1250_CR3","unstructured":"Hui (editor), J., & Thubert, P. (2011). Compression format for IPv6 Datagrams over IEEE 802.15.4-Based Networks. RFC 6282."},{"key":"1250_CR4","unstructured":"Winter (editor), T., Thubert (editor), P., Brandt, A., Hui, J., Kelsey, R., Levis, P., et al. (2012). RPL: IPv6 Routing Protocol for Low power and Lossy Networks. RFC 6550."},{"key":"1250_CR5","doi-asserted-by":"crossref","unstructured":"Butt, T. A., Phillips, I., Guan, L., & Oikonomou, G. (2012). TRENDY: An adaptive and context-aware service discovery protocol for 6LoWPANs. In Proceedings of the third international workshop on the web of things (WoT 2012). Newcastle, UK.","DOI":"10.1145\/2379756.2379758"},{"key":"1250_CR6","unstructured":"Klauck, R., & Kirsche, M. (2012). Bonjour contiki: A case study of a DNS-based discovery service for the internet of things. In Proceedings of the 11th international IEEE conference on ad-hoc networks and wireless (ADHOC-NOW 2012) Lecture Notes in Computer Science (LNCS) (Vol. 7363, pp. 316\u2013329). Berlin: Springer."},{"key":"1250_CR7","doi-asserted-by":"crossref","unstructured":"Cheshire, S., & Krochmal, M. (2013). Multicast DNS. RFC 6762.","DOI":"10.17487\/rfc6762"},{"key":"1250_CR8","unstructured":"Lynn, K., & Sturek, D. (2012). Extended multicast dns. Internet Draft (version 01). (draft-lynn-homenet-site-mdns-01)."},{"key":"1250_CR9","doi-asserted-by":"crossref","unstructured":"Cheshire, S., & Krochmal, M. (2013). DNS-based service discovery. RFC 6763.","DOI":"10.17487\/rfc6763"},{"key":"1250_CR10","doi-asserted-by":"crossref","unstructured":"Klauck, R., & Kirsche, M. (2013). Enhanced DNS message compression\u2014optimizing mDNS\/DNS-SD for the use in 6LoWPANs. In Proceedings of the 9th international workshop on sensor networks and systems for pervasive computing (PerSeNS 2013).","DOI":"10.1109\/PerComW.2013.6529565"},{"key":"1250_CR11","unstructured":"Shelby, Z., Hartke, K., & Bormann, C. (2013). Constrained application protocol (CoAP). Internet Draft. (draft-ietf-core-coap-15)."},{"issue":"5","key":"1250_CR12","doi-asserted-by":"crossref","first-page":"627","DOI":"10.1109\/JSEN.2007.894149","volume":"7","author":"JA Sanchez","year":"2007","unstructured":"Sanchez, J. A., Ruiz, P. M., Liu, J., & Stojmenovic, I. (2007). Bandwidth-efficient geographic multicast routing protocol for wireless sensor networks. IEEE Sensors Journal, 7(5), 627\u2013636.","journal-title":"IEEE Sensors Journal"},{"issue":"5","key":"1250_CR13","doi-asserted-by":"crossref","first-page":"565","DOI":"10.1007\/s11276-012-0419-2","volume":"18","author":"JA Sanchez","year":"2012","unstructured":"Sanchez, J. A., Marin-Perez, R., & Ruiz, P. M. (2012). Beacon-less geographic multicast routing in a real-world wireless sensor network testbed. Wireless Networks, 18(5), 565\u2013578.","journal-title":"Wireless Networks"},{"key":"1250_CR14","doi-asserted-by":"crossref","unstructured":"Carzaniga, A., Khazaei, K., & Kuhn, F. (2012). Oblivious low-congestion multicast routing in wireless networks. In Proceedings of the thirteenth international symposium on mobile ad hoc networking and computing (MobiHoc 2012).","DOI":"10.1145\/2248371.2248395"},{"issue":"2","key":"1250_CR15","doi-asserted-by":"crossref","first-page":"240","DOI":"10.1109\/TMC.2011.61","volume":"11","author":"CH Feng","year":"2012","unstructured":"Feng, C. H., Zhang, Y., Demirkol, I., & Heinzelman, W. B. (2012). Stateless multicast protocol for ad hoc networks. IEEE Transactions on Mobile Computing, 11(2), 240\u2013253.","journal-title":"IEEE Transactions on Mobile Computing"},{"issue":"2","key":"1250_CR16","doi-asserted-by":"crossref","first-page":"449","DOI":"10.1007\/s11276-008-0146-x","volume":"16","author":"D Koutsonikolas","year":"2010","unstructured":"Koutsonikolas, D., Das, S. M., Hu, Y. C., & Stojmenovic, I. (2010). Hierarchical geographic multicast routing for wireless sensor networks. Wireless Networks, 16(2), 449\u2013466.","journal-title":"Wireless Networks"},{"key":"1250_CR17","unstructured":"Song, S., Choi, B. Y., Kim, D. (2010). MR. BIN: Multicast routing with branch information nodes for wireless sensor networks. In Proceedings of the 19th international conference on computer communications and networks (ICCCN 2010) (pp. 1\u20136)."},{"key":"1250_CR18","unstructured":"Hui, J., & Kelsey, R. (2012). Multicast forwarding using trickle. Internet Draft (version 01). (draft-ietf-roll-trickle-mcast-01)."},{"key":"1250_CR19","unstructured":"Oikonomou, G., & Phillips, I. (2011). Experiences from porting the contiki operating system to a popular hardware platform. In Proceedings of the 2011 international conference on distributed computing in sensor systems and workshops (DCOSS). Spain: Barcelona."},{"key":"1250_CR20","unstructured":"Oikonomou, G., & Phillips, I. (2012). Stateless multicast forwarding with RPL in 6LoWPAN sensor networks. In Proceedings of the 2012 IEEE international conference on pervasive computing and communications workshops (PERCOM Workshops). Switzerland: Lugano."},{"issue":"3","key":"1250_CR21","doi-asserted-by":"crossref","first-page":"347","DOI":"10.1109\/TPDS.2007.70731","volume":"19","author":"SM Das","year":"2008","unstructured":"Das, S. M., Pucha, H., & Hu, Y. C. (2008). Distributed hashing for scalable multicast in wireless ad hoc networks. IEEE Transactions on Parallel and Distributed Systems, 19(3), 347\u2013362.","journal-title":"IEEE Transactions on Parallel and Distributed Systems"},{"key":"1250_CR22","unstructured":"Song, S., Kim, D., & Choi, B. Y. (2009). Agsmr: Adaptive geo-source multicast routing for wireless sensor networks. In Proceedings of the wireless algorithms, systems, and applications, Lecture notes in computer science (Vol. 5682, pp. 200\u2013209). Springer:Berlin\/Heidelberg."},{"key":"1250_CR23","unstructured":"Okura, A., Ihara, T., & Miura, A. (2005). Bam: branch aggregation multicast for wireless sensor networks. In: IEEE international conference on mobile ad hoc and sensor systems conference (pp. 354\u2013363)."},{"key":"1250_CR24","doi-asserted-by":"crossref","unstructured":"Flury, R., & Wattenhofer, R. (2006). MLS: An efficient location service for mobile ad hoc networks. In Proceedings of the 7th ACM international symposium on mobile ad hoc networking and computing (MOBIHOC) (pp. 226\u2013237).","DOI":"10.1145\/1132905.1132931"},{"key":"1250_CR25","doi-asserted-by":"crossref","unstructured":"Li, J., Jannotti, J., De Couto, D. S. J., Karger, D. R., & Morris, R. (2000). A scalable location service for geographic ad hoc routing. In Proceedings of the 6th annual international conference on mobile computing and networking, MobiCom\u201900 (pp. 120\u2013130).","DOI":"10.1145\/345910.345931"},{"issue":"3","key":"1250_CR26","first-page":"19","volume":"3","author":"Silva J S\u00e1","year":"2008","unstructured":"S\u00e1, Silva J., Camilo, T., Pinto, P., Ruivo, R., Rodrigues, A., Gaud\u00eancio, F., et al. (2008). Multicast and ip multicast support in wireless sensor networks. Journal of Networks, 3(3), 19\u201326.","journal-title":"Journal of Networks"},{"key":"1250_CR27","doi-asserted-by":"crossref","unstructured":"Royer, E. M., & Perkins, C. E. (1999). Multicast operation of the ad-hoc on-demand distance vector routing protocol. In Proceedings of the 5th annual ACM\/IEEE international conference on Mobile computing and networking (MobiCom\u201999) (pp. 207\u2013218).","DOI":"10.1145\/313451.313538"},{"key":"1250_CR28","doi-asserted-by":"crossref","unstructured":"Bhattacharyya, S. (Ed.) (2003). An overview of source-specific multicast (SSM). RFC 3569.","DOI":"10.17487\/rfc3569"},{"key":"1250_CR29","unstructured":"Clausen, T., & Herberg, U. (2010). Comparative study of RPL-enabled optimized broadcast in wireless sensor networks. In Proceedings of the sixth international conference on intelligent sensors, sensor networks and information processing (ISSNIP 2010). Brisbane, Australia: IEEE."},{"key":"1250_CR30","unstructured":"Levis, P., Patel, N., Culler, D., & Shenker, S. (2004). Trickle: A self-regulating algorithm for code propagation and maintenance in wireless sensor networks. In Proceedings of the first USENIX\/ACM symposium on networked systems design and implementation (NSDI) (pp. 15\u201328)."},{"key":"1250_CR31","doi-asserted-by":"crossref","unstructured":"Levis, P., Clausen, T.H., Hui, J., Gnawali, O., & Ko, J. (2011). The trickle algorithm. RFC 6206.","DOI":"10.17487\/rfc6206"},{"issue":"7","key":"1250_CR32","doi-asserted-by":"crossref","first-page":"99","DOI":"10.1145\/1364782.1364804","volume":"51","author":"P Levis","year":"2008","unstructured":"Levis, P., Brewer, E., Culler, D., Gay, D., Madden, S., Patel, N., et al. (2008). The emergence of a networking primitive in wireless sensor networks. Communications of the ACM, 51(7), 99\u2013106.","journal-title":"Communications of the ACM"},{"key":"1250_CR33","doi-asserted-by":"crossref","unstructured":"Hui, J., & Culler, D. (2004). The dynamic behavior of a data dissemination protocol for network programming at scale. In Proceedings of the 2nd international conference on Embedded networked sensor systems (SenSys) (pp. 81\u201394).","DOI":"10.1145\/1031495.1031506"},{"key":"1250_CR34","unstructured":"Lin, K., & Levis, P. (2008). Data discovery and dissemination with DIP. In Proceedings of 7th international conference on information processing in sensor networks, IPSN\u201908 (pp. 433\u2013444). Washington, DC, USA: IEEE."},{"key":"1250_CR35","doi-asserted-by":"crossref","unstructured":"Hui, J., & Vasseur, J. P. (2012). The routing protocol for low-power and lossy networks (RPL) option for carrying RPL information in data-plane datagrams. RFC 6553.","DOI":"10.17487\/rfc6553"},{"key":"1250_CR36","unstructured":"Dunkels, A. (2011). The ContikiMAC radio duty cycling protocol. Technical Report T2011:13, Swedish Institute of Computer Science."},{"key":"1250_CR37","doi-asserted-by":"crossref","unstructured":"Dunkels, A., Mottola, L., Tsiftes, N., \u00d6sterlind, F., Eriksson, J., & Finne, N. (2011). The announcement layer: Beacon coordination for the sensornet stack. In Proceedings of the European conference on wireless sensor networks (EWSN).","DOI":"10.1007\/978-3-642-19186-2_14"},{"key":"1250_CR38","unstructured":"\u00d6sterlind, F., & Dunkels, A. (2008). Approaching the maximum 802.15.4 multi-hop throughput. In Proceedings of the fifth ACM workshop on embedded networked sensors (HotEmNets 2008)."},{"key":"1250_CR39","doi-asserted-by":"crossref","unstructured":"Duquennoy, S., \u00d6sterlind, F., & Dunkels, A. (2011). Lossy links, low power, high throughput. In Proceedings of the 9th ACM conference on embedded networked sensor systems (SenSys 2011).","DOI":"10.1145\/2070942.2070945"},{"key":"1250_CR40","unstructured":"Michopoulos, V., Guan, L., Oikonomou, G., & Phillips, I. (2012). DCCC6: Duty cycle-aware congestion control for 6LoWPAN networks. In Proceedings of the 2012 IEEE international conference on pervasive computing and communications workshops (PERCOM Workshops). Switzerland: Lugano."},{"key":"1250_CR41","unstructured":"Dunkels, A., \u00d6sterlind, F., Tsiftes, N., & He, Z. (2007). Demo abstract: Software-based sensor node energy estimation. In Proceedings of the fifth ACM conference on networked embedded sensor systems (SenSys 2007). Sydney, Australia: ACM."},{"key":"1250_CR42","unstructured":"Dunkels, A., \u00d6sterlind, F., Tsiftes, N., & He, Z. (2007). Software-based on-line energy estimation for sensor nodes. In Proceedings of the fourth workshop on embedded networked sensors (Emnets IV). Cork, Ireland: ACM."},{"key":"1250_CR43","unstructured":"Tmote sky: Ultra low power IEEE 802.15.4 compliant wireless sensor module. Moteiv Corporation (2006). Tmote Sky Datasheet Revision 1.0.2."},{"key":"1250_CR44","unstructured":"A True System on Chip solution for 2.4 GHz IEEE 802.15.4\/Zigbee\u00ae. (2007). CC2430 Data Sheet (rev. 2.1)."}],"container-title":["Wireless Personal Communications"],"original-title":[],"language":"en","link":[{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/s11277-013-1250-5.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"text-mining"},{"URL":"http:\/\/link.springer.com\/article\/10.1007\/s11277-013-1250-5\/fulltext.html","content-type":"text\/html","content-version":"vor","intended-application":"text-mining"},{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/s11277-013-1250-5","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2019,7,15]],"date-time":"2019-07-15T04:25:08Z","timestamp":1563164708000},"score":1,"resource":{"primary":{"URL":"http:\/\/link.springer.com\/10.1007\/s11277-013-1250-5"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2013,6,12]]},"references-count":44,"journal-issue":{"issue":"3","published-print":{"date-parts":[[2013,12]]}},"alternative-id":["1250"],"URL":"https:\/\/doi.org\/10.1007\/s11277-013-1250-5","relation":{},"ISSN":["0929-6212","1572-834X"],"issn-type":[{"value":"0929-6212","type":"print"},{"value":"1572-834X","type":"electronic"}],"subject":[],"published":{"date-parts":[[2013,6,12]]}}}