{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,3,2]],"date-time":"2025-03-02T11:40:02Z","timestamp":1740915602981,"version":"3.38.0"},"reference-count":36,"publisher":"Springer Science and Business Media LLC","issue":"3","license":[{"start":{"date-parts":[[2011,2,1]],"date-time":"2011-02-01T00:00:00Z","timestamp":1296518400000},"content-version":"tdm","delay-in-days":0,"URL":"http:\/\/www.springer.com\/tdm"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":["Sci. China Inf. Sci."],"published-print":{"date-parts":[[2011,3]]},"DOI":"10.1007\/s11432-010-4177-4","type":"journal-article","created":{"date-parts":[[2011,2,3]],"date-time":"2011-02-03T22:09:11Z","timestamp":1296770951000},"page":"609-622","source":"Crossref","is-referenced-by-count":3,"title":["Self-healing routing: failure, modeling and analysis"],"prefix":"10.1007","volume":"54","author":[{"given":"MingWei","family":"Xu","sequence":"first","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Qi","family":"Li","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Yuan","family":"Yang","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"MeiJia","family":"Hou","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"LingTao","family":"Pan","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"297","published-online":{"date-parts":[[2011,2,1]]},"reference":[{"key":"4177_CR1","unstructured":"Malkin G. RIP Version 2. RFC 1732, 1994"},{"key":"4177_CR2","doi-asserted-by":"crossref","unstructured":"Moy J. OSPF Version 2. RFC 2328, 1998","DOI":"10.17487\/rfc2328"},{"key":"4177_CR3","doi-asserted-by":"crossref","unstructured":"Oran D. OSI IS-IS Intra-domain Routing Protocol. RFC 1142, 1990","DOI":"10.17487\/rfc1142"},{"key":"4177_CR4","doi-asserted-by":"crossref","unstructured":"Rekhter Y, Li T. A Border Gateway Protocol 4 (BGP-4). RFC 1771, 1995","DOI":"10.17487\/rfc1771"},{"key":"4177_CR5","doi-asserted-by":"crossref","first-page":"33","DOI":"10.1145\/166237.166241","volume-title":"ACM SIGCOMM","author":"S. Floyd","year":"1993","unstructured":"Floyd S, Jacobson V. The synchronization of periodic routing messages. In: ACM SIGCOMM. New York: ACM, 1993. 33\u201344"},{"key":"4177_CR6","doi-asserted-by":"crossref","first-page":"293","DOI":"10.1109\/90.929852","volume":"9","author":"C. Labovitz","year":"2001","unstructured":"Labovitz C, Ahuja A, Bose A, et al. Delayed Internet routing convergence. IEEE\/ACM Trans Netw, 2001, 9: 293\u2013306","journal-title":"IEEE\/ACM Trans Netw"},{"key":"4177_CR7","first-page":"285","volume-title":"ACM IMW","author":"A. Sridharan","year":"2003","unstructured":"Sridharan A, Moon S B, Diot C. On the correlation between route dynamics and routing loops. In: ACM IMW. New York: ACM, 2003. 285\u2013294"},{"key":"4177_CR8","first-page":"30","volume-title":"ICNP","author":"F. Wang","year":"2005","unstructured":"Wang F, Gao L, Wang J, et al. On understanding of transient interdomain routing failures. In: ICNP. Washington: IEEE, 2005. 30\u201339"},{"key":"4177_CR9","first-page":"2307","volume-title":"INFOCOM","author":"A. Markopoulou","year":"2004","unstructured":"Markopoulou A, Iannaccone G, Bhattacharyya S, et al. Characterization of failures in an IP backbone. In: INFOCOM. New York: IEEE, 2004 2307\u20132317"},{"key":"4177_CR10","first-page":"237","volume-title":"ACM IMW","author":"G. Iannaccone","year":"2002","unstructured":"Iannaccone G, Chuah C, Mortier R, et al. Analysis of link failures in an IP backbone. In: ACM IMW. New York: ACM, 2002. 237\u2013242"},{"key":"4177_CR11","first-page":"348","volume-title":"INFOCOM","author":"L. Wang","year":"2007","unstructured":"Wang L, Saranu M, Gottlieb J, et al. Understanding BGP session failures in a large ISP. In: INFOCOM. New York: IEEE, 2007. 348\u2013356"},{"key":"4177_CR12","doi-asserted-by":"crossref","unstructured":"Katz D, Ward D. Bidirectional forwarding detection. In: RFC 5880 Internet Engineering Task Force, 2010","DOI":"10.17487\/rfc5880"},{"key":"4177_CR13","first-page":"307","volume-title":"SIGMETRICS","author":"R. Teixeira","year":"2003","unstructured":"Teixeira R, Shaikh A, Griffin T, et al. Dynamics of hot-potato routing in IP networks. In: SIGMETRICS. New York: ACM, 2003. 307\u2013319"},{"key":"4177_CR14","doi-asserted-by":"crossref","unstructured":"Villamizar C., Chandra R., Govindan. R., BGP Route Flap Dampening. RFC 2439. 1998.","DOI":"10.17487\/rfc2439"},{"key":"4177_CR15","doi-asserted-by":"crossref","first-page":"221","DOI":"10.1145\/633025.633047","volume-title":"ACM SIGCOMM","author":"Z. M. Mao","year":"2002","unstructured":"Mao Z M, Govindan R, Varghese G, et al. Route flap damping exacerbates Internet routing convergence. In: ACM SIGCOMM. New York: ACM, 2002. 221\u2013233"},{"key":"4177_CR16","doi-asserted-by":"crossref","first-page":"756","DOI":"10.1109\/JSAC.2002.1003042","volume":"20","author":"B. Fortz","year":"2002","unstructured":"Fortz B, Thorup M. Optimizing OSPF\/IS-IS weights in a changing world. IEEE J Select Areas Commun, 2002, 20: 756\u2013767","journal-title":"IEEE J Select Areas Commun"},{"key":"4177_CR17","doi-asserted-by":"crossref","first-page":"1933","DOI":"10.1109\/JSAC.2004.836002","volume":"22","author":"Y. Afek","year":"2004","unstructured":"Afek Y, Bremler-Barr A, Schwarz S. Improved BGP convergence via ghost flushing. IEEE J Select Areas Commun, 2004, 22: 1933\u20131948","journal-title":"IEEE J Select Areas Commun"},{"key":"4177_CR18","doi-asserted-by":"crossref","first-page":"241","DOI":"10.1145\/1282380.1282408","volume-title":"ACM SIGCOMM","author":"K. Lakshminarayanan","year":"2007","unstructured":"Lakshminarayanan K, Caesar M, Rangan M, et al. Achieving convergence-free routing using failure-carrying packets. In: ACM SIGCOMM. New York: ACM, 2007. 241\u2013252"},{"key":"4177_CR19","first-page":"91","volume-title":"HPSR 2003","author":"G. Schollmeiers","year":"2003","unstructured":"Schollmeiers G, Charzinski J, Kirstadter A, et al. Improving the resilience in IP networks. In: HPSR 2003. New York: IEEE, 2003. 91\u201396"},{"key":"4177_CR20","first-page":"547","volume-title":"INFOCOM 2001","author":"L. Gao","year":"2001","unstructured":"Gao L, Griffin T G, Rexford J. Inherently safe backup routing with BGP. In: INFOCOM 2001. New York: IEEE, 2001. 547\u2013556"},{"key":"4177_CR21","doi-asserted-by":"crossref","first-page":"171","DOI":"10.1145\/1159913.1159934","volume-title":"SIGCOMM 2006","author":"W. Xu","year":"2006","unstructured":"Xu W, Rexford J. MIRO: multi-path interdomain routing. In: SIGCOMM 2006. New York: ACM, 2006. 171\u2013182"},{"key":"4177_CR22","doi-asserted-by":"crossref","first-page":"126","DOI":"10.1145\/781027.781043","volume-title":"SIGMETRICS","author":"N. Feamster","year":"2003","unstructured":"Feamster N, Andersen D, Balakrishnan H, et al. Measuring the effects of Internet path faults on reactive routing. In: SIGMETRICS. New York: ACM, 2003. 126\u2013137"},{"key":"4177_CR23","doi-asserted-by":"crossref","first-page":"175","DOI":"10.1016\/j.comnet.2004.09.008","volume":"48","author":"D. Pei","year":"2005","unstructured":"Pei D, Azuma M, Massey D, et al. BGP-RCN: improving BGP convergence through root cause notification. Comput Netw, 2005, 48: 175\u2013194","journal-title":"Comput Netw"},{"key":"4177_CR24","doi-asserted-by":"crossref","unstructured":"Pei D, Zhao X L, Wang L, et al. Improving BGP convergence through consistency assertions. In: INFOCOM 2002, New York, 2002. 902\u2013911","DOI":"10.1109\/INFCOM.2002.1019337"},{"key":"4177_CR25","doi-asserted-by":"crossref","first-page":"13","DOI":"10.1145\/1080091.1080095","volume-title":"SIGCOMM","author":"L. Subramanian","year":"2005","unstructured":"Subramanian L, Caesar M, Ee C T, et al. HLP: a next generation interdomain routing protocol. In: SIGCOMM. New York: ACM, 2005. 13\u201324"},{"key":"4177_CR26","doi-asserted-by":"crossref","unstructured":"Bates T, Chen E, Chandra R. BGP route reflection: an alternative to full mesh internal BGP (iBGP). RFC 4456. 2006","DOI":"10.17487\/rfc4456"},{"key":"4177_CR27","first-page":"235","volume-title":"SIGCOMM","author":"A. Basu","year":"2002","unstructured":"Basu A, Ong C L, Rasala A, et al. Router oscillations in I-BGP with route reflection. In: SIGCOMM. New York: ACM, 2002. 235\u2013247"},{"key":"4177_CR28","unstructured":"Shand M, Bryant S. IP fast reroute framework. In: Internet Draft, draft-ietf-rtgwg-ipfrr-framework-08.txt, Internet Engineering Task Force, 2008"},{"key":"4177_CR29","unstructured":"Shand M, Bryant S. A framework for loop-free convergence. In: Internet Draft, draft-ietf-rtgwg-lf-conv-frmwk-02. txt, Internet Engineering Task Force, 2008"},{"key":"4177_CR30","unstructured":"Bryant S, Shand M, Previdi S. IP fast reroute using Notvia addresses. In: Internet Draft, draft-ietf-rtgwg-ipfrr-notviaaddresses-02. txt, Internet Engineering Task Force, 2008"},{"key":"4177_CR31","doi-asserted-by":"crossref","first-page":"359","DOI":"10.1109\/TNET.2007.892851","volume":"15","author":"S. Nelakuditi","year":"2007","unstructured":"Nelakuditi S, Lee S, Yu Y, et al. Fast local rerouting for handling transient link failures. IEEE\/ACM Trans Netw, 2007, 15: 359\u2013372","journal-title":"IEEE\/ACM Trans Netw"},{"key":"4177_CR32","unstructured":"Bryant S, Filsfils C, Previdi S, et al. IP fast reroute using tunnels. In: Internet Draft, draft-bryant-ipfrr-tunnels-03. txt, Internet Engineering Task Force, 2007"},{"key":"4177_CR33","unstructured":"Atlas A, Zinin A. Basic specification for IP fast-reroute: loop-free alternates. In: Internet Draft, draft-ietf-rtgwg-ipfrrspec-base-12. txt, Internet Engineering Task Force, 2008"},{"key":"4177_CR34","doi-asserted-by":"crossref","first-page":"1123","DOI":"10.1109\/TNET.2007.906045","volume":"15","author":"O. Bonaventure","year":"2007","unstructured":"Bonaventure O, Filsfils C, Francois P. Achieving Sub50 milliseconds recovery upon BGP peering link failures. IEEE\/ACM Trans Netw, 2007, 15: 1123\u20131135","journal-title":"IEEE\/ACM Trans Netw"},{"key":"4177_CR35","first-page":"554","volume-title":"IFIP Networking","author":"Q. Li","year":"2008","unstructured":"Li Q, Xu M, Pan L, et al. A study of path protection in self-healing routing. In: IFIP Networking. Berlin: Springer-Verlag, 2008. 554\u2013561"},{"key":"4177_CR36","doi-asserted-by":"crossref","unstructured":"Li Q, Xu M, Wu J, et al. Achieving unified protection for IP routing. In: IEEE ICCCN 2010, New York, 2010. 1\u20136","DOI":"10.1109\/ICCCN.2010.5560122"}],"container-title":["Science China Information Sciences"],"original-title":[],"language":"en","link":[{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/s11432-010-4177-4.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"text-mining"},{"URL":"http:\/\/link.springer.com\/article\/10.1007\/s11432-010-4177-4\/fulltext.html","content-type":"text\/html","content-version":"vor","intended-application":"text-mining"},{"URL":"http:\/\/link.springer.com\/content\/pdf\/10.1007\/s11432-010-4177-4","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,3,2]],"date-time":"2025-03-02T10:40:15Z","timestamp":1740912015000},"score":1,"resource":{"primary":{"URL":"http:\/\/link.springer.com\/10.1007\/s11432-010-4177-4"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2011,2,1]]},"references-count":36,"journal-issue":{"issue":"3","published-print":{"date-parts":[[2011,3]]}},"alternative-id":["4177"],"URL":"https:\/\/doi.org\/10.1007\/s11432-010-4177-4","relation":{},"ISSN":["1674-733X","1869-1919"],"issn-type":[{"type":"print","value":"1674-733X"},{"type":"electronic","value":"1869-1919"}],"subject":[],"published":{"date-parts":[[2011,2,1]]}}}