{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,10,2]],"date-time":"2025-10-02T16:24:11Z","timestamp":1759422251514,"version":"3.37.3"},"reference-count":44,"publisher":"Springer Science and Business Media LLC","issue":"1","license":[{"start":{"date-parts":[[2021,1,2]],"date-time":"2021-01-02T00:00:00Z","timestamp":1609545600000},"content-version":"tdm","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0"},{"start":{"date-parts":[[2021,1,2]],"date-time":"2021-01-02T00:00:00Z","timestamp":1609545600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0"}],"content-domain":{"domain":["link.springer.com"],"crossmark-restriction":false},"short-container-title":["Comput Softw Big Sci"],"published-print":{"date-parts":[[2021,12]]},"abstract":"<jats:title>Abstract<\/jats:title><jats:p>Data collection at the Belle II experiment started in the spring of 2019. During the early stages of the experiment it is important that the raw data are both copied to permanent storage and made available soon after being recorded to allow for the timely commissioning and calibration of the detector. Automated procedures have been developed to transfer the data from the detector in a timely manner; these procedures include fault management, performance monitoring, and quality checks. It is important that the systems put in place will also scale to the much higher data rates expected in the coming years at Belle\u00a0II. The development, implementation, and operations of the Belle\u00a0II online\u2013offline data transfer system will be described.<\/jats:p>","DOI":"10.1007\/s41781-020-00045-9","type":"journal-article","created":{"date-parts":[[2021,1,2]],"date-time":"2021-01-02T18:02:26Z","timestamp":1609610546000},"update-policy":"https:\/\/doi.org\/10.1007\/springer_crossmark_policy","source":"Crossref","is-referenced-by-count":1,"title":["The Belle II Online\u2013Offline Data Operations System"],"prefix":"10.1007","volume":"5","author":[{"ORCID":"https:\/\/orcid.org\/0000-0002-2095-603X","authenticated-orcid":false,"given":"Matthew","family":"Barrett","sequence":"first","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Takanori","family":"Hara","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Michel","family":"Hern\u00e1ndez Villanueva","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Kunxian","family":"Huang","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Dhiraj","family":"Kalita","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Petteri","family":"Kettunen","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Prashant","family":"Shingade","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"297","published-online":{"date-parts":[[2021,1,2]]},"reference":[{"issue":"11","key":"45_CR1","doi-asserted-by":"publisher","first-page":"3026","DOI":"10.1140\/epjc\/s10052-014-3026-9","volume":"74","author":"AJ Bevan","year":"2014","unstructured":"Bevan AJ et al (2014) The physics of the B factories. Eur Phys J C 74(11):3026. https:\/\/doi.org\/10.1140\/epjc\/s10052-014-3026-9","journal-title":"Eur Phys J C"},{"key":"45_CR2","unstructured":"Abe T et\u00a0al. (2010) Belle II technical design report. Technical report, Belle II collaboration. arXiv:1011.0352"},{"key":"45_CR3","doi-asserted-by":"publisher","first-page":"123C01","DOI":"10.1093\/ptep\/ptz106","volume":"2019","author":"E Kou","year":"2019","unstructured":"Kou E et al (2019) The Belle II Physics Book. Prog Theor Exp Phys 2019:123C01. https:\/\/doi.org\/10.1093\/ptep\/ptz106","journal-title":"Prog Theor Exp Phys"},{"key":"45_CR4","unstructured":"Taniguchi N (2020) SuperKEKB\/Belle II. In: Presented at KEK roadmap open symposium. https:\/\/kds.kek.jp\/indico\/event\/34739\/. Accessed 6 July 2020"},{"key":"45_CR5","doi-asserted-by":"publisher","first-page":"81","DOI":"10.1016\/S0168-9002(97)00048-X","volume":"389","author":"R Brun","year":"1997","unstructured":"Brun R, Rademakers F (1997) Root\u2014an object oriented data analysis framework. Nucl Instrum Methods 389:81. https:\/\/doi.org\/10.1016\/S0168-9002(97)00048-X","journal-title":"Nucl Instrum Methods"},{"key":"45_CR6","unstructured":"DIRAC | The Interware. http:\/\/diracgrid.org\/. Accessed 05 May 2020"},{"issue":"5","key":"45_CR7","doi-asserted-by":"publisher","first-page":"052028","DOI":"10.1088\/1742-6596\/664\/5\/052028","volume":"664","author":"H Miyake","year":"2015","unstructured":"Miyake H, Grzymkowski R, Ludacka R, Schram M (2015) Belle II production system. J Phys Conf Ser 664(5):052028. https:\/\/doi.org\/10.1088\/1742-6596\/664\/5\/052028","journal-title":"J Phys Conf Ser"},{"key":"45_CR8","unstructured":"Brookhaven National Laboratory (BNL), P.O. Box 5000, Upton, NY 11973-5000, USA. http:\/\/www.bnl.gov\/. Accessed 11 Oct 2019"},{"key":"45_CR9","doi-asserted-by":"publisher","first-page":"69","DOI":"10.1016\/j.nima.2018.05.071","volume":"914","author":"P Lewis","year":"2019","unstructured":"Lewis P et al (2019) Nuclear instruments and methods in physics research section A: accelerators. Spectrom Detect Assoc Equip 914:69. https:\/\/doi.org\/10.1016\/j.nima.2018.05.071","journal-title":"Spectrom Detect Assoc Equip"},{"key":"45_CR10","unstructured":"SuperKEKB Project. http:\/\/www-superkekb.kek.jp. Accessed 22 Jan 2020"},{"key":"45_CR11","unstructured":"Belle II Luminosity. https:\/\/confluence.desy.de\/display\/BI\/Belle+II+Luminosity. Accessed 7 July 2020"},{"key":"45_CR12","unstructured":"Forti F BELLE II and flavor physics in e+e-. In: Presented at European physical society conference on high energy physics (EPS-HEP2019). https:\/\/indico.cern.ch\/event\/577856\/contributions\/3396819\/. Accessed 7 July 2020"},{"issue":"3","key":"45_CR13","doi-asserted-by":"publisher","first-page":"1175","DOI":"10.1109\/TNS.2015.2424717","volume":"62","author":"S Yamada","year":"2015","unstructured":"Yamada S et al (2015) Data acquisition system for the Belle II experiment. IEEE Trans Nuclear Sci 62(3):1175. https:\/\/doi.org\/10.1109\/TNS.2015.2424717","journal-title":"IEEE Trans Nuclear Sci"},{"issue":"3","key":"45_CR14","doi-asserted-by":"publisher","first-page":"1162","DOI":"10.1109\/TNS.2015.2422376","volume":"62","author":"SY Suzuki","year":"2015","unstructured":"Suzuki SY et al (2015) The three-level event building system for the Belle II experiment. IEEE Trans Nuclear Sci 62(3):1162. https:\/\/doi.org\/10.1109\/TNS.2015.2422376","journal-title":"IEEE Trans Nuclear Sci"},{"key":"45_CR15","unstructured":"Rsync. https:\/\/rsync.samba.org\/. Accessed 19 Apr 2019"},{"issue":"1","key":"45_CR16","doi-asserted-by":"publisher","first-page":"1","DOI":"10.1007\/s41781-018-0017-9","volume":"3","author":"T Kuhr","year":"2018","unstructured":"Kuhr T et al (2018) The Belle II core software. Comput Softw Big Sci 3(1):1. https:\/\/doi.org\/10.1007\/s41781-018-0017-9","journal-title":"Comput Softw Big Sci"},{"key":"45_CR17","unstructured":"GNU Bash. http:\/\/www.gnu.org\/software\/bash\/. Accessed 13 May 2019"},{"key":"45_CR18","unstructured":"IBM Spectrum Scale. https:\/\/www.ibm.com\/support\/knowledgecenter\/en\/SSFKCN\/gpfs_welcome.html.\u00a0Accessed 28 Nov 2020"},{"key":"45_CR19","unstructured":"KEKCC HSM System. https:\/\/kekcc.kek.jp\/service\/kekcc\/html\/Eng\/HSM20System.html. Accessed 21 Jan 2020"},{"key":"45_CR20","doi-asserted-by":"publisher","unstructured":"Gerhards R (2009) The Syslog protocol, RFC 5424. https:\/\/doi.org\/10.17487\/RFC5424","DOI":"10.17487\/RFC5424"},{"key":"45_CR21","unstructured":"Logger. https:\/\/www.linux.org\/docs\/man1\/logger.html. Accessed 15 May 2019"},{"key":"45_CR22","unstructured":"Netsyslog. http:\/\/hacksaw.sourceforge.net\/netsyslog\/. Accessed 15 May 2019"},{"key":"45_CR23","unstructured":"Task Spooler. http:\/\/viric.name\/soft\/ts\/. Accessed 13 May 2019"},{"key":"45_CR24","unstructured":"ITU-T Recommendation X.733 (02\/92): information technology\u2014open systems interconnection\u2014systems management: alarm reporting function. https:\/\/www.itu.int\/rec\/T-REC-X.733-199202-I. Accessed 6 Aug 2019"},{"key":"45_CR25","doi-asserted-by":"publisher","unstructured":"Deutsch P, Gailly, JL (1996) ZLIB Compressed Data Format Specification version 3.3, RFC 1950. https:\/\/doi.org\/10.17487\/RFC1950","DOI":"10.17487\/RFC1950"},{"key":"45_CR26","doi-asserted-by":"publisher","unstructured":"Rivest R (1992) The MD5 message\u2014digest algorithm. RFC 1321. https:\/\/doi.org\/10.17487\/RFC1321","DOI":"10.17487\/RFC1321"},{"key":"45_CR27","unstructured":"ELOG. https:\/\/elog.psi.ch\/elog\/. Accessed 1 Aug 2019"},{"key":"45_CR28","doi-asserted-by":"publisher","first-page":"04005","DOI":"10.1051\/epjconf\/202024504005","volume":"245","author":"M Villanueva","year":"2020","unstructured":"Villanueva M, Ueda I (2020) The Belle II raw data management system. EPJ Web Conf. 245:04005. https:\/\/doi.org\/10.1051\/epjconf\/202024504005","journal-title":"EPJ Web Conf."},{"key":"45_CR29","doi-asserted-by":"publisher","first-page":"04007","DOI":"10.1051\/epjconf\/202024504007","volume":"245","author":"S Padolski","year":"2020","unstructured":"Padolski S et al (2020) The Belle II raw data management system. EPJ Web Conf. 245:04007. https:\/\/doi.org\/10.1051\/epjconf\/202024504007","journal-title":"EPJ Web Conf."},{"key":"45_CR30","doi-asserted-by":"publisher","first-page":"11","DOI":"10.1007\/s41781-019-0026-3","volume":"3","author":"M Barisits","year":"2019","unstructured":"Barisits M et al (2019) Rucio: scientific data management. Comput Softw Big Sci 3:11. https:\/\/doi.org\/10.1007\/s41781-019-0026-3","journal-title":"Comput Softw Big Sci"},{"key":"45_CR31","doi-asserted-by":"publisher","first-page":"11006","DOI":"10.1051\/epjconf\/202024511006","volume":"245","author":"M Lassnig","year":"2020","unstructured":"Lassnig M et al (2020) Rucio beyond ATLAS: experiences from Belle II, CMS, DUNE, EISCAT3D, LIGO\/VIRGO, SKA, Xenon. EPJ Web Conf. 245:11006. https:\/\/doi.org\/10.1051\/epjconf\/202024511006","journal-title":"EPJ Web Conf."},{"key":"45_CR32","unstructured":"PostgreSQL. https:\/\/www.postgresql.org\/. Accessed 19 Aug 2019"},{"key":"45_CR33","unstructured":"Django. https:\/\/www.djangoproject.com. Accessed 14 Sep 2019"},{"key":"45_CR34","unstructured":"React. https:\/\/reactjs.org\/. Accessed 14 Sep 2019"},{"key":"45_CR35","unstructured":"Pandas: python data analysis library. https:\/\/pandas.pydata.org\/. Accessed 19 July 2019"},{"key":"45_CR36","unstructured":"Plotly. https:\/\/plot.ly\/python\/. Accessed 19 Sep 2019"},{"key":"45_CR37","unstructured":"DataTables. https:\/\/datatables.net\/. Accessed 22 Jan 2020"},{"key":"45_CR38","unstructured":"Flaskapp. https:\/\/pypi.org\/project\/flaskapp\/. Accessed 22 Jan 2020"},{"key":"45_CR39","unstructured":"Deutsches Elektronen-Synchrotron (DESY), Notkestra\u00dfe 85, D\u201322607 Hamburg, Germany. https:\/\/www.desy.de\/. Accessed 11 Oct 2019"},{"key":"45_CR40","unstructured":"Git. https:\/\/git-scm.com\/. Accessed 22 Jan 2020"},{"key":"45_CR41","unstructured":"Bitbucket. https:\/\/bitbucket.org. Accessed 22 Jan 2020"},{"key":"45_CR42","unstructured":"Jira\u2014issue and project tracking software. https:\/\/www.atlassian.com\/software\/jira. Accessed 22 Jan 2020"},{"key":"45_CR43","unstructured":"Atlassian Agile. https:\/\/www.atlassian.com\/agile. Accessed 22 Jan 2020"},{"key":"45_CR44","unstructured":"Confluence\u2014team collaboration software. https:\/\/www.atlassian.com\/software\/confluence. Accessed 22 Jan 2020"}],"container-title":["Computing and Software for Big Science"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/link.springer.com\/content\/pdf\/10.1007\/s41781-020-00045-9.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/link.springer.com\/article\/10.1007\/s41781-020-00045-9\/fulltext.html","content-type":"text\/html","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/link.springer.com\/content\/pdf\/10.1007\/s41781-020-00045-9.pdf","content-type":"application\/pdf","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2021,12,26]],"date-time":"2021-12-26T11:02:57Z","timestamp":1640516577000},"score":1,"resource":{"primary":{"URL":"https:\/\/link.springer.com\/10.1007\/s41781-020-00045-9"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2021,1,2]]},"references-count":44,"journal-issue":{"issue":"1","published-print":{"date-parts":[[2021,12]]}},"alternative-id":["45"],"URL":"https:\/\/doi.org\/10.1007\/s41781-020-00045-9","relation":{},"ISSN":["2510-2036","2510-2044"],"issn-type":[{"type":"print","value":"2510-2036"},{"type":"electronic","value":"2510-2044"}],"subject":[],"published":{"date-parts":[[2021,1,2]]},"assertion":[{"value":"29 July 2020","order":1,"name":"received","label":"Received","group":{"name":"ArticleHistory","label":"Article History"}},{"value":"9 November 2020","order":2,"name":"accepted","label":"Accepted","group":{"name":"ArticleHistory","label":"Article History"}},{"value":"2 January 2021","order":3,"name":"first_online","label":"First Online","group":{"name":"ArticleHistory","label":"Article History"}},{"order":1,"name":"Ethics","group":{"name":"EthicsHeading","label":"Compliance with ethical standards"}},{"value":"The authors declare that they have no conflict of interest.","order":2,"name":"Ethics","group":{"name":"EthicsHeading","label":"Conflict of interest"}}],"article-number":"1"}}