{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,8,10]],"date-time":"2026-08-10T15:31:17Z","timestamp":1786375877396,"version":"build-2736575974"},"reference-count":71,"publisher":"Elsevier BV","license":[{"start":{"date-parts":[[2026,9,1]],"date-time":"2026-09-01T00:00:00Z","timestamp":1788220800000},"content-version":"tdm","delay-in-days":0,"URL":"https:\/\/www.elsevier.com\/tdm\/userlicense\/1.0\/"},{"start":{"date-parts":[[2026,9,1]],"date-time":"2026-09-01T00:00:00Z","timestamp":1788220800000},"content-version":"tdm","delay-in-days":0,"URL":"https:\/\/www.elsevier.com\/legal\/tdmrep-license"},{"start":{"date-parts":[[2026,7,16]],"date-time":"2026-07-16T00:00:00Z","timestamp":1784160000000},"content-version":"vor","delay-in-days":0,"URL":"http:\/\/creativecommons.org\/licenses\/by\/4.0\/"}],"funder":[{"DOI":"10.13039\/501100000780","name":"European Commission","doi-asserted-by":"publisher","id":[{"id":"10.13039\/501100000780","id-type":"DOI","asserted-by":"publisher"}]},{"DOI":"10.13039\/501100024370","name":"Ministero dell'Istruzione dell'Universit\u00e0 e della Ricerca","doi-asserted-by":"publisher","id":[{"id":"10.13039\/501100024370","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["elsevier.com","sciencedirect.com"],"crossmark-restriction":true},"short-container-title":["Computer Networks"],"published-print":{"date-parts":[[2026,9]]},"DOI":"10.1016\/j.comnet.2026.112560","type":"journal-article","created":{"date-parts":[[2026,7,16]],"date-time":"2026-07-16T05:33:48Z","timestamp":1784180028000},"page":"112560","update-policy":"https:\/\/doi.org\/10.1016\/elsevier_cm_policy","source":"Crossref","is-referenced-by-count":0,"special_numbering":"C","title":["P4ICS: P4 in-network security for Industrial Control Systems networks"],"prefix":"10.1016","volume":"287","author":[{"ORCID":"https:\/\/orcid.org\/0000-0003-1767-7256","authenticated-orcid":false,"given":"Lorenzo","family":"Rinieri","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-0101-2551","authenticated-orcid":false,"given":"Andrea","family":"Melis","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-1298-7960","authenticated-orcid":false,"given":"Roberto","family":"Girau","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0003-2216-7170","authenticated-orcid":false,"given":"Giovanni","family":"Pau","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-3962-5513","authenticated-orcid":false,"given":"Marco","family":"Prandini","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-6669-8072","authenticated-orcid":false,"given":"Franco","family":"Callegati","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"78","reference":[{"issue":"4","key":"10.1016\/j.comnet.2026.112560_b1","doi-asserted-by":"crossref","first-page":"2248","DOI":"10.1109\/COMST.2021.3094360","article-title":"A survey on industrial control system testbeds and datasets for security research","volume":"23","author":"Conti","year":"2021","journal-title":"IEEE Commun. Surv. Tutor."},{"key":"10.1016\/j.comnet.2026.112560_b2","doi-asserted-by":"crossref","unstructured":"E. Rescorla, The Transport Layer Security (TLS) Protocol Version 1.3, RFC 8446, 2018, http:\/\/dx.doi.org\/10.17487\/RFC8446, URL https:\/\/www.rfc-editor.org\/info\/rfc8446.","DOI":"10.17487\/RFC8446"},{"key":"10.1016\/j.comnet.2026.112560_b3","doi-asserted-by":"crossref","unstructured":"E. Rescorla, N. Modadugu, Datagram Transport Layer Security Version 1.2, RFC 6347, 2012, http:\/\/dx.doi.org\/10.17487\/RFC6347, URL https:\/\/www.rfc-editor.org\/info\/rfc6347.","DOI":"10.17487\/rfc6347"},{"key":"10.1016\/j.comnet.2026.112560_b4","series-title":"Modbus\/TCP security protocol specification","author":"Modbus Organization","year":"2021"},{"key":"10.1016\/j.comnet.2026.112560_b5","series-title":"CIP security specification","author":"ODVA","year":"2015"},{"key":"10.1016\/j.comnet.2026.112560_b6","series-title":"IEC 62351: Power systems management and associated information exchange \u2013 data and communications security","author":"IEC","year":"2007"},{"key":"10.1016\/j.comnet.2026.112560_b7","series-title":"Proceedings of the ACM Internet Measurement Conference","first-page":"101","article-title":"Easing the conscience with OPC UA: An internet-wide study on insecure deployments","author":"Dahlmanns","year":"2020"},{"key":"10.1016\/j.comnet.2026.112560_b8","doi-asserted-by":"crossref","unstructured":"M. Dahlmanns, J. Lohm\u00f6ller, J. Pennekamp, J. Bodenhausen, K. Wehrle, M. Henze, Missed opportunities: measuring the untapped TLS support in the industrial internet of things, in: Proceedings of the 2022 ACM on Asia Conference on Computer and Communications Security, 2022, pp. 252\u2013266.","DOI":"10.1145\/3488932.3497762"},{"key":"10.1016\/j.comnet.2026.112560_b9","series-title":"NOMS 2024-2024 IEEE Network Operations and Management Symposium","first-page":"1","article-title":"Protocol security in the industrial internet of things","author":"Dahlmanns","year":"2024"},{"key":"10.1016\/j.comnet.2026.112560_b10","doi-asserted-by":"crossref","unstructured":"I. Kunze, K. Wehrle, D. Trossen, M.-J. Montpetit, X. de Foy, D. Griffin, M. Rio, Use Cases for In-Network Computing, RFC 9817, 2025, http:\/\/dx.doi.org\/10.17487\/RFC9817, URL https:\/\/www.rfc-editor.org\/info\/rfc9817.","DOI":"10.17487\/RFC9817"},{"issue":"3","key":"10.1016\/j.comnet.2026.112560_b11","doi-asserted-by":"crossref","first-page":"87","DOI":"10.1145\/2656877.2656890","article-title":"P4: Programming protocol-independent packet processors","volume":"44","author":"Bosshart","year":"2014","journal-title":"ACM SIGCOMM Comput. Commun. Rev."},{"key":"10.1016\/j.comnet.2026.112560_b12","doi-asserted-by":"crossref","DOI":"10.1016\/j.comnet.2024.110397","article-title":"Leveraging data plane programmability to enhance service orchestration at the edge: A focus on industrial security","volume":"246","author":"Pittal\u00e0","year":"2024","journal-title":"Computer Networks"},{"key":"10.1016\/j.comnet.2026.112560_b13","series-title":"Modbus protocol specification","author":"Modicon","year":"1979"},{"key":"10.1016\/j.comnet.2026.112560_b14","series-title":"IEEE standard for electric power systems communications \u2013 distributed network protocol (DNP3)","author":"IEEE","year":"2010"},{"key":"10.1016\/j.comnet.2026.112560_b15","series-title":"Overview of DNP3 security version 6","author":"Harris","year":"2020"},{"issue":"3","key":"10.1016\/j.comnet.2026.112560_b16","doi-asserted-by":"crossref","first-page":"74","DOI":"10.1109\/MSP.2015.47","article-title":"Bolt-on security extensions for industrial control system protocols: A case study of dnp3 sav5","volume":"13","author":"Crain","year":"2015","journal-title":"IEEE Secur. Priv."},{"key":"10.1016\/j.comnet.2026.112560_b17","unstructured":"C. Rosborough, C. Gordon, B. Waldron, All about eve: comparing DNP3 secure authentication with standard security technologies for SCADA communications, in: 13th Australasian Information Security Conference, Vol. 161, 2019."},{"key":"10.1016\/j.comnet.2026.112560_b18","series-title":"Authentication of individual users in DNP3 secure authentication- TB2019-001, and more","author":"Landheer-Cieslak","year":"2019"},{"key":"10.1016\/j.comnet.2026.112560_b19","series-title":"Ethernet\/IP specification: CIP on ethernet technology","author":"ODVA","year":"2000"},{"key":"10.1016\/j.comnet.2026.112560_b20","series-title":"MQTT version 3.1 specification","author":"IBM","year":"1999"},{"key":"10.1016\/j.comnet.2026.112560_b21","series-title":"OASIS standard: MQTT version 5.0","author":"OASIS","year":"2019"},{"key":"10.1016\/j.comnet.2026.112560_b22","doi-asserted-by":"crossref","first-page":"201071","DOI":"10.1109\/ACCESS.2020.3035849","article-title":"The use of MQTT in M2M and IoT systems: A survey","volume":"8","author":"Mishra","year":"2020","journal-title":"IEEE Access"},{"key":"10.1016\/j.comnet.2026.112560_b23","series-title":"IEC 60870-5-104: Telecontrol equipment and systems \u2013 transmission protocols \u2013 network access for IEC 60870-5-101 using standard transport profiles","author":"IEC","year":"2000"},{"key":"10.1016\/j.comnet.2026.112560_b24","series-title":"IEC 61850: Communication networks and systems in substations","author":"IEC","year":"2003"},{"key":"10.1016\/j.comnet.2026.112560_b25","series-title":"PROFINET standard","author":"International","year":"2003"},{"key":"10.1016\/j.comnet.2026.112560_b26","series-title":"ANSI\/ASHRAE standard 135-1995: BACnet \u2014 A data communication protocol for building automation and control networks","author":"ASHRAE","year":"1995"},{"key":"10.1016\/j.comnet.2026.112560_b27","series-title":"2021 International Conference on Computer Communications and Networks (Icccn)","first-page":"1","article-title":"Assessing the use of insecure ics protocols via ixp network traffic analysis","author":"Barbieri","year":"2021"},{"key":"10.1016\/j.comnet.2026.112560_b28","series-title":"PROFINET security classes","author":"International","year":"2019"},{"key":"10.1016\/j.comnet.2026.112560_b29","series-title":"BACnet secure connect (BACnet\/SC)","author":"ASHRAE","year":"2019"},{"key":"10.1016\/j.comnet.2026.112560_b30","doi-asserted-by":"crossref","first-page":"58845","DOI":"10.1109\/ACCESS.2020.2982859","article-title":"P4-MACsec: Dynamic topology monitoring and data layer protection with MACsec in P4-based SDN","volume":"8","author":"Hauser","year":"2020","journal-title":"IEEE Access"},{"key":"10.1016\/j.comnet.2026.112560_b31","doi-asserted-by":"crossref","first-page":"139567","DOI":"10.1109\/ACCESS.2020.3012738","article-title":"P4-ipsec: Site-to-site and host-to-site vpn with ipsec in p4-based sdn","volume":"8","author":"Hauser","year":"2020","journal-title":"IEEE Access"},{"key":"10.1016\/j.comnet.2026.112560_b32","doi-asserted-by":"crossref","first-page":"56300","DOI":"10.1109\/ACCESS.2023.3283428","article-title":"P4sec: Automated deployment of 802.1 X, IPsec, and MACsec network protection in P4-based SDN","volume":"11","author":"Hauser","year":"2023","journal-title":"IEEE Access"},{"key":"10.1016\/j.comnet.2026.112560_b33","doi-asserted-by":"crossref","unstructured":"X. Chen, Implementing AES encryption on programmable switches via scrambled lookup tables, in: Proceedings of the Workshop on Secure Programmable Network Infrastructure, 2020, pp. 8\u201314.","DOI":"10.1145\/3405669.3405819"},{"key":"10.1016\/j.comnet.2026.112560_b34","series-title":"2021 IEEE Conference on Network Function Virtualization and Software Defined Networks (NFV-SDN)","first-page":"148","article-title":"Dh-aes-p4: on-premise encryption and in-band key-exchange in p4 fully programmable data planes","author":"Oliveira","year":"2021"},{"key":"10.1016\/j.comnet.2026.112560_b35","doi-asserted-by":"crossref","unstructured":"K. Kecskem\u00e9ti, C. Gy\u00f6rgyi, P. V\u00f6r\u00f6s, S. Laki, In-network security applications with p4rrot, in: Proceedings of the Twenty-Fourth International Symposium on Theory, Algorithmic Foundations, and Protocol Design for Mobile Networks and Mobile Computing, 2023, pp. 346\u2013351.","DOI":"10.1145\/3565287.3617612"},{"issue":"1","key":"10.1016\/j.comnet.2026.112560_b36","doi-asserted-by":"crossref","first-page":"30","DOI":"10.1145\/3594255.3594258","article-title":"P4rrot: Generating p4 code for the application layer","volume":"53","author":"Gy\u00f6rgyi","year":"2023","journal-title":"ACM SIGCOMM Comput. Commun. Rev."},{"key":"10.1016\/j.comnet.2026.112560_b37","doi-asserted-by":"crossref","unstructured":"A. AlSabeh, E. Kfoury, J. Crichigno, E. Bou-Harb, P4ddpi: Securing p4-programmable data plane networks via dns deep packet inspection, in: NDSS Symposium 2022, 2022.","DOI":"10.14722\/madweb.2022.23012"},{"key":"10.1016\/j.comnet.2026.112560_b38","doi-asserted-by":"crossref","DOI":"10.1016\/j.cose.2024.104007","article-title":"On dga detection and classification using p4 programmable switches","volume":"145","author":"AlSabeh","year":"2024","journal-title":"Comput. Secur."},{"key":"10.1016\/j.comnet.2026.112560_b39","series-title":"IEEE SmartGridComm","article-title":"Industrial network protocol security enhancement using programmable switches","author":"Hu","year":"2023"},{"key":"10.1016\/j.comnet.2026.112560_b40","series-title":"Dynamic Data Driven Applications Systems: 5th International Conference, DDDAS\/Infosymbiotics for Reliable AI 2024, New Brunswick, NJ, USA, November 6\u20138, 2024, Proceedings","first-page":"153","article-title":"Dynamic data driven security framework for industrial control networks using programmable switches","author":"Raj","year":"2025"},{"issue":"3","key":"10.1016\/j.comnet.2026.112560_b41","doi-asserted-by":"crossref","first-page":"95","DOI":"10.3390\/fi15030095","article-title":"When operation technology meets information technology: challenges and opportunities","volume":"15","author":"Berardi","year":"2023","journal-title":"Future Internet"},{"key":"10.1016\/j.comnet.2026.112560_b42","series-title":"History of Industrial Control System Cyber Incidents","author":"Hemsley","year":"2018"},{"key":"10.1016\/j.comnet.2026.112560_b43","series-title":"Bidirectional TLS handshake caching for constrained industrial IoT scenarios","author":"Bodenhausen","year":"2025"},{"key":"10.1016\/j.comnet.2026.112560_b44","series-title":"Security for Industrial Automation and Control Systems \u2013 Part 3-2: Security Risk Assessment for System Design","author":"ISA\/IEC","year":"2020"},{"issue":"2\u20133","key":"10.1016\/j.comnet.2026.112560_b45","doi-asserted-by":"crossref","first-page":"141","DOI":"10.1016\/0166-3615(94)90017-5","article-title":"The Purdue enterprise reference architecture","volume":"24","author":"Williams","year":"1994","journal-title":"Comput. Ind."},{"key":"10.1016\/j.comnet.2026.112560_b46","series-title":"ISO\/IEC 62443-3-3: Industrial Communication Networks - Network and System Security - Part 3-3: System Security Requirements and Security Levels","author":"International Organization for Standardization (ISO) and International Electrotechnical Commission (IEC)","year":"2013"},{"issue":"2","key":"10.1016\/j.comnet.2026.112560_b47","doi-asserted-by":"crossref","first-page":"198","DOI":"10.1109\/TIT.1983.1056650","article-title":"On the security of public key protocols","volume":"29","author":"Dolev","year":"1983","journal-title":"IEEE Trans. Inform. Theory"},{"key":"10.1016\/j.comnet.2026.112560_b48","unstructured":"S.G. Abbas, M.O. Ozmen, A. Alsaheel, A. Khan, Z.B. Celik, D. Xu, {SAIN}: Improving {ICS} Attack Detection Sensitivity via {State\u2212Aware} Invariants, in: 33rd USENIX Security Symposium (USENIX Security 24), 2024, pp. 6597\u20136613."},{"key":"10.1016\/j.comnet.2026.112560_b49","series-title":"2023 IEEE Symposium on Security and Privacy","first-page":"20","article-title":"Scaphy: Detecting modern ics attacks by correlating behaviors in scada and physical","author":"Ike","year":"2023"},{"key":"10.1016\/j.comnet.2026.112560_b50","doi-asserted-by":"crossref","unstructured":"H.R. Ghaeini, D. Antonioli, F. Brasser, A.-R. Sadeghi, N.O. Tippenhauer, State-aware anomaly detection for industrial control systems, in: Proceedings of the 33rd Annual ACM Symposium on Applied Computing, 2018, pp. 1620\u20131628.","DOI":"10.1145\/3167132.3167305"},{"key":"10.1016\/j.comnet.2026.112560_b51","doi-asserted-by":"crossref","unstructured":"A. Erba, R. Taormina, S. Galelli, M. Pogliani, M. Carminati, S. Zanero, N.O. Tippenhauer, Constrained concealment attacks against reconstruction-based anomaly detectors in industrial control systems, in: Proceedings of the 36th Annual Computer Security Applications Conference, 2020, pp. 480\u2013495.","DOI":"10.1145\/3427228.3427660"},{"issue":"2","key":"10.1016\/j.comnet.2026.112560_b52","doi-asserted-by":"crossref","first-page":"1480","DOI":"10.1109\/TNSE.2023.3324329","article-title":"Collaborative defense against hybrid network attacks by SDN controllers and P4 switches","volume":"11","author":"Wang","year":"2023","journal-title":"IEEE Trans. Netw. Sci. Eng."},{"key":"10.1016\/j.comnet.2026.112560_b53","series-title":"Advanced encryption standard (AES)","author":"of Standards","year":"2001"},{"key":"10.1016\/j.comnet.2026.112560_b54","doi-asserted-by":"crossref","unstructured":"T. Hansen, D.E.E. 3rd, US Secure Hash Algorithms (SHA and HMAC-SHA), RFC 4634, 2006, http:\/\/dx.doi.org\/10.17487\/RFC4634, URL https:\/\/www.rfc-editor.org\/info\/rfc4634.","DOI":"10.17487\/rfc4634"},{"key":"10.1016\/j.comnet.2026.112560_b55","series-title":"AWS IoT core: Developer guide","author":"Amazon Web Services","year":"2025"},{"issue":"3","key":"10.1016\/j.comnet.2026.112560_b56","doi-asserted-by":"crossref","first-page":"3482","DOI":"10.1109\/TNSM.2024.3377538","article-title":"Unleashing dynamic pipeline reconfiguration of P4 switches for efficient network monitoring","volume":"21","author":"Al Sadi","year":"2024","journal-title":"IEEE Trans. Netw. Serv. Manag."},{"key":"10.1016\/j.comnet.2026.112560_b57","series-title":"2024 IEEE 10th International Conference on Network Softwarization","first-page":"190","article-title":"In-network encryption for secure industrial control systems communications","author":"Rinieri","year":"2024"},{"key":"10.1016\/j.comnet.2026.112560_b58","unstructured":"D. Formby, M. Rad, R. Beyah, Lowering the barriers to industrial control system security with {GRFICS}, in: 2018 USENIX Workshop on Advances in Security Education (ASE 18), 2018."},{"key":"10.1016\/j.comnet.2026.112560_b59","doi-asserted-by":"crossref","unstructured":"C. Fung, E. Zeng, L. Bauer, Attributions for ML-based ICS anomaly detection: From theory to practice, in: Proc. 31st Netw. Distrib. Syst. Secur. Symp, 2024.","DOI":"10.14722\/ndss.2024.23216"},{"key":"10.1016\/j.comnet.2026.112560_b60","series-title":"International Joint Conference on Rough Sets","first-page":"272","article-title":"Determining thresholds in three-way decisions with chi-square statistic","author":"Gao","year":"2016"},{"key":"10.1016\/j.comnet.2026.112560_b61","series-title":"European Symposium on Research in Computer Security","first-page":"493","article-title":"Perspectives from a comprehensive evaluation of reconstruction-based anomaly detection in industrial control systems","author":"Fung","year":"2022"},{"key":"10.1016\/j.comnet.2026.112560_b62","series-title":"P4runtime specification","author":"Consortium","year":"2024"},{"key":"10.1016\/j.comnet.2026.112560_b63","doi-asserted-by":"crossref","unstructured":"D.K. Gillmor, Negotiated Finite Field Diffie-Hellman Ephemeral Parameters for Transport Layer Security (TLS), RFC 7919, 2016, http:\/\/dx.doi.org\/10.17487\/RFC7919, URL https:\/\/www.rfc-editor.org\/info\/rfc7919.","DOI":"10.17487\/RFC7919"},{"issue":"1","key":"10.1016\/j.comnet.2026.112560_b64","doi-asserted-by":"crossref","first-page":"1","DOI":"10.1145\/3371038","article-title":"Fast packet processing with ebpf and xdp: Concepts, code, challenges, and applications","volume":"53","author":"Vieira","year":"2020","journal-title":"ACM Comput. Surv."},{"issue":"1","key":"10.1016\/j.comnet.2026.112560_b65","doi-asserted-by":"crossref","first-page":"133","DOI":"10.1109\/TNSM.2021.3055676","article-title":"A framework for eBPF-based network functions in an era of microservices","volume":"18","author":"Miano","year":"2021","journal-title":"IEEE Trans. Netw. Serv. Manag."},{"key":"10.1016\/j.comnet.2026.112560_b66","article-title":"A review of P4 programmable data planes for network security","volume":"2021","author":"Gao","year":"2021","journal-title":"Mob. Inf. Syst."},{"key":"10.1016\/j.comnet.2026.112560_b67","doi-asserted-by":"crossref","unstructured":"A.-A. Agape, M.C. Danceanu, R.R. Hansen, S. Schmid, P4fuzz: Compiler fuzzer for dependable programmable dataplanes, in: Proceedings of the 22nd International Conference on Distributed Computing and Networking, 2021, pp. 16\u201325.","DOI":"10.1145\/3427796.3427798"},{"key":"10.1016\/j.comnet.2026.112560_b68","doi-asserted-by":"crossref","unstructured":"H. Wang, R. Soul\u00e9, H.T. Dang, K.S. Lee, V. Shrivastav, N. Foster, H. Weatherspoon, P4fpga: A rapid prototyping framework for p4, in: Proceedings of the Symposium on SDN Research, 2017, pp. 122\u2013135.","DOI":"10.1145\/3050220.3050234"},{"key":"10.1016\/j.comnet.2026.112560_b69","doi-asserted-by":"crossref","unstructured":"S. Ibanez, G. Brebner, N. McKeown, N. Zilberman, The p4-> netfpga workflow for line-rate packet processing, in: Proceedings of the 2019 ACM\/SIGDA International Symposium on Field-Programmable Gate Arrays, 2019, pp. 1\u20139.","DOI":"10.1145\/3289602.3293924"},{"key":"10.1016\/j.comnet.2026.112560_b70","series-title":"2019 ACM\/IEEE Symposium on Architectures for Networking and Communications Systems","first-page":"1","article-title":"Cryptographic hashing in p4 data planes","author":"Scholz","year":"2019"},{"key":"10.1016\/j.comnet.2026.112560_b71","series-title":"2024 IEEE Future Networks World Forum","first-page":"226","article-title":"Programmable architecture for offloading PDCP on FPGA-capable SmartNIC","author":"Kumar","year":"2024"}],"container-title":["Computer Networks"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/api.elsevier.com\/content\/article\/PII:S1389128626005724?httpAccept=text\/xml","content-type":"text\/xml","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/api.elsevier.com\/content\/article\/PII:S1389128626005724?httpAccept=text\/plain","content-type":"text\/plain","content-version":"vor","intended-application":"text-mining"}],"deposited":{"date-parts":[[2026,8,10]],"date-time":"2026-08-10T15:15:22Z","timestamp":1786374922000},"score":1,"resource":{"primary":{"URL":"https:\/\/linkinghub.elsevier.com\/retrieve\/pii\/S1389128626005724"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2026,9]]},"references-count":71,"alternative-id":["S1389128626005724"],"URL":"https:\/\/doi.org\/10.1016\/j.comnet.2026.112560","relation":{},"ISSN":["1389-1286"],"issn-type":[{"value":"1389-1286","type":"print"}],"subject":[],"published":{"date-parts":[[2026,9]]},"assertion":[{"value":"Elsevier","name":"publisher","label":"This article is maintained by"},{"value":"P4ICS: P4 in-network security for Industrial Control Systems networks","name":"articletitle","label":"Article Title"},{"value":"Computer Networks","name":"journaltitle","label":"Journal Title"},{"value":"https:\/\/doi.org\/10.1016\/j.comnet.2026.112560","name":"articlelink","label":"CrossRef DOI link to publisher maintained version"},{"value":"article","name":"content_type","label":"Content Type"},{"value":"\u00a9 2026 The Authors. Published by Elsevier B.V.","name":"copyright","label":"Copyright"}],"article-number":"112560"}}