{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2024,9,4]],"date-time":"2024-09-04T12:13:20Z","timestamp":1725452000788},"reference-count":24,"publisher":"IEEE","content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2012,1]]},"DOI":"10.1109\/comsnets.2012.6151319","type":"proceedings-article","created":{"date-parts":[[2012,2,15]],"date-time":"2012-02-15T15:20:00Z","timestamp":1329319200000},"page":"1-10","source":"Crossref","is-referenced-by-count":0,"title":["A router primitive approach for building diverse network services"],"prefix":"10.1109","author":[{"given":"Joel","family":"Sommers","sequence":"first","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Paul","family":"Barford","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Ben","family":"Liblit","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"263","reference":[{"key":"ref10","doi-asserted-by":"publisher","DOI":"10.1145\/1592631.1592633"},{"key":"ref11","article-title":"Nettle: Taking the sting out of programming network routers","author":"voellmy","year":"0","journal-title":"PADL"},{"key":"ref12","doi-asserted-by":"publisher","DOI":"10.1145\/781131.781133"},{"key":"ref13","doi-asserted-by":"publisher","DOI":"10.1145\/2034773.2034812"},{"key":"ref14","doi-asserted-by":"publisher","DOI":"10.1145\/1355734.1355746"},{"key":"ref15","doi-asserted-by":"publisher","DOI":"10.1145\/1592631.1592635"},{"key":"ref16","article-title":"Can the production network be the testbed?","author":"sherwood","year":"0","journal-title":"Proceedings of OSDI"},{"year":"0","key":"ref17","article-title":"Cisco CRS-l Multishelf System"},{"key":"ref18","doi-asserted-by":"publisher","DOI":"10.1145\/1282380.1282405"},{"key":"ref19","doi-asserted-by":"publisher","DOI":"10.1145\/1080091.1080111"},{"key":"ref4","doi-asserted-by":"publisher","DOI":"10.1109\/35.568214"},{"key":"ref3","doi-asserted-by":"publisher","DOI":"10.1145\/505733.505735"},{"key":"ref6","doi-asserted-by":"publisher","DOI":"10.1145\/289423.289431"},{"key":"ref5","doi-asserted-by":"publisher","DOI":"10.1145\/231699.231701"},{"key":"ref8","doi-asserted-by":"publisher","DOI":"10.1145\/1592631.1592634"},{"key":"ref7","article-title":"Building extensible networks with rule-based forwarding","author":"popa","year":"0","journal-title":"USENIX OSDI"},{"key":"ref2","doi-asserted-by":"publisher","DOI":"10.1145\/357401.357402"},{"key":"ref1","doi-asserted-by":"publisher","DOI":"10.1145\/354871.354874"},{"key":"ref9","doi-asserted-by":"publisher","DOI":"10.1145\/1397718.1397720"},{"key":"ref20","article-title":"The Interfaces Group MIB","author":"mccloghrie","year":"0","journal-title":"IETF RFC 2863"},{"key":"ref22","article-title":"Cilk: an efficient multithreaded runtime system","author":"blumofe","year":"0","journal-title":"Proceedings of ACM SIGPLAN PPoPP"},{"key":"ref21","article-title":"Multiprotocol Label Switching Architecture","author":"rosen","year":"0","journal-title":"IETF RFC 3031"},{"key":"ref24","doi-asserted-by":"publisher","DOI":"10.1145\/1028788.1028798"},{"key":"ref23","article-title":"The Addition of Explicit Congestion Notification (ECN) to IP","author":"ramakrishnan","year":"0","journal-title":"IETF RFC 3168"}],"event":{"name":"2012 Fourth International Conference on Communication Systems and Networks (COMSNETS)","start":{"date-parts":[[2012,1,3]]},"location":"Bangalore, India","end":{"date-parts":[[2012,1,7]]}},"container-title":["2012 Fourth International Conference on Communication Systems and Networks (COMSNETS 2012)"],"original-title":[],"link":[{"URL":"http:\/\/xplorestaging.ieee.org\/ielx5\/6145051\/6151271\/06151319.pdf?arnumber=6151319","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2017,3,21]],"date-time":"2017-03-21T19:03:43Z","timestamp":1490123023000},"score":1,"resource":{"primary":{"URL":"http:\/\/ieeexplore.ieee.org\/document\/6151319\/"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2012,1]]},"references-count":24,"URL":"https:\/\/doi.org\/10.1109\/comsnets.2012.6151319","relation":{},"subject":[],"published":{"date-parts":[[2012,1]]}}}