{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,23]],"date-time":"2026-10-23T03:23:32Z","timestamp":1792725812134,"version":"4.5.0"},"reference-count":127,"publisher":"Institute of Electrical and Electronics Engineers (IEEE)","issue":"4","license":[{"start":{"date-parts":[[2019,1,1]],"date-time":"2019-01-01T00:00:00Z","timestamp":1546300800000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/ieeexplore.ieee.org\/Xplorehelp\/downloads\/license-information\/IEEE.html"},{"start":{"date-parts":[[2019,1,1]],"date-time":"2019-01-01T00:00:00Z","timestamp":1546300800000},"content-version":"stm-asf","delay-in-days":0,"URL":"https:\/\/doi.org\/10.15223\/policy-029"},{"start":{"date-parts":[[2019,1,1]],"date-time":"2019-01-01T00:00:00Z","timestamp":1546300800000},"content-version":"stm-asf","delay-in-days":0,"URL":"https:\/\/doi.org\/10.15223\/policy-037"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":["IEEE Commun. Surv. Tutorials"],"published-print":{"date-parts":[[2019]]},"DOI":"10.1109\/comst.2019.2904994","type":"journal-article","created":{"date-parts":[[2019,3,18]],"date-time":"2019-03-18T23:41:58Z","timestamp":1552952518000},"page":"3609-3638","source":"Crossref","is-referenced-by-count":105,"title":["A Survey of Delay-Based and Hybrid TCP Congestion Control Algorithms"],"prefix":"10.1109","volume":"21","author":[{"ORCID":"https:\/\/orcid.org\/0000-0003-4084-987X","authenticated-orcid":false,"given":"Rasool","family":"Al-Saadi","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-2805-6511","authenticated-orcid":false,"given":"Grenville","family":"Armitage","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Jason","family":"But","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0003-2188-1452","authenticated-orcid":false,"given":"Philip","family":"Branch","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"263","reference":[{"key":"ref39","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8290"},{"key":"ref38","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8033"},{"key":"ref33","doi-asserted-by":"publisher","DOI":"10.1109\/COMST.2003.5342228"},{"key":"ref32","doi-asserted-by":"publisher","DOI":"10.1109\/90.251892"},{"key":"ref31","doi-asserted-by":"publisher","DOI":"10.17487\/RFC7567"},{"key":"ref30","doi-asserted-by":"publisher","DOI":"10.1145\/2063166.2071893"},{"key":"ref37","doi-asserted-by":"publisher","DOI":"10.1109\/HPSR.2013.6602305"},{"key":"ref36","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8289"},{"key":"ref35","doi-asserted-by":"publisher","DOI":"10.1109\/SURV.2012.082212.00018"},{"key":"ref34","first-page":"130","article-title":"A survey on active queue management mechanisms","volume":"8","author":"thiruchelvi","year":"2008","journal-title":"Int J Comput Sci Netw Security"},{"key":"ref28","author":"wei","year":"2006","journal-title":"TCP Pacing Revisited"},{"key":"ref27","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.2000.832483"},{"key":"ref29","first-page":"73","article-title":"TCP New Vegas: Improving the performance of TCP Vegas over high latency links","author":"sing","year":"2005","journal-title":"Proc 4th IEEE Int Symp Netw Comput Appl"},{"key":"ref20","doi-asserted-by":"publisher","DOI":"10.1109\/90.793002"},{"key":"ref22","doi-asserted-by":"publisher","DOI":"10.1109\/49.464716"},{"key":"ref21","doi-asserted-by":"publisher","DOI":"10.17487\/rfc5681"},{"key":"ref24","doi-asserted-by":"publisher","DOI":"10.1145\/1232919.1232926"},{"key":"ref23","author":"la","year":"1999","journal-title":"Issues in TCP vegas"},{"key":"ref101","doi-asserted-by":"publisher","DOI":"10.21236\/ADA461170"},{"key":"ref26","doi-asserted-by":"publisher","DOI":"10.17487\/rfc2018"},{"key":"ref100","doi-asserted-by":"publisher","DOI":"10.23919\/IFIPNetworking.2017.8264882"},{"key":"ref25","author":"floyd","year":"2004","journal-title":"The NewReno modification to TCP s fast recovery algorithm"},{"key":"ref50","doi-asserted-by":"publisher","DOI":"10.17487\/rfc1323"},{"key":"ref51","doi-asserted-by":"publisher","DOI":"10.1109\/TNET.2006.879702"},{"key":"ref59","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8511"},{"key":"ref58","doi-asserted-by":"publisher","DOI":"10.17487\/rfc3550"},{"key":"ref57","doi-asserted-by":"publisher","DOI":"10.1109\/IWQOS.2000.847939"},{"key":"ref56","first-page":"362","article-title":"LDA+ TCP-friendly adaptation: A measurement and comparison study","author":"sisalem","year":"2000","journal-title":"Proc NOSSDAV"},{"key":"ref55","doi-asserted-by":"publisher","DOI":"10.1145\/74681.74686"},{"key":"ref54","doi-asserted-by":"publisher","DOI":"10.1109\/AINA.2011.98"},{"key":"ref53","doi-asserted-by":"publisher","DOI":"10.1016\/j.comcom.2004.08.016"},{"key":"ref52","doi-asserted-by":"publisher","DOI":"10.1109\/GLOCOM.2010.5683559"},{"key":"ref40","author":"al-saadi","year":"2016","journal-title":"Dummynet AQM v0 2&#x2014;CoDel FQ-CoDel PIE and FQ-PIE for FreeBSD&#x2019;s ipfw\/dummynet framework"},{"key":"ref4","doi-asserted-by":"publisher","DOI":"10.1109\/LCOMM.2013.040213.130137"},{"key":"ref3","doi-asserted-by":"publisher","DOI":"10.17487\/rfc3168"},{"key":"ref6","doi-asserted-by":"publisher","DOI":"10.17487\/rfc6817"},{"key":"ref5","doi-asserted-by":"publisher","DOI":"10.1109\/LCN.2013.6761285"},{"key":"ref8","author":"huitema","year":"2016","journal-title":"Announcing New Transport Advancements in the Anniversary Update for Windows 10 and Windows Server 2016"},{"key":"ref49","article-title":"Delay-based congestion control for low latency","author":"hayes","year":"2013","journal-title":"ISOC Workshop on Reducing Internet Latency"},{"key":"ref7","doi-asserted-by":"publisher","DOI":"10.1145\/844128.844159"},{"key":"ref9","year":"2014","journal-title":"TCP LEDBAT Implementation"},{"key":"ref46","doi-asserted-by":"publisher","DOI":"10.1145\/948205.948240"},{"key":"ref45","doi-asserted-by":"publisher","DOI":"10.1109\/TNET.2003.813038"},{"key":"ref48","article-title":"On the effectiveness of delay-based congestion avoidance","volume":"4","author":"prasad","year":"2004","journal-title":"Proc PFLDnet"},{"key":"ref47","author":"mccullagh","year":"2008","journal-title":"Delay-based Congestion Control Sampling and Correlation Issues Revisited"},{"key":"ref42","doi-asserted-by":"publisher","DOI":"10.1145\/1400097.1400105"},{"key":"ref41","doi-asserted-by":"publisher","DOI":"10.1145\/52325.52356"},{"key":"ref44","doi-asserted-by":"publisher","DOI":"10.1109\/GLOCOM.1998.776899"},{"key":"ref43","doi-asserted-by":"publisher","DOI":"10.1109\/MCOM.2005.1404595"},{"key":"ref127","doi-asserted-by":"publisher","DOI":"10.1016\/j.bjp.2014.01.009"},{"key":"ref126","doi-asserted-by":"publisher","DOI":"10.1016\/j.adhoc.2014.07.032"},{"key":"ref125","doi-asserted-by":"publisher","DOI":"10.1145\/1080754.1080770"},{"key":"ref124","doi-asserted-by":"publisher","DOI":"10.1109\/WOWMOM.2009.5282435"},{"key":"ref73","doi-asserted-by":"publisher","DOI":"10.1145\/1282427.1282420"},{"key":"ref72","doi-asserted-by":"publisher","DOI":"10.1109\/TNET.2006.886335"},{"key":"ref71","doi-asserted-by":"publisher","DOI":"10.1109\/MNET.2005.1383434"},{"key":"ref70","doi-asserted-by":"publisher","DOI":"10.1145\/141800.141801"},{"key":"ref76","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.1999.752178"},{"key":"ref77","doi-asserted-by":"publisher","DOI":"10.1109\/ICNP.2000.896302"},{"key":"ref74","doi-asserted-by":"publisher","DOI":"10.1145\/2829988.2787510"},{"key":"ref75","doi-asserted-by":"publisher","DOI":"10.1109\/LCN.2017.42"},{"key":"ref78","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.2000.832553"},{"key":"ref79","doi-asserted-by":"publisher","DOI":"10.1109\/PCCC.2003.1203713"},{"key":"ref60","doi-asserted-by":"publisher","DOI":"10.1145\/1851182.1851192"},{"key":"ref62","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.2013.6567018"},{"key":"ref61","doi-asserted-by":"publisher","DOI":"10.1145\/2342356.2342388"},{"key":"ref63","author":"briscoe","year":"2018","journal-title":"Low latency low loss scalable throughput (L4S) Internet service Architecture"},{"key":"ref64","article-title":"DualQ coupled AQMs for low latency, low loss and scalable throughput (L4S)","author":"de schepper","year":"2018"},{"key":"ref65","doi-asserted-by":"publisher","DOI":"10.1016\/j.comnet.2011.01.014"},{"key":"ref66","doi-asserted-by":"publisher","DOI":"10.17487\/rfc5166"},{"key":"ref67","doi-asserted-by":"publisher","DOI":"10.1016\/0376-5075(78)90028-4"},{"key":"ref68","volume":"38","author":"jain","year":"1984","journal-title":"A quantitative measure of fairness and discrimination for resource allocation in shared computer system"},{"key":"ref2","doi-asserted-by":"publisher","DOI":"10.17487\/rfc0791"},{"key":"ref69","doi-asserted-by":"publisher","DOI":"10.1145\/964723.383080"},{"key":"ref1","doi-asserted-by":"publisher","DOI":"10.17487\/rfc0793"},{"key":"ref109","year":"2011","journal-title":"Description of a Hotfix That Adds Compound TCP (CTCP) Support to Computers That Are Running Windows Server 2003 or a 64-Bit Version of Windows XP"},{"key":"ref95","doi-asserted-by":"publisher","DOI":"10.1145\/3232755.3232783"},{"key":"ref108","doi-asserted-by":"publisher","DOI":"10.1016\/j.peva.2007.12.007"},{"key":"ref94","doi-asserted-by":"publisher","DOI":"10.1109\/TNET.2011.2159736"},{"key":"ref107","first-page":"1005","author":"marfia","year":"2007","journal-title":"TCP-Libra Exploring RTT Fairness for TCP"},{"key":"ref93","first-page":"37","article-title":"YeAH-TCP: Yet another highspeed TCP","volume":"7","author":"baiocchi","year":"2007","journal-title":"Proc PFLDnet"},{"key":"ref106","doi-asserted-by":"publisher","DOI":"10.1109\/INFOCOM.2006.188"},{"key":"ref92","doi-asserted-by":"publisher","DOI":"10.1145\/2999572.2999593"},{"key":"ref105","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.2005.1498463"},{"key":"ref91","doi-asserted-by":"publisher","DOI":"10.1109\/LCN.2017.22"},{"key":"ref104","doi-asserted-by":"publisher","DOI":"10.1145\/347057.347557"},{"key":"ref90","doi-asserted-by":"publisher","DOI":"10.1109\/ITC.2010.5608714"},{"key":"ref103","author":"jacobson","year":"0","journal-title":"Pathchar A Tool to Infer Characteristics of Internet Paths"},{"key":"ref102","first-page":"11","article-title":"Nettimer: A tool for measuring bottleneck link bandwidth","volume":"1","author":"lai","year":"2001","journal-title":"Proc USITS"},{"key":"ref111","doi-asserted-by":"publisher","DOI":"10.1145\/1015467.1015476"},{"key":"ref112","doi-asserted-by":"publisher","DOI":"10.1145\/381677.381704"},{"key":"ref110","author":"balasubramanian","year":"2017","journal-title":"Updates on Windows TCP"},{"key":"ref98","doi-asserted-by":"publisher","DOI":"10.1145\/956981.956989"},{"key":"ref99","doi-asserted-by":"publisher","DOI":"10.1109\/LCN.2010.5735714"},{"key":"ref96","doi-asserted-by":"publisher","DOI":"10.1145\/3232755.3232772"},{"key":"ref97","doi-asserted-by":"publisher","DOI":"10.17487\/rfc3649"},{"key":"ref10","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-20798-3_25"},{"key":"ref11","first-page":"304","article-title":"Efficiency\/friendliness tradeoffs in TCP Westwood","author":"wang","year":"2002","journal-title":"Proc 7th Int Symp Comput Commun (ISCC)"},{"key":"ref12","first-page":"1461","article-title":"Survey on fairness issues in TCP congestion control mechanisms","volume":"84","author":"hasegawa","year":"2001","journal-title":"IEICE Trans Commun"},{"key":"ref13","doi-asserted-by":"publisher","DOI":"10.1109\/SURV.2010.042710.00114"},{"key":"ref14","doi-asserted-by":"publisher","DOI":"10.1109\/SURV.2012.060912.00176"},{"key":"ref15","doi-asserted-by":"publisher","DOI":"10.1002\/wcm.524"},{"key":"ref118","doi-asserted-by":"publisher","DOI":"10.1145\/3009824"},{"key":"ref16","first-page":"28","author":"callegari","year":"2014","journal-title":"A Survey of Congestion Control Mechanisms in Linux TCP"},{"key":"ref82","author":"jin","year":"2010","journal-title":"Method and apparatus for network congestion control using queue control and one-way delay measurements"},{"key":"ref117","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.2009.5061900"},{"key":"ref17","doi-asserted-by":"publisher","DOI":"10.17487\/rfc2914"},{"key":"ref81","author":"jin","year":"2011","journal-title":"Method and Apparatus for Network Congestion Control"},{"key":"ref18","author":"postel","year":"1981","journal-title":"Internet control message protocol"},{"key":"ref84","year":"2017","journal-title":"Network Simulator 2"},{"key":"ref119","doi-asserted-by":"publisher","DOI":"10.1145\/997150.997155"},{"key":"ref19","doi-asserted-by":"publisher","DOI":"10.17487\/rfc6633"},{"key":"ref83","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.2001.916670"},{"key":"ref114","first-page":"2604","article-title":"Adaptive bandwidth share estimation in TCP Westwood","volume":"3","author":"wang","year":"2002","journal-title":"Proc Global Telecommun Conf (Globecom)"},{"key":"ref113","first-page":"130","author":"grieco","year":"2002","journal-title":"TCP Westwood and Easy RED to Improve Fairness in High-Speed Networks"},{"key":"ref116","doi-asserted-by":"publisher","DOI":"10.1109\/TNET.2010.2095038"},{"key":"ref80","doi-asserted-by":"publisher","DOI":"10.1109\/LCOMM.2005.1496608"},{"key":"ref115","doi-asserted-by":"publisher","DOI":"10.1109\/ICC.2003.1204260"},{"key":"ref120","doi-asserted-by":"publisher","DOI":"10.1145\/115994.116006"},{"key":"ref89","year":"2010","journal-title":"libutp - uTorrent Transport Protocol implementation"},{"key":"ref121","doi-asserted-by":"publisher","DOI":"10.1109\/ICC.2005.1495079"},{"key":"ref122","doi-asserted-by":"publisher","DOI":"10.1109\/JSAC.2004.839426"},{"key":"ref123","doi-asserted-by":"publisher","DOI":"10.1109\/ICNP.2017.8117540"},{"key":"ref85","doi-asserted-by":"publisher","DOI":"10.1109\/IWQOS.2008.18"},{"key":"ref86","doi-asserted-by":"publisher","DOI":"10.1109\/IWQoS.2009.5201387"},{"key":"ref87","doi-asserted-by":"publisher","DOI":"10.1109\/ICCCN.2010.5560080"},{"key":"ref88","year":"2017","journal-title":"UTorrent Transport Protocol"}],"container-title":["IEEE Communications Surveys &amp; Tutorials"],"original-title":[],"link":[{"URL":"http:\/\/xplorestaging.ieee.org\/ielx7\/9739\/8915915\/08668433.pdf?arnumber=8668433","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2022,7,13]],"date-time":"2022-07-13T21:07:46Z","timestamp":1657746466000},"score":1,"resource":{"primary":{"URL":"https:\/\/ieeexplore.ieee.org\/document\/8668433\/"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2019]]},"references-count":127,"journal-issue":{"issue":"4"},"URL":"https:\/\/doi.org\/10.1109\/comst.2019.2904994","relation":{},"ISSN":["1553-877X","2373-745X"],"issn-type":[{"value":"1553-877X","type":"electronic"},{"value":"2373-745X","type":"electronic"}],"subject":[],"published":{"date-parts":[[2019]]}}}