{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,26]],"date-time":"2026-10-26T16:43:22Z","timestamp":1793033002198,"version":"4.5.0"},"reference-count":20,"publisher":"IEEE","content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2009,11]]},"DOI":"10.1109\/glocom.2009.5425449","type":"proceedings-article","created":{"date-parts":[[2010,3,8]],"date-time":"2010-03-08T11:49:02Z","timestamp":1268048942000},"page":"1-6","source":"Crossref","is-referenced-by-count":3,"title":["ANTS - A Framework for Knowledge Based NAT Traversal"],"prefix":"10.1109","author":[{"given":"Andreas","family":"Muller","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Andreas","family":"Klenk","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Georg","family":"Carle","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"263","reference":[{"key":"ref10","article-title":"NAT Behavioral Requirements for TCP","author":"saikat","year":"2008","journal-title":"IETF RFC 5382"},{"key":"ref11","article-title":"Session Traversal Utilities for NAT (STUN)","author":"rosenberg","year":"2008","journal-title":"RFC 5389 IETF"},{"key":"ref12","article-title":"On the Applicability of knowledge-based NAT-Traversal for future Home Networks","author":"m\u00fcller","year":"2008","journal-title":"Proceedings of IFIP Networking 2008"},{"key":"ref13","article-title":"Internet gateway device (IGD) standardized device control protocol","year":"2001"},{"key":"ref14","article-title":"Peer-to-Peer Communication Across Network Address Translation","author":"ford","year":"2005","journal-title":"MIT Tech Rep"},{"key":"ref15","article-title":"Traversal Using Relays around NAT (TURN)","author":"rosenberg","year":"2009","journal-title":"IETF internet draft work in progress"},{"key":"ref16","article-title":"SIP: Session Initiation Protocol","author":"schulzrinne","year":"2002","journal-title":"RFC 3261 IETF"},{"key":"ref17","article-title":"HTTP Authentication: Basic and Digest Access Authentication","author":"franks","year":"1999","journal-title":"RFC 2617 IETF"},{"key":"ref18","article-title":"Extensible Messaging and Presence Protocol (XMPP)","author":"saint-andre","year":"2004","journal-title":"IETF RFC 3920"},{"key":"ref19","article-title":"Towards a Secure Internet Architecture Through Signaling","author":"guha","year":"2006","journal-title":"Cornell University Tech Rep"},{"key":"ref4","article-title":"Protocol Complications with the IP Network Address Translator","author":"holdrege","year":"2001","journal-title":"RFC 3027 IETF"},{"key":"ref3","article-title":"Local Network Protection for IPv6","author":"de velde","year":"2007","journal-title":"RFC 4864 IETF"},{"key":"ref6","article-title":"NUTSS: A SIP-based Approach to UDP and TCP Network Connectivity","author":"francis","year":"2004","journal-title":"Proceedings of SIGCOMM Workshops"},{"key":"ref5","doi-asserted-by":"publisher","DOI":"10.1109\/MNET.2008.4626227"},{"key":"ref8","article-title":"TCP Connections for P2P Applications","author":"eppinger","year":"2005","journal-title":"Carnegie Mellon University Tech Rep"},{"key":"ref7","article-title":"NATBLASTER: Establishing TCP connections between hosts behind NATs","author":"andrew","year":"2005","journal-title":"ACM SIGCOMM ASIA Workshop"},{"key":"ref2","article-title":"IPv6-to-IPv6 Network Address Translation (NAT66)","author":"wasserman","year":"2008","journal-title":"IETF internet draft work in progress"},{"key":"ref1","article-title":"The IP Network Address Translator (NAT)","author":"egevang","year":"1994","journal-title":"IETF RFC 1631"},{"key":"ref9","article-title":"Interactive Connectivity Establishment (ICE)","author":"rosenberg","year":"2007","journal-title":"IETF internet draft work in progress"},{"key":"ref20","article-title":"An Analysis of the Skype P2P Internet Telephony Protocol","author":"baset","year":"2004","journal-title":"Columbia University Technical Report"}],"event":{"name":"GLOBECOM 2009 - 2009 IEEE Global Telecommunications Conference","location":"Honolulu, Hawaii","start":{"date-parts":[[2009,11,30]]},"end":{"date-parts":[[2009,12,4]]}},"container-title":["GLOBECOM 2009 - 2009 IEEE Global Telecommunications Conference"],"original-title":[],"link":[{"URL":"http:\/\/xplorestaging.ieee.org\/ielx5\/5425207\/5425208\/05425449.pdf?arnumber=5425449","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2017,3,19]],"date-time":"2017-03-19T00:41:55Z","timestamp":1489884115000},"score":1,"resource":{"primary":{"URL":"http:\/\/ieeexplore.ieee.org\/document\/5425449\/"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2009,11]]},"references-count":20,"URL":"https:\/\/doi.org\/10.1109\/glocom.2009.5425449","relation":{},"subject":[],"published":{"date-parts":[[2009,11]]}}}