{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2024,11,19]],"date-time":"2024-11-19T16:17:49Z","timestamp":1732033069087},"reference-count":10,"publisher":"IEEE","content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2009,8]]},"DOI":"10.1109\/icccn.2009.5235278","type":"proceedings-article","created":{"date-parts":[[2009,9,11]],"date-time":"2009-09-11T15:26:15Z","timestamp":1252682775000},"page":"1-7","source":"Crossref","is-referenced-by-count":18,"title":["NATCracker: NAT Combinations Matter"],"prefix":"10.1109","author":[{"given":"Roberto","family":"Roverso","sequence":"first","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Sameh","family":"El-Ansary","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Seif","family":"Haridi","sequence":"additional","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"263","reference":[{"key":"3","article-title":"stun - simple traversal of user datagram protocol (udp) through network address translators (nats)","author":"rosenberg","year":"2003","journal-title":"RFC 3489 (Proposed Standard) Internet Engineering Task Force"},{"key":"2","article-title":"state of peer-to-peer (p2p) communication across network address translators (nats)","author":"srisuresh","year":"2008","journal-title":"RFC 5128 (Informational) Internet Engineering Task Force"},{"key":"10","article-title":"myp2pworld: highly reproducible applicationlevel emulation of p2p systems","author":"roverso","year":"2008","journal-title":"Decentralized Self Management for Grid P2P User Communities Workshop SASO 2008"},{"key":"1","first-page":"13","article-title":"peer-to-peer communication across network address translators","author":"ford","year":"2005","journal-title":"ATEC '05 Proceedings of the annual conference on USENIX Annual Technical Conference"},{"key":"7","article-title":"teredo extensions","author":"thaler","year":"2009","journal-title":"Internet draft"},{"key":"6","article-title":"symmetric nat traversal using stun","author":"takeda","year":"2003","journal-title":"Internet draft"},{"key":"5","article-title":"interactive connectivity establishment (ice): a protocol for network address translator (nat) traversal for offer\/answer protocols","author":"rosenberg","year":"2007","journal-title":"Internet draft"},{"key":"4","article-title":"traversal using relays around nat (turn): relay extensions to session traversal utilities for nat (stun)","author":"rosenberg","year":"2008","journal-title":"Internet draft"},{"key":"9","article-title":"natblaster: establishing tcp connections between hosts behind nats","author":"biggadike","year":"2005","journal-title":"Proceedings of ACM SIGCOMM ASIA Workshop"},{"key":"8","article-title":"network address translation (nat) behavioral requirements for unicast udp","author":"audet","year":"2007","journal-title":"RFC 4787 (Best Current Practice) Internet Engineering Task Force"}],"event":{"name":"2009 Proceedings of 18th International Conference on Computer Communications and Networks - ICCCN 2009","start":{"date-parts":[[2009,8,3]]},"location":"San Francisco, CA, USA","end":{"date-parts":[[2009,8,6]]}},"container-title":["2009 Proceedings of 18th International Conference on Computer Communications and Networks"],"original-title":[],"link":[{"URL":"http:\/\/xplorestaging.ieee.org\/ielx5\/5235208\/5235209\/05235278.pdf?arnumber=5235278","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2017,3,19]],"date-time":"2017-03-19T01:34:37Z","timestamp":1489887277000},"score":1,"resource":{"primary":{"URL":"http:\/\/ieeexplore.ieee.org\/document\/5235278\/"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2009,8]]},"references-count":10,"URL":"https:\/\/doi.org\/10.1109\/icccn.2009.5235278","relation":{},"subject":[],"published":{"date-parts":[[2009,8]]}}}