{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,7,14]],"date-time":"2026-07-14T02:14:32Z","timestamp":1783995272290,"version":"3.55.0"},"reference-count":55,"publisher":"Institute of Electrical and Electronics Engineers (IEEE)","issue":"3","license":[{"start":{"date-parts":[[2021,4,1]],"date-time":"2021-04-01T00:00:00Z","timestamp":1617235200000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/ieeexplore.ieee.org\/Xplorehelp\/downloads\/license-information\/IEEE.html"},{"start":{"date-parts":[[2021,4,1]],"date-time":"2021-04-01T00:00:00Z","timestamp":1617235200000},"content-version":"am","delay-in-days":0,"URL":"https:\/\/ieeexplore.ieee.org\/Xplorehelp\/downloads\/license-information\/IEEE.html"},{"start":{"date-parts":[[2021,4,1]],"date-time":"2021-04-01T00:00:00Z","timestamp":1617235200000},"content-version":"stm-asf","delay-in-days":0,"URL":"https:\/\/doi.org\/10.15223\/policy-029"},{"start":{"date-parts":[[2021,4,1]],"date-time":"2021-04-01T00:00:00Z","timestamp":1617235200000},"content-version":"stm-asf","delay-in-days":0,"URL":"https:\/\/doi.org\/10.15223\/policy-037"}],"funder":[{"name":"NSF","award":["EARS-1 839 818"],"award-info":[{"award-number":["EARS-1 839 818"]}]},{"name":"NSF","award":["CNS-1 717 454"],"award-info":[{"award-number":["CNS-1 717 454"]}]},{"name":"NSF","award":["CNS-1 731 424"],"award-info":[{"award-number":["CNS-1 731 424"]}]},{"name":"NSF","award":["CNS-1 702 850"],"award-info":[{"award-number":["CNS-1 702 850"]}]},{"DOI":"10.13039\/100007225","name":"Ministry of Science and Technology","doi-asserted-by":"publisher","award":["MOST 109-2634-F-009-018"],"award-info":[{"award-number":["MOST 109-2634-F-009-018"]}],"id":[{"id":"10.13039\/100007225","id-type":"DOI","asserted-by":"publisher"}]},{"name":"Pervasive Artificial Intelligence Research"},{"DOI":"10.13039\/501100005799","name":"National Chiao Tung University","doi-asserted-by":"publisher","id":[{"id":"10.13039\/501100005799","id-type":"DOI","asserted-by":"publisher"}]},{"name":"Ministry of Education, Taiwan"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":["IEEE J. Sel. Top. Signal Process."],"published-print":{"date-parts":[[2021,4]]},"DOI":"10.1109\/jstsp.2021.3055957","type":"journal-article","created":{"date-parts":[[2021,2,2]],"date-time":"2021-02-02T19:34:12Z","timestamp":1612294452000},"page":"617-629","source":"Crossref","is-referenced-by-count":22,"title":["Tensor-Based Reinforcement Learning for Network Routing"],"prefix":"10.1109","volume":"15","author":[{"ORCID":"https:\/\/orcid.org\/0000-0002-8651-8550","authenticated-orcid":false,"given":"Kai-Chu","family":"Tsai","sequence":"first","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0003-3345-1732","authenticated-orcid":false,"given":"Zirui","family":"Zhuang","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0003-4884-3456","authenticated-orcid":false,"given":"Ricardo","family":"Lent","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-2182-2228","authenticated-orcid":false,"given":"Jingyu","family":"Wang","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0003-0829-4624","authenticated-orcid":false,"given":"Qi","family":"Qi","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-7883-6217","authenticated-orcid":false,"given":"Li-Chun","family":"Wang","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-6606-5822","authenticated-orcid":false,"given":"Zhu","family":"Han","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"263","reference":[{"key":"ref39","author":"wrede","year":"1963","journal-title":"Introduction to Vector and Tensor Analysis"},{"key":"ref38","author":"kleinrock","year":"1972","journal-title":"Communication Nets Stochastic Message Flow and Delay"},{"key":"ref33","doi-asserted-by":"publisher","DOI":"10.1109\/IJCNN.2018.8489213"},{"key":"ref32","doi-asserted-by":"publisher","DOI":"10.1109\/TII.2018.2808910"},{"key":"ref31","doi-asserted-by":"crossref","first-page":"17","DOI":"10.1007\/978-3-319-46128-1_2","article-title":"Semi-supervised tensor factorization for brain network analysis","author":"cao","year":"2016","journal-title":"Mach Learn Knowl Discov Databases"},{"key":"ref30","doi-asserted-by":"publisher","DOI":"10.1109\/TSP.2017.2690524"},{"key":"ref37","author":"kurose","year":"2016","journal-title":"Computer Networking A Top-down Approach"},{"key":"ref36","doi-asserted-by":"publisher","DOI":"10.1002\/0471791571"},{"key":"ref35","doi-asserted-by":"publisher","DOI":"10.1109\/WI-IAT.2012.21"},{"key":"ref34","doi-asserted-by":"publisher","DOI":"10.1109\/ICASSP.2019.8683659"},{"key":"ref28","doi-asserted-by":"publisher","DOI":"10.1109\/ICPR.2004.1334001"},{"key":"ref27","doi-asserted-by":"publisher","DOI":"10.1145\/1150402.1150445"},{"key":"ref29","doi-asserted-by":"publisher","DOI":"10.1109\/ICDM.2007.54"},{"key":"ref2","doi-asserted-by":"publisher","DOI":"10.1109\/35.668287"},{"key":"ref1","doi-asserted-by":"publisher","DOI":"10.1109\/9.182479"},{"key":"ref20","doi-asserted-by":"publisher","DOI":"10.1109\/ICC.2019.8761276"},{"key":"ref22","article-title":"On the sample complexity of reinforcement learning","author":"kakade","year":"2003"},{"key":"ref21","doi-asserted-by":"publisher","DOI":"10.1145\/3152434.3152441"},{"key":"ref24","doi-asserted-by":"publisher","DOI":"10.1002\/sapm19287139"},{"key":"ref23","doi-asserted-by":"publisher","DOI":"10.1002\/sapm192761164"},{"key":"ref26","article-title":"The extension of factor analysis to three-dimensional matrices","volume":"110119","author":"tucker","year":"1964","journal-title":"Contributions to Mathematical Psychology"},{"key":"ref25","first-page":"122","article-title":"Implications of factor analysis of three-way matrices for measurement of change","volume":"15","author":"tucker","year":"1963","journal-title":"Problems Measuring Change"},{"key":"ref50","doi-asserted-by":"publisher","DOI":"10.1145\/1143844.1143955"},{"key":"ref51","doi-asserted-by":"crossref","first-page":"2551","DOI":"10.1109\/TNNLS.2015.2496858","article-title":"Generalized higher order orthogonal iteration for tensor learning and decomposition","volume":"27","author":"liu","year":"2015","journal-title":"IEEE Trans Neural Netw Learn Syst"},{"key":"ref55","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-35289-8_26"},{"key":"ref54","doi-asserted-by":"publisher","DOI":"10.1145\/2018436.2018466"},{"key":"ref53","first-page":"1","article-title":"Tensorly: Tensor learning in python","volume":"20","author":"kossaifi","year":"2019","journal-title":"J Mach Learn Res"},{"key":"ref52","author":"topology","year":"2012"},{"key":"ref10","doi-asserted-by":"publisher","DOI":"10.1109\/TWC.2017.2769644"},{"key":"ref11","doi-asserted-by":"publisher","DOI":"10.1109\/MNET.2017.1700200"},{"key":"ref40","doi-asserted-by":"publisher","DOI":"10.1145\/1186785.1186794"},{"key":"ref12","doi-asserted-by":"publisher","DOI":"10.1007\/s10586-017-1086-y"},{"key":"ref13","doi-asserted-by":"publisher","DOI":"10.1109\/MWC.2016.1600317WC"},{"key":"ref14","doi-asserted-by":"crossref","first-page":"1946","DOI":"10.1109\/TC.2017.2709742","volume":"66","author":"mao","year":"2017","journal-title":"IEEE Trans Comput"},{"key":"ref15","doi-asserted-by":"publisher","DOI":"10.1109\/GLOCOM.2017.8254036"},{"key":"ref16","doi-asserted-by":"publisher","DOI":"10.1109\/TC.2018.2874483"},{"key":"ref17","doi-asserted-by":"publisher","DOI":"10.1109\/ISMSC.2015.7594025"},{"key":"ref18","article-title":"A deep-reinforcement learning approach for software-defined networking routing optimization","author":"xu","year":"2020","journal-title":"Proc 4th Int Conf Comput Sci Appl Eng"},{"key":"ref19","first-page":"14","article-title":"Deep reinforcement learning based qos-aware routing in knowledge-defined networking","author":"pham","year":"2018","journal-title":"Proc Int Conf Heterogeneous Netw Qual Rel Sec Robustness"},{"key":"ref4","article-title":"RFC1940: Source demand routing: Packet format and forwarding specification (version 1)","author":"estrin","year":"1996"},{"key":"ref3","article-title":"RFC3031: Multiprotocol label switching architecture","author":"rosen","year":"2001"},{"key":"ref6","doi-asserted-by":"publisher","DOI":"10.17487\/RFC7868"},{"key":"ref5","article-title":"RFC2328: OSPF Version 2","author":"moy","year":"1998"},{"key":"ref8","doi-asserted-by":"publisher","DOI":"10.1109\/JIOT.2018.2878435"},{"key":"ref7","doi-asserted-by":"publisher","DOI":"10.17487\/rfc2992"},{"key":"ref49","doi-asserted-by":"publisher","DOI":"10.1137\/S0895479898346995"},{"key":"ref9","doi-asserted-by":"publisher","DOI":"10.1109\/MWC.2016.1500356WC"},{"key":"ref46","doi-asserted-by":"publisher","DOI":"10.1162\/089976602753712972"},{"key":"ref45","doi-asserted-by":"publisher","DOI":"10.1007\/BF00993104"},{"key":"ref48","article-title":"Hedera: Dynamic flow scheduling for data center networks","author":"al-fares","year":"2010","journal-title":"Proc 7th USENIX Symp Netw Syst Des Implementation"},{"key":"ref47","article-title":"Learning from delayed rewards","author":"watkins","year":"1989"},{"key":"ref42","doi-asserted-by":"publisher","DOI":"10.2172\/923081"},{"key":"ref41","doi-asserted-by":"publisher","DOI":"10.1137\/S0895479896305696"},{"key":"ref44","author":"sutton","year":"2018","journal-title":"Reinforcement Learning An Introduction"},{"key":"ref43","doi-asserted-by":"publisher","DOI":"10.1613\/jair.301"}],"container-title":["IEEE Journal of Selected Topics in Signal Processing"],"original-title":[],"link":[{"URL":"https:\/\/ieeexplore.ieee.org\/ielam\/4200690\/9393360\/9343680-aam.pdf","content-type":"application\/pdf","content-version":"am","intended-application":"syndication"},{"URL":"http:\/\/xplorestaging.ieee.org\/ielx7\/4200690\/9393360\/09343680.pdf?arnumber=9343680","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2022,5,10]],"date-time":"2022-05-10T14:52:44Z","timestamp":1652194364000},"score":1,"resource":{"primary":{"URL":"https:\/\/ieeexplore.ieee.org\/document\/9343680\/"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2021,4]]},"references-count":55,"journal-issue":{"issue":"3"},"URL":"https:\/\/doi.org\/10.1109\/jstsp.2021.3055957","relation":{},"ISSN":["1932-4553","1941-0484"],"issn-type":[{"value":"1932-4553","type":"print"},{"value":"1941-0484","type":"electronic"}],"subject":[],"published":{"date-parts":[[2021,4]]}}}