{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,7]],"date-time":"2026-10-07T18:08:43Z","timestamp":1791396523859,"version":"4.3.3"},"reference-count":62,"publisher":"Institute of Electrical and Electronics Engineers (IEEE)","issue":"1","license":[{"start":{"date-parts":[[2022,3,1]],"date-time":"2022-03-01T00:00:00Z","timestamp":1646092800000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/ieeexplore.ieee.org\/Xplorehelp\/downloads\/license-information\/IEEE.html"},{"start":{"date-parts":[[2022,3,1]],"date-time":"2022-03-01T00:00:00Z","timestamp":1646092800000},"content-version":"stm-asf","delay-in-days":0,"URL":"https:\/\/doi.org\/10.15223\/policy-029"},{"start":{"date-parts":[[2022,3,1]],"date-time":"2022-03-01T00:00:00Z","timestamp":1646092800000},"content-version":"stm-asf","delay-in-days":0,"URL":"https:\/\/doi.org\/10.15223\/policy-037"}],"funder":[{"DOI":"10.13039\/501100002347","name":"German Federal Ministry for Education and Research (BMBF) within the project PIVOT \u2013 Privacy-Integrated design and Validation in the constrained IoT, and the Hamburg ahoi.digital initiative","doi-asserted-by":"publisher","id":[{"id":"10.13039\/501100002347","id-type":"DOI","asserted-by":"publisher"}]},{"name":"Ericsson AB"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":["IEEE Trans. Netw. Serv. Manage."],"published-print":{"date-parts":[[2022,3]]},"DOI":"10.1109\/tnsm.2021.3099902","type":"journal-article","created":{"date-parts":[[2021,7,26]],"date-time":"2021-07-26T21:40:28Z","timestamp":1627335628000},"page":"538-553","source":"Crossref","is-referenced-by-count":18,"title":["Content Object Security in the Internet of Things: Challenges, Prospects, and Emerging Solutions"],"prefix":"10.1109","volume":"19","author":[{"ORCID":"https:\/\/orcid.org\/0000-0002-9395-625X","authenticated-orcid":false,"given":"Cenk","family":"Gundogan","sequence":"first","affiliation":[{"name":"Internet Technologies Group, Hamburg University of Applied Sciences (HAW), Hamburg, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-5168-5861","authenticated-orcid":false,"given":"Christian","family":"Amsuss","sequence":"additional","affiliation":[],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-0956-7885","authenticated-orcid":false,"given":"Thomas C.","family":"Schmidt","sequence":"additional","affiliation":[{"name":"Internet Technologies Group, Hamburg University of Applied Sciences (HAW), Hamburg, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-3825-2807","authenticated-orcid":false,"given":"Matthias","family":"Wahlisch","sequence":"additional","affiliation":[{"name":"Department of Computer Science, Freie Universit&#x00E4;t Berlin, Berlin, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"263","reference":[{"key":"ref39","doi-asserted-by":"publisher","DOI":"10.17487\/rfc5116"},{"key":"ref38","author":"selander","year":"2020","journal-title":"Ephemeral Diffie-Hellman Over COSE (EDHOC)"},{"key":"ref33","author":"tschudin","year":"2018","journal-title":"CCN Lite Lightweight Implementation of the Content Centric Networking Protocol"},{"key":"ref32","doi-asserted-by":"publisher","DOI":"10.17487\/rfc3610"},{"key":"ref31","author":"montenegro","year":"2007","journal-title":"Transmission of IPv6 Packets over IEEE 802 15 4 Networks"},{"key":"ref30","author":"lenders","year":"2018","journal-title":"Connecting the world of embedded mobiles The RIOT approach to ubiquitous networking for the Internet of Things"},{"key":"ref37","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8442"},{"key":"ref36","doi-asserted-by":"publisher","DOI":"10.17487\/rfc6655"},{"key":"ref35","author":"mattsson","year":"2018","journal-title":"Controlling actuators with CoAP"},{"key":"ref34","first-page":"79","article-title":"A performance study of crypto-hardware in the low-end IoT","author":"kietzmann","year":"2021","journal-title":"Proc Int Conf Embedded Wireless Syst Netw (EWSN)"},{"key":"ref60","first-page":"77","article-title":"Toward a RESTful information-centric Web of things: A deeper look at data orientation in CoAP","author":"g\u00fcndogan","year":"2020","journal-title":"Proc 7th ACM Conf Inf Centric Netw (ICN)"},{"key":"ref62","doi-asserted-by":"publisher","DOI":"10.1145\/3097766.3097768"},{"key":"ref61","year":"2017","journal-title":"Result and artifact review and badging"},{"key":"ref28","first-page":"1","article-title":"ICNLoWPAN&#x2014;Named-data networking in low power IoT networks","author":"g\u00fcndogan","year":"2019","journal-title":"Proc 18th IFIP Netw Conf"},{"key":"ref27","doi-asserted-by":"publisher","DOI":"10.1145\/2660129.2660144"},{"key":"ref29","doi-asserted-by":"publisher","DOI":"10.1109\/JIOT.2018.2815038"},{"key":"ref2","doi-asserted-by":"publisher","DOI":"10.14722\/ndss.2016.23374"},{"key":"ref1","doi-asserted-by":"publisher","DOI":"10.1145\/357401.357402"},{"key":"ref20","author":"vucinic","year":"2020","journal-title":"Requirements for a Lightweight AKE for OSCORE"},{"key":"ref22","author":"tiloca","year":"2021","journal-title":"Group OSCORE&#x2014;Secure group communication for CoAP"},{"key":"ref21","doi-asserted-by":"publisher","DOI":"10.17487\/rfc7390"},{"key":"ref24","doi-asserted-by":"publisher","DOI":"10.1109\/SURV.2013.070813.00063"},{"key":"ref23","doi-asserted-by":"publisher","DOI":"10.1109\/MCOM.2012.6231276"},{"key":"ref26","doi-asserted-by":"publisher","DOI":"10.1145\/1658939.1658941"},{"key":"ref25","doi-asserted-by":"publisher","DOI":"10.1145\/2070562.2070563"},{"key":"ref50","doi-asserted-by":"publisher","DOI":"10.1145\/3125719.3125737"},{"key":"ref51","author":"tiloca","year":"2021","journal-title":"Proxy operations for CoAP group communication"},{"key":"ref59","author":"palombini","year":"2020","journal-title":"Combining EDHOC and OSCORE"},{"key":"ref58","author":"mattsson","year":"2018","journal-title":"Comparison of CoAP security protocols"},{"key":"ref57","first-page":"159","article-title":"NDN, CoAP, and MQTT: A Comparative measurement study in the IoT","author":"g\u00fcndogan","year":"2018","journal-title":"Proc 5th ACM Conf Inf Centric Netw (ICN)"},{"key":"ref56","year":"2009","journal-title":"Low Power 2 4 GHz Transceiver for Zigbee IEEE 802 15 4 6LoWPAN RF4CE and ISM Applications"},{"key":"ref55","doi-asserted-by":"publisher","DOI":"10.17487\/rfc7228"},{"key":"ref54","doi-asserted-by":"publisher","DOI":"10.1109\/WF-IoT.2015.7389098"},{"key":"ref53","author":"amsuess","year":"2021","journal-title":"Cacheable OSCORE"},{"key":"ref52","author":"tiloca","year":"2020","journal-title":"Observe notifications as CoAP multicast responses"},{"key":"ref10","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOMW.2013.6970748"},{"key":"ref11","doi-asserted-by":"publisher","DOI":"10.1109\/PST47121.2019.8949058"},{"key":"ref40","doi-asserted-by":"publisher","DOI":"10.17487\/rfc5077"},{"key":"ref12","doi-asserted-by":"publisher","DOI":"10.1109\/TNSM.2021.3089549"},{"key":"ref13","doi-asserted-by":"publisher","DOI":"10.1145\/3131672.3131699"},{"key":"ref14","doi-asserted-by":"publisher","DOI":"10.17487\/rfc5757"},{"key":"ref15","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8446"},{"key":"ref16","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-319-31875-2_22"},{"key":"ref17","author":"rescorla","year":"2021","journal-title":"Connection identifiers for DTLS 1 2"},{"key":"ref18","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8152"},{"key":"ref19","author":"amsuess","year":"2021","journal-title":"CoAP Echo request-tag and token processing"},{"key":"ref4","doi-asserted-by":"publisher","DOI":"10.17487\/rfc7252"},{"key":"ref3","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-33167-1_13"},{"key":"ref6","author":"stanford-clark","year":"2013","journal-title":"MQTT for Sensor Networks (MQTT-SN) Protocol Specification Version 1 2"},{"key":"ref5","doi-asserted-by":"publisher","DOI":"10.17487\/rfc6347"},{"key":"ref8","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8613"},{"key":"ref7","author":"banks","year":"2014","journal-title":"MQTT Version 3 1 1 OASIS Standard"},{"key":"ref49","doi-asserted-by":"publisher","DOI":"10.17487\/rfc2373"},{"key":"ref9","first-page":"19","article-title":"IoT content object security with OSCORE and NDN: A first experimental comparison","author":"g\u00fcndogan","year":"2020","journal-title":"Proc 19th IFIP Netw Conf"},{"key":"ref46","doi-asserted-by":"publisher","DOI":"10.17487\/rfc4861"},{"key":"ref45","doi-asserted-by":"publisher","DOI":"10.17487\/rfc4764"},{"key":"ref48","author":"amsuess","year":"2021","journal-title":"CoRE Resource Directory"},{"key":"ref47","doi-asserted-by":"publisher","DOI":"10.17487\/rfc4941"},{"key":"ref42","doi-asserted-by":"publisher","DOI":"10.1145\/2984356.2984374"},{"key":"ref41","doi-asserted-by":"publisher","DOI":"10.1145\/2810156.2810170"},{"key":"ref44","first-page":"232","article-title":"Entity authentication and key distribution","author":"bellare","year":"1993","journal-title":"Proc 13th Annu Int Cryptol Conf Adv Cryptol"},{"key":"ref43","doi-asserted-by":"publisher","DOI":"10.1109\/JIOT.2017.2725238"}],"container-title":["IEEE Transactions on Network and Service Management"],"original-title":[],"link":[{"URL":"http:\/\/xplorestaging.ieee.org\/ielx7\/4275028\/9732399\/09495929.pdf?arnumber=9495929","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2022,5,23]],"date-time":"2022-05-23T20:31:12Z","timestamp":1653337872000},"score":1,"resource":{"primary":{"URL":"https:\/\/ieeexplore.ieee.org\/document\/9495929\/"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2022,3]]},"references-count":62,"journal-issue":{"issue":"1"},"URL":"https:\/\/doi.org\/10.1109\/tnsm.2021.3099902","relation":{},"ISSN":["1932-4537","2373-7379"],"issn-type":[{"value":"1932-4537","type":"electronic"},{"value":"2373-7379","type":"electronic"}],"subject":[],"published":{"date-parts":[[2022,3]]}}}