{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,6,19]],"date-time":"2025-06-19T04:43:31Z","timestamp":1750308211189,"version":"3.41.0"},"publisher-location":"New York, NY, USA","reference-count":20,"publisher":"ACM","license":[{"start":{"date-parts":[[2004,8,30]],"date-time":"2004-08-30T00:00:00Z","timestamp":1093824000000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2004,8,30]]},"DOI":"10.1145\/1016707.1016717","type":"proceedings-article","created":{"date-parts":[[2004,10,7]],"date-time":"2004-10-07T17:39:48Z","timestamp":1097170788000},"page":"49-56","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":40,"title":["Steps towards a DoS-resistant internet architecture"],"prefix":"10.1145","author":[{"given":"Mark","family":"Handley","sequence":"first","affiliation":[{"name":"University College London"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Adam","family":"Greenhalgh","sequence":"additional","affiliation":[{"name":"University College London"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2004,8,30]]},"reference":[{"key":"e_1_3_2_1_1_1","unstructured":"APNIC. Root server trial FAQ. http:\/\/www.apnic.net\/info\/faq\/rootserver-faq.html.]]  APNIC. Root server trial FAQ. http:\/\/www.apnic.net\/info\/faq\/rootserver-faq.html.]]"},{"key":"e_1_3_2_1_2_1","volume-title":"IETF","author":"Aura T.","year":"2004","unstructured":"T. Aura . Cryptographically Generated Addresses (CGA). draft-ietf-send-cga-05.txt, work-in-progress , IETF , Feb. 2004 .]] T. Aura. Cryptographically Generated Addresses (CGA). draft-ietf-send-cga-05.txt, work-in-progress, IETF, Feb. 2004.]]"},{"key":"e_1_3_2_1_3_1","volume-title":"Multiprotocol extensions for BGP-4. RFC","author":"Bates T.","year":"2000","unstructured":"T. Bates , Y. Rekhter , R. Chandra , and D. Katz . Multiprotocol extensions for BGP-4. RFC 2858, June 2000 .]] T. Bates, Y. Rekhter, R. Chandra, and D. Katz. Multiprotocol extensions for BGP-4. RFC 2858, June 2000.]]"},{"key":"e_1_3_2_1_4_1","volume-title":"IETF","author":"S. Bhattacharyya","year":"2003","unstructured":"S. Bhattacharyya (editor). An overview of source-specific multicast (SSM). RFC 3569 , IETF , July 2003 .]] S. Bhattacharyya (editor). An overview of source-specific multicast (SSM). RFC 3569, IETF, July 2003.]]"},{"key":"e_1_3_2_1_5_1","volume-title":"February","author":"Castelluccia C.","year":"2002","unstructured":"C. Castelluccia and G. Montenegro . Securing group management in IPv6 with CGA (Cryptographically Generated Addresses). presentation to the IRTF GSEC Research Group , February , 2002 .]] C. Castelluccia and G. Montenegro. Securing group management in IPv6 with CGA (Cryptographically Generated Addresses). presentation to the IRTF GSEC Research Group, February, 2002.]]"},{"key":"e_1_3_2_1_6_1","volume-title":"Jan.","author":"CERT","year":"1998","unstructured":"CERT Advisory CA-1998-01. Smurf IP denial-of-service attacks , Jan. 1998 . http:\/\/www.cert.org\/advisories\/CA-1998-01.html.]] CERT Advisory CA-1998-01. Smurf IP denial-of-service attacks, Jan. 1998. http:\/\/www.cert.org\/advisories\/CA-1998-01.html.]]"},{"key":"e_1_3_2_1_7_1","volume-title":"IETF","author":"Deering S.","year":"1989","unstructured":"S. Deering . Host extensions for IP multicasting. RFC 1112 , IETF , Aug. 1989 .]] S. Deering. Host extensions for IP multicasting. RFC 1112, IETF, Aug. 1989.]]"},{"key":"e_1_3_2_1_8_1","doi-asserted-by":"publisher","DOI":"10.1145\/944759.944771"},{"key":"e_1_3_2_1_9_1","volume-title":"IETF","author":"IAB, M.","year":"2004","unstructured":"IAB, M. Handley (editor). Internet denial of service considerations. draft-iab-dos-00.txt, work-in-progress , IETF , Jan. 2004 .]] IAB, M. Handley (editor). Internet denial of service considerations. draft-iab-dos-00.txt, work-in-progress, IETF, Jan. 2004.]]"},{"key":"e_1_3_2_1_10_1","volume-title":"Proc. Network and Distributed System Security Symposium","author":"Ioannidis J.","year":"2002","unstructured":"J. Ioannidis and S. M. Bellovin . Implementing pushback: Router-based defense against DDoS attacks . In Proc. Network and Distributed System Security Symposium , San Diego. ISOC, Reston, VA. , February 2002 .]] J. Ioannidis and S. M. Bellovin. Implementing pushback: Router-based defense against DDoS attacks. In Proc. Network and Distributed System Security Symposium, San Diego. ISOC, Reston, VA., February 2002.]]"},{"key":"e_1_3_2_1_11_1","volume-title":"IETF","author":"Kohler E.","year":"2004","unstructured":"E. Kohler , M. Handley , and S. Floyd . Datagram congestion control protocol (dccp). draft-ietf-dccp-spec-06.txt, work-in-progress , IETF , Feb. 2004 .]] E. Kohler, M. Handley, and S. Floyd. Datagram congestion control protocol (dccp). draft-ietf-dccp-spec-06.txt, work-in-progress, IETF, Feb. 2004.]]"},{"key":"e_1_3_2_1_12_1","volume-title":"Proc. ACM SIGCOMM 2nd Workshop on Hot Topics in Networks","author":"Lakshminarayanan K.","year":"2003","unstructured":"K. Lakshminarayanan , D. Adkins , A. Perrig , and I. Stoica . Taming IP packet flooding attacks . In Proc. ACM SIGCOMM 2nd Workshop on Hot Topics in Networks , Nov. 2003 .]] K. Lakshminarayanan, D. Adkins, A. Perrig, and I. Stoica. Taming IP packet flooding attacks. In Proc. ACM SIGCOMM 2nd Workshop on Hot Topics in Networks, Nov. 2003.]]"},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.1145\/571697.571724"},{"key":"e_1_3_2_1_14_1","volume-title":"Apr.","author":"Moore D.","year":"2003","unstructured":"D. Moore , C. Shannon , G. Voelker , and S. Savage . Internet quarantine: Requirements for containing self-propagating code , Apr. 2003 .]] D. Moore, C. Shannon, G. Voelker, and S. Savage. Internet quarantine: Requirements for containing self-propagating code, Apr. 2003.]]"},{"key":"e_1_3_2_1_15_1","volume-title":"IETF","author":"Moskowitz R.","year":"2004","unstructured":"R. Moskowitz , P. Nikander , and P. Jokela . Host Identity Protocol. draft-moskowitz-hip-09.txt, work-in-progress , IETF , Feb. 2004 .]] R. Moskowitz, P. Nikander, and P. Jokela. Host Identity Protocol. draft-moskowitz-hip-09.txt, work-in-progress, IETF, Feb. 2004.]]"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.1145\/505659.505664"},{"key":"e_1_3_2_1_17_1","volume-title":"SIP: Session Initiation Protocol. RFC","author":"Rosenberg J.","year":"2002","unstructured":"J. Rosenberg , H. Schulzrinne , G. Camarillo , A. Johnston , J. Peterson , R. Sparks , M. Handley , and E. Schooler . SIP: Session Initiation Protocol. RFC 3261, June 2002 .]] J. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, and E. Schooler. SIP: Session Initiation Protocol. RFC 3261, June 2002.]]"},{"key":"e_1_3_2_1_18_1","volume-title":"IETF","author":"Schulzrinne H.","year":"2003","unstructured":"H. Schulzrinne , S. Casner , R. Frederick , and V. Jacobson . RTP: A Transport Protocol for Real-Time Applications. RFC 3550 , IETF , July 2003 .]] H. Schulzrinne, S. Casner, R. Frederick, and V. Jacobson. RTP: A Transport Protocol for Real-Time Applications. RFC 3550, IETF, July 2003.]]"},{"key":"e_1_3_2_1_19_1","volume-title":"Proc. ACM SIGCOMM 2nd Workshop on Hot Topics in Networks","author":"Tom Anderson D. W.","year":"2003","unstructured":"D. W. Tom Anderson , Timothy Roscoe . Preventing internet denial-of-service with capabilities . In Proc. ACM SIGCOMM 2nd Workshop on Hot Topics in Networks , Nov. 2003 .]] D. W. Tom Anderson, Timothy Roscoe. Preventing internet denial-of-service with capabilities. In Proc. ACM SIGCOMM 2nd Workshop on Hot Topics in Networks, Nov. 2003.]]"},{"key":"e_1_3_2_1_20_1","unstructured":"N. Weaver V. Paxson S. Staniford and R. Cunningham. Large scale malicious code: A research agenda. Darpa sponsored report. http:\/\/www.cs.berkeley.edu\/~nweaver\/\/large_scale_malicious_code.pdf.]]  N. Weaver V. Paxson S. Staniford and R. Cunningham. Large scale malicious code: A research agenda. Darpa sponsored report. http:\/\/www.cs.berkeley.edu\/~nweaver\/\/large_scale_malicious_code.pdf.]]"}],"event":{"name":"SIGCOMM04: ACM SIGCOMM 2004 Conference","sponsor":["SIGCOMM ACM Special Interest Group on Data Communication","ACM Association for Computing Machinery"],"location":"Portland Oregon USA","acronym":"SIGCOMM04"},"container-title":["Proceedings of the ACM SIGCOMM workshop on Future directions in network architecture"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1016707.1016717","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/1016707.1016717","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T16:31:04Z","timestamp":1750264264000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1016707.1016717"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2004,8,30]]},"references-count":20,"alternative-id":["10.1145\/1016707.1016717","10.1145\/1016707"],"URL":"https:\/\/doi.org\/10.1145\/1016707.1016717","relation":{},"subject":[],"published":{"date-parts":[[2004,8,30]]},"assertion":[{"value":"2004-08-30","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}