{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,1,13]],"date-time":"2026-01-13T23:41:48Z","timestamp":1768347708360,"version":"3.49.0"},"reference-count":52,"publisher":"Association for Computing Machinery (ACM)","issue":"3","license":[{"start":{"date-parts":[[2005,8,1]],"date-time":"2005-08-01T00:00:00Z","timestamp":1122854400000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":["ACM Trans. Internet Technol."],"published-print":{"date-parts":[[2005,8]]},"abstract":"<jats:p>\n            We design an adaptive admission control mechanism,\n            <jats:italic>network early warning system<\/jats:italic>\n            (NEWS), to protect servers and networks from flash crowds and maintain high performance for end-users. NEWS detects flash crowds from performance degradation in responses and mitigates flash crowds by admitting incoming requests adaptively. We evaluate NEWS performance with both simulations and testbed experiments. We first investigate a network-limited scenarion in simulations. We find that NEWS detects flash crowds within 20 seconds. By discarding 32% of incoming requests, NEWS protects the target server and networks from overloading, reducing the response packet drop rate from 25% to 2%. For admitted requests, NEWS increases their response rate by two times. This performance is similar to the best static rate limiter deployed in the same scenario. We also investigate the impact of detection intervals on NEWS performance, showing it affects both detection delay and false alarm rate. We further consider a server memory-limited scenario in testbed experiments, confirming that NEWS is also effective in this case. We also examine the runtime cost of NEWS traffic monitoring in practice and find that it consumes little CPU time and relatively small memory. Finally, we show NEWS effectively protects bystander traffic from flash crowds.\n          <\/jats:p>","DOI":"10.1145\/1084772.1084776","type":"journal-article","created":{"date-parts":[[2005,11,7]],"date-time":"2005-11-07T16:00:45Z","timestamp":1131379245000},"page":"532-569","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":36,"title":["Flash crowd mitigation via adaptive admission control based on application-level observations"],"prefix":"10.1145","volume":"5","author":[{"given":"Xuan","family":"Chen","sequence":"first","affiliation":[{"name":"University of Southern California, Marina del Rey, CA"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"John","family":"Heidemann","sequence":"additional","affiliation":[{"name":"University of Southern California, Marina del Rey, CA"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2005,8]]},"reference":[{"key":"e_1_2_1_1_1","unstructured":"Adler S. 1999. The slashdot effect an analysis of three Internet publications. Available at http:\/\/ssadler.phy.bnl.gov\/adler\/SDE\/SlashDotEffect.html.]]  Adler S. 1999. The slashdot effect an analysis of three Internet publications. Available at http:\/\/ssadler.phy.bnl.gov\/adler\/SDE\/SlashDotEffect.html.]]"},{"key":"e_1_2_1_2_1","first-page":"3","article-title":"A workload characterization study of the 1998 World Cup Web site. IEEE Network","volume":"14","author":"Arlitt M.","year":"2000","unstructured":"Arlitt , M. and Jin , T. 2000 . A workload characterization study of the 1998 World Cup Web site. IEEE Network , Special Issue on Web Performance 14 , 3 (May), 30--37.]] Arlitt, M. and Jin, T. 2000. A workload characterization study of the 1998 World Cup Web site. IEEE Network, Special Issue on Web Performance 14, 3 (May), 30--37.]]","journal-title":"Special Issue on Web Performance"},{"key":"e_1_2_1_3_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Balakrishnan H.","unstructured":"Balakrishnan , H. , Rahul , H. , and Seshan , S . 1999. An integrated congestion management architecture for internet hosts . In Proceedings of the ACM SIGCOMM . Cambridge, MA, 175--187.]] 10.1145\/316188.316220 Balakrishnan, H., Rahul, H., and Seshan, S. 1999. An integrated congestion management architecture for internet hosts. In Proceedings of the ACM SIGCOMM. Cambridge, MA, 175--187.]] 10.1145\/316188.316220"},{"key":"e_1_2_1_4_1","volume-title":"Proceedings of the ACM SIGCOMM Internet Measurement Workshop","author":"Barford P.","unstructured":"Barford , P. and Plonka , D . 2001. Characteristics of network traffic flow anomalies . In Proceedings of the ACM SIGCOMM Internet Measurement Workshop . San Francisco, CA, 2--13.]] 10.1145\/505202.505211 Barford, P. and Plonka, D. 2001. Characteristics of network traffic flow anomalies. In Proceedings of the ACM SIGCOMM Internet Measurement Workshop. San Francisco, CA, 2--13.]] 10.1145\/505202.505211"},{"key":"e_1_2_1_5_1","unstructured":"Basseville M. and Nikiforov I. V. 1993. Detection of Abrupt Changes---Theory and Application 1st Ed. Prentice-Hall Englewood Cliffs NJ.]]   Basseville M. and Nikiforov I. V. 1993. Detection of Abrupt Changes---Theory and Application 1st Ed. Prentice-Hall Englewood Cliffs NJ.]]"},{"key":"e_1_2_1_6_1","volume-title":"RFC 1945","author":"Berners-Lee T.","year":"1945","unstructured":"Berners-Lee , T. , Fielding , R. , and Frystyk , H . 1996. Hypertext transfer protocol---HTTP\/1.0 . RFC 1945 . IETF. Available at ftp:\/\/ftp.isi.edu\/in-notes\/rfc 1945 .txt.]] Berners-Lee, T., Fielding, R., and Frystyk, H. 1996. Hypertext transfer protocol---HTTP\/1.0. RFC 1945. IETF. Available at ftp:\/\/ftp.isi.edu\/in-notes\/rfc1945.txt.]]"},{"key":"e_1_2_1_7_1","volume-title":"Proceedings of the IEEE Systems, Man, and Cybernetics Information Assurance Workshop","author":"Blazek R. B.","unstructured":"Blazek , R. B. , Kim , H. , Rozovskii , B. , and Tartakovsky , A . 2001. A novel approach to detection of denial-of-service attacks via adaptive sequential and batch-sequential change-point detection methods . In Proceedings of the IEEE Systems, Man, and Cybernetics Information Assurance Workshop . West Point, NY.]] Blazek, R. B., Kim, H., Rozovskii, B., and Tartakovsky, A. 2001. A novel approach to detection of denial-of-service attacks via adaptive sequential and batch-sequential change-point detection methods. In Proceedings of the IEEE Systems, Man, and Cybernetics Information Assurance Workshop. West Point, NY.]]"},{"key":"e_1_2_1_8_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Breslau L.","unstructured":"Breslau , L. , Knightly , E. W. , Shenker , S. , Stoica , I. , and Zhang , H . 2000. Endpoint admission control: Architectural issues and performance . In Proceedings of the ACM SIGCOMM . Stockholm, Sweden, 57--69.]] 10.1145\/347059.347400 Breslau, L., Knightly, E. W., Shenker, S., Stoica, I., and Zhang, H. 2000. Endpoint admission control: Architectural issues and performance. In Proceedings of the ACM SIGCOMM. Stockholm, Sweden, 57--69.]] 10.1145\/347059.347400"},{"key":"e_1_2_1_9_1","volume-title":"Proceedings of the IEEE Infocom. Tel-Aviv, Israel, 1471--1480","author":"Cetinkaya C.","unstructured":"Cetinkaya , C. and Knightly , E . 2000. Egress admission control . In Proceedings of the IEEE Infocom. Tel-Aviv, Israel, 1471--1480 .]] Cetinkaya, C. and Knightly, E. 2000. Egress admission control. In Proceedings of the IEEE Infocom. Tel-Aviv, Israel, 1471--1480.]]"},{"key":"e_1_2_1_10_1","volume-title":"Proceedings of the IEEE Infocom","author":"Chen H.","unstructured":"Chen , H. and Mohapatra , P . 2002. Session-based overload control in qos-aware Web servers . In Proceedings of the IEEE Infocom . New York, NY.]] Chen, H. and Mohapatra, P. 2002. Session-based overload control in qos-aware Web servers. In Proceedings of the IEEE Infocom. New York, NY.]]"},{"key":"e_1_2_1_11_1","doi-asserted-by":"publisher","DOI":"10.1016\/S1389-1286(02)00439-5"},{"key":"e_1_2_1_12_1","doi-asserted-by":"publisher","DOI":"10.1109\/90.720870"},{"key":"e_1_2_1_13_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Clark D. D.","unstructured":"Clark , D. D. , Shenker , S. , and Zhang , L . 1992. Supporting real-time applications in an integrated services packet network: Architecture and mechanism . In Proceedings of the ACM SIGCOMM . Baltimore, MD. 14--26. Available at citeseer.nj.nec.com\/clark92supporting.html.]] 10.1145\/144179.144199 Clark, D. D., Shenker, S., and Zhang, L. 1992. Supporting real-time applications in an integrated services packet network: Architecture and mechanism. In Proceedings of the ACM SIGCOMM. Baltimore, MD. 14--26. Available at citeseer.nj.nec.com\/clark92supporting.html.]] 10.1145\/144179.144199"},{"key":"e_1_2_1_14_1","unstructured":"Cormen T. H. Leiserson C. E. Rivest R. L. and Stein C. 2001. Introduction to Algorithms. 2nd Ed. The MIT Press Cambridge MA.]]   Cormen T. H. Leiserson C. E. Rivest R. L. and Stein C. 2001. Introduction to Algorithms. 2nd Ed. The MIT Press Cambridge MA.]]"},{"key":"e_1_2_1_15_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Demers A.","unstructured":"Demers , A. , Keshav , S. , and Shenker , S . 1989. Analysis and simulation of a fair-queueing algorithm . In Proceedings of the ACM SIGCOMM . Austin, TX. 1--12.]] 10.1145\/75246.75248 Demers, A., Keshav, S., and Shenker, S. 1989. Analysis and simulation of a fair-queueing algorithm. In Proceedings of the ACM SIGCOMM. Austin, TX. 1--12.]] 10.1145\/75246.75248"},{"key":"e_1_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.1023\/A:1019200806549"},{"key":"e_1_2_1_17_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Estan C.","unstructured":"Estan , C. and Varghese , G . 2002. New directions in traffic measurement and accounting . In Proceedings of the ACM SIGCOMM . Pittsburgh, PA. 323--336.]] 10.1145\/633025.633056 Estan, C. and Varghese, G. 2002. New directions in traffic measurement and accounting. In Proceedings of the ACM SIGCOMM. Pittsburgh, PA. 323--336.]] 10.1145\/633025.633056"},{"key":"e_1_2_1_18_1","doi-asserted-by":"crossref","unstructured":"Fang W. Seddigh N. and Nandy B. 2000. A time-sliding window three colour marker (TSWTCM). RFC 2859. IETF.]]   Fang W. Seddigh N. and Nandy B. 2000. A time-sliding window three colour marker (TSWTCM). RFC 2859. IETF.]]","DOI":"10.17487\/rfc2859"},{"key":"e_1_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1109\/90.793002"},{"key":"e_1_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1109\/90.251892"},{"key":"e_1_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.1109\/90.944338"},{"key":"e_1_2_1_22_1","unstructured":"Gettys J. Mogul J. Frystyk H. Masinter L. Leach P. and Berners-Lee T. 1999. Hypertext transfer protocol---HTTP\/1.1. RFC 2616. IETF. Available at http:\/\/www.w3.org\/Protocols\/rfc2616\/rfc2616.html.]]  Gettys J. Mogul J. Frystyk H. Masinter L. Leach P. and Berners-Lee T. 1999. Hypertext transfer protocol---HTTP\/1.1. RFC 2616. IETF. Available at http:\/\/www.w3.org\/Protocols\/rfc2616\/rfc2616.html.]]"},{"key":"e_1_2_1_23_1","doi-asserted-by":"crossref","first-page":"6","DOI":"10.1109\/49.400665","article-title":"A decision-theoretic approach to call admission control in ATM networks","volume":"13","author":"Gibbens R.","year":"1995","unstructured":"Gibbens , R. , Kelly , F. P. , and Key , P. 1995 . A decision-theoretic approach to call admission control in ATM networks . IEEE J. Select. Areas Comm. 13 , 6 (Aug.), 30--37.]] Gibbens, R., Kelly, F. P., and Key, P. 1995. A decision-theoretic approach to call admission control in ATM networks. IEEE J. Select. Areas Comm. 13, 6 (Aug.), 30--37.]]","journal-title":"IEEE J. Select. Areas Comm."},{"key":"e_1_2_1_24_1","volume-title":"Proceedings of the IEEE International Conference on Network Protocols","author":"Guo L.","unstructured":"Guo , L. and Matta , I . 2001. The war between mice and elephants . In Proceedings of the IEEE International Conference on Network Protocols . Riverside, CA.]] Guo, L. and Matta, I. 2001. The war between mice and elephants. In Proceedings of the IEEE International Conference on Network Protocols. Riverside, CA.]]"},{"key":"e_1_2_1_25_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Jacobson V.","year":"1988","unstructured":"Jacobson , V. 1988 . Congestion avoidance and control . In Proceedings of the ACM SIGCOMM . Stanford, CA. 314--329.]] 10.1145\/52324.52356 Jacobson, V. 1988. Congestion avoidance and control. In Proceedings of the ACM SIGCOMM. Stanford, CA. 314--329.]] 10.1145\/52324.52356"},{"key":"e_1_2_1_26_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Jamin S.","unstructured":"Jamin , S. , Danzig , P. , Shenker , S. , and Zhang , L . 1995. Measurement-based admission control algorithms for controlled-load service . In Proceedings of the ACM SIGCOMM . Cambridge, MA. 2--13.]] 10.1145\/217382.217396 Jamin, S., Danzig, P., Shenker, S., and Zhang, L. 1995. Measurement-based admission control algorithms for controlled-load service. In Proceedings of the ACM SIGCOMM. Cambridge, MA. 2--13.]] 10.1145\/217382.217396"},{"key":"e_1_2_1_27_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Jamjoom H.","unstructured":"Jamjoom , H. and Shin , K. G . 2003. Persistent dropping: An efficient control of traffic aggregates . In Proceedings of the ACM SIGCOMM . Karlsruhe, Germany, 287--298.]] 10.1145\/863955.863988 Jamjoom, H. and Shin, K. G. 2003. Persistent dropping: An efficient control of traffic aggregates. In Proceedings of the ACM SIGCOMM. Karlsruhe, Germany, 287--298.]] 10.1145\/863955.863988"},{"key":"e_1_2_1_28_1","volume-title":"Proceedings of the International World Wide Web Conference. Hawaii, 252--262","author":"Jung J.","unstructured":"Jung , J. , Krishnamurthy , B. , and Rabinovich , M . 2002. Flash crowds and denial of service attacks: Characterization and implications for CDNs and Web sites . In Proceedings of the International World Wide Web Conference. Hawaii, 252--262 .]] 10.1145\/511446.511485 Jung, J., Krishnamurthy, B., and Rabinovich, M. 2002. Flash crowds and denial of service attacks: Characterization and implications for CDNs and Web sites. In Proceedings of the International World Wide Web Conference. Hawaii, 252--262.]] 10.1145\/511446.511485"},{"key":"e_1_2_1_29_1","volume-title":"Proceedings of the ACM\/IEEE International Conference on Mobile Computing and Networking","author":"Kim M.","unstructured":"Kim , M. and Noble , B . 2001. Mobile network estimation . In Proceedings of the ACM\/IEEE International Conference on Mobile Computing and Networking . Rome, Italy, 298--309.]] 10.1145\/381677.381705 Kim, M. and Noble, B. 2001. Mobile network estimation. In Proceedings of the ACM\/IEEE International Conference on Mobile Computing and Networking. Rome, Italy, 298--309.]] 10.1145\/381677.381705"},{"key":"e_1_2_1_30_1","unstructured":"Labs L.-B. 1992. The Internet Traffic Archive. Available at http:\/\/ita.ee.lbl.gov\/.]]  Labs L.-B. 1992. The Internet Traffic Archive. Available at http:\/\/ita.ee.lbl.gov\/.]]"},{"key":"e_1_2_1_31_1","doi-asserted-by":"publisher","DOI":"10.1145\/643114.643117"},{"key":"e_1_2_1_32_1","unstructured":"Lever C. Eriksen M. A. and Molloy S. P. 2000. An analysis of the TUX Web server. Tech. rep. (Nov.) Center for Information Technology Integration University of Michigan.]]  Lever C. Eriksen M. A. and Molloy S. P. 2000. An analysis of the TUX Web server. Tech. rep. (Nov.) Center for Information Technology Integration University of Michigan.]]"},{"key":"e_1_2_1_33_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Lin D.","unstructured":"Lin , D. and Morris , R . 1997. Dynamics of random early detection . In Proceedings of the ACM SIGCOMM . Cannes, France, 127--137.]] 10.1145\/263105.263154 Lin, D. and Morris, R. 1997. Dynamics of random early detection. In Proceedings of the ACM SIGCOMM. Cannes, France, 127--137.]] 10.1145\/263105.263154"},{"key":"e_1_2_1_34_1","volume-title":"Proceedings of the IEEE Real-Time Technology and Applications Symposium","author":"Lu C.","unstructured":"Lu , C. , Abdelzaher , T. F. , Stankovic , J. A. , and Son , S. H . 2001. A feedback control approach for guaranteeing relative delays in Web servers . In Proceedings of the IEEE Real-Time Technology and Applications Symposium . Taipei, Taiwan.]] Lu, C., Abdelzaher, T. F., Stankovic, J. A., and Son, S. H. 2001. A feedback control approach for guaranteeing relative delays in Web servers. In Proceedings of the IEEE Real-Time Technology and Applications Symposium. Taipei, Taiwan.]]"},{"key":"e_1_2_1_35_1","doi-asserted-by":"crossref","unstructured":"Mahajan R. Bellovin S. Floyd S. Ioannidis J. Paxson V. and Shenker S. 2001. Controlling high bandwidth aggregates in the network. Tech. rep. International Computer Science Institute (ICSI) Berkeley CA. (July).]]  Mahajan R. Bellovin S. Floyd S. Ioannidis J. Paxson V. and Shenker S. 2001. Controlling high bandwidth aggregates in the network. Tech. rep. International Computer Science Institute (ICSI) Berkeley CA. (July).]]","DOI":"10.1145\/571697.571724"},{"key":"e_1_2_1_36_1","volume-title":"Proceedings of the IEEE International Conference on Network Protocols","author":"Mahajan R.","unstructured":"Mahajan , R. and Floyd , S . 2001. Controlling high bandwidth flows at the congested router . In Proceedings of the IEEE International Conference on Network Protocols . Riverside, CA, 1--12.]] Mahajan, R. and Floyd, S. 2001. Controlling high bandwidth flows at the congested router. In Proceedings of the IEEE International Conference on Network Protocols. Riverside, CA, 1--12.]]"},{"key":"e_1_2_1_37_1","volume-title":"Proceedings of the IEEE International Conference on Multimedia Computing and Systems","author":"Mundur P.","unstructured":"Mundur , P. , Simon , R. , and Sood , A . 1999. Integrated admission control in hierarchical video-on-demand systems . In Proceedings of the IEEE International Conference on Multimedia Computing and Systems . Florence, Italy, 220--225.]] Mundur, P., Simon, R., and Sood, A. 1999. Integrated admission control in hierarchical video-on-demand systems. In Proceedings of the IEEE International Conference on Multimedia Computing and Systems. Florence, Italy, 220--225.]]"},{"key":"e_1_2_1_38_1","unstructured":"Netfilter\/iptables. 2003. Netfilter\/iptables project. Available at http:\/\/www.netfilter.org\/.]]  Netfilter\/iptables. 2003. Netfilter\/iptables project. Available at http:\/\/www.netfilter.org\/.]]"},{"key":"e_1_2_1_39_1","volume-title":"NetFlow performance analysis. White paper. Cisco Systems","author":"NetFlow","unstructured":"NetFlow . 2003. NetFlow performance analysis. White paper. Cisco Systems , Inc . Available at http:\/\/www.cisco.com\/warp\/public\/cc\/pd\/iosw\/prodlit\/ntfo_wp.htm.]] NetFlow. 2003. NetFlow performance analysis. White paper. Cisco Systems, Inc. Available at http:\/\/www.cisco.com\/warp\/public\/cc\/pd\/iosw\/prodlit\/ntfo_wp.htm.]]"},{"key":"e_1_2_1_40_1","unstructured":"NIST. 1998. NIST net network emulator. Available at http:\/\/is2.antd.nist.gov\/itg\/nistnet\/.]]  NIST. 1998. NIST net network emulator. Available at http:\/\/is2.antd.nist.gov\/itg\/nistnet\/.]]"},{"key":"e_1_2_1_41_1","volume-title":"Proceedings of the IEEE Infocom. Tel-Aviv, Israel, 942--951","author":"Pan R.","unstructured":"Pan , R. , Prabhakar , B. , and Psounis , K . 2000. CHOKE, a stateless active queue management scheme for approximating fair bandwidth allocation . In Proceedings of the IEEE Infocom. Tel-Aviv, Israel, 942--951 .]] Pan, R., Prabhakar, B., and Psounis, K. 2000. CHOKE, a stateless active queue management scheme for approximating fair bandwidth allocation. In Proceedings of the IEEE Infocom. Tel-Aviv, Israel, 942--951.]]"},{"key":"e_1_2_1_42_1","doi-asserted-by":"publisher","DOI":"10.1109\/90.234856"},{"key":"e_1_2_1_43_1","volume-title":"Proceedings of the ACM SIGCOMM. San Diego CA, 15--26","author":"Park K.","unstructured":"Park , K. and Lee , H . 2001. On the effectiveness of route-based packet filtering for distributed DoS attack prevention in power-law Internets . In Proceedings of the ACM SIGCOMM. San Diego CA, 15--26 .]] 10.1145\/383059.383061 Park, K. and Lee, H. 2001. On the effectiveness of route-based packet filtering for distributed DoS attack prevention in power-law Internets. In Proceedings of the ACM SIGCOMM. San Diego CA, 15--26.]] 10.1145\/383059.383061"},{"key":"e_1_2_1_44_1","unstructured":"Pieda P. Ethridge J. Baines M. and Shallwani F. 2000. A network simulator differentiated services implementation. Available at http:\/\/www7.nortel.com:8080\/CTL\/.]]  Pieda P. Ethridge J. Baines M. and Shallwani F. 2000. A network simulator differentiated services implementation. Available at http:\/\/www7.nortel.com:8080\/CTL\/.]]"},{"key":"e_1_2_1_45_1","unstructured":"Rahin M. A. and Kara M. 1998. Call admission control algorithms in ATM networks: A performance comparison and research directions. Research rep. (Feb.) University of Leeds.]]  Rahin M. A. and Kara M. 1998. Call admission control algorithms in ATM networks: A performance comparison and research directions. Research rep. (Feb.) University of Leeds.]]"},{"key":"e_1_2_1_46_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Savage S.","unstructured":"Savage , S. , Wetherall , D. , Karlin , A. , and Anderson , T . 2000. Practical network support for IP traceback . In Proceedings of the ACM SIGCOMM . Stockholm, Sweden, 295--306.]] 10.1145\/347059.347560 Savage, S., Wetherall, D., Karlin, A., and Anderson, T. 2000. Practical network support for IP traceback. In Proceedings of the ACM SIGCOMM. Stockholm, Sweden, 295--306.]] 10.1145\/347059.347560"},{"key":"e_1_2_1_47_1","doi-asserted-by":"crossref","unstructured":"Shenker S. and Wroclawski J. 1997. General characterization parameters for integrated service network elements. RFC 2215. IETF.]]   Shenker S. and Wroclawski J. 1997. General characterization parameters for integrated service network elements. RFC 2215. IETF.]]","DOI":"10.17487\/rfc2215"},{"key":"e_1_2_1_48_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Shoeten A. C.","unstructured":"Shoeten , A. C. , Partridge , C. , Sanchez , L. A. , Jones , C. E. , Tchakountio , F. , Kent , S. T. , and Strayer , W. T . 2001. Hash-based IP traceback . In Proceedings of the ACM SIGCOMM . San Diego, CA. 3--14.]] 10.1145\/383059.383060 Shoeten, A. C., Partridge, C., Sanchez, L. A., Jones, C. E., Tchakountio, F., Kent, S. T., and Strayer, W. T. 2001. Hash-based IP traceback. In Proceedings of the ACM SIGCOMM. San Diego, CA. 3--14.]] 10.1145\/383059.383060"},{"key":"e_1_2_1_49_1","volume-title":"Proceedings of the ACM SIGCOMM","author":"Stoica I.","unstructured":"Stoica , I. , Shenker , S. , and Zhang , H . 1998. Core-stateless fair queueing: Achieving approximately fair bandwidth allocations in high speed networks . In Proceedings of the ACM SIGCOMM . Vancouver, British Columbia, Canada, 118--130.]] 10.1145\/285237.285273 Stoica, I., Shenker, S., and Zhang, H. 1998. Core-stateless fair queueing: Achieving approximately fair bandwidth allocations in high speed networks. In Proceedings of the ACM SIGCOMM. Vancouver, British Columbia, Canada, 118--130.]] 10.1145\/285237.285273"},{"key":"e_1_2_1_50_1","unstructured":"VINT. 1997. UCB\/LBNL\/VINT network simulator---ns (version 2). Available at http:\/\/www. isi.edu\/nsnam\/ns\/.]]  VINT. 1997. UCB\/LBNL\/VINT network simulator---ns (version 2). Available at http:\/\/www. isi.edu\/nsnam\/ns\/.]]"},{"key":"e_1_2_1_51_1","volume-title":"Proceedings of the USENIX Symposium on Internet Technologies and Systems","author":"Welsh M.","unstructured":"Welsh , M. and Culler , D . 2003. Adaptive overload control for busy Internet servers . In Proceedings of the USENIX Symposium on Internet Technologies and Systems . Seattle, WA.]] Welsh, M. and Culler, D. 2003. Adaptive overload control for busy Internet servers. In Proceedings of the USENIX Symposium on Internet Technologies and Systems. Seattle, WA.]]"},{"key":"e_1_2_1_52_1","doi-asserted-by":"publisher","DOI":"10.1016\/S0167-739X(99)00025-4"}],"container-title":["ACM Transactions on Internet Technology"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1084772.1084776","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/1084772.1084776","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T16:08:24Z","timestamp":1750262904000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1084772.1084776"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2005,8]]},"references-count":52,"journal-issue":{"issue":"3","published-print":{"date-parts":[[2005,8]]}},"alternative-id":["10.1145\/1084772.1084776"],"URL":"https:\/\/doi.org\/10.1145\/1084772.1084776","relation":{},"ISSN":["1533-5399","1557-6051"],"issn-type":[{"value":"1533-5399","type":"print"},{"value":"1557-6051","type":"electronic"}],"subject":[],"published":{"date-parts":[[2005,8]]},"assertion":[{"value":"2005-08-01","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}