{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,6,19]],"date-time":"2025-06-19T04:38:42Z","timestamp":1750307922813,"version":"3.41.0"},"publisher-location":"New York, NY, USA","reference-count":49,"publisher":"ACM","license":[{"start":{"date-parts":[[2006,10,25]],"date-time":"2006-10-25T00:00:00Z","timestamp":1161734400000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2006,10,25]]},"DOI":"10.1145\/1177080.1177095","type":"proceedings-article","created":{"date-parts":[[2007,1,17]],"date-time":"2007-01-17T01:15:56Z","timestamp":1168996556000},"page":"105-118","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":9,"title":["Monarch"],"prefix":"10.1145","author":[{"given":"Andreas","family":"Haeberlen","sequence":"first","affiliation":[{"name":"Rice University"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Marcel","family":"Dischinger","sequence":"additional","affiliation":[{"name":"Rice University"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Krishna P.","family":"Gummadi","sequence":"additional","affiliation":[{"name":"Rice University"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Stefan","family":"Saroiu","sequence":"additional","affiliation":[{"name":"University of Toronto"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2006,10,25]]},"reference":[{"key":"e_1_3_2_1_1_1","doi-asserted-by":"publisher","DOI":"10.5555\/1097871.1098174"},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1145\/956993.956996"},{"key":"e_1_3_2_1_3_1","volume-title":"Proceedings of NSDI'06","author":"Anderson T.","year":"2006","unstructured":"T. Anderson , A. Collins , A. Krishnamurthy , and J. Zahorjan . PCP: Efficient endpoint congestion control . In Proceedings of NSDI'06 , May 2006 .]] T. Anderson, A. Collins, A. Krishnamurthy, and J. Zahorjan. PCP: Efficient endpoint congestion control. In Proceedings of NSDI'06, May 2006.]]"},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.5555\/1251086.1251105"},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.1998.659661"},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"publisher","DOI":"10.1145\/637201.637216"},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.1145\/166237.166265"},{"key":"e_1_3_2_1_8_1","doi-asserted-by":"publisher","DOI":"10.1109\/49.464716"},{"key":"e_1_3_2_1_9_1","doi-asserted-by":"publisher","DOI":"10.1145\/956993.957007"},{"key":"e_1_3_2_1_10_1","volume-title":"Dec","author":"Floyd S.","year":"2003","unstructured":"S. Floyd . RFC 3649 - HighSpeed TCP for large congestion windows , Dec 2003 . ftp:\/\/ftp.rfc-editor.org\/in-notes\/rfc3649.txt.]] S. Floyd. RFC 3649 - HighSpeed TCP for large congestion windows, Dec 2003. ftp:\/\/ftp.rfc-editor.org\/in-notes\/rfc3649.txt.]]"},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"publisher","DOI":"10.1145\/347059.347397"},{"key":"e_1_3_2_1_12_1","volume-title":"Apr","author":"Floyd S.","year":"2004","unstructured":"S. Floyd , T. Henderson , and A. Gurtov . RFC 3782 - The NewReno modification to TCP's fast recovery algorithm , Apr 2004 . ftp:\/\/ftp.rfc-editor.org\/in-notes\/rfc3782.txt.]] S. Floyd, T. Henderson, and A. Gurtov. RFC 3782 - The NewReno modification to TCP's fast recovery algorithm, Apr 2004. ftp:\/\/ftp.rfc-editor.org\/in-notes\/rfc3782.txt.]]"},{"key":"e_1_3_2_1_13_1","volume-title":"Proceedings of Passive and Active Measurement (PAM'02)","author":"Govindan R.","year":"2002","unstructured":"R. Govindan and V. Paxson . Estimating router ICMP generation delays . In Proceedings of Passive and Active Measurement (PAM'02) , 2002 .]] R. Govindan and V. Paxson. Estimating router ICMP generation delays. In Proceedings of Passive and Active Measurement (PAM'02), 2002.]]"},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"publisher","DOI":"10.1145\/637201.637203"},{"key":"e_1_3_2_1_15_1","volume-title":"May","author":"Jacobson V.","year":"1992","unstructured":"V. Jacobson , R. Braden , and D. Borman . RFC 1323 - TCP extensions for high performance , May 1992 . http:\/\/www.faqs.org\/rfcs\/rfc1323.html.]] V. Jacobson, R. Braden, and D. Borman. RFC 1323 - TCP extensions for high performance, May 1992. http:\/\/www.faqs.org\/rfcs\/rfc1323.html.]]"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.2004.1354571"},{"key":"e_1_3_2_1_17_1","volume-title":"Proceedings of IEEE Infocom 2004","author":"Jin C.","year":"2004","unstructured":"C. Jin , D. X. Wei , and S. H. Low . FAST TCP: Motivation, architecture, algorithms, performance . In Proceedings of IEEE Infocom 2004 , Mar 2004 .]] C. Jin, D. X. Wei, and S. H. Low. FAST TCP: Motivation, architecture, algorithms, performance. In Proceedings of IEEE Infocom 2004, Mar 2004.]]"},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.1145\/633025.633035"},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1145\/956981.956989"},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1145\/948205.948212"},{"key":"e_1_3_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.1145\/945445.945456"},{"key":"e_1_3_2_1_22_1","doi-asserted-by":"publisher","DOI":"10.1145\/381677.381704"},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"publisher","DOI":"10.1145\/248156.248181"},{"key":"e_1_3_2_1_24_1","volume-title":"RFC 2018 - TCP selective acknowledgment options","author":"Mathis M.","year":"1996","unstructured":"M. Mathis , J. Mahdavi , S. Floyd , and A. Romanow . RFC 2018 - TCP selective acknowledgment options , Oct. 1996 . http:\/\/www.faqs.org\/rfcs\/rfc2018.html.]] M. Mathis, J. Mahdavi, S. Floyd, and A. Romanow. RFC 2018 - TCP selective acknowledgment options, Oct. 1996. http:\/\/www.faqs.org\/rfcs\/rfc2018.html.]]"},{"key":"e_1_3_2_1_25_1","doi-asserted-by":"publisher","DOI":"10.1145\/1064413.1064418"},{"key":"e_1_3_2_1_26_1","doi-asserted-by":"publisher","DOI":"10.1145\/1028788.1028835"},{"key":"e_1_3_2_1_27_1","unstructured":"Monarch web site. http:\/\/monarch.mpi-sws.mpg.de\/.]]  Monarch web site. http:\/\/monarch.mpi-sws.mpg.de\/.]]"},{"key":"e_1_3_2_1_28_1","first-page":"155","volume-title":"Proceedings of NSDI'04","author":"Musuvathi M.","year":"2004","unstructured":"M. Musuvathi and D. R. Engler . Model-checking large network protocol implementations . In Proceedings of NSDI'04 , pages 155 -- 168 , March 2004 .]] M. Musuvathi and D. R. Engler. Model-checking large network protocol implementations. In Proceedings of NSDI'04, pages 155--168, March 2004.]]"},{"key":"e_1_3_2_1_29_1","volume-title":"NAT, and packet mangling for Linux","author":"Netfilter","year":"2006","unstructured":"Netfilter : Firewalling , NAT, and packet mangling for Linux , 2006 . http:\/\/www.netfilter.org.]] Netfilter: Firewalling, NAT, and packet mangling for Linux, 2006. http:\/\/www.netfilter.org.]]"},{"key":"e_1_3_2_1_30_1","unstructured":"The network simulator - ns2. http:\/\/www.isi.edu\/nsnam\/ns.]]  The network simulator - ns2. http:\/\/www.isi.edu\/nsnam\/ns.]]"},{"key":"e_1_3_2_1_31_1","volume-title":"Papers on TCP modeling and related topics","author":"Padhye J.","year":"2001","unstructured":"J. Padhye . Papers on TCP modeling and related topics , 2001 . http:\/\/research.microsoft.com\/~padhye\/tcp-model.html.]] J. Padhye. Papers on TCP modeling and related topics, 2001. http:\/\/research.microsoft.com\/~padhye\/tcp-model.html.]]"},{"key":"e_1_3_2_1_32_1","volume-title":"Proceedings of the ACM SIGCOMM Conference","author":"Padhye J.","year":"2001","unstructured":"J. Padhye and S. Floyd . Identifying the TCP behavior of web servers . In Proceedings of the ACM SIGCOMM Conference , San Diego, CA, USA , June 2001 .]] J. Padhye and S. Floyd. Identifying the TCP behavior of web servers. In Proceedings of the ACM SIGCOMM Conference, San Diego, CA, USA, June 2001.]]"},{"key":"e_1_3_2_1_33_1","doi-asserted-by":"publisher","DOI":"10.1109\/90.649563"},{"key":"e_1_3_2_1_34_1","doi-asserted-by":"publisher","DOI":"10.5555\/580055.829295"},{"key":"e_1_3_2_1_35_1","unstructured":"PlanetLab. http:\/\/www.planet-lab.org\/.]]  PlanetLab. http:\/\/www.planet-lab.org\/.]]"},{"volume-title":"Current slices in PlanetLab","year":"2006","key":"e_1_3_2_1_36_1","unstructured":"PlanetLab. Current slices in PlanetLab , 2006 . http:\/\/www.planet-lab.org\/php\/slices.php.]] PlanetLab. Current slices in PlanetLab, 2006. http:\/\/www.planet-lab.org\/php\/slices.php.]]"},{"key":"e_1_3_2_1_37_1","doi-asserted-by":"crossref","unstructured":"J. Postel. RFC 792 - Internet control message protocol 1981. http:\/\/www.faqs.org\/rfcs\/rfc792.html.]]   J. Postel. RFC 792 - Internet control message protocol 1981. http:\/\/www.faqs.org\/rfcs\/rfc792.html.]]","DOI":"10.17487\/rfc0777"},{"key":"e_1_3_2_1_38_1","volume-title":"Sep","author":"Ramakrishnan K. K.","year":"2001","unstructured":"K. K. Ramakrishnan , S. Floyd , and D. L. Black . RFC 3168 - The addition of explicit congestion notification (ECN) to IP , Sep 2001 . http:\/\/www.faqs.org\/rfcs\/rfc3168.html.]] K. K. Ramakrishnan, S. Floyd, and D. L. Black. RFC 3168 - The addition of explicit congestion notification (ECN) to IP, Sep 2001. http:\/\/www.faqs.org\/rfcs\/rfc3168.html.]]"},{"key":"e_1_3_2_1_39_1","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.1999.752152"},{"key":"e_1_3_2_1_40_1","doi-asserted-by":"publisher","DOI":"10.1145\/251007.251012"},{"key":"e_1_3_2_1_41_1","volume-title":"Proceedings of the Multimedia Computing and Networking (MMCN)","author":"Saroiu S.","year":"2002","unstructured":"S. Saroiu , K. P. Gummadi , and S. D. Gribble . A measurement study of peer-to-peer file sharing systems . In Proceedings of the Multimedia Computing and Networking (MMCN) , San Jose, CA , January 2002 .]] S. Saroiu, K. P. Gummadi, and S. D. Gribble. A measurement study of peer-to-peer file sharing systems. In Proceedings of the Multimedia Computing and Networking (MMCN), San Jose, CA, January 2002.]]"},{"key":"e_1_3_2_1_42_1","volume-title":"SProbe: A fast tool for measuring bottleneck bandwidth in uncooperative environments","author":"Saroiu S.","year":"2002","unstructured":"S. Saroiu , K. P. Gummadi , and S. D. Gribble . SProbe: A fast tool for measuring bottleneck bandwidth in uncooperative environments , 2002 . http:\/\/sprobe.cs.washington.edu.]] S. Saroiu, K. P. Gummadi, and S. D. Gribble. SProbe: A fast tool for measuring bottleneck bandwidth in uncooperative environments, 2002. http:\/\/sprobe.cs.washington.edu.]]"},{"key":"e_1_3_2_1_43_1","volume-title":"Proceedings of USENIX 2002","author":"Sarolahti P.","year":"2002","unstructured":"P. Sarolahti and A. Kuznetsov . Congestion control in Linux TCP . In Proceedings of USENIX 2002 , June 2002 .]] P. Sarolahti and A. Kuznetsov. Congestion control in Linux TCP. In Proceedings of USENIX 2002, June 2002.]]"},{"key":"e_1_3_2_1_44_1","volume-title":"Proceedings of the 1999 USENIX Symposium on Internet Technologies and Systems","author":"Savage S.","year":"1999","unstructured":"S. Savage . Sting : a TCP-based network measurement tool . In Proceedings of the 1999 USENIX Symposium on Internet Technologies and Systems , Boulder, CO, USA , October 1999 .]] S. Savage. Sting: a TCP-based network measurement tool. In Proceedings of the 1999 USENIX Symposium on Internet Technologies and Systems, Boulder, CO, USA, October 1999.]]"},{"key":"e_1_3_2_1_45_1","volume-title":"Information Sciences Institute. RFC 793 - Transmission control protocol","author":"University of Southern California","year":"1981","unstructured":"University of Southern California , Information Sciences Institute. RFC 793 - Transmission control protocol , 1981 . http:\/\/www.faqs.org\/rfcs\/rfc793.html.]] University of Southern California, Information Sciences Institute. RFC 793 - Transmission control protocol, 1981. http:\/\/www.faqs.org\/rfcs\/rfc793.html.]]"},{"key":"e_1_3_2_1_46_1","doi-asserted-by":"publisher","DOI":"10.5555\/1060289.1060315"},{"key":"e_1_3_2_1_47_1","doi-asserted-by":"publisher","DOI":"10.5555\/1060289.1060320"},{"key":"e_1_3_2_1_48_1","doi-asserted-by":"publisher","DOI":"10.5555\/1060289.1060313"},{"key":"e_1_3_2_1_49_1","volume-title":"Proceedings of IEEE Infocom","author":"Xu L.","year":"2004","unstructured":"L. Xu , K. Harfoush , and I. Rhee . Binary increase congestion control for fast long-distance networks . In Proceedings of IEEE Infocom , Hong Kong , March 2004 .]] L. Xu, K. Harfoush, and I. Rhee. Binary increase congestion control for fast long-distance networks. In Proceedings of IEEE Infocom, Hong Kong, March 2004.]]"}],"event":{"name":"IMC06: Internet Measurement Conference","sponsor":["SIGCOMM ACM Special Interest Group on Data Communication","ACM Association for Computing Machinery"],"location":"Rio de Janeriro Brazil","acronym":"IMC06"},"container-title":["Proceedings of the 6th ACM SIGCOMM conference on Internet measurement"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1177080.1177095","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/1177080.1177095","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T14:51:39Z","timestamp":1750258299000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1177080.1177095"}},"subtitle":["a tool to emulate transport protocol flowsover the internet at large"],"short-title":[],"issued":{"date-parts":[[2006,10,25]]},"references-count":49,"alternative-id":["10.1145\/1177080.1177095","10.1145\/1177080"],"URL":"https:\/\/doi.org\/10.1145\/1177080.1177095","relation":{},"subject":[],"published":{"date-parts":[[2006,10,25]]},"assertion":[{"value":"2006-10-25","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}