{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T14:10:02Z","timestamp":1750255802175,"version":"3.41.0"},"reference-count":4,"publisher":"Association for Computing Machinery (ACM)","issue":"6","license":[{"start":{"date-parts":[[2009,6,1]],"date-time":"2009-06-01T00:00:00Z","timestamp":1243814400000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":["Commun. ACM"],"published-print":{"date-parts":[[2009,6]]},"abstract":"<jats:p>High bandwidth, low latency, and multihoming challenge the sockets API.<\/jats:p>","DOI":"10.1145\/1516046.1516061","type":"journal-article","created":{"date-parts":[[2009,5,19]],"date-time":"2009-05-19T16:47:42Z","timestamp":1242751662000},"page":"51-55","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":2,"title":["Whither sockets?"],"prefix":"10.1145","volume":"52","author":[{"given":"George V.","family":"Neville-Neil","sequence":"first","affiliation":[],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2009,6]]},"reference":[{"volume-title":"Proceedings of the 20th IEEE International Parallel and Distributed Processing Symposium.","author":"Balaji P.","key":"e_1_2_1_1_1"},{"key":"e_1_2_1_2_1","doi-asserted-by":"crossref","unstructured":"Gilligan R. Thomson S. Bound J. McCann J. and Stevens W. Basic Socket Interface Extensions for IPv6. RFC 3493 (Feb. 2003); http:\/\/www.rfc-editor.org\/rfc\/rfc3493.txt.   Gilligan R. Thomson S. Bound J. McCann J. and Stevens W. Basic Socket Interface Extensions for IPv6. RFC 3493 (Feb. 2003); http:\/\/www.rfc-editor.org\/rfc\/rfc3493.txt.","DOI":"10.17487\/rfc3493"},{"key":"e_1_2_1_3_1","doi-asserted-by":"crossref","unstructured":"Romanow A. Mogul J. Talpey T. and Bailey S. Remote Direct Memory Access (RDMA) over IP Problem Statement. RFC 4297 (Dec. 2005); http:\/\/www.rfc-editor.org\/rfc\/rfc4297.txt.  Romanow A. Mogul J. Talpey T. and Bailey S. Remote Direct Memory Access (RDMA) over IP Problem Statement. RFC 4297 (Dec. 2005); http:\/\/www.rfc-editor.org\/rfc\/rfc4297.txt.","DOI":"10.17487\/rfc4297"},{"key":"e_1_2_1_4_1","unstructured":"Stewart R. etal Stream Control Transmission Protocol. RFC 2960 (Oct. 2000); http:\/\/www.ietf.org\/rfc\/rfc2960.txt.  Stewart R. et al. Stream Control Transmission Protocol. RFC 2960 (Oct. 2000); http:\/\/www.ietf.org\/rfc\/rfc2960.txt."}],"container-title":["Communications of the ACM"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1516046.1516061","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/1516046.1516061","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T13:38:40Z","timestamp":1750253920000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1516046.1516061"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2009,6]]},"references-count":4,"journal-issue":{"issue":"6","published-print":{"date-parts":[[2009,6]]}},"alternative-id":["10.1145\/1516046.1516061"],"URL":"https:\/\/doi.org\/10.1145\/1516046.1516061","relation":{},"ISSN":["0001-0782","1557-7317"],"issn-type":[{"type":"print","value":"0001-0782"},{"type":"electronic","value":"1557-7317"}],"subject":[],"published":{"date-parts":[[2009,6]]},"assertion":[{"value":"2009-06-01","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}