{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,1,21]],"date-time":"2026-01-21T15:52:58Z","timestamp":1769010778736,"version":"3.49.0"},"publisher-location":"New York, NY, USA","reference-count":23,"publisher":"ACM","license":[{"start":{"date-parts":[[2010,10,4]],"date-time":"2010-10-04T00:00:00Z","timestamp":1286150400000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2010,10,4]]},"DOI":"10.1145\/1866307.1866363","type":"proceedings-article","created":{"date-parts":[[2010,10,5]],"date-time":"2010-10-05T14:38:23Z","timestamp":1286289503000},"page":"493-504","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":35,"title":["On the (in)security of IPsec in MAC-then-encrypt configurations"],"prefix":"10.1145","author":[{"given":"Jean Paul","family":"Degabriele","sequence":"first","affiliation":[{"name":"Royal Holloway, University of London, Egham, United Kingdom"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Kenneth G.","family":"Paterson","sequence":"additional","affiliation":[{"name":"Royal Holloway, University of London, Egham, United Kingdom"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2010,10,4]]},"reference":[{"key":"e_1_3_2_1_1_1","volume-title":"CA","author":"Bellovin S.","year":"1996","unstructured":"]] S. Bellovin , \"Problem Areas for the IP Security Protocols.\" In Proceedings of the Sixth Usenix Unix Security Symposium, pp. 1--16, San Jose , CA , July 1996 . ]]S. Bellovin, \"Problem Areas for the IP Security Protocols.\" In Proceedings of the Sixth Usenix Unix Security Symposium, pp. 1--16, San Jose, CA, July 1996."},{"key":"e_1_3_2_1_2_1","first-page":"531","volume-title":"Authenticated Encryption: Relations Among Notions and Analysis of the Generic Composition Paradigm.\" In T","author":"Bellare M.","year":"2000","unstructured":"]] M. Bellare and C. Namprempre , \" Authenticated Encryption: Relations Among Notions and Analysis of the Generic Composition Paradigm.\" In T . Okamoto, ed., Asiacrypt 2000 , LNCS Vol. 1976, Springer , 2000, pp. 531 -- 545 . ]]M. Bellare and C. Namprempre, \"Authenticated Encryption: Relations Among Notions and Analysis of the Generic Composition Paradigm.\" In T. Okamoto, ed., Asiacrypt 2000, LNCS Vol. 1976, Springer, 2000, pp. 531--545."},{"key":"e_1_3_2_1_3_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC1122"},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-540-45146-4_34"},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2007.8"},{"key":"e_1_3_2_1_6_1","volume-title":"A Cryptographic Evaluation of IPsec","author":"Ferguson N.","year":"2003","unstructured":"]] N. Ferguson and B. Schneier , \" A Cryptographic Evaluation of IPsec \", 2003 . Available from http:\/\/www.schneier.com\/paper-ipsec.pdf. ]]N. Ferguson and B. Schneier, \"A Cryptographic Evaluation of IPsec\", 2003. Available from http:\/\/www.schneier.com\/paper-ipsec.pdf."},{"key":"e_1_3_2_1_7_1","volume-title":"Cryptography Engineering","author":"Ferguson N.","year":"2010","unstructured":"]] N. Ferguson , B. Schneier and T. Kohno . Cryptography Engineering . John Wiley & Sons , 2010 . ]]N. Ferguson, B. Schneier and T. Kohno. Cryptography Engineering. John Wiley & Sons, 2010."},{"key":"e_1_3_2_1_8_1","doi-asserted-by":"crossref","unstructured":"]]R. Housely \"Using Advanced Encryption Standard (AES) Counter Mode With IPsec Encapsulating Security Payload (ESP)\" RFC 3686 Jan. 2004.  ]]R. Housely \"Using Advanced Encryption Standard (AES) Counter Mode With IPsec Encapsulating Security Payload (ESP)\" RFC 3686 Jan. 2004.","DOI":"10.17487\/rfc3686"},{"key":"e_1_3_2_1_9_1","volume-title":"RFC","author":"Kaufman C.","year":"2005","unstructured":"]] C. Kaufman , editor, \" Internet Key Exchange (IKEv2) Protocol \", RFC 4306, Dec. 2005 . ]]C. Kaufman, editor, \"Internet Key Exchange (IKEv2) Protocol\", RFC 4306, Dec. 2005."},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2401"},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2402"},{"key":"e_1_3_2_1_12_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2406"},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2401"},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"crossref","unstructured":"]]S. Kent \"IP Authentication Header\" RFC 4302 (obsoletes RFC 2402) Dec. 2005.  ]]S. Kent \"IP Authentication Header\" RFC 4302 (obsoletes RFC 2402) Dec. 2005.","DOI":"10.17487\/rfc4302"},{"key":"e_1_3_2_1_15_1","doi-asserted-by":"crossref","unstructured":"]]S. Kent \"IP Encapsulating Security Payload (ESP)\" RFC 4303 (obsoletes RFC 2406) Dec. 2005.  ]]S. Kent \"IP Encapsulating Security Payload (ESP)\" RFC 4303 (obsoletes RFC 2406) Dec. 2005.","DOI":"10.17487\/rfc4303"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.5555\/646766.704278"},{"key":"e_1_3_2_1_17_1","doi-asserted-by":"crossref","unstructured":"]]V. Manral \"Cryptographic Algorithm Implementation Requirements for Encapsulating Security Payload (ESP) and Authentication Header (AH)\" RFC 4835 April 2007.  ]]V. Manral \"Cryptographic Algorithm Implementation Requirements for Encapsulating Security Payload (ESP) and Authentication Header (AH)\" RFC 4835 April 2007.","DOI":"10.17487\/rfc4835"},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.1007\/11761679_2"},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-13190-5_18"},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1109\/CSF.2009.23"},{"key":"e_1_3_2_1_21_1","volume-title":"Network Security Essentials: Applications and Standards","author":"Stallings W.","year":"2008","unstructured":"]] W. Stallings . Network Security Essentials: Applications and Standards , 3 rd edition. Pearson Education , 2008 . ]]W. Stallings. Network Security Essentials: Applications and Standards, 3rd edition. Pearson Education, 2008.","edition":"3"},{"key":"e_1_3_2_1_22_1","doi-asserted-by":"publisher","DOI":"10.5555\/647087.715705"},{"key":"e_1_3_2_1_23_1","volume-title":"Analysis of the SSL 3.0 Protocol.\" In The Second USENIX Workshop on Electronic Commerce}","author":"Wagner D.","year":"1996","unstructured":"]] D. Wagner and B. Schneier , \" Analysis of the SSL 3.0 Protocol.\" In The Second USENIX Workshop on Electronic Commerce} , USENIX press , 1996 . ]]D. Wagner and B. Schneier, \"Analysis of the SSL 3.0 Protocol.\" In The Second USENIX Workshop on Electronic Commerce}, USENIX press, 1996."}],"event":{"name":"CCS '10: 17th ACM Conference on Computer and Communications Security 2010","location":"Chicago Illinois USA","acronym":"CCS '10","sponsor":["SIGSAC ACM Special Interest Group on Security, Audit, and Control"]},"container-title":["Proceedings of the 17th ACM conference on Computer and communications security"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1866307.1866363","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/1866307.1866363","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T12:08:59Z","timestamp":1750248539000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1866307.1866363"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2010,10,4]]},"references-count":23,"alternative-id":["10.1145\/1866307.1866363","10.1145\/1866307"],"URL":"https:\/\/doi.org\/10.1145\/1866307.1866363","relation":{},"subject":[],"published":{"date-parts":[[2010,10,4]]},"assertion":[{"value":"2010-10-04","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}