{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,6,19]],"date-time":"2025-06-19T04:26:50Z","timestamp":1750307210400,"version":"3.41.0"},"publisher-location":"New York, NY, USA","reference-count":35,"publisher":"ACM","license":[{"start":{"date-parts":[[2012,4,16]],"date-time":"2012-04-16T00:00:00Z","timestamp":1334534400000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2012,4,16]]},"DOI":"10.1145\/2187836.2187926","type":"proceedings-article","created":{"date-parts":[[2012,4,24]],"date-time":"2012-04-24T18:41:27Z","timestamp":1335292887000},"page":"659-668","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":13,"title":["Practical end-to-end web content integrity"],"prefix":"10.1145","author":[{"given":"Kapil","family":"Singh","sequence":"first","affiliation":[{"name":"IBM Research, Hawthorne, NY, USA"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Helen J.","family":"Wang","sequence":"additional","affiliation":[{"name":"Microsoft Research, Redmond, WA, USA"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Alexander","family":"Moshchuk","sequence":"additional","affiliation":[{"name":"Microsoft Research, Redmond, WA, USA"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Collin","family":"Jackson","sequence":"additional","affiliation":[{"name":"Carnegie Mellon University, Mountain View, CA, USA"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Wenke","family":"Lee","sequence":"additional","affiliation":[{"name":"Georgia Institute of Technology, Atlanta, GA, USA"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2012,4,16]]},"reference":[{"key":"e_1_3_2_1_1_1","unstructured":"About Asynchronous Pluggable Protocols. http:\/\/msdn.microsoft.com\/en-us\/library\/aa767916(v=VS.85).aspx.  About Asynchronous Pluggable Protocols. http:\/\/msdn.microsoft.com\/en-us\/library\/aa767916(v=VS.85).aspx."},{"key":"e_1_3_2_1_2_1","volume-title":"Forecast and Methodology","author":"Networking Index Cisco Visual","year":"2009","unstructured":"Cisco Visual Networking Index : Forecast and Methodology , 2009 -2014. Cisco Visual Networking Index: Forecast and Methodology, 2009-2014."},{"key":"e_1_3_2_1_3_1","unstructured":"Dispelling the New SSL Myth. http:\/\/devcentral.f5.com\/weblogs\/macvittie\/archive\/2011\/01\/31\/dispelling-the-new-ssl-myth.aspx.  Dispelling the New SSL Myth. http:\/\/devcentral.f5.com\/weblogs\/macvittie\/archive\/2011\/01\/31\/dispelling-the-new-ssl-myth.aspx."},{"key":"e_1_3_2_1_4_1","unstructured":"IInternetProtocolInfo interface.http:\/\/msdn.microsoft.com\/en-us\/library\/aa767874(VS.85).aspx.  IInternetProtocolInfo interface.http:\/\/msdn.microsoft.com\/en-us\/library\/aa767874(VS.85).aspx."},{"key":"e_1_3_2_1_5_1","unstructured":"Network Simulator. http:\/\/www.akmalabs.com\/downloads_netsim.php.  Network Simulator. http:\/\/www.akmalabs.com\/downloads_netsim.php."},{"key":"e_1_3_2_1_6_1","unstructured":"Akamai Technologies. Secure Content Delivery. http:\/\/www.akamai.com\/dl\/feature_sheets\/fs_edgesuite_securecontentdelivery.pdf.  Akamai Technologies. Secure Content Delivery. http:\/\/www.akamai.com\/dl\/feature_sheets\/fs_edgesuite_securecontentdelivery.pdf."},{"key":"e_1_3_2_1_7_1","volume-title":"Securing Frame Communication in Browsers. In USENIX Security Symposium","author":"Barth A.","year":"2008","unstructured":"A. Barth , C. Jackson , and J. C. Mitchell . Securing Frame Communication in Browsers. In USENIX Security Symposium , San Jose, CA , July 2008 . A. Barth, C. Jackson, and J. C. Mitchell. Securing Frame Communication in Browsers. In USENIX Security Symposium, San Jose, CA, July 2008."},{"key":"e_1_3_2_1_8_1","doi-asserted-by":"publisher","DOI":"10.1145\/1062745.1062929"},{"key":"e_1_3_2_1_9_1","doi-asserted-by":"publisher","DOI":"10.1109\/CSAC.2005.37"},{"key":"e_1_3_2_1_12_1","volume-title":"RFC 4785: Pre-Shared Key (PSK) Ciphersuites with NULL Encryption for Transport Layer Security (TLS)","author":"Blumenthal U.","year":"2007","unstructured":"U. Blumenthal and P. Goel . RFC 4785: Pre-Shared Key (PSK) Ciphersuites with NULL Encryption for Transport Layer Security (TLS) , 2007 . U. Blumenthal and P. Goel. RFC 4785: Pre-Shared Key (PSK) Ciphersuites with NULL Encryption for Transport Layer Security (TLS), 2007."},{"key":"e_1_3_2_1_13_1","unstructured":"K. DeGrande. CDNetworks Sept. 2010. Personal communication.  K. DeGrande. CDNetworks Sept. 2010. Personal communication."},{"key":"e_1_3_2_1_14_1","unstructured":"FiddlerCore. http:\/\/fiddler.wikidot.com\/fiddlercore.  FiddlerCore. http:\/\/fiddler.wikidot.com\/fiddlercore."},{"key":"e_1_3_2_1_15_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2616"},{"key":"e_1_3_2_1_16_1","unstructured":"S. Friedl. An Illustrated Guide to the Kaminsky DNS Vulnerability. http:\/\/unixwiz.net\/techtips\/iguide-kaminsky-dns-vuln.html.  S. Friedl. An Illustrated Guide to the Kaminsky DNS Vulnerability. http:\/\/unixwiz.net\/techtips\/iguide-kaminsky-dns-vuln.html."},{"key":"e_1_3_2_1_17_1","volume-title":"SINE: Cache-Friendly Integrity for the Web. In NPSec Workshop","author":"Gaspard C.","year":"2009","unstructured":"C. Gaspard , S. Goldberg , W. Itani , E. Bertino , and C. Nita-Rotaru . SINE: Cache-Friendly Integrity for the Web. In NPSec Workshop , Princeton, NJ , Oct. 2009 . C. Gaspard, S. Goldberg, W. Itani, E. Bertino, and C. Nita-Rotaru. SINE: Cache-Friendly Integrity for the Web. In NPSec Workshop, Princeton, NJ, Oct. 2009."},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.5555\/646762.706183"},{"key":"e_1_3_2_1_19_1","volume-title":"CA","author":"Hanna S.","year":"2010","unstructured":"S. Hanna , R. Shin , D. Akhawe , P. Saxena , A. Boehm , and D. Song . The Emperor's New APIs: On the (In)Secure Usage of New Client-side Primitives. In W2SP, Oakland , CA , May 2010 . S. Hanna, R. Shin, D. Akhawe, P. Saxena, A. Boehm, and D. Song. The Emperor's New APIs: On the (In)Secure Usage of New Client-side Primitives. In W2SP, Oakland, CA, May 2010."},{"key":"e_1_3_2_1_20_1","volume-title":"HTTP Strict Transport Security (HSTS)","author":"Hodges J.","year":"2010","unstructured":"J. Hodges , C. Jackson , and A. Barth . HTTP Strict Transport Security (HSTS) , 2010 . http:\/\/tools.ietf.org\/html\/draft-hodges-strict-transport-sec. J. Hodges, C. Jackson, and A. Barth. HTTP Strict Transport Security (HSTS), 2010. http:\/\/tools.ietf.org\/html\/draft-hodges-strict-transport-sec."},{"key":"e_1_3_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.1145\/1315245.1315298"},{"key":"e_1_3_2_1_22_1","volume-title":"Aug.","author":"Jirasek V.","year":"2010","unstructured":"V. Jirasek . Overcoming man in the middle attack on Strict Transport Security , Aug. 2010 . http:\/\/www.jirasekonsecurity.com\/2010\/08\/overcoming-man-in-middle-attack-on.html. V. Jirasek. Overcoming man in the middle attack on Strict Transport Security, Aug. 2010. http:\/\/www.jirasekonsecurity.com\/2010\/08\/overcoming-man-in-middle-attack-on.html."},{"key":"e_1_3_2_1_23_1","volume-title":"Chang. Overclocking SSL. In Velocity: Web Performance and Operations Conference","author":"Langley A.","year":"2010","unstructured":"A. Langley , N. Modadugu , and W.- T. Chang. Overclocking SSL. In Velocity: Web Performance and Operations Conference , Santa Clara, CA , June 2010 .http:\/\/www.imperialviolet.org\/2010\/06\/25\/overclocking-ssl.html. A. Langley, N. Modadugu, and W.-T. Chang. Overclocking SSL. In Velocity: Web Performance and Operations Conference, Santa Clara, CA, June 2010.http:\/\/www.imperialviolet.org\/2010\/06\/25\/overclocking-ssl.html."},{"key":"e_1_3_2_1_24_1","unstructured":"E. Lawrence. Fiddler Web Debugging Tool. http:\/\/www.fiddler2.com\/fiddler2\/.  E. Lawrence. Fiddler Web Debugging Tool. http:\/\/www.fiddler2.com\/fiddler2\/."},{"key":"e_1_3_2_1_25_1","doi-asserted-by":"publisher","DOI":"10.1145\/306225.306235"},{"key":"e_1_3_2_1_26_1","unstructured":"S. Ramachandran. Let's make the web faster.http:\/\/code.google.com\/speed\/articles\/web-metrics.html.  S. Ramachandran. Let's make the web faster.http:\/\/code.google.com\/speed\/articles\/web-metrics.html."},{"key":"e_1_3_2_1_27_1","volume-title":"NSDI","author":"Reis C.","year":"2008","unstructured":"C. Reis , S. D. Gribble , T. Kohno , and N. C. Weaver . Detecting In-Flight Page Changes with Web Tripwires . In NSDI , San Francisco, CA , Apr. 2008 . C. Reis, S. D. Gribble, T. Kohno, and N. C. Weaver. Detecting In-Flight Page Changes with Web Tripwires. In NSDI, San Francisco, CA, Apr. 2008."},{"key":"e_1_3_2_1_28_1","volume-title":"RFC 2818: HTTP Over TLS","author":"Rescorla E.","year":"2000","unstructured":"E. Rescorla . RFC 2818: HTTP Over TLS , 2000 . E. Rescorla. RFC 2818: HTTP Over TLS, 2000."},{"key":"e_1_3_2_1_29_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2660"},{"key":"e_1_3_2_1_30_1","unstructured":"J. Ruderman. Same Origin Policy for JavaScript. http:\/\/www.mozilla.org\/projects\/security\/components\/same-origin.html.  J. Ruderman. Same Origin Policy for JavaScript. http:\/\/www.mozilla.org\/projects\/security\/components\/same-origin.html."},{"key":"e_1_3_2_1_31_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2007.35"},{"key":"e_1_3_2_1_32_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2010.35"},{"key":"e_1_3_2_1_33_1","doi-asserted-by":"publisher","DOI":"10.1145\/1772690.1772784"},{"key":"e_1_3_2_1_34_1","doi-asserted-by":"publisher","DOI":"10.1023\/B:ELEC.0000045975.59531.08"},{"key":"e_1_3_2_1_35_1","doi-asserted-by":"publisher","DOI":"10.1145\/1294261.1294263"},{"key":"e_1_3_2_1_36_1","volume-title":"The Multi-Principal OS Construction of the Gazelle Web Browser. In USENIX Security Symposium","author":"Wang H. J.","year":"2009","unstructured":"H. J. Wang , C. Grier , A. Moshchuk , S. T. King , P. Choudhury , and H. Venter . The Multi-Principal OS Construction of the Gazelle Web Browser. In USENIX Security Symposium , Montreal, Canada , Aug. 2009 . H. J. Wang, C. Grier, A. Moshchuk, S. T. King, P. Choudhury, and H. Venter. The Multi-Principal OS Construction of the Gazelle Web Browser. In USENIX Security Symposium, Montreal, Canada, Aug. 2009."},{"key":"e_1_3_2_1_37_1","doi-asserted-by":"publisher","DOI":"10.1145\/319151.319153"}],"event":{"name":"WWW 2012: 21st World Wide Web Conference 2012","sponsor":["Univ. de Lyon Universite de Lyon","SIGWEB ACM Special Interest Group on Hypertext, Hypermedia, and Web"],"location":"Lyon France","acronym":"WWW 2012"},"container-title":["Proceedings of the 21st international conference on World Wide Web"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/2187836.2187926","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/2187836.2187926","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T10:06:34Z","timestamp":1750241194000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/2187836.2187926"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2012,4,16]]},"references-count":35,"alternative-id":["10.1145\/2187836.2187926","10.1145\/2187836"],"URL":"https:\/\/doi.org\/10.1145\/2187836.2187926","relation":{},"subject":[],"published":{"date-parts":[[2012,4,16]]},"assertion":[{"value":"2012-04-16","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}