{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,31]],"date-time":"2026-10-31T19:46:02Z","timestamp":1793475962184,"version":"4.5.0"},"publisher-location":"New York, NY, USA","reference-count":36,"publisher":"ACM","license":[{"start":{"date-parts":[[2017,11,9]],"date-time":"2017-11-09T00:00:00Z","timestamp":1510185600000},"content-version":"vor","delay-in-days":365,"URL":"http:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"funder":[{"DOI":"10.13039\/100000001","name":"National Science Foundation","doi-asserted-by":"publisher","award":["CNS-1539920"],"award-info":[{"award-number":["CNS-1539920"]}],"id":[{"id":"10.13039\/100000001","id-type":"DOI","asserted-by":"publisher"}]},{"DOI":"10.13039\/501100007601","name":"Horizon 2020","doi-asserted-by":"publisher","award":["644960"],"award-info":[{"award-number":["644960"]}],"id":[{"id":"10.13039\/501100007601","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2016,11,9]]},"DOI":"10.1145\/3005745.3005748","type":"proceedings-article","created":{"date-parts":[[2016,11,2]],"date-time":"2016-11-02T08:22:17Z","timestamp":1478074937000},"page":"106-112","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":46,"title":["Network Monitoring as a Streaming Analytics Problem"],"prefix":"10.1145","author":[{"given":"Arpit","family":"Gupta","sequence":"first","affiliation":[{"name":"Princeton University"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"R\u00fcdiger","family":"Birkner","sequence":"additional","affiliation":[{"name":"ETH Z\u00fcrich"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Marco","family":"Canini","sequence":"additional","affiliation":[{"name":"KAUST"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Nick","family":"Feamster","sequence":"additional","affiliation":[{"name":"Princeton University"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Chris","family":"Mac-Stoker","sequence":"additional","affiliation":[{"name":"NIKSUN, Inc."}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Walter","family":"Willinger","sequence":"additional","affiliation":[{"name":"NIKSUN, Inc."}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2016,11,9]]},"reference":[{"key":"e_1_3_2_1_1_2","doi-asserted-by":"publisher","DOI":"10.1145\/872757.872855"},{"key":"e_1_3_2_1_2_2","unstructured":"Apache Spark. http:\/\/spark.apache.org\/."},{"key":"e_1_3_2_1_3_2","doi-asserted-by":"publisher","DOI":"10.1145\/2723372.2742797"},{"key":"e_1_3_2_1_4_2","volume-title":"June","author":"Black D.","year":"2005","unstructured":"D. Black, K. McCloghrie, and J. Schoenwaelder. Uniform Resource Identifier (URI) Scheme for the Simple Network Management Protocol (SNMP). RFC 4088 (Proposed Standard), June 2005."},{"key":"e_1_3_2_1_5_2","doi-asserted-by":"publisher","DOI":"10.5555\/2362793.2362812"},{"key":"e_1_3_2_1_6_2","doi-asserted-by":"publisher","DOI":"10.1145\/2656877.2656890"},{"key":"e_1_3_2_1_7_2","volume-title":"ArsTechnica","author":"Bright P.","year":"2013","unstructured":"P. Bright. Spamhaus DDoS grows to Internet-threatening Size. ArsTechnica, March 2013."},{"key":"e_1_3_2_1_8_2","doi-asserted-by":"publisher","DOI":"10.1016\/j.is.2012.01.005"},{"key":"e_1_3_2_1_9_2","doi-asserted-by":"publisher","DOI":"10.5555\/1287369.1287389"},{"key":"e_1_3_2_1_10_2","doi-asserted-by":"crossref","unstructured":"B. Claise. Cisco Systems NetFlow Services Export Version 9. RFC 3954 (Informational) October 2004.","DOI":"10.17487\/rfc3954"},{"key":"e_1_3_2_1_11_2","volume-title":"Specification of the ip flow information export (ipfix) protocol for the exchange of ip traffic flow information. Technical report","author":"Claise B.","year":"2008","unstructured":"B. Claise. Specification of the ip flow information export (ipfix) protocol for the exchange of ip traffic flow information. Technical report, 2008."},{"key":"e_1_3_2_1_12_2","doi-asserted-by":"publisher","DOI":"10.1145\/1366102.1366106"},{"key":"e_1_3_2_1_13_2","doi-asserted-by":"publisher","DOI":"10.1145\/872757.872838"},{"key":"e_1_3_2_1_14_2","unstructured":"Five Year Traffic Growth at DE-CIX. https:\/\/www.de-cix.net\/about\/statistics\/."},{"key":"e_1_3_2_1_15_2","unstructured":"Deepfield Defender. http:\/\/deepfield.com\/products\/deepfield-defender\/."},{"key":"e_1_3_2_1_16_2","unstructured":"Google Cloud DataFlow. https:\/\/cloud.google.com\/dataflow\/."},{"key":"e_1_3_2_1_17_2","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-32584-7_25"},{"key":"e_1_3_2_1_18_2","doi-asserted-by":"publisher","DOI":"10.5555\/1972422.1972439"},{"key":"e_1_3_2_1_19_2","doi-asserted-by":"publisher","DOI":"10.1109\/SECPRI.2004.1301325"},{"key":"e_1_3_2_1_20_2","doi-asserted-by":"publisher","DOI":"10.1145\/2834050.2834098"},{"key":"e_1_3_2_1_21_2","doi-asserted-by":"publisher","DOI":"10.1145\/1355734.1355746"},{"key":"e_1_3_2_1_22_2","volume-title":"Conference on Innovative Data Systems Research (CIDR)","author":"Motwani R.","year":"2003","unstructured":"R. Motwani, J. Widom, A. Arasu, B. Babcock, S. Babu, M. Datar, G. Manku, C. Olston, J. Rosenstein, and R. Varma. Query Processing, Resource Management, and Approximation in a Data Stream Management System. In Conference on Innovative Data Systems Research (CIDR), January 2003."},{"key":"e_1_3_2_1_23_2","doi-asserted-by":"publisher","DOI":"10.1145\/3005745.3005775"},{"key":"e_1_3_2_1_24_2","unstructured":"OpenSOC. http:\/\/opensoc.github.io\/."},{"key":"e_1_3_2_1_25_2","unstructured":"OpenSOC Scalability. https:\/\/goo.gl\/CX2jWr."},{"key":"e_1_3_2_1_26_2","volume-title":"InMon corporation's sFlow. RFC3176 (September","author":"Phaal P.","year":"2001","unstructured":"P. Phaal, S. Panchen, and N. McKee. InMon corporation's sFlow. RFC3176 (September 2001), 2001."},{"key":"e_1_3_2_1_27_2","doi-asserted-by":"publisher","DOI":"10.1145\/2588555.2610521"},{"key":"e_1_3_2_1_28_2","unstructured":"Ryu SDN Framework. http:\/\/osrg.github.io\/ryu\/."},{"key":"e_1_3_2_1_29_2","unstructured":"Apache Storm. http:\/\/storm.apache.org\/."},{"key":"e_1_3_2_1_30_2","doi-asserted-by":"publisher","DOI":"10.5555\/645922.673489"},{"key":"e_1_3_2_1_31_2","doi-asserted-by":"publisher","DOI":"10.1007\/s10115-009-0269-0"},{"key":"e_1_3_2_1_32_2","unstructured":"Tigon. http:\/\/tigon.io\/."},{"key":"e_1_3_2_1_33_2","unstructured":"UDP-Based Distributed Reflective Denial of Service Attacks. https:\/\/www.us-cert.gov\/ncas\/alerts\/TA14-017A."},{"key":"e_1_3_2_1_34_2","volume-title":"OSDI","author":"Viswanathan R.","year":"2016","unstructured":"R. Viswanathan, G. Ananthanarayanan, and A. Akella. Clarinet: WAN-Aware Optimization for Analytics Queries. In OSDI, 2016. To appear."},{"key":"e_1_3_2_1_35_2","doi-asserted-by":"publisher","DOI":"10.5555\/2482626.2482631"},{"key":"e_1_3_2_1_36_2","doi-asserted-by":"publisher","DOI":"10.1145\/1282427.1282392"}],"event":{"name":"HotNets-XV: The 15th ACM Workshop on Hot Topics in Networks","location":"Atlanta GA USA","acronym":"HotNets-XV","sponsor":["SIGCOMM ACM Special Interest Group on Data Communication"]},"container-title":["Proceedings of the 15th ACM Workshop on Hot Topics in Networks"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3005745.3005748","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3005745.3005748","content-type":"application\/pdf","content-version":"vor","intended-application":"syndication"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3005745.3005748","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,11,18]],"date-time":"2025-11-18T09:46:54Z","timestamp":1763459214000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3005745.3005748"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2016,11,9]]},"references-count":36,"alternative-id":["10.1145\/3005745.3005748","10.1145\/3005745"],"URL":"https:\/\/doi.org\/10.1145\/3005745.3005748","relation":{},"subject":[],"published":{"date-parts":[[2016,11,9]]},"assertion":[{"value":"2016-11-09","order":3,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}