{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,2,4]],"date-time":"2026-02-04T15:39:39Z","timestamp":1770219579985,"version":"3.49.0"},"publisher-location":"New York, NY, USA","reference-count":23,"publisher":"ACM","license":[{"start":{"date-parts":[[2017,4,3]],"date-time":"2017-04-03T00:00:00Z","timestamp":1491177600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2017,4,3]]},"DOI":"10.1145\/3019612.3019728","type":"proceedings-article","created":{"date-parts":[[2017,6,15]],"date-time":"2017-06-15T20:27:45Z","timestamp":1497558465000},"page":"578-585","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":2,"title":["Prediction of the domain name system (DNS) quality attributes"],"prefix":"10.1145","author":[{"given":"Marwan","family":"Radwan","sequence":"first","affiliation":[{"name":"University of Leicester, Leicester"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Reiko","family":"Heckel","sequence":"additional","affiliation":[{"name":"University of Leicester, Leicester"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2017,4,3]]},"reference":[{"key":"e_1_3_2_1_1_1","first-page":"147","volume-title":"Brownlee and k. claffy, \"Measurements and Laboratory Simulations of the Upper DNS Hierarchy,\" in Passive and Active Network Measurement","author":"Wessels D.","year":"2004","unstructured":"D. Wessels , M. Fomenkov , N. Brownlee and k. claffy, \"Measurements and Laboratory Simulations of the Upper DNS Hierarchy,\" in Passive and Active Network Measurement , vol. 3015 , C. Barakat and I. Pratt, Eds ., Springer Berlin Heidelberg , 2004 , pp. 147 -- 157 . D. Wessels, M. Fomenkov, N. Brownlee and k. claffy, \"Measurements and Laboratory Simulations of the Upper DNS Hierarchy,\" in Passive and Active Network Measurement, vol. 3015, C. Barakat and I. Pratt, Eds., Springer Berlin Heidelberg, 2004, pp. 147--157."},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-319-24174-6_1"},{"key":"e_1_3_2_1_3_1","volume-title":"RFC 2182: Selection and Operation of Secondary DNS Servers,\" International Engineering Task Force","author":"Robert E.","year":"1997","unstructured":"E. Robert , B. Randy , B. Scott and P. Michael , \" RFC 2182: Selection and Operation of Secondary DNS Servers,\" International Engineering Task Force , Status : Standard , 1997 . E. Robert, B. Randy, B. Scott and P. Michael, \"RFC 2182: Selection and Operation of Secondary DNS Servers,\" International Engineering Task Force, Status: Standard, 1997."},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.1145\/1330107.1330152"},{"key":"e_1_3_2_1_5_1","volume-title":"Detecting and Refactoring Operational Smells within the Domain Name System,\" arXiv preprint arXiv:1504.02615","author":"Radwan M.","year":"2015","unstructured":"M. Radwan and R. Heckel , \" Detecting and Refactoring Operational Smells within the Domain Name System,\" arXiv preprint arXiv:1504.02615 , 2015 . M. Radwan and R. Heckel, \"Detecting and Refactoring Operational Smells within the Domain Name System,\" arXiv preprint arXiv:1504.02615, 2015."},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"publisher","DOI":"10.1109\/JSAC.2009.090404"},{"key":"e_1_3_2_1_7_1","article-title":"Operational implications of the DNS control plane","author":"Osterweil E.","year":"2011","unstructured":"E. Osterweil , D. McPherson and L. Zhang , \" Operational implications of the DNS control plane ,\" IEEE Reliability Society Newsletter , 2011 . E. Osterweil, D. McPherson and L. Zhang, \"Operational implications of the DNS control plane,\" IEEE Reliability Society Newsletter, 2011.","journal-title":"IEEE Reliability Society Newsletter"},{"key":"e_1_3_2_1_8_1","volume-title":"Domain names implementation and specification,\" Work in Progress","author":"Mockapetris P.","year":"1987","unstructured":"P. Mockapetris , \" RFC 1035 : Domain names implementation and specification,\" Work in Progress , 1987 . P. Mockapetris, \"RFC 1035: Domain names implementation and specification,\" Work in Progress, 1987."},{"key":"e_1_3_2_1_9_1","volume-title":"Domain names: concepts and facilities,\" Work in Progress","author":"Mockapetris P.","year":"1987","unstructured":"P. Mockapetris , \" RFC 1034 : Domain names: concepts and facilities,\" Work in Progress , 1987 . P. Mockapetris, \"RFC 1034: Domain names: concepts and facilities,\" Work in Progress, 1987."},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICSAI.2014.7009359"},{"key":"e_1_3_2_1_11_1","volume-title":"Domain Administrators Operations Guide,\" Work in Progress","author":"Lotter M.","year":"1987","unstructured":"M. Lotter , \"Rfc 1033 : Domain Administrators Operations Guide,\" Work in Progress , 1987 . M. Lotter, \"Rfc 1033: Domain Administrators Operations Guide,\" Work in Progress, 1987."},{"key":"e_1_3_2_1_12_1","doi-asserted-by":"publisher","DOI":"10.1145\/1452520.1452546"},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.1109\/CNS.2013.6682730"},{"key":"e_1_3_2_1_14_1","volume-title":"Data mining: concepts and techniques","author":"Han J.","year":"2011","unstructured":"J. Han , J. Pei and M. Kamber , Data mining: concepts and techniques , Elsevier , 2011 . J. Han, J. Pei and M. Kamber, Data mining: concepts and techniques, Elsevier, 2011."},{"key":"e_1_3_2_1_15_1","doi-asserted-by":"publisher","DOI":"10.1145\/1656274.1656278"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.5555\/1833515.1833531"},{"key":"e_1_3_2_1_17_1","unstructured":"M. Corporation \"Microsoft Responds to DNS Issues \" Microsoft Corporation 2001.  M. Corporation \"Microsoft Responds to DNS Issues \" Microsoft Corporation 2001."},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.1109\/CSAC.2005.9"},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-35764-0_12"},{"key":"e_1_3_2_1_20_1","volume-title":"Common DNS operational and configuration errors,\" International Engineering Task Force","author":"Barr D.","year":"1996","unstructured":"D. Barr , \" RFC 1912 : Common DNS operational and configuration errors,\" International Engineering Task Force , Status : Standard , 1996 . D. Barr, \"RFC 1912: Common DNS operational and configuration errors,\" International Engineering Task Force, Status: Standard, 1996."},{"key":"e_1_3_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.1109\/SCAM.2009.27"},{"key":"e_1_3_2_1_22_1","volume-title":"DNS Best Practices,\" The Communications Security","author":"Working Group 4, \"Report","year":"2012","unstructured":"Working Group 4, \"Report : DNS Best Practices,\" The Communications Security , Reliability and Interoperability Council III , 2012 . Working Group 4, \"Report: DNS Best Practices,\" The Communications Security, Reliability and Interoperability Council III, 2012."},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"publisher","DOI":"10.1037\/0033-2909.86.2.420"}],"event":{"name":"SAC 2017: Symposium on Applied Computing","location":"Marrakech Morocco","acronym":"SAC 2017","sponsor":["SIGAPP ACM Special Interest Group on Applied Computing"]},"container-title":["Proceedings of the Symposium on Applied Computing"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3019612.3019728","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3019612.3019728","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T03:03:40Z","timestamp":1750215820000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3019612.3019728"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2017,4,3]]},"references-count":23,"alternative-id":["10.1145\/3019612.3019728","10.1145\/3019612"],"URL":"https:\/\/doi.org\/10.1145\/3019612.3019728","relation":{},"subject":[],"published":{"date-parts":[[2017,4,3]]},"assertion":[{"value":"2017-04-03","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}