{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T04:29:49Z","timestamp":1750220989825,"version":"3.41.0"},"publisher-location":"New York, NY, USA","reference-count":27,"publisher":"ACM","license":[{"start":{"date-parts":[[2019,2,17]],"date-time":"2019-02-17T00:00:00Z","timestamp":1550361600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"funder":[{"DOI":"10.13039\/100000185","name":"Defense Advanced Research Projects Agency","doi-asserted-by":"publisher","award":["HR0011-17-C-0047 and HR0011-16-C-0056"],"award-info":[{"award-number":["HR0011-17-C-0047 and HR0011-16-C-0056"]}],"id":[{"id":"10.13039\/100000185","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2019,2,17]]},"DOI":"10.1145\/3300111.3300113","type":"proceedings-article","created":{"date-parts":[[2019,1,25]],"date-time":"2019-01-25T19:21:47Z","timestamp":1548444107000},"page":"1-9","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":0,"title":["What we talk about when we talk about pcap expressions"],"prefix":"10.1145","author":[{"given":"Nik","family":"Sultana","sequence":"first","affiliation":[{"name":"University of Pennsylvania"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2019,2,17]]},"reference":[{"key":"e_1_3_2_1_1_1","unstructured":"{n. d.}. tcpdump and libpcap. https:\/\/www.tcpdump.org\/.  {n. d.}. tcpdump and libpcap. https:\/\/www.tcpdump.org\/."},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1145\/277044.277186"},{"key":"e_1_3_2_1_3_1","doi-asserted-by":"publisher","DOI":"10.1145\/316194.316214"},{"key":"e_1_3_2_1_4_1","volume-title":"First International Workshop on Proof eXchange for Theorem Proving-PxTP","author":"Besson Fr\u00e9d\u00e9ric","year":"2011","unstructured":"Fr\u00e9d\u00e9ric Besson , Pierre-Emmanuel Cornilleau , and David Pichardie . 2011 . A Nelson-Oppen based Proof System using Theory Specific Proof Systems . In First International Workshop on Proof eXchange for Theorem Proving-PxTP 2011. Fr\u00e9d\u00e9ric Besson, Pierre-Emmanuel Cornilleau, and David Pichardie. 2011. A Nelson-Oppen based Proof System using Theory Specific Proof Systems. In First International Workshop on Proof eXchange for Theorem Proving-PxTP 2011."},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"publisher","DOI":"10.1145\/1111320.1111043"},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-25379-9_15"},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"crossref","unstructured":"Alex Conta Stephen Deering and Mukesh Gupta. 2006. Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification. RFC 4443.  Alex Conta Stephen Deering and Mukesh Gupta. 2006. Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification. RFC 4443.","DOI":"10.17487\/rfc4443"},{"key":"e_1_3_2_1_8_1","unstructured":"National Vulnerability Database. {n. d.}. CVE-2014-0160. https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2014-0160.  National Vulnerability Database. {n. d.}. CVE-2014-0160. https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2014-0160."},{"volume-title":"Tools and Algorithms for the Construction and Analysis of Systems","author":"de Moura Leonardo","key":"e_1_3_2_1_9_1","unstructured":"Leonardo de Moura and Nikolaj Bj\u00f8rner . 2008. Z3: An Efficient SMT Solver . In Tools and Algorithms for the Construction and Analysis of Systems , C. R. Ramakrishnan and Jakob Rehof (Eds.). Springer Berlin Heidelberg , Berlin, Heidelberg , 337--340. Leonardo de Moura and Nikolaj Bj\u00f8rner. 2008. Z3: An Efficient SMT Solver. In Tools and Algorithms for the Construction and Analysis of Systems, C. R. Ramakrishnan and Jakob Rehof (Eds.). Springer Berlin Heidelberg, Berlin, Heidelberg, 337--340."},{"key":"e_1_3_2_1_10_1","volume-title":"Hinden","author":"Deering Stephen E.","year":"2017","unstructured":"Stephen E. Deering and Robert M . Hinden . 2017 . Internet Protocol, Version 6 (IPv6) Specification. RFC 8200. Stephen E. Deering and Robert M. Hinden. 2017. Internet Protocol, Version 6 (IPv6) Specification. RFC 8200."},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"crossref","unstructured":"Tim Dierks and Eric Rescorla. 2008. The Transport Layer Security (TLS) Protocol Version 1.2. RFC 5246.  Tim Dierks and Eric Rescorla. 2008. The Transport Layer Security (TLS) Protocol Version 1.2. RFC 5246.","DOI":"10.17487\/rfc5246"},{"key":"e_1_3_2_1_12_1","unstructured":"Ethernet Working Group. {n.d.}. IEEE 802.3. http:\/\/www.ieee802.org\/3\/.  Ethernet Working Group. {n.d.}. IEEE 802.3. http:\/\/www.ieee802.org\/3\/."},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-662-48899-7_24"},{"key":"e_1_3_2_1_14_1","first-page":"802","volume-title":"Bridges and Bridged Networks","author":"IEEE","unstructured":"IEEE 2014. 802.1Q-2014 : Bridges and Bridged Networks . IEEE , http:\/\/www.ieee802.org\/1\/pages\/ 802 .1Q.html. IEEE 2014. 802.1Q-2014: Bridges and Bridged Networks. IEEE, http:\/\/www.ieee802.org\/1\/pages\/802.1Q.html."},{"key":"e_1_3_2_1_15_1","unstructured":"University of Southern California Information Sciences Institute. 1981. Internet Protocol. RFC 791.  University of Southern California Information Sciences Institute. 1981. Internet Protocol. RFC 791."},{"key":"e_1_3_2_1_16_1","unstructured":"University of Southern California Information Sciences Institute. 1981. Transmission Control Protocol. RFC 793.  University of Southern California Information Sciences Institute. 1981. Transmission Control Protocol. RFC 793."},{"key":"e_1_3_2_1_17_1","unstructured":"The SMT-LIB Initiative. {n. d.}. SMT-LIB: The Satisfiability Modulo Theories Library. http:\/\/smtlib.cs.uiowa.edu\/.  The SMT-LIB Initiative. {n. d.}. SMT-LIB: The Satisfiability Modulo Theories Library. http:\/\/smtlib.cs.uiowa.edu\/."},{"key":"e_1_3_2_1_18_1","unstructured":"P.J. Malloy. {n. d.}. How to Detect a Prior Heartbleed Exploit. https:\/\/bit.ly\/2T5fMu7.  P.J. Malloy. {n. d.}. How to Detect a Prior Heartbleed Exploit. https:\/\/bit.ly\/2T5fMu7."},{"key":"e_1_3_2_1_19_1","volume-title":"Proceedings of the USENIX","author":"McCanne Steven","year":"1993","unstructured":"Steven McCanne and Van Jacobson . 1993 . The BSD Packet Filter: A New Architecture for User-level Packet Capture . In Proceedings of the USENIX Winter 1993 Conference Proceedings on USENIX Winter 1993 Conference Proceedings (USENIX'93). USENIX Association, Berkeley, CA, USA, 2--2. http:\/\/dl.acm.org\/citation.cfm?id=1267303.1267305 Steven McCanne and Van Jacobson. 1993. The BSD Packet Filter: A New Architecture for User-level Packet Capture. In Proceedings of the USENIX Winter 1993 Conference Proceedings on USENIX Winter 1993 Conference Proceedings (USENIX'93). USENIX Association, Berkeley, CA, USA, 2--2. http:\/\/dl.acm.org\/citation.cfm?id=1267303.1267305"},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1145\/37499.37505"},{"key":"e_1_3_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.1145\/1217856.1217859"},{"key":"e_1_3_2_1_22_1","unstructured":"Eric Steven Raymond. {n. d.}. Applying the Rule of Least Surprise. http:\/\/www.catb.org\/esr\/writings\/taoup\/html\/ch11s01.html.  Eric Steven Raymond. {n. d.}. Applying the Rule of Least Surprise. http:\/\/www.catb.org\/esr\/writings\/taoup\/html\/ch11s01.html."},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"crossref","unstructured":"Robin Seggelmann Michael Tuexen and Michael Glenn Williams. 2012. Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat Extension. RFC 6520.  Robin Seggelmann Michael Tuexen and Michael Glenn Williams. 2012. Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat Extension. RFC 6520.","DOI":"10.17487\/rfc6520"},{"key":"e_1_3_2_1_24_1","unstructured":"Juho Snellman. {n. d.}. What's wrong with pcap filters? https:\/\/www.snellman.net\/blog\/archive\/2015-05-18-whats-wrong-with-pcap-filters\/.  Juho Snellman. {n. d.}. What's wrong with pcap filters? https:\/\/www.snellman.net\/blog\/archive\/2015-05-18-whats-wrong-with-pcap-filters\/."},{"key":"e_1_3_2_1_25_1","unstructured":"Nik Sultana and Richard Mortier. 2016. Kneecap: Model-based Generation of Network Traffic. In Proceedings of the 14th International Workshop on Satisfiability Modulo Theories affiliated with the International Joint Conference on Automated Reasoning SMT@IJCAR 2016 Coimbra Portugal July 1-2 2016. (CEUR Workshop Proceedings) Tim King and Ruzica Piskac (Eds.) Vol. 1617. CEUR-WS.org 4--14. http:\/\/ceur-ws.org\/Vol-1617\/paper1.pdf  Nik Sultana and Richard Mortier. 2016. Kneecap: Model-based Generation of Network Traffic. In Proceedings of the 14th International Workshop on Satisfiability Modulo Theories affiliated with the International Joint Conference on Automated Reasoning SMT@IJCAR 2016 Coimbra Portugal July 1-2 2016. (CEUR Workshop Proceedings) Tim King and Ruzica Piskac (Eds.) Vol. 1617. CEUR-WS.org 4--14. http:\/\/ceur-ws.org\/Vol-1617\/paper1.pdf"},{"key":"e_1_3_2_1_26_1","volume-title":"Jitk: A Trustworthy In-Kernel Interpreter Infrastructure. In 11th USENIX Symposium on Operating Systems Design and Implementation (OSDI 14)","author":"Wang Xi","year":"2014","unstructured":"Xi Wang , David Lazar , Nickolai Zeldovich , Adam Chlipala , and Zachary Tatlock . 2014 . Jitk: A Trustworthy In-Kernel Interpreter Infrastructure. In 11th USENIX Symposium on Operating Systems Design and Implementation (OSDI 14) . USENIX Association, Broomfield, CO, 33--47. https:\/\/www.usenix.org\/conference\/osdi14\/technical-sessions\/presentation\/wang_xi Xi Wang, David Lazar, Nickolai Zeldovich, Adam Chlipala, and Zachary Tatlock. 2014. Jitk: A Trustworthy In-Kernel Interpreter Infrastructure. In 11th USENIX Symposium on Operating Systems Design and Implementation (OSDI 14). USENIX Association, Broomfield, CO, 33--47. https:\/\/www.usenix.org\/conference\/osdi14\/technical-sessions\/presentation\/wang_xi"},{"key":"e_1_3_2_1_27_1","unstructured":"Rafal Wojtczuk. {n. d.}. libnids. http:\/\/libnids.sourceforge.net\/.  Rafal Wojtczuk. {n. d.}. libnids. http:\/\/libnids.sourceforge.net\/."}],"event":{"name":"RWDSL '19: Real World Domain Specific Languages","sponsor":["EPSRC Engineering and Physical Sciences Research Council","Heriot-Watt University Heriot-Watt University"],"location":"Washington D. C. DC USA","acronym":"RWDSL '19"},"container-title":["Proceedings of the 4th ACM International Workshop on Real World Domain Specific Languages"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3300111.3300113","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3300111.3300113","content-type":"application\/pdf","content-version":"vor","intended-application":"syndication"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3300111.3300113","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T00:25:22Z","timestamp":1750206322000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3300111.3300113"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2019,2,17]]},"references-count":27,"alternative-id":["10.1145\/3300111.3300113","10.1145\/3300111"],"URL":"https:\/\/doi.org\/10.1145\/3300111.3300113","relation":{},"subject":[],"published":{"date-parts":[[2019,2,17]]},"assertion":[{"value":"2019-02-17","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}