{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,8,28]],"date-time":"2026-08-28T09:53:22Z","timestamp":1787910802367,"version":"build-2784847793"},"publisher-location":"New York, NY, USA","reference-count":53,"publisher":"ACM","license":[{"start":{"date-parts":[[2020,10,30]],"date-time":"2020-10-30T00:00:00Z","timestamp":1604016000000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2020,10,30]]},"DOI":"10.1145\/3372297.3417884","type":"proceedings-article","created":{"date-parts":[[2020,11,2]],"date-time":"2020-11-02T18:27:04Z","timestamp":1604341624000},"page":"1323-1335","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":43,"title":["Off-Path TCP Exploits of the Mixed IPID Assignment"],"prefix":"10.1145","author":[{"given":"Xuewei","family":"Feng","sequence":"first","affiliation":[{"name":"Tsinghua University, Beijing, China"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Chuanpu","family":"Fu","sequence":"additional","affiliation":[{"name":"Tsinghua University, Beijing, China"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Qi","family":"Li","sequence":"additional","affiliation":[{"name":"Tsinghua University, Beijing, China"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Kun","family":"Sun","sequence":"additional","affiliation":[{"name":"George Mason University, Fairfax, VA, USA"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Ke","family":"Xu","sequence":"additional","affiliation":[{"name":"Tsinghua University &amp; Peng Cheng Laboratory, Beijing, China"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2020,11,2]]},"reference":[{"key":"e_1_3_2_2_1_1","doi-asserted-by":"publisher","DOI":"10.1109\/ACSAT.2014.34"},{"key":"e_1_3_2_2_2_1","first-page":"68","article-title":"Survey of DDoS Attacks Based on TCP\/IP Protocol Vulnerabilities","volume":"18","author":"Acharya Saket","year":"2016","unstructured":"Saket Acharya and Namita Tiwari . 2016 . Survey of DDoS Attacks Based on TCP\/IP Protocol Vulnerabilities . IOSR Journal of Computer Engineering , Vol. 18 , 3 (2016), 68 -- 76 . Saket Acharya and Namita Tiwari. 2016. Survey of DDoS Attacks Based on TCP\/IP Protocol Vulnerabilities. IOSR Journal of Computer Engineering, Vol. 18, 3 (2016), 68--76.","journal-title":"IOSR Journal of Computer Engineering"},{"key":"e_1_3_2_2_3_1","doi-asserted-by":"publisher","DOI":"10.2478\/popets-2019-0071"},{"key":"e_1_3_2_2_4_1","volume-title":"Requirements for IP Version 4 Routers. RFC","author":"Baker Fred","year":"1812","unstructured":"Fred Baker . 1995. Requirements for IP Version 4 Routers. RFC 1812 . Internet Engineering Task Force . 1--175 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc1812.txt Fred Baker. 1995. Requirements for IP Version 4 Routers. RFC 1812. Internet Engineering Task Force. 1--175 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc1812.txt"},{"key":"e_1_3_2_2_5_1","volume-title":"Proceedings of International Conference on Information and Communication Systems. 149--155","author":"Bani-Hani R","year":"2013","unstructured":"R Bani-Hani and Zaid Al-Ali . 2013 . SYN Flooding Attacks and Countermeasures: A Survey . In Proceedings of International Conference on Information and Communication Systems. 149--155 . R Bani-Hani and Zaid Al-Ali. 2013. SYN Flooding Attacks and Countermeasures: A Survey. In Proceedings of International Conference on Information and Communication Systems. 149--155."},{"key":"e_1_3_2_2_6_1","doi-asserted-by":"crossref","unstructured":"Mike Belshe Roberto Peon and Martin Thomson. 2015. Hypertext Transfer Protocol Version 2 (HTTP\/2). RFC 7540. Internet Engineering Task Force. 1--97 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc7540.txt  Mike Belshe Roberto Peon and Martin Thomson. 2015. Hypertext Transfer Protocol Version 2 (HTTP\/2). RFC 7540. Internet Engineering Task Force. 1--97 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc7540.txt","DOI":"10.17487\/RFC7540"},{"key":"e_1_3_2_2_7_1","unstructured":"Bootlin. 2020. IPID assignment in Linux Kernel. https:\/\/elixir.bootlin.com\/linux\/latest\/source\/include\/net\/ip.h.  Bootlin. 2020. IPID assignment in Linux Kernel. https:\/\/elixir.bootlin.com\/linux\/latest\/source\/include\/net\/ip.h."},{"key":"e_1_3_2_2_8_1","unstructured":"David Borman Bob Braden and V Jacobson. 2014. TCP Extensions for High Performance. RFC 7323. Internet Engineering Task Force. 1--49 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc7323.txt  David Borman Bob Braden and V Jacobson. 2014. TCP Extensions for High Performance. RFC 7323. Internet Engineering Task Force. 1--49 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc7323.txt"},{"key":"e_1_3_2_2_9_1","volume-title":"Off-Path TCP Exploits: Global Rate Limit Considered Dangerous. In 25th USENIX Security Symposium (USENIX Security 16)","author":"Cao Yue","year":"2016","unstructured":"Yue Cao , Zhiyun Qian , Zhongjie Wang , Tuan Dao , Srikanth V Krishnamurthy , and Lisa M Marvel . 2016 . Off-Path TCP Exploits: Global Rate Limit Considered Dangerous. In 25th USENIX Security Symposium (USENIX Security 16) . 209--225. Yue Cao, Zhiyun Qian, Zhongjie Wang, Tuan Dao, Srikanth V Krishnamurthy, and Lisa M Marvel. 2016. Off-Path TCP Exploits: Global Rate Limit Considered Dangerous. In 25th USENIX Security Symposium (USENIX Security 16). 209--225."},{"key":"e_1_3_2_2_10_1","doi-asserted-by":"publisher","DOI":"10.1109\/TNET.2018.2797081"},{"key":"e_1_3_2_2_11_1","doi-asserted-by":"publisher","DOI":"10.1145\/3319535.3354250"},{"key":"e_1_3_2_2_12_1","volume-title":"Off-Path TCP Exploit: How Wireless Routers Can Jeopardize Your Secrets. In 27th USENIX Security Symposium (USENIX Security 18)","author":"Chen Weiteng","year":"2018","unstructured":"Weiteng Chen and Zhiyun Qian . 2018 . Off-Path TCP Exploit: How Wireless Routers Can Jeopardize Your Secrets. In 27th USENIX Security Symposium (USENIX Security 18) . 1581--1598. Weiteng Chen and Zhiyun Qian. 2018. Off-Path TCP Exploit: How Wireless Routers Can Jeopardize Your Secrets. In 27th USENIX Security Symposium (USENIX Security 18). 1581--1598."},{"key":"e_1_3_2_2_13_1","unstructured":"Martin Duke Robert Braden W Eddy Ethan Blanton and Alexander Zimmermann. 2015. A Roadmap for Transmission Control Protocol (TCP) Specification Documents. RFC 7414. Internet Engineering Task Force. 1--57 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc7414.txt  Martin Duke Robert Braden W Eddy Ethan Blanton and Alexander Zimmermann. 2015. A Roadmap for Transmission Control Protocol (TCP) Specification Documents. RFC 7414. Internet Engineering Task Force. 1--57 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc7414.txt"},{"key":"e_1_3_2_2_14_1","unstructured":"Eric Dumazet. 2014. inetpeer: get rid of ip_id_count. https:\/\/lore.kernel.org\/patchwork\/patch\/490770\/.  Eric Dumazet. 2014. inetpeer: get rid of ip_id_count. https:\/\/lore.kernel.org\/patchwork\/patch\/490770\/."},{"key":"e_1_3_2_2_15_1","unstructured":"Wesley Eddy. 2007. TCP SYN Flooding Attacks and Common Mitigations. RFC 4987. Internet Engineering Task Force. 1--19 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc4987.txt  Wesley Eddy. 2007. TCP SYN Flooding Attacks and Common Mitigations. RFC 4987. Internet Engineering Task Force. 1--19 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc4987.txt"},{"key":"e_1_3_2_2_16_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-319-04918-2_11"},{"key":"e_1_3_2_2_17_1","volume-title":"Idle Port Scanning and Non-interference Analysis of Network Protocol Stacks Using Model Checking. In USENIX Security Symposium. 257--272","author":"Ensafi Roya","year":"2010","unstructured":"Roya Ensafi , Jong Chun Park , Deepak Kapur , and Jedidiah R Crandall . 2010 . Idle Port Scanning and Non-interference Analysis of Network Protocol Stacks Using Model Checking. In USENIX Security Symposium. 257--272 . Roya Ensafi, Jong Chun Park, Deepak Kapur, and Jedidiah R Crandall. 2010. Idle Port Scanning and Non-interference Analysis of Network Protocol Stacks Using Model Checking. In USENIX Security Symposium. 257--272."},{"key":"e_1_3_2_2_18_1","unstructured":"Dino Farinacci Tony Li Stan Hanks David Meyer and Paul Traina. 2000. Generic Routing Encapsulation (GRE). RFC 2784. Internet Engineering Task Force. 1--9 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc2784.txt  Dino Farinacci Tony Li Stan Hanks David Meyer and Paul Traina. 2000. Generic Routing Encapsulation (GRE). RFC 2784. Internet Engineering Task Force. 1--9 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc2784.txt"},{"key":"e_1_3_2_2_19_1","doi-asserted-by":"crossref","unstructured":"Roy Fielding Jim Gettys Jeffrey Mogul Henrik Frystyk Larry Masinter Paul Leach and Tim Berners-Lee. 1999. Hypertext Transfer Protocol -- HTTP\/1.1. RFC 2616. Internet Engineering Task Force. 1--176 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc2616.txt  Roy Fielding Jim Gettys Jeffrey Mogul Henrik Frystyk Larry Masinter Paul Leach and Tim Berners-Lee. 1999. Hypertext Transfer Protocol -- HTTP\/1.1. RFC 2616. Internet Engineering Task Force. 1--176 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc2616.txt","DOI":"10.17487\/rfc2616"},{"key":"e_1_3_2_2_20_1","unstructured":"Yossi Gilad and Amir Herzberg. 2012a. Off-Path Attacking the Web. In WOOT. 41--52.  Yossi Gilad and Amir Herzberg. 2012a. Off-Path Attacking the Web. In WOOT. 41--52."},{"key":"e_1_3_2_2_21_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-31680-7_6"},{"key":"e_1_3_2_2_22_1","doi-asserted-by":"publisher","DOI":"10.1145\/2488388.2488427"},{"key":"e_1_3_2_2_23_1","doi-asserted-by":"publisher","DOI":"10.1145\/2597173"},{"key":"e_1_3_2_2_24_1","doi-asserted-by":"publisher","DOI":"10.1109\/MSP.2013.130"},{"key":"e_1_3_2_2_25_1","unstructured":"Fernando Gont and Steven Bellovin. 2012. Defending against Sequence Number Attacks. RFC 6528. Internet Engineering Task Force. 1--12 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc6528.txt  Fernando Gont and Steven Bellovin. 2012. Defending against Sequence Number Attacks. RFC 6528. Internet Engineering Task Force. 1--12 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc6528.txt"},{"key":"e_1_3_2_2_26_1","unstructured":"Amir Herzberg and Haya Shulman. 2010. Stealth DoS Attacks on Secure Channels.. In NDSS.  Amir Herzberg and Haya Shulman. 2010. Stealth DoS Attacks on Secure Channels.. In NDSS."},{"key":"e_1_3_2_2_27_1","unstructured":"Kunihiro Ishiguro. 2020. Quagga Routing Suite. https:\/\/www.quagga.net\/.  Kunihiro Ishiguro. 2020. Quagga Routing Suite. https:\/\/www.quagga.net\/."},{"key":"e_1_3_2_2_28_1","unstructured":"JAVAPIPE. 2020. 35 Types of DDoS Attacks Explained. https:\/\/javapipe.com\/blog\/ddos-types\/.  JAVAPIPE. 2020. 35 Types of DDoS Attacks Explained. https:\/\/javapipe.com\/blog\/ddos-types\/."},{"key":"e_1_3_2_2_29_1","volume-title":"Proceedings of the 4th USENIX Workshop on Free and Open Communications on the Internet (FOCI'14)","author":"Jeffrey Knockel","year":"2014","unstructured":"Knockel Jeffrey and Crandall Jedidiah , R. 2014 . Counting Packets Sent between Arbitrary Internet Hosts . In Proceedings of the 4th USENIX Workshop on Free and Open Communications on the Internet (FOCI'14) . USENIX Association. Knockel Jeffrey and Crandall Jedidiah, R. 2014. Counting Packets Sent between Arbitrary Internet Hosts. In Proceedings of the 4th USENIX Workshop on Free and Open Communications on the Internet (FOCI'14). USENIX Association."},{"key":"e_1_3_2_2_30_1","volume-title":"David R Choffnes, Alan Mislove, and Cristina Nita-Rotaru.","author":"Jero Samuel","year":"2018","unstructured":"Samuel Jero , Md Endadul Hoque , David R Choffnes, Alan Mislove, and Cristina Nita-Rotaru. 2018 . Automated Attack Discovery in TCP Congestion Control Using a Model-guided Approach. In NDSS. Samuel Jero, Md Endadul Hoque, David R Choffnes, Alan Mislove, and Cristina Nita-Rotaru. 2018. Automated Attack Discovery in TCP Congestion Control Using a Model-guided Approach. In NDSS."},{"key":"e_1_3_2_2_31_1","doi-asserted-by":"publisher","DOI":"10.1145\/863955.863966"},{"key":"e_1_3_2_2_32_1","unstructured":"Michael Larsen and Fernando Gont. 2011. Recommendations for Transport-Protocol Port Randomization. RFC 6056. Internet Engineering Task Force. 1--29 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc6056.txt  Michael Larsen and Fernando Gont. 2011. Recommendations for Transport-Protocol Port Randomization. RFC 6056. Internet Engineering Task Force. 1--29 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc6056.txt"},{"key":"e_1_3_2_2_33_1","doi-asserted-by":"publisher","DOI":"10.1145\/3319535.3354232"},{"key":"e_1_3_2_2_34_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC1981"},{"key":"e_1_3_2_2_35_1","unstructured":"Jeffrey Mogul and Steve Deering. 1990. Path MTU discovery. RFC 1191. Internet Engineering Task Force. 1--19 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc1191.txt  Jeffrey Mogul and Steve Deering. 1990. Path MTU discovery. RFC 1191. Internet Engineering Task Force. 1--19 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc1191.txt"},{"key":"e_1_3_2_2_36_1","volume-title":"On the Feasibility of Rerouting-Based DDoS Defenses. In 2019 IEEE Symposium on Security and Privacy (SP). IEEE, 798--813","author":"Muoi Tran","year":"2019","unstructured":"Tran Muoi , Kang Min , Suk, Hsiao Hsu-Chun , Chiang Wei-Hsuan , Tung Shu-Po , and Wang Yu-Su . 2019 . On the Feasibility of Rerouting-Based DDoS Defenses. In 2019 IEEE Symposium on Security and Privacy (SP). IEEE, 798--813 . Tran Muoi, Kang Min, Suk, Hsiao Hsu-Chun, Chiang Wei-Hsuan, Tung Shu-Po, and Wang Yu-Su. 2019. On the Feasibility of Rerouting-Based DDoS Defenses. In 2019 IEEE Symposium on Security and Privacy (SP). IEEE, 798--813."},{"key":"e_1_3_2_2_37_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2017.55"},{"key":"e_1_3_2_2_38_1","doi-asserted-by":"publisher","DOI":"10.1109\/MSP.2018.1331018"},{"key":"e_1_3_2_2_39_1","unstructured":"Jon Postel. 1981 a. Internet Control Message Protocol. RFC 792. Internet Engineering Task Force. 1--21 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc792.txt  Jon Postel. 1981 a. Internet Control Message Protocol. RFC 792. Internet Engineering Task Force. 1--21 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc792.txt"},{"key":"e_1_3_2_2_40_1","unstructured":"Jon Postel. 1981 b. Internet Protocol. RFC 791. Internet Engineering Task Force. 1--45 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc791.txt  Jon Postel. 1981 b. Internet Protocol. RFC 791. Internet Engineering Task Force. 1--45 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc791.txt"},{"key":"e_1_3_2_2_41_1","unstructured":"Jon Postel. 1981 c. Transmission Control Protocol. RFC 793. Internet Engineering Task Force. 1--85 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc793.txt  Jon Postel. 1981 c. Transmission Control Protocol. RFC 793. Internet Engineering Task Force. 1--85 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc793.txt"},{"key":"e_1_3_2_2_42_1","volume-title":"Off-Path TCP Sequence Number Inference Attack How Firewall Middleboxes Reduce Security. In 2012 IEEE Symposium on Security and Privacy. IEEE, 347--361","author":"Qian Zhiyun","year":"2012","unstructured":"Zhiyun Qian and Z Morley Mao . 2012 . Off-Path TCP Sequence Number Inference Attack How Firewall Middleboxes Reduce Security. In 2012 IEEE Symposium on Security and Privacy. IEEE, 347--361 . Zhiyun Qian and Z Morley Mao. 2012. Off-Path TCP Sequence Number Inference Attack How Firewall Middleboxes Reduce Security. In 2012 IEEE Symposium on Security and Privacy. IEEE, 347--361."},{"key":"e_1_3_2_2_43_1","doi-asserted-by":"publisher","DOI":"10.1145\/2382196.2382258"},{"key":"e_1_3_2_2_44_1","unstructured":"Anantha Ramaiah R Stewart and Mitesh Dalal. 2010. Improving TCP's Robustness to Blind In-Window Attacks. RFC 5961. Internet Engineering Task Force. 1--19 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc5961.txt  Anantha Ramaiah R Stewart and Mitesh Dalal. 2010. Improving TCP's Robustness to Blind In-Window Attacks. RFC 5961. Internet Engineering Task Force. 1--19 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc5961.txt"},{"key":"e_1_3_2_2_45_1","unstructured":"Rocket.Chat. 2020. Web Application. https:\/\/rocket.chat\/.  Rocket.Chat. 2020. Web Application. https:\/\/rocket.chat\/."},{"key":"e_1_3_2_2_46_1","doi-asserted-by":"publisher","DOI":"10.1109\/LCOMM.2005.1413635"},{"key":"e_1_3_2_2_47_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2018.00032"},{"key":"e_1_3_2_2_48_1","unstructured":"Pyda Srisuresh and Matt Holdrege. 1999. IP Network Address Translator (NAT) Terminology and Considerations. RFC 2663. Internet Engineering Task Force. 1--30 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc2663.txt  Pyda Srisuresh and Matt Holdrege. 1999. IP Network Address Translator (NAT) Terminology and Considerations. RFC 2663. Internet Engineering Task Force. 1--30 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc2663.txt"},{"key":"e_1_3_2_2_49_1","unstructured":"Joe Touch. 2007. Defending TCP Against Spoofing Attacks. RFC 4953. Internet Engineering Task Force. 1--28 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc4953.txt  Joe Touch. 2007. Defending TCP Against Spoofing Attacks. RFC 4953. Internet Engineering Task Force. 1--28 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc4953.txt"},{"key":"e_1_3_2_2_50_1","unstructured":"Joe Touch. 2013. Updated Specification of the IPv4 ID Field. RFC 6864. Internet Engineering Task Force. 1--19 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc6864.txt  Joe Touch. 2013. Updated Specification of the IPv4 ID Field. RFC 6864. Internet Engineering Task Force. 1--19 pages. http:\/\/www.rfc-editor.org\/rfc\/rfc6864.txt"},{"key":"e_1_3_2_2_51_1","doi-asserted-by":"publisher","DOI":"10.1109\/INFCOM.2002.1019404"},{"key":"e_1_3_2_2_52_1","doi-asserted-by":"publisher","DOI":"10.1109\/IWQoS.2018.8624169"},{"key":"e_1_3_2_2_53_1","volume-title":"ONIS: Inferring TCP\/IP-based Trust Relationships Completely Off-Path. In IEEE INFOCOM 2018-IEEE Conference on Computer Communications. IEEE","author":"Zhang Xu","year":"2018","unstructured":"Xu Zhang , Jeffrey Knockel , and Jedidiah R Crandall . 2018 . ONIS: Inferring TCP\/IP-based Trust Relationships Completely Off-Path. In IEEE INFOCOM 2018-IEEE Conference on Computer Communications. IEEE , 2069--2077. Xu Zhang, Jeffrey Knockel, and Jedidiah R Crandall. 2018. ONIS: Inferring TCP\/IP-based Trust Relationships Completely Off-Path. In IEEE INFOCOM 2018-IEEE Conference on Computer Communications. IEEE, 2069--2077."}],"event":{"name":"CCS '20: 2020 ACM SIGSAC Conference on Computer and Communications Security","location":"Virtual Event USA","acronym":"CCS '20","sponsor":["SIGSAC ACM Special Interest Group on Security, Audit, and Control"]},"container-title":["Proceedings of the 2020 ACM SIGSAC Conference on Computer and Communications Security"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3372297.3417884","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3372297.3417884","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,17]],"date-time":"2025-06-17T22:01:32Z","timestamp":1750197692000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3372297.3417884"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2020,10,30]]},"references-count":53,"alternative-id":["10.1145\/3372297.3417884","10.1145\/3372297"],"URL":"https:\/\/doi.org\/10.1145\/3372297.3417884","relation":{},"subject":[],"published":{"date-parts":[[2020,10,30]]},"assertion":[{"value":"2020-11-02","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}