{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,9,3]],"date-time":"2026-09-03T15:30:43Z","timestamp":1788449443640,"version":"build-2803163510"},"publisher-location":"New York, NY, USA","reference-count":29,"publisher":"ACM","license":[{"start":{"date-parts":[[2021,11,4]],"date-time":"2021-11-04T00:00:00Z","timestamp":1635984000000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2021,11,10]]},"DOI":"10.1145\/3484266.3487370","type":"proceedings-article","created":{"date-parts":[[2021,11,4]],"date-time":"2021-11-04T18:31:15Z","timestamp":1636050675000},"page":"84-90","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":17,"title":["Stats 101 in P4"],"prefix":"10.1145","author":[{"given":"Sam","family":"Gao","sequence":"first","affiliation":[{"name":"University College London London, UK"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Mark","family":"Handley","sequence":"additional","affiliation":[{"name":"University College London London, UK"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Stefano","family":"Vissicchio","sequence":"additional","affiliation":[{"name":"University College London London, UK"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2021,11,4]]},"reference":[{"key":"e_1_3_2_1_1_1","doi-asserted-by":"publisher","DOI":"10.1145\/2656877.2656890"},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1145\/2486001.2486011"},{"key":"e_1_3_2_1_3_1","doi-asserted-by":"crossref","unstructured":"Stewart Bryant Clarence Filsfils Stefano Previdi Mike Shand and Ning So. 2015. Remote Loop-Free Alternate (LFA) Fast Reroute (FRR). RFC 7490. (2015). https:\/\/rfc-editor.org\/rfc\/rfc7490.txt  Stewart Bryant Clarence Filsfils Stefano Previdi Mike Shand and Ning So. 2015. Remote Loop-Free Alternate (LFA) Fast Reroute (FRR). RFC 7490. (2015). https:\/\/rfc-editor.org\/rfc\/rfc7490.txt","DOI":"10.17487\/RFC7490"},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.1145\/3359989.3365408"},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"crossref","unstructured":"Benoit Claise. 2004. Cisco Systems NetFlow Services Export Version 9. RFC 3954. (2004). https:\/\/rfc-editor.org\/rfc\/rfc3954.txt  Benoit Claise. 2004. Cisco Systems NetFlow Services Export Version 9. RFC 3954. (2004). https:\/\/rfc-editor.org\/rfc\/rfc3954.txt","DOI":"10.17487\/rfc3954"},{"key":"e_1_3_2_1_6_1","unstructured":"Cloudflare blog. 2020. Famous DDoS attacks. www.cloudflare.com\/en-us\/learning\/ddos\/famous-ddos-attacks\/. (2020).  Cloudflare blog. 2020. Famous DDoS attacks. www.cloudflare.com\/en-us\/learning\/ddos\/famous-ddos-attacks\/. (2020)."},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.1109\/NOMS47738.2020.9110257"},{"key":"e_1_3_2_1_8_1","volume-title":"Case","author":"Fedor Mark","year":"1990","unstructured":"Mark Fedor , Martin L. Schoffstall , James R. Davin , and Jeff D . Case . 1990 . Simple Network Management Protocol (SNMP). RFC 1157. (1990). Mark Fedor, Martin L. Schoffstall, James R. Davin, and Jeff D. Case. 1990. Simple Network Management Protocol (SNMP). RFC 1157. (1990)."},{"key":"e_1_3_2_1_9_1","unstructured":"Sam Gao Mark Handley and Stefano Vissicchio. 2021. Stat4 repository. https:\/\/gitlab.com\/svissicchio\/stat4. (2021).  Sam Gao Mark Handley and Stefano Vissicchio. 2021. Stat4 repository. https:\/\/gitlab.com\/svissicchio\/stat4. (2021)."},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.1145\/3050220.3050228"},{"key":"e_1_3_2_1_11_1","unstructured":"Vladimir Gurevich. 2017. P4 mapping to Barefoot Tofino(tm). Talk at P4 Developers Day. (2017).  Vladimir Gurevich. 2017. P4 mapping to Barefoot Tofino(tm). Talk at P4 Developers Day. (2017)."},{"key":"e_1_3_2_1_12_1","volume-title":"Proceedings of the 16th USENIX Conference on Networked Systems Design and Implementation (NSDI'19)","author":"Holterbach T.","unstructured":"T. Holterbach , E. Molero , M. Apostolaki , A. Dainotti , S. Vissicchio , and L. Vanbever . 2019. Blink: Fast Connectivity Recovery Entirely in the Data Plane . In Proceedings of the 16th USENIX Conference on Networked Systems Design and Implementation (NSDI'19) . USENIX Association, USA, 161--176. T. Holterbach, E. Molero, M. Apostolaki, A. Dainotti, S. Vissicchio, and L. Vanbever. 2019. Blink: Fast Connectivity Recovery Entirely in the Data Plane. In Proceedings of the 16th USENIX Conference on Networked Systems Design and Implementation (NSDI'19). USENIX Association, USA, 161--176."},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.1145\/3359989.3365433"},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"publisher","DOI":"10.1109\/NFV-SDN.2018.8725736"},{"key":"e_1_3_2_1_15_1","volume-title":"Proceedings of the 13th Usenix Conference on Networked Systems Design and Implementation (NSDI'16)","author":"Li Yuliang","year":"2016","unstructured":"Yuliang Li , Rui Miao , Changhoon Kim , and Minlan Yu . 2016 . FlowRadar: A Better NetFlow for Data Centers . In Proceedings of the 13th Usenix Conference on Networked Systems Design and Implementation (NSDI'16) . USENIX Association, USA, 311--324. Yuliang Li, Rui Miao, Changhoon Kim, and Minlan Yu. 2016. FlowRadar: A Better NetFlow for Data Centers. In Proceedings of the 13th Usenix Conference on Networked Systems Design and Implementation (NSDI'16). USENIX Association, USA, 311--324."},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.1145\/2999572.2999609"},{"key":"e_1_3_2_1_17_1","unstructured":"Stephane Litkowski Ahmed Bashandy Clarence Filsfils Pierre Francois Bruno Decraene and Daniel Voyer. 2021. Topology Independent Fast Reroute using Segment Routing. (2021). Internet Draft.  Stephane Litkowski Ahmed Bashandy Clarence Filsfils Pierre Francois Bruno Decraene and Daniel Voyer. 2021. Topology Independent Fast Reroute using Segment Routing. (2021). Internet Draft."},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.1145\/2934872.2934906"},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1145\/3098822.3098829"},{"key":"e_1_3_2_1_20_1","unstructured":"P4.org Applications Working Group. 2020. In-band Network Telemetry (INT) Dataplane Specification v2.0. https:\/\/p4.org\/specs\/. (2020).  P4.org Applications Working Group. 2020. In-band Network Telemetry (INT) Dataplane Specification v2.0. https:\/\/p4.org\/specs\/. (2020)."},{"key":"e_1_3_2_1_21_1","unstructured":"Sonia Panchen Neil McKee and Peter Phaal. 2001. InMon Corporation's sFlow: A Method for Monitoring Traffic in Switched and Routed Networks. RFC 3176. (2001). https:\/\/rfc-editor.org\/rfc\/rfc3176.txt  Sonia Panchen Neil McKee and Peter Phaal. 2001. InMon Corporation's sFlow: A Method for Monitoring Traffic in Switched and Routed Networks. RFC 3176. (2001). https:\/\/rfc-editor.org\/rfc\/rfc3176.txt"},{"key":"e_1_3_2_1_22_1","doi-asserted-by":"publisher","DOI":"10.5555\/3154630.3154637"},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"publisher","DOI":"10.1145\/3050220.3063772"},{"key":"e_1_3_2_1_24_1","doi-asserted-by":"publisher","DOI":"10.1145\/3183713.3183759"},{"key":"e_1_3_2_1_25_1","doi-asserted-by":"publisher","DOI":"10.1145\/1064413.1064417"},{"key":"e_1_3_2_1_26_1","doi-asserted-by":"publisher","DOI":"10.1080\/00401706.1962.10490022"},{"key":"e_1_3_2_1_27_1","doi-asserted-by":"publisher","DOI":"10.1145\/3365609.3365864"},{"key":"e_1_3_2_1_28_1","doi-asserted-by":"publisher","DOI":"10.5555\/2482626.2482631"},{"key":"e_1_3_2_1_29_1","doi-asserted-by":"publisher","DOI":"10.1145\/3387514.3406214"}],"event":{"name":"HotNets '21: The 20th ACM Workshop on Hot Topics in Networks","location":"Virtual Event United Kingdom","acronym":"HotNets '21","sponsor":["SIGCOMM ACM Special Interest Group on Data Communication"]},"container-title":["Proceedings of the Twentieth ACM Workshop on Hot Topics in Networks"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3484266.3487370","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3484266.3487370","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,17]],"date-time":"2025-06-17T16:17:13Z","timestamp":1750177033000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3484266.3487370"}},"subtitle":["Towards In-Switch Anomaly Detection"],"short-title":[],"issued":{"date-parts":[[2021,11,4]]},"references-count":29,"alternative-id":["10.1145\/3484266.3487370","10.1145\/3484266"],"URL":"https:\/\/doi.org\/10.1145\/3484266.3487370","relation":{},"subject":[],"published":{"date-parts":[[2021,11,4]]},"assertion":[{"value":"2021-11-04","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}