{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,27]],"date-time":"2026-10-27T19:41:05Z","timestamp":1793130065736,"version":"4.5.0"},"publisher-location":"New York, NY, USA","reference-count":42,"publisher":"ACM","license":[{"start":{"date-parts":[[2021,12,2]],"date-time":"2021-12-02T00:00:00Z","timestamp":1638403200000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"funder":[{"DOI":"10.13039\/501100002347","name":"Bundesministerium f\u00fcr Bildung und Forschung","doi-asserted-by":"publisher","award":["PRIMEnet"],"award-info":[{"award-number":["PRIMEnet"]}],"id":[{"id":"10.13039\/501100002347","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2021,12,2]]},"DOI":"10.1145\/3485983.3494872","type":"proceedings-article","created":{"date-parts":[[2021,12,3]],"date-time":"2021-12-03T22:36:56Z","timestamp":1638571016000},"page":"454-462","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":26,"title":["Transparent forwarders"],"prefix":"10.1145","author":[{"given":"Marcin","family":"Nawrocki","sequence":"first","affiliation":[{"name":"Freie Universit\u00e4t Berlin, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Maynard","family":"Koch","sequence":"additional","affiliation":[{"name":"Freie Universit\u00e4t Berlin, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Thomas C.","family":"Schmidt","sequence":"additional","affiliation":[{"name":"HAW Hamburg, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Matthias","family":"W\u00e4hlisch","sequence":"additional","affiliation":[{"name":"Freie Universit\u00e4t Berlin, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2021,12,3]]},"reference":[{"key":"e_1_3_2_2_1_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-030-72582-2_25"},{"key":"e_1_3_2_2_2_1","doi-asserted-by":"publisher","DOI":"10.1145\/3419394.3423659"},{"key":"e_1_3_2_2_3_1","doi-asserted-by":"publisher","DOI":"10.1145\/3143361.3143375"},{"key":"e_1_3_2_2_4_1","doi-asserted-by":"publisher","DOI":"10.1016\/j.cose.2013.10.001"},{"key":"e_1_3_2_2_5_1","volume-title":"USENIX Workshop on Free and Open Communications on the Internet (FOCI)","author":"Anonymous","year":"2014","unstructured":"Anonymous . 2014 . Towards a Comprehensive Picture of the Great Firewall's DNS Censorship . In USENIX Workshop on Free and Open Communications on the Internet (FOCI) ( San Diego, CA, USA). USENIX Association, Berkeley, CA, USA. https:\/\/www.usenix.org\/conference\/foci14\/workshop-program\/presentation\/anonymous Anonymous. 2014. Towards a Comprehensive Picture of the Great Firewall's DNS Censorship. In USENIX Workshop on Free and Open Communications on the Internet (FOCI) (San Diego, CA, USA). USENIX Association, Berkeley, CA, USA. https:\/\/www.usenix.org\/conference\/foci14\/workshop-program\/presentation\/anonymous"},{"key":"e_1_3_2_2_6_1","unstructured":"CAIDA. 2005. AS Rank API. Website. http:\/\/as-rank.caida.org\/ Retrieved: May 2021.  CAIDA. 2005. AS Rank API. Website. http:\/\/as-rank.caida.org\/ Retrieved: May 2021."},{"key":"e_1_3_2_2_8_1","volume-title":"Censys IO Search 2.0. Website. https:\/\/search.censys.io\/ Retrieved","year":"2021","unstructured":"Censys. 2017. Censys IO Search 2.0. Website. https:\/\/search.censys.io\/ Retrieved : May , 2021 . Censys. 2017. Censys IO Search 2.0. Website. https:\/\/search.censys.io\/ Retrieved: May, 2021."},{"key":"e_1_3_2_2_9_1","doi-asserted-by":"publisher","DOI":"10.1109\/NOMS47738.2020.9110336"},{"key":"e_1_3_2_2_10_1","doi-asserted-by":"publisher","DOI":"10.23919\/IFIPNetworking52078.2021.9472831"},{"key":"e_1_3_2_2_11_1","volume-title":"Proc. of the 22nd USENIX Security Symposium (Washington, D.C., USA). USENIX Association","author":"Durumeric Zakir","unstructured":"Zakir Durumeric , Eric Wustrow , and J. Halderman . 2013. ZMap: Fast Internet-Wide Scanning and its Security Applications . In Proc. of the 22nd USENIX Security Symposium (Washington, D.C., USA). USENIX Association , Berkeley, CA, USA, 605--620. https:\/\/www.usenix.org\/conference\/usenixsecurity13\/technical-sessions\/paper\/durumeric Zakir Durumeric, Eric Wustrow, and J. Halderman. 2013. ZMap: Fast Internet-Wide Scanning and its Security Applications. In Proc. of the 22nd USENIX Security Symposium (Washington, D.C., USA). USENIX Association, Berkeley, CA, USA, 605--620. https:\/\/www.usenix.org\/conference\/usenixsecurity13\/technical-sessions\/paper\/durumeric"},{"key":"e_1_3_2_2_12_1","doi-asserted-by":"publisher","DOI":"10.1145\/3132465.3132474"},{"key":"e_1_3_2_2_13_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2827"},{"key":"e_1_3_2_2_14_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-030-72582-2_16"},{"key":"e_1_3_2_2_15_1","doi-asserted-by":"crossref","unstructured":"P. Hoffman and P. McManus. 2018. DNS Queries over HTTPS (DoH). RFC 8484. IETF.  P. Hoffman and P. McManus. 2018. DNS Queries over HTTPS (DoH). RFC 8484. IETF.","DOI":"10.17487\/RFC8484"},{"key":"e_1_3_2_2_16_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8499"},{"key":"e_1_3_2_2_17_1","doi-asserted-by":"crossref","unstructured":"Z. Hu L. Zhu J. Heidemann A. Mankin D. Wessels and P. Hoffman. 2016. Specification for DNS over Transport Layer Security (TLS). RFC 7858. IETF.  Z. Hu L. Zhu J. Heidemann A. Mankin D. Wessels and P. Hoffman. 2016. Specification for DNS over Transport Layer Security (TLS). RFC 7858. IETF.","DOI":"10.17487\/RFC7858"},{"key":"e_1_3_2_2_18_1","volume-title":"Measuring Recursive Resolver Centrality. RIPE Meeting 82","author":"Huston Geoff","year":"2021","unstructured":"Geoff Huston and Joao Damas . 2021 . Measuring Recursive Resolver Centrality. RIPE Meeting 82 . https:\/\/ripe82.ripe.net\/wp-content\/uploads\/presentations\/41-2021-05-19-resolver-centrality.pdf Retrieved : June, 2021. Geoff Huston and Joao Damas. 2021. Measuring Recursive Resolver Centrality. RIPE Meeting 82. https:\/\/ripe82.ripe.net\/wp-content\/uploads\/presentations\/41-2021-05-19-resolver-centrality.pdf Retrieved: June, 2021."},{"key":"e_1_3_2_2_19_1","doi-asserted-by":"publisher","DOI":"10.1109\/TNSM.2021.3078428"},{"key":"e_1_3_2_2_20_1","volume-title":"Proc. of 30th USENIX Security Symposium (Virtual conference). USENIX Association","author":"Izhikevich Liz","year":"2021","unstructured":"Liz Izhikevich , Renata Teixeira , and Zakir Durumeric . 2021 . LZR: Identifying Unexpected Internet Services . In Proc. of 30th USENIX Security Symposium (Virtual conference). USENIX Association , Berkeley, CA, USA, 18 pages. https:\/\/www.usenix.org\/conference\/usenixsecurity21\/presentation\/izhikevich Prepublication. Liz Izhikevich, Renata Teixeira, and Zakir Durumeric. 2021. LZR: Identifying Unexpected Internet Services. In Proc. of 30th USENIX Security Symposium (Virtual conference). USENIX Association, Berkeley, CA, USA, 18 pages. https:\/\/www.usenix.org\/conference\/usenixsecurity21\/presentation\/izhikevich Prepublication."},{"key":"e_1_3_2_2_21_1","volume-title":"RouterOS Post Exploitation. Blog. https:\/\/medium.com\/tenable-techblog\/routeros-post-exploitation-784c08044790 Retrieved","author":"Baines Jacob","year":"2021","unstructured":"Jacob Baines . 2019. RouterOS Post Exploitation. Blog. https:\/\/medium.com\/tenable-techblog\/routeros-post-exploitation-784c08044790 Retrieved : September , 2021 . Jacob Baines. 2019. RouterOS Post Exploitation. Blog. https:\/\/medium.com\/tenable-techblog\/routeros-post-exploitation-784c08044790 Retrieved: September, 2021."},{"key":"e_1_3_2_2_22_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-319-30505-9_21"},{"key":"e_1_3_2_2_23_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-030-44081-7_7"},{"key":"e_1_3_2_2_24_1","doi-asserted-by":"publisher","DOI":"10.1145\/1879141.1879173"},{"key":"e_1_3_2_2_25_1","doi-asserted-by":"publisher","DOI":"10.1145\/2815675.2815683"},{"key":"e_1_3_2_2_26_1","volume-title":"Proc. of 23rd USENIX Security Symposium","author":"K\u00fchrer Marc","year":"2014","unstructured":"Marc K\u00fchrer , Thomas Hupperich , Christian Rossow , and Thorsten Holz . 2014 . Exit from Hell? Reducing the Impact of Amplification DDoS Attacks . In Proc. of 23rd USENIX Security Symposium ( San Diego, CA). USENIX Association, Berkeley, CA, USA, 111--125. https:\/\/www.usenix.org\/conference\/usenixsecurity14\/technical-sessions\/presentation\/kuhrer Marc K\u00fchrer, Thomas Hupperich, Christian Rossow, and Thorsten Holz. 2014. Exit from Hell? Reducing the Impact of Amplification DDoS Attacks. In Proc. of 23rd USENIX Security Symposium (San Diego, CA). USENIX Association, Berkeley, CA, USA, 111--125. https:\/\/www.usenix.org\/conference\/usenixsecurity14\/technical-sessions\/presentation\/kuhrer"},{"key":"e_1_3_2_2_27_1","volume-title":"Proc. of the 27nd USENIX Security Symposium","author":"Liu Baojun","year":"2018","unstructured":"Baojun Liu , Chaoyi Lu , Hai-Xin Duan , Ying Liu , Zhou Li , Shuang Hao , and Min Yang . 2018 . Who Is Answering My Queries: Understanding and Characterizing Interception of the DNS Resolution Path . In Proc. of the 27nd USENIX Security Symposium ( Baltimore, MD, USA.). USENIX Association, Berkeley, CA, USA, 1113--1128. https:\/\/www.usenix.org\/conference\/usenixsecurity18\/presentation\/liu-baojun Baojun Liu, Chaoyi Lu, Hai-Xin Duan, Ying Liu, Zhou Li, Shuang Hao, and Min Yang. 2018. Who Is Answering My Queries: Understanding and Characterizing Interception of the DNS Resolution Path. In Proc. of the 27nd USENIX Security Symposium (Baltimore, MD, USA.). USENIX Association, Berkeley, CA, USA, 1113--1128. https:\/\/www.usenix.org\/conference\/usenixsecurity18\/presentation\/liu-baojun"},{"key":"e_1_3_2_2_28_1","doi-asserted-by":"publisher","DOI":"10.1093\/comjnl\/bxab063"},{"key":"e_1_3_2_2_29_1","doi-asserted-by":"publisher","DOI":"10.1145\/3297156.3297272"},{"key":"e_1_3_2_2_30_1","doi-asserted-by":"publisher","DOI":"10.1145\/3372297.3417280"},{"key":"e_1_3_2_2_31_1","unstructured":"Jared Mauch. 2013. Spoofing ASNs. NANOG mailing list. http:\/\/seclists.org\/nanog\/2013\/Aug\/132 Retrieved: May 2021.  Jared Mauch. 2013. Spoofing ASNs. NANOG mailing list. http:\/\/seclists.org\/nanog\/2013\/Aug\/132 Retrieved: May 2021."},{"key":"e_1_3_2_2_32_1","volume-title":"DNS library in Go. Code repository. https:\/\/github.com\/miekg\/dns Retrieved","author":"Gieben Miek","year":"2021","unstructured":"Miek Gieben . 2010. DNS library in Go. Code repository. https:\/\/github.com\/miekg\/dns Retrieved : April , 2021 . Miek Gieben. 2010. DNS library in Go. Code repository. https:\/\/github.com\/miekg\/dns Retrieved: April, 2021."},{"key":"e_1_3_2_2_33_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC1035"},{"key":"e_1_3_2_2_34_1","doi-asserted-by":"publisher","DOI":"10.1145\/3487552.3487817"},{"key":"e_1_3_2_2_35_1","volume-title":"Schmidt","author":"Ryba Fabrice J.","year":"2015","unstructured":"Fabrice J. Ryba , Matthew Orlinski , Matthias W\u00e4hlisch , Christian Rossow , and Thomas C . Schmidt . 2015 . Amplification and DRDoS Attack Defense - A Survey and New Perspectives. Technical Report arXiv:1505.07892. Open Archive : arXiv.org. http:\/\/arxiv.org\/abs\/1505.07892 Fabrice J. Ryba, Matthew Orlinski, Matthias W\u00e4hlisch, Christian Rossow, and Thomas C. Schmidt. 2015. Amplification and DRDoS Attack Defense - A Survey and New Perspectives. Technical Report arXiv:1505.07892. Open Archive: arXiv.org. http:\/\/arxiv.org\/abs\/1505.07892"},{"key":"e_1_3_2_2_36_1","doi-asserted-by":"publisher","DOI":"10.1109\/INM.2015.7140298"},{"key":"e_1_3_2_2_37_1","doi-asserted-by":"publisher","DOI":"10.1145\/2504730.2504734"},{"key":"e_1_3_2_2_38_1","volume-title":"Shodan - the world's first search engine for Internet-connected devices. Website. https:\/\/www.shodan.io\/ Retrieved","year":"2021","unstructured":"Shodan. 2014. Shodan - the world's first search engine for Internet-connected devices. Website. https:\/\/www.shodan.io\/ Retrieved : September , 2021 . Shodan. 2014. Shodan - the world's first search engine for Internet-connected devices. Website. https:\/\/www.shodan.io\/ Retrieved: September, 2021."},{"key":"e_1_3_2_2_39_1","volume-title":"Open Resolver Scanning Project. Website. https:\/\/scan.shadowserver.org\/dns\/ Retrieved","author":"Foundation The Shadowserver","year":"2021","unstructured":"The Shadowserver Foundation . 2021. Open Resolver Scanning Project. Website. https:\/\/scan.shadowserver.org\/dns\/ Retrieved : May , 2021 . The Shadowserver Foundation. 2021. Open Resolver Scanning Project. Website. https:\/\/scan.shadowserver.org\/dns\/ Retrieved: May, 2021."},{"key":"e_1_3_2_2_40_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC4893"},{"key":"e_1_3_2_2_41_1","volume-title":"Redirecting DNS for Ads and Profit. In USENIX Workshop on Free and Open Communications on the Internet (FOCI)","author":"Weaver Nicholas","year":"2011","unstructured":"Nicholas Weaver , Christian Kreibich , and Vern Paxson . 2011 . Redirecting DNS for Ads and Profit. In USENIX Workshop on Free and Open Communications on the Internet (FOCI) ( San Francisco, CA, USA). USENIX Association, Berkeley, CA, USA, 2--3. https:\/\/www.usenix.org\/conference\/foci11\/redirecting-dns-ads-and-profit Nicholas Weaver, Christian Kreibich, and Vern Paxson. 2011. Redirecting DNS for Ads and Profit. In USENIX Workshop on Free and Open Communications on the Internet (FOCI) (San Francisco, CA, USA). USENIX Association, Berkeley, CA, USA, 2--3. https:\/\/www.usenix.org\/conference\/foci11\/redirecting-dns-ads-and-profit"},{"key":"e_1_3_2_2_42_1","volume-title":"Heidemann","author":"Wei Lan","year":"2020","unstructured":"Lan Wei and John S . Heidemann . 2020 . Whac-A-Mole: Six Years of DNS Spoofing. Technical Report arXiv:2109.08783. Open Archive : arXiv.org. https:\/\/arxiv.org\/abs\/2011.12978 Lan Wei and John S. Heidemann. 2020. Whac-A-Mole: Six Years of DNS Spoofing. Technical Report arXiv:2109.08783. Open Archive: arXiv.org. https:\/\/arxiv.org\/abs\/2011.12978"},{"key":"e_1_3_2_2_43_1","volume-title":"Proc. of 29th USENIX Security Symposium (Virtual conference). USENIX Association","author":"Zheng Xiaofeng","year":"2020","unstructured":"Xiaofeng Zheng , Chaoyi Lu , Jian Peng , Qiushi Yang , Dongjie Zhou , Baojun Liu , Keyu Man , Shuang Hao , Haixin Duan , and Zhiyun Qian . 2020 . Poison Over Troubled Forwarders: A Cache Poisoning Attack Targeting DNS Forwarding Devices . In Proc. of 29th USENIX Security Symposium (Virtual conference). USENIX Association , Berkeley, CA, USA, 577--593. https:\/\/www.usenix.org\/conference\/usenixsecurity20\/presentation\/zheng Xiaofeng Zheng, Chaoyi Lu, Jian Peng, Qiushi Yang, Dongjie Zhou, Baojun Liu, Keyu Man, Shuang Hao, Haixin Duan, and Zhiyun Qian. 2020. Poison Over Troubled Forwarders: A Cache Poisoning Attack Targeting DNS Forwarding Devices. In Proc. of 29th USENIX Security Symposium (Virtual conference). USENIX Association, Berkeley, CA, USA, 577--593. https:\/\/www.usenix.org\/conference\/usenixsecurity20\/presentation\/zheng"}],"event":{"name":"CoNEXT '21: The 17th International Conference on emerging Networking EXperiments and Technologies","location":"Virtual Event Germany","acronym":"CoNEXT '21","sponsor":["SIGCOMM ACM Special Interest Group on Data Communication"]},"container-title":["Proceedings of the 17th International Conference on emerging Networking EXperiments and Technologies"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3485983.3494872","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3485983.3494872","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,17]],"date-time":"2025-06-17T20:12:32Z","timestamp":1750191152000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3485983.3494872"}},"subtitle":["an unnoticed component of the open DNS infrastructure"],"short-title":[],"issued":{"date-parts":[[2021,12,2]]},"references-count":42,"alternative-id":["10.1145\/3485983.3494872","10.1145\/3485983"],"URL":"https:\/\/doi.org\/10.1145\/3485983.3494872","relation":{},"subject":[],"published":{"date-parts":[[2021,12,2]]},"assertion":[{"value":"2021-12-03","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}