{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,9,29]],"date-time":"2026-09-29T13:38:46Z","timestamp":1790689126565,"version":"4.1.0"},"publisher-location":"New York, NY, USA","reference-count":40,"publisher":"ACM","license":[{"start":{"date-parts":[[2021,11,2]],"date-time":"2021-11-02T00:00:00Z","timestamp":1635811200000},"content-version":"vor","delay-in-days":0,"URL":"http:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"funder":[{"DOI":"10.13039\/100000001","name":"National Science Foundation","doi-asserted-by":"publisher","award":["CNS-1629973,CNS-1705050"],"award-info":[{"award-number":["CNS-1629973,CNS-1705050"]}],"id":[{"id":"10.13039\/100000001","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2021,11,2]]},"DOI":"10.1145\/3487552.3487820","type":"proceedings-article","created":{"date-parts":[[2021,11,1]],"date-time":"2021-11-01T17:35:11Z","timestamp":1635788111000},"page":"122-136","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":19,"title":["Who's got your mail?"],"prefix":"10.1145","author":[{"given":"Enze","family":"Liu","sequence":"first","affiliation":[{"name":"UC San Diego"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Gautam","family":"Akiwate","sequence":"additional","affiliation":[{"name":"UC San Diego"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Mattijs","family":"Jonker","sequence":"additional","affiliation":[{"name":"University of Twente"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Ariana","family":"Mirian","sequence":"additional","affiliation":[{"name":"UC San Diego"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Stefan","family":"Savage","sequence":"additional","affiliation":[{"name":"UC San Diego"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Geoffrey M.","family":"Voelker","sequence":"additional","affiliation":[{"name":"UC San Diego"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2021,11,2]]},"reference":[{"key":"e_1_3_2_1_1_1","unstructured":"Stored Communications Act. 2018. 18 USC 2713. Required preservation and disclosure of communications and records."},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1145\/1052812.1052822"},{"key":"e_1_3_2_1_3_1","unstructured":"Alexa. 2021. Top 1M sites. https:\/\/toplists.net.in.tum.de\/archive\/alexa\/"},{"key":"e_1_3_2_1_4_1","volume-title":"Comments on DNS Robustness. In 2018 Internet Measurement Conference. ACM","author":"Allman Mark","year":"2018","unstructured":"Mark Allman. 2018. Comments on DNS Robustness. In 2018 Internet Measurement Conference. ACM, Boston, MA."},{"key":"e_1_3_2_1_5_1","volume-title":"ten Oever","author":"Arkko J.","year":"2019","unstructured":"J. Arkko, B. Trammell, M. Nottingham, C. Huitema, M. Thomson, J. Tantsura, and N. ten Oever. 2019. Considerations on Internet Consolidation and the Internet Architecture. https:\/\/tools.ietf.org\/html\/draft-arkko-iab-internet-consolidation-02"},{"key":"e_1_3_2_1_6_1","unstructured":"CAIDA. 2021. Routeviews Prefix to AS mappings Dataset for IPv4 and IPv6. http:\/\/www.caida.org\/data\/routing\/routeviews-prefix2as.xml"},{"key":"e_1_3_2_1_7_1","unstructured":"Censys. 2020. Bulk Data. Censys. https:\/\/censys.io\/data"},{"key":"e_1_3_2_1_8_1","unstructured":"Censys. 2021. Censys Search 2.0 Official Announcement. https:\/\/support.censys.io\/hc\/en-us\/articles\/360060941211-Censys-Search-2-0-Official-Announcement"},{"key":"e_1_3_2_1_9_1","volume-title":"29th {USENIX} Security Symposium ({USENIX} Security 20). 2183--2199.","author":"Chen Jianjun","unstructured":"Jianjun Chen, Vern Paxson, and Jian Jiang. 2020. Composition kills: A case study of email sender authentication. In 29th {USENIX} Security Symposium ({USENIX} Security 20). 2183--2199."},{"key":"e_1_3_2_1_10_1","volume-title":"The Global Internet Report: Consolidation in the Internet Economy","author":"de Leusse Constance Bommelaer","year":"2019","unstructured":"Constance Bommelaer de Leusse and Carl Gahnberg. 2019. The Global Internet Report: Consolidation in the Internet Economy. Internet Society. https:\/\/www.internetsociety.org\/blog\/2019\/02\/is-the-internet-shrinking-the-global-internet-report-consolidation-in-the-internet-economy-explores-this-question\/"},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"publisher","unstructured":"Viktor Dukhovni and Wes Hardaker. 2015. SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS). RFC 7672. 34 pages. 10.17487\/RFC7672","DOI":"10.17487\/RFC7672"},{"key":"e_1_3_2_1_12_1","doi-asserted-by":"publisher","DOI":"10.1145\/2810103.2813703"},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.1145\/2815675.2815695"},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"publisher","DOI":"10.1145\/2810103.2813607"},{"key":"e_1_3_2_1_15_1","unstructured":"Alex Hern. 2020. Google suffers global outage with Gmail YouTube and majority of services affected - The Guardian. https:\/\/www.theguardian.com\/technology\/2020\/dec\/14\/google-suffers-worldwide-outage-with-gmail-youtube-and-other-services-down"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","unstructured":"Paul E. Hoffman. 2002. SMTP Service Extension for Secure SMTP over Transport Layer Security. RFC 3207. 9 pages. 10.17487\/RFC3207","DOI":"10.17487\/RFC3207"},{"key":"e_1_3_2_1_17_1","unstructured":"Cecilia Kang and David McCabe. 2020. Lawmakers United in Their Ire Lash Out at Big Tech's Leaders - The New York Times. The New York Times. https:\/\/www.nytimes.com\/2020\/07\/29\/technology\/big-tech-hearing-apple-amazon-facebook-google.html"},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","unstructured":"Dr. John C. Klensin. 2008. Simple Mail Transfer Protocol. RFC 5321. 10.17487\/RFC5321","DOI":"10.17487\/RFC5321"},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC6409"},{"key":"e_1_3_2_1_20_1","unstructured":"Brian Krebs. 2017. At Least 30 000 U.S. Organizations Newly Hacked Via Holes in Microsoft's Email Software Krebs on Security. https:\/\/krebsonsecurity.com\/2021\/03\/at-least-30000-u-s-organizations-newly-hacked-via-holes-in-microsofts-email-software\/"},{"key":"e_1_3_2_1_21_1","unstructured":"Public Suffix List. 2021. Public Suffix List. https:\/\/publicsuffix.org\/"},{"key":"e_1_3_2_1_22_1","doi-asserted-by":"publisher","DOI":"10.1145\/2976749.2978387"},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"crossref","unstructured":"P. Mockapetris. 1987. Domain Names - Implementation and Specification. RFC 1035. https:\/\/rfc-editor.org\/rfc\/rfc1035.txt","DOI":"10.17487\/rfc1035"},{"key":"e_1_3_2_1_24_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8314"},{"key":"e_1_3_2_1_25_1","doi-asserted-by":"publisher","DOI":"10.1145\/3419394.3423625"},{"key":"e_1_3_2_1_26_1","doi-asserted-by":"publisher","unstructured":"Craig Partridge. 1986. Mail routing and the domain system. RFC 974. 10.17487\/RFC0974","DOI":"10.17487\/RFC0974"},{"key":"e_1_3_2_1_27_1","doi-asserted-by":"publisher","unstructured":"Jonathan B. Postel. 1982. Simple Mail Transfer Protocol. RFC 821. 10.17487\/RFC0821","DOI":"10.17487\/RFC0821"},{"key":"e_1_3_2_1_28_1","unstructured":"Protonmail. 2021. Verify your custom domain and set MX record. https:\/\/protonmail.com\/support\/knowledge-base\/dns-records\/"},{"key":"e_1_3_2_1_29_1","unstructured":"Joshua Avery Reed and JC Reed. 2020. Potential Email Compromise via Dangling DNS MX."},{"key":"e_1_3_2_1_30_1","volume-title":"Weekend Effect: Recommendations for the Use of Top Domain Lists in Security Research. In PAM.","author":"Rweyemamu Walter","year":"2019","unstructured":"Walter Rweyemamu, Tobias Lauinger, Christo Wilson, William K. Robertson, and E. Kirda. 2019. Clustering and the Weekend Effect: Recommendations for the Use of Top Domain Lists in Security Research. In PAM."},{"key":"e_1_3_2_1_31_1","doi-asserted-by":"publisher","DOI":"10.1145\/3278532.3278574"},{"key":"e_1_3_2_1_32_1","volume-title":"Authentication Chains: A Large-scale Analysis of Email Sender Spoofing Attacks. arXiv preprint arXiv:2011.08420","author":"Shen Kaiwen","year":"2020","unstructured":"Kaiwen Shen, Chuhan Wang, Minglei Guo, Xiaofeng Zheng, Chaoyi Lu, Baojun Liu, Yuxuan Zhao, Shuang Hao, Haixin Duan, Qingfeng Pan, et al. 2020. Weak Links in Authentication Chains: A Large-scale Analysis of Email Sender Spoofing Attacks. arXiv preprint arXiv:2011.08420 (2020)."},{"key":"e_1_3_2_1_33_1","doi-asserted-by":"publisher","unstructured":"Rob Siemborski and Alexey Melnikov. 2007. SMTP Service Extension for Authentication. RFC 4954. 10.17487\/RFC4954","DOI":"10.17487\/RFC4954"},{"key":"e_1_3_2_1_34_1","volume-title":"Number of sent and received e-mails per day worldwide from 2017 to","year":"2024","unstructured":"Statistica. 2021. Number of sent and received e-mails per day worldwide from 2017 to 2024. https:\/\/www.statista.com\/statistics\/456500\/daily-number-of-e-mails-worldwide\/"},{"key":"e_1_3_2_1_35_1","unstructured":"Google Support. 2021. Set up MX records for Google Workspace email - Google Workspace Admin Help. https:\/\/support.google.com\/a\/answer\/140034?hl=en"},{"key":"e_1_3_2_1_36_1","unstructured":"Jason Trost. 2020. Mining DNS MX Records for Fun and Profit - Medium. https:\/\/medium.com\/@jason_trost\/mining-dns-mx-records-for-fun-and-profit-7a069da9ee2d"},{"key":"e_1_3_2_1_37_1","doi-asserted-by":"publisher","DOI":"10.1145\/2785956.2789996"},{"key":"e_1_3_2_1_38_1","doi-asserted-by":"publisher","DOI":"10.1109\/JSAC.2016.2558918"},{"key":"e_1_3_2_1_39_1","unstructured":"Wikipedia. 2020. Simple Mail Transfer Protocol. Wikipedia. https:\/\/en.wikipedia.org\/wiki\/Simple_Mail_Transfer_Protocol"},{"key":"e_1_3_2_1_40_1","doi-asserted-by":"publisher","DOI":"10.1145\/3487552.3487853"}],"event":{"name":"IMC '21: ACM Internet Measurement Conference","location":"Virtual Event","acronym":"IMC '21","sponsor":["SIGCOMM ACM Special Interest Group on Data Communication","SIGMETRICS ACM Special Interest Group on Measurement and Evaluation","USENIX Assoc USENIX Assoc"]},"container-title":["Proceedings of the 21st ACM Internet Measurement Conference"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3487552.3487820","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/abs\/10.1145\/3487552.3487820","content-type":"text\/html","content-version":"vor","intended-application":"syndication"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3487552.3487820","content-type":"application\/pdf","content-version":"vor","intended-application":"syndication"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3487552.3487820","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,12,15]],"date-time":"2025-12-15T17:22:24Z","timestamp":1765819344000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3487552.3487820"}},"subtitle":["characterizing mail service provider usage"],"short-title":[],"issued":{"date-parts":[[2021,11,2]]},"references-count":40,"alternative-id":["10.1145\/3487552.3487820","10.1145\/3487552"],"URL":"https:\/\/doi.org\/10.1145\/3487552.3487820","relation":{},"subject":[],"published":{"date-parts":[[2021,11,2]]},"assertion":[{"value":"2021-11-02","order":3,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}