{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,5,8]],"date-time":"2026-05-08T20:39:18Z","timestamp":1778272758776,"version":"3.51.4"},"reference-count":148,"publisher":"Association for Computing Machinery (ACM)","issue":"3","license":[{"start":{"date-parts":[[2022,2,3]],"date-time":"2022-02-03T00:00:00Z","timestamp":1643846400000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":["ACM Comput. Surv."],"published-print":{"date-parts":[[2023,3,31]]},"abstract":"<jats:p>The use of unified communication; video conferencing, audio conferencing, and instant messaging has skyrocketed during the COVID-19 pandemic. However, security and privacy considerations have often been neglected. This article provides a comprehensive survey of security and privacy in Unified Communication (UC). We systematically analyze security and privacy threats and mitigations in a generic UC scenario. Based on this, we analyze security and privacy features of the major UC market leaders, and we draw conclusions on the overall UC landscape. While confidentiality in communication channels is generally well protected through encryption, other privacy properties are mostly lacking on UC platforms.<\/jats:p>","DOI":"10.1145\/3498335","type":"journal-article","created":{"date-parts":[[2022,2,3]],"date-time":"2022-02-03T10:02:04Z","timestamp":1643882524000},"page":"1-36","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":22,"title":["Security and Privacy in Unified Communication"],"prefix":"10.1145","volume":"55","author":[{"given":"Thomas","family":"Reisinger","sequence":"first","affiliation":[{"name":"De Montfort University, Cyber Technology Institute (CTI), Leicester, United Kingdom"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Isabel","family":"Wagner","sequence":"additional","affiliation":[{"name":"De Montfort University, Cyber Technology Institute (CTI), Leicester, United Kingdom"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Eerke Albert","family":"Boiten","sequence":"additional","affiliation":[{"name":"De Montfort University, Cyber Technology Institute (CTI), Leicester, United Kingdom"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2022,2,3]]},"reference":[{"key":"e_1_3_2_2_2","doi-asserted-by":"publisher","DOI":"10.1109\/CCST.2017.8167801"},{"key":"e_1_3_2_3_2","doi-asserted-by":"publisher","DOI":"10.1145\/3442381.3450048"},{"key":"e_1_3_2_4_2","doi-asserted-by":"publisher","DOI":"10.1109\/49.668971"},{"key":"e_1_3_2_5_2","doi-asserted-by":"publisher","DOI":"10.5555\/3489212.3489268"},{"key":"e_1_3_2_6_2","doi-asserted-by":"publisher","DOI":"10.1007\/978-1-4614-1650-0_5"},{"key":"e_1_3_2_7_2","doi-asserted-by":"publisher","DOI":"10.1016\/j.diin.2014.04.003"},{"key":"e_1_3_2_8_2","unstructured":"AN.ON. [n.d.]. AN.ON - anonymity.online. Retrieved from https:\/\/anon.inf.tu-dresden.de\/index_en.html. Accessed: 15-03-2020."},{"key":"e_1_3_2_9_2","doi-asserted-by":"publisher","DOI":"10.5555\/1929820.1929827"},{"key":"e_1_3_2_10_2","article-title":"An analysis of the skype peer-to-peer internet telephony protocol","author":"Baset Salman","year":"2005","unstructured":"Salman Baset and Henning Schulzrinne. 2005. An analysis of the skype peer-to-peer internet telephony protocol. In Proceedings of the IEEE INFOCOM (01 2005). DOI:https:\/\/doi.org\/10.1109\/INFOCOM.2006.312","journal-title":"Proceedings of the IEEE INFOCOM"},{"key":"e_1_3_2_11_2","doi-asserted-by":"publisher","DOI":"10.17487\/RFC3711"},{"key":"e_1_3_2_12_2","unstructured":"Cullen Jennings Henrik Bostr\u00f6m Jan-Ivar Bruaroey Adam Bergkvist Daniel C. Burnett Anant Narayanan Bernard Aboba Taylor Brandstetter. 2017. WebRTC 1.0 Real-time.Communication between browsers. https:\/\/www.w3.org\/TR\/webrtc\/ Accessed: 30-06-2021."},{"key":"e_1_3_2_13_2","unstructured":"Berliner Datenschutz Beauftragte. 2020. Hinweise f\u00fcr berliner verantwortliche zu anbietern vonvideokonferenz-diensten. Retrieved from https:\/\/www.datenschutz-berlin.de\/fileadmin\/user_upload\/pdf\/orientierungshilfen\/2020-BlnBDI-Hinweise_Berliner_Verantwortliche_zu_Anbietern_Videokonferenz-Dienste.pdf. Accessed: 24-09-2020."},{"key":"e_1_3_2_14_2","doi-asserted-by":"publisher","DOI":"10.1007\/11745853_14"},{"key":"e_1_3_2_15_2","first-page":"3","volume-title":"Proceedings of the Workshop Record of SASC","volume":"8","author":"Bernstein Daniel J.","year":"2008","unstructured":"Daniel J. Bernstein. 2008. Chacha, a variant of Salsa20. In Proceedings of the Workshop Record of SASC, Vol. 8. 3\u20135."},{"key":"e_1_3_2_16_2","unstructured":"Tom Berson. 2005. Skype security evaluation. Retrieved from http:\/\/www.anagram.com\/berson\/skyeval.pdf. Accessed: 18-07-2019."},{"key":"e_1_3_2_17_2","doi-asserted-by":"publisher","DOI":"10.1145\/1029179.1029200"},{"key":"e_1_3_2_18_2","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-37282-7_4"},{"key":"e_1_3_2_19_2","unstructured":"Dell Cameron. 2020. Edward snowden tells you what encrypted messaging apps you should use. Retrieved from https:\/\/www.dailydot.com\/layer8\/edward-snowden-signal-encryption-privacy-messaging\/. Accessed: 04-08-2019."},{"key":"e_1_3_2_20_2","unstructured":"Dana Casielles. 2020. Cisco microsoft zoom: Comparing one to another. Retrieved from https:\/\/www.nojitter.com\/team-collaboration-tools-workspaces\/cisco-microsoft-zoom-comparing-one-another?_mc=NL_NJ_EDT_NJ_weekly_20200901cid=NL_NJ_EDT_NJ_weekly_20200901elq_cid=26974084elq_mid=99292. Accessed: 24-09-2020."},{"key":"e_1_3_2_21_2","doi-asserted-by":"publisher","DOI":"10.1002\/sec.1109"},{"key":"e_1_3_2_22_2","doi-asserted-by":"crossref","first-page":"451","DOI":"10.1109\/EuroSP.2017.27","volume-title":"Proceedings of the 2017 IEEE European Symposium on Security and Privacy","author":"Katriel Cohn-Gordon","year":"2017","unstructured":"Cohn-Gordon Katriel, Cremers Cas, Dowling Benjamin, Garratt Luke, and Stebila Douglas. 2017. A formal security analysis of the signal messaging protocol. In Proceedings of the 2017 IEEE European Symposium on Security and Privacy. 451\u2013466. DOI:https:\/\/doi.org\/10.1109\/EuroSP.2017.27"},{"key":"e_1_3_2_23_2","article-title":"The whatsapp architecture facebook bought for 19 billion USD","author":"Constine Josh","year":"2014","unstructured":"Josh Constine. 2014. The whatsapp architecture facebook bought for 19 billion USD. High Scalability. Retrieved from http:\/\/highscalability.com\/blog\/2014\/2\/26\/the-whatsapp-architecture-facebook-bought-for-19-billion.html. Accessed: 11-05-2019.","journal-title":"High Scalability"},{"key":"e_1_3_2_24_2","doi-asserted-by":"publisher","DOI":"10.5555\/1576303.1576305"},{"key":"e_1_3_2_25_2","doi-asserted-by":"publisher","DOI":"10.1007\/s00766-010-0115-7"},{"key":"e_1_3_2_26_2","first-page":"168","article-title":"Internet Calendaring and Scheduling Core Object Specification (iCalendar)","author":"Desruisseaux B.","year":"2009","unstructured":"B. Desruisseaux. 2009. Internet Calendaring and Scheduling Core Object Specification (iCalendar). RFC 5545 (Proposed Standard). 168 pages. DOI:https:\/\/doi.org\/10.17487\/RFC5545Updated by RFCs 5546, 6868, 7529, 7953, 7986.","journal-title":"RFC 5545 (Proposed Standard)"},{"key":"e_1_3_2_27_2","doi-asserted-by":"publisher","DOI":"10.1007\/11787006_1"},{"key":"e_1_3_2_28_2","unstructured":"European Commission. 2017. Commission fines facebook 110 million euro for providing misleading information about whatsapp takeover. (2017). Retrieved from http:\/\/europa.eu\/rapid\/press-release_IP-17-1369_en.htm. Accessed: 19-06-2019."},{"key":"e_1_3_2_29_2","unstructured":"European Data Protection Supervisor (EDPS). 2020. Outcome of own-initiative investigation into EU institutions\u2019 use of microsoft products and services. Retrieved from https:\/\/edps.europa.eu\/sites\/edp\/files\/publication\/20-07-02_edps_euis_microsoft_contract_investigation_en.html. Accessed: 24-09-2020."},{"key":"e_1_3_2_30_2","unstructured":"European Union. 2016. General data protection regulation. Retrieved from https:\/\/eur-lex.europa.eu\/eli\/reg\/2016\/679\/oj. Accessed: 26-04-2020."},{"key":"e_1_3_2_31_2","doi-asserted-by":"publisher","DOI":"10.3390\/fi12050092"},{"key":"e_1_3_2_32_2","unstructured":"David Fifield. 2017. Threat modeling and circumvention of internet censorship. Ph.D. Dissertation. EECS Department University of California Berkeley."},{"key":"e_1_3_2_33_2","unstructured":"David Fifield and Mia Gil Epner. 2016. Fingerprintability of WebRTC. arxiv:1605.08805. Retrieved from https:\/\/arxiv.org\/abs\/1605.08805."},{"key":"e_1_3_2_34_2","first-page":"37","article-title":"Framework for Establishing a Secure Real-time Transport Protocol (SRTP) Security Context Using Datagram Transport Layer Security (DTLS)","author":"Fischl J.","year":"2010","unstructured":"J. Fischl, H. Tschofenig, and E. Rescorla. 2010. Framework for Establishing a Secure Real-time Transport Protocol (SRTP) Security Context Using Datagram Transport Layer Security (DTLS). RFC 5763 (Proposed Standard). 37 pages. DOI:https:\/\/doi.org\/10.17487\/RFC5763","journal-title":"RFC 5763 (Proposed Standard)"},{"key":"e_1_3_2_35_2","doi-asserted-by":"publisher","DOI":"10.1109\/EuroSP.2016.41"},{"key":"e_1_3_2_36_2","unstructured":"Oded Gal. 2020. The facts around zoom and encryption for Meetings\/Webinars. Retrieved from https:\/\/blog.zoom.us\/wordpress\/2020\/04\/01\/facts-around-zoom-encryption-for-meetings-webinars\/. Accessed: 11-05-2020."},{"key":"e_1_3_2_37_2","unstructured":"Gartner I. T. Glossary. [n.d.]. Unified Communications (UC). Retrieved from https:\/\/www.gartner.com\/it-glossary\/unified-communications-uc. Accessed: 30-10-2018."},{"key":"e_1_3_2_38_2","unstructured":"Google. [n.d.]. Google meet audit log. Retrieved from https:\/\/support.google.com\/a\/answer\/9186729?hl=en. Accessed: 15-06-2021."},{"key":"e_1_3_2_39_2","unstructured":"Google. [n.d.]. Prepare your network for meet video calls. Retrieved from https:\/\/support.google.com\/a\/answer\/1279090. Accessed: 14-06-2021."},{"key":"e_1_3_2_40_2","unstructured":"Google. [n.d.]. Real-time communication for the web. Retrieved from https:\/\/webrtc.org\/. Accessed: 29-12-2020."},{"key":"e_1_3_2_41_2","unstructured":"Google. 2017. encryption in transit in google cloud. Retrieved from https:\/\/cloud.google.com\/security\/encryption-in-transit. Accessed: 14-06-2021."},{"key":"e_1_3_2_42_2","unstructured":"Google. 2019. Google security whitepaper. Retrieved from https:\/\/cloud.google.com\/security\/overview\/whitepaper. Accessed: 13-06-2021."},{"key":"e_1_3_2_43_2","unstructured":"Google. 2021. Google meet security and privacy for admins. Retrieved from https:\/\/support.google.com\/a\/answer\/7582940?hl=en&ref_topic=7302923. Accessed: 14-06-2021."},{"key":"e_1_3_2_44_2","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2327"},{"key":"e_1_3_2_45_2","doi-asserted-by":"publisher","DOI":"10.1016\/S1363-4127(04)00014-7"},{"key":"e_1_3_2_46_2","doi-asserted-by":"publisher","DOI":"10.5555\/3277203.3277243"},{"key":"e_1_3_2_47_2","unstructured":"Bill Haskins. 2018. 2018 Worldwide unified communications forecast. Retrieved from https:\/\/insight.wainhouse.com\/reportaction\/UC-FCST18-UCaaS-WW\/Marketing. Accessed: 01-11-2018."},{"key":"e_1_3_2_48_2","doi-asserted-by":"publisher","DOI":"10.5555\/1202957"},{"key":"e_1_3_2_49_2","unstructured":"David Huerta. 2013. [tor-talk] WebRTC via tor. Retrieved from https:\/\/www.mail-archive.com\/tor-talk@lists.torproject.org\/msg08733.html. Accessed: 12-08-2021."},{"key":"e_1_3_2_50_2","unstructured":"Hyperledger FABRIC. [n.d.]. MSP implementation with identity mixer. Retrieved from https:\/\/hyperledger-fabric.readthedocs.io\/en\/release-1.4\/idemix.html. Accessed: 12-03-2020."},{"key":"e_1_3_2_51_2","unstructured":"Ian Goldberg David Goulet and Jurre van Bergen. [n. d.]. Off-the-Record Messaging. https:\/\/otr.cypherpunks.ca\/ Accessed: 13-05-2019."},{"key":"e_1_3_2_52_2","unstructured":"Emil Ivov. 2020. This is what end-to-end encryption should look like. Retrieved from https:\/\/jitsi.org\/e2ee. Accessed: 27-04-2020."},{"key":"e_1_3_2_53_2","unstructured":"jitsi.org. [n.d.]. Jitsi meet security and privacy. Retrieved from https:\/\/jitsi.org\/security\/. Accessed: 27-04-2020."},{"key":"e_1_3_2_54_2","article-title":"Information about jitsi","author":"Community jitsi.org","year":"2018","unstructured":"jitsi.org Community. 2018. Information about jitsi. Jitsi Community Forum. Retrieved from https:\/\/community.jitsi.org\/t\/information-about-jitsi\/15426\/3. Accessed: 02-10-2019.","journal-title":"Jitsi Community Forum"},{"key":"e_1_3_2_55_2","unstructured":"Scott Johnston. 2017. Meet the new hangouts. Retrieved from https:\/\/www.blog.google\/products\/g-suite\/meet-the-new-enterprise-focused-hangouts\/. Accessed: 16-06-2021."},{"key":"e_1_3_2_56_2","unstructured":"Smita Hashim Karthik Lakshminarayanan. 2020. Secure connections: How google meet keeps your video conferences protected. Retrieved from https:\/\/cloud.google.com\/blog\/products\/g-suite\/how-google-meet-keeps-video-conferences-secure. Accessed: 13-06-2021."},{"key":"e_1_3_2_57_2","doi-asserted-by":"publisher","DOI":"10.5555\/548089"},{"key":"e_1_3_2_58_2","article-title":"What zoom\u2019s privacy policy changes mean for you","author":"Kelly Girard","year":"2020","unstructured":"Girard Kelly. 2020. What zoom\u2019s privacy policy changes mean for you. Common Sense. Retrieved from https:\/\/www.commonsense.org\/education\/articles\/what-zooms-privacy-policy-changes-mean-for-you. Accessed: 13-12-2020.","journal-title":"Common Sense"},{"key":"e_1_3_2_59_2","volume-title":"Systems Analysis and Design","author":"Kendall Kenneth E. Kendall, Julie E.","year":"2019","unstructured":"Kenneth E. Kendall, Julie E. Kendall. 2019. Systems Analysis and Design. Pearson Education Limited."},{"key":"e_1_3_2_60_2","unstructured":"Swati Khandelwal. 2020. Zoom bug could have let uninvited people join private meetings. Retrieved from https:\/\/thehackernews.com\/2020\/01\/zoom-meeting-password.html. Accessed: 11-05-2020."},{"key":"e_1_3_2_61_2","doi-asserted-by":"publisher","DOI":"10.5555\/646761.706156"},{"key":"e_1_3_2_62_2","doi-asserted-by":"publisher","DOI":"10.1109\/ISCAS.2006.1693105"},{"key":"e_1_3_2_63_2","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2104"},{"key":"e_1_3_2_64_2","first-page":"14","article-title":"HMAC-based Extract-and-Expand Key Derivation Function (HKDF)","author":"Krawczyk H.","year":"2010","unstructured":"H. Krawczyk and P. Eronen. 2010. HMAC-based Extract-and-Expand Key Derivation Function (HKDF). RFC 5869 (Informational). 14 pages. DOI:https:\/\/doi.org\/10.17487\/RFC5869","journal-title":"RFC 5869 (Informational)"},{"key":"e_1_3_2_65_2","unstructured":"Ujjwal Kumar. 2016. Skype has over 300 million monthly active users microsoft announces at build 2016. Retrieved from https:\/\/windowsreport.com\/skype-number-of-users\/. Accessed: 22-05-2019."},{"key":"e_1_3_2_66_2","unstructured":"Ravie Lakshmanan. 2019. Zoom security flaw could let websites turn on your mac\u2019s webcam without permission. Retrieved from https:\/\/thenextweb.com\/security\/2019\/07\/09\/zoom-security-flaw-could-let-websites-turn-on-your-macs-webcam-without-permission\/. Accessed: 11-05-2020."},{"key":"e_1_3_2_67_2","doi-asserted-by":"publisher","DOI":"10.1007\/s00779-004-0304-9"},{"key":"e_1_3_2_68_2","unstructured":"Dave Lee. 2011. Profile: How skype connected. Retrieved from https:\/\/www.bbc.com\/news\/technology-13350425Accessed: 21-05-2019."},{"key":"e_1_3_2_69_2","article-title":"Battle of the secure messaging apps: How ginal beats whatsapp","author":"Lee Micah","year":"2016","unstructured":"Micah Lee. 2016. Battle of the secure messaging apps: How ginal beats whatsapp. The Intercept. Retrieved from https:\/\/theintercept.com\/2016\/06\/22\/battle-of-the-secure-messaging-apps-how-signal-beats-whatsapp\/. Accessed: 04-08-2019.","journal-title":"The Intercept"},{"key":"e_1_3_2_70_2","doi-asserted-by":"publisher","DOI":"10.1145\/3178876.3186087"},{"key":"e_1_3_2_71_2","unstructured":"Lorrie Cranor Marc Langheinrich Massimo Marchiori Martin Presler-Marshall and Joseph Reagle. 2002. The platform for privacy preferences. Retrieved from https:\/\/www.w3.org\/TR\/P3P\/. Accessed: 22-03-2020."},{"key":"e_1_3_2_72_2","first-page":"67","article-title":"Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)","author":"Mahy R.","year":"2010","unstructured":"R. Mahy, P. Matthews, and J. Rosenberg. 2010. Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN). RFC 5766 (Proposed Standard). 67 pages. DOI:https:\/\/doi.org\/10.17487\/RFC5766Updated by RFCs 8155, 8553.","journal-title":"RFC 5766 (Proposed Standard)"},{"key":"e_1_3_2_73_2","unstructured":"Bill Marczak and John Scott-Railton. 2020. Move fast and roll your own crypto. Retrieved from https:\/\/citizenlab.ca\/2020\/04\/move-fast-roll-your-own-crypto-a-quick-look-at-the-confidentiality-of-zoom-meetings\/. Accessed: 11-05-2020."},{"key":"e_1_3_2_74_2","unstructured":"Moxie Marlinspike. 2013. Advanced cryptographic ratcheting. Retrieved from https:\/\/signal.org\/blog\/advanced-ratcheting\/. Accessed: 19-05-2020."},{"key":"e_1_3_2_75_2","unstructured":"Moxie Marlinspike. 2013. Simplifying OTR deniability. Retrieved from https:\/\/signal.org\/blog\/simplifying-otr-deniability\/. Accessed: 19-05-2020."},{"key":"e_1_3_2_76_2","article-title":"Free, worldwide, encrypted phone calls for iphone","author":"Marlinspike Moxie","year":"2014","unstructured":"Moxie Marlinspike. 2014. Free, worldwide, encrypted phone calls for iphone. Signal.org. Retrieved from https:\/\/signal.org\/blog\/signal\/. Accessed: 04-08-2019.","journal-title":"Signal.org"},{"key":"e_1_3_2_77_2","unstructured":"Moxie Marlinspike. 2018. A letter from amazon. Retrieved from https:\/\/signal.org\/blog\/looking-back-on-the-front\/. Accessed: 04-08-2019."},{"key":"e_1_3_2_78_2","first-page":"26","article-title":"Datagram Transport Layer Security (DTLS) Extension to Establish Keys for the Secure Real-time Transport Protocol (SRTP)","author":"McGrew D.","year":"2010","unstructured":"D. McGrew and E. Rescorla. 2010. Datagram Transport Layer Security (DTLS) Extension to Establish Keys for the Secure Real-time Transport Protocol (SRTP). RFC 5764 (Proposed Standard). 26 pages. DOI:https:\/\/doi.org\/10.17487\/RFC5764Updated by RFC 7983.","journal-title":"RFC 5764 (Proposed Standard)"},{"key":"e_1_3_2_79_2","unstructured":"Yael Grauer Micah Lee. 2020. Zoom meetings aren\u2019t end-to-end encrypted despite misleading markteing. Retrieved from https:\/\/theintercept.com\/2020\/03\/31\/zoom-meeting-encryption\/. Accessed: 11-05-2020."},{"key":"e_1_3_2_80_2","doi-asserted-by":"publisher","DOI":"10.5555\/646767.704301"},{"key":"e_1_3_2_81_2","unstructured":"National Cyber Security Center. 2020. Video conferencing services: Security guidance for organisations. Retrieved from https:\/\/www.ncsc.gov.uk\/guidance\/video-conferencing-services-security-guidance-organisations. Accessed: 23-04-2020."},{"key":"e_1_3_2_82_2","unstructured":"National Cyber Security Centre. 2020. Video conferencing services: Using them securely. Retrieved from https:\/\/www.ncsc.gov.uk\/guidance\/video-conferencing-services-using-them-securely. Accessed: 23-04-2020."},{"key":"e_1_3_2_83_2","unstructured":"NSA. 2012. Users guide for PRISM skype collection. Retrieved from https:\/\/edwardsnowden.com\/2015\/01\/05\/users-guide-for-prism-skype-collection\/. Accessed: 22-05-2019."},{"key":"e_1_3_2_84_2","doi-asserted-by":"publisher","DOI":"10.1007\/978-1-84882-477-5_8"},{"key":"e_1_3_2_85_2","unstructured":"Colin Percival. 2009. Stronger key derivation via sequential memory-hard functions. Retrieved from http:\/\/www.bsdcan.org\/2009\/schedule\/attachments\/87_scrypt.pdf. Accessed: 19-05-2020."},{"key":"e_1_3_2_86_2","first-page":"16","article-title":"the scrypt password-based key derivation function","author":"Percival C.","year":"2016","unstructured":"C. Percival and S. Josefsson. 2016. the scrypt password-based key derivation function. RFC 7914 (Informational). 16 pages. DOI:https:\/\/doi.org\/10.17487\/RFC7914","journal-title":"RFC 7914 (Informational)"},{"key":"e_1_3_2_87_2","unstructured":"Trevor Perrin (editor) and Moxie Marlinspike. 2016. The double ratchet algorithm. Retrieved from https:\/\/signal.org\/docs\/specifications\/doubleratchet\/. Accessed: 19-05-2020."},{"key":"e_1_3_2_88_2","unstructured":"Jay Peters. 2020. Zoom will let paying customers pick which data center their calls are routed from. Retrieved from https:\/\/www.theverge.com\/2020\/4\/13\/21219835\/zoom-data-center-call-routing-china-security-privacy-encryption. Accessed: 11-05-2020."},{"key":"e_1_3_2_89_2","unstructured":"Andreas Pfitzmann and Marit Hansen. 2010. A terminology for talking about privacy by data minimization: Anonymity unlinkability undetectability unobservability pseudonymity and identity management. Retrieved from https:\/\/dud.inf.tu-dresden.de\/literatur\/Anon_Terminology_v0.34.pdf. Accessed: 30-06-2021."},{"key":"e_1_3_2_90_2","unstructured":"Philippe Biondi Fabrice Desclaux. 2006. silver needle in the skype. Retrieved from http:\/\/www.oklabs.net\/wp-content\/uploads\/2012\/06\/bh-eu-06-Biondi.pdf. Accessed: 23-07-2019."},{"key":"e_1_3_2_91_2","unstructured":"Blair Pleasant. [n.d.]. UC cutting through the hype - what UC is and isn\u2019t. Retrieved from http:\/\/viewer.media.bitpipe.com\/1206484657_637\/1206511483_362\/SearchUC-v5.pdf. Accessed: 04-11-2018."},{"key":"e_1_3_2_92_2","unstructured":"Nidhi Rastogi and James Hendler. 2017. Whatsapp security and role of metadata in preserving privacy. In 12th International Conference on Cyber Warfare and Security . Academic Conferences and publishing limited 269\u2013275."},{"key":"e_1_3_2_93_2","unstructured":"Thomas Reisinger. 2020. Zoom security: I\u2019ve researched problems with video conferencing for years \u2013 here\u2019s what you need to know. Retrieved from https:\/\/theconversation.com\/zoom-security-ive-researched-problems-with-video-conferencing-for-years-heres-what-you-need-to-know-136330. Accessed: 25-07-2021."},{"key":"e_1_3_2_94_2","first-page":"160","article-title":"The Transport Layer Security (TLS) Protocol Version 1.3","author":"Rescorla E.","year":"2018","unstructured":"E. Rescorla. 2018. The Transport Layer Security (TLS) Protocol Version 1.3. RFC 8446 (Proposed Standard). 160 pages. DOI:https:\/\/doi.org\/10.17487\/RFC8446","journal-title":"RFC 8446 (Proposed Standard)"},{"key":"e_1_3_2_95_2","article-title":"security considerations for WebRTC","author":"Rescorla E.","year":"2019","unstructured":"E. Rescorla. 2019. security considerations for WebRTC. IETF. Retrieved from https:\/\/tools.ietf.org\/html\/draft-ietf-rtcweb-security-12. Accessed: 29-12-2020.","journal-title":"IETF"},{"key":"e_1_3_2_96_2","unstructured":"Eric Rescorla. 2019. WebRTC security architecture. Retrieved from https:\/\/tools.ietf.org\/html\/draft-ietf-rtcweb-security-arch-20. Accessed: 28-04-2020."},{"key":"e_1_3_2_97_2","doi-asserted-by":"publisher","DOI":"10.17487\/RFC3552"},{"key":"e_1_3_2_98_2","first-page":"25","article-title":"Datagram transport layer security","author":"Rescorla E.","year":"2006","unstructured":"E. Rescorla and N. Modadugu. 2006. Datagram transport layer security. RFC 4347 (Proposed Standard). 25 pages. https:\/\/doi.org\/10.17487\/RFC4347Obsoleted by RFC 6347, updated by RFCs 5746, 7507.","journal-title":"RFC 4347 (Proposed Standard)"},{"key":"e_1_3_2_99_2","doi-asserted-by":"publisher","DOI":"10.1145\/2046556.2046564"},{"key":"e_1_3_2_100_2","unstructured":"Colleen Rodriguez. 2020. Zoom hits milestone on 90-Day security plan releases zoom 5.0. Retrieved from https:\/\/blog.zoom.us\/wordpress\/2020\/04\/22\/zoom-hits-milestone-on-90-day-security-plan-releases-zoom-5-0\/. Accessed: 29-04-2020."},{"key":"e_1_3_2_101_2","doi-asserted-by":"publisher","DOI":"10.5555\/1942870"},{"key":"e_1_3_2_102_2","first-page":"117","article-title":"Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer\/Answer Protocols","author":"Rosenberg J.","year":"2010","unstructured":"J. Rosenberg. 2010. Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer\/Answer Protocols. RFC 5245 (Proposed Standard). 117 pages. DOI:https:\/\/doi.org\/10.17487\/RFC5245Updated by RFC 6336.","journal-title":"RFC 5245 (Proposed Standard)"},{"key":"e_1_3_2_103_2","first-page":"51","article-title":"Session Traversal Utilities for NAT (STUN)","author":"Rosenberg J.","year":"2008","unstructured":"J. Rosenberg, R. Mahy, P. Matthews, and D. Wing. 2008. Session Traversal Utilities for NAT (STUN). RFC 5389 (Proposed Standard). 51 pages. DOI:https:\/\/doi.org\/10.17487\/RFC5389Updated by RFCs 7350, 8553.","journal-title":"RFC 5389 (Proposed Standard)"},{"key":"e_1_3_2_104_2","doi-asserted-by":"publisher","DOI":"10.1109\/69.971193"},{"key":"e_1_3_2_105_2","unstructured":"Bruce Schneier. 2016. Comparing messaging apps. Retrieved from https:\/\/www.schneier.com\/blog\/archives\/2016\/06\/comparing_messa.html. Accessed: 04-08-2019."},{"key":"e_1_3_2_106_2","doi-asserted-by":"publisher","DOI":"10.5555\/2829295"},{"key":"e_1_3_2_107_2","unstructured":"Signal.org. [n.d.]. Signal github repository. Retrieved from https:\/\/github.com\/signalapp. Accessed: 03-08-2021."},{"key":"e_1_3_2_108_2","unstructured":"Signal.org. [n.d.]. Signal support - features. Retrieved from https:\/\/support.signal.org\/hc\/en-us. Accessed: 04-08-2019."},{"key":"e_1_3_2_109_2","unstructured":"Signal.org. [n.d.]. Signal Terms & Privacy Policy. Retrieved from https:\/\/signal.org\/legal\/. Accessed: 04-08-2019."},{"key":"e_1_3_2_110_2","unstructured":"Varun Singh. 2018. Explaining the WebRTC Secure Real-Time Transport Protocol (SRTP). Retrieved from https:\/\/www.callstats.io\/blog\/2018\/05\/16\/explaining-webrtc-secure-real-time-transport-protocol-srtp. Accessed: 11-07-2020."},{"key":"e_1_3_2_111_2","unstructured":"Skype Communications SARL. [n.d.]. What is skype? Retrieved from https:\/\/www.skype.com\/en\/about\/. Accessed: 21-05-2019."},{"key":"e_1_3_2_112_2","unstructured":"Skype Limited. 2010. Skype IT administrators guide - skype for windows version 4.2. Retrieved from https:\/\/download.skype.com\/share\/business\/guides\/skype-it-administrators-guide.pdf. Accessed: 07-07-2019."},{"key":"e_1_3_2_113_2","unstructured":"Javier Soltero. 2020. Google meet premium video meetings\u2013free for everyone. Retrieved from https:\/\/blog.google\/products\/meet\/bringing-google-meet-to-more-people. Accessed: 13-06-2021."},{"key":"e_1_3_2_114_2","unstructured":"Stackexchange. [n.d.]. Does tor work with WebRTC? Retrieved from https:\/\/tor.stackexchange.com\/questions\/876\/does-tor-work-with-webrtc. Accessed: 10-08-2021."},{"key":"e_1_3_2_115_2","unstructured":"Statista Research Department. 2021. Whatsapp - statistics and facts. Retrieved from https:\/\/www.statista.com\/topics\/2018\/whatsapp\/#dossierKeyfigures. Accessed: 2021-11-09."},{"key":"e_1_3_2_116_2","doi-asserted-by":"publisher","DOI":"10.5555\/1855366"},{"key":"e_1_3_2_117_2","doi-asserted-by":"publisher","DOI":"10.1002\/sec.1183"},{"key":"e_1_3_2_118_2","unstructured":"Editorial Team. 2016. End-to-end whatsapp: An opinionated series on why signal protocol is well-designed. Retrieved from https:\/\/www.praetorian.com\/blog\/whatsapp-end-to-end-encryption-why-signal-protocol-is-well-designed\/. Accessed: 01-07-2021."},{"key":"e_1_3_2_119_2","unstructured":"TeleGeography. 2014. Skype traffic continues to thrive. Retrieved from https:\/\/www.telegeography.com\/products\/commsupdate\/articles\/2014\/01\/15\/skype-traffic-continues-to-thrive\/. Accessed: 22-05-2019."},{"key":"e_1_3_2_120_2","unstructured":"The Linux Foundation. [n.d.]. Hyperledger indy. Retrieved from https:\/\/www.hyperledger.org\/projects\/hyperledger-indy. Accessed: 24-03-2020."},{"key":"e_1_3_2_121_2","unstructured":"Tor Project. [n.d.]. Tor project. Retrieved from https:\/\/www.torproject.org\/. Accessed: 15-03-2020."},{"key":"e_1_3_2_122_2","unstructured":"Torproject. 2017. UDP over tor. Retrieved from https:\/\/gitlab.torproject.org\/legacy\/trac\/-\/issues\/7830. Accessed: 10-08-2021."},{"key":"e_1_3_2_123_2","unstructured":"Zeynep Tufekci. [n.d.]. In response to guardian\u2019s irresponsible reporting on whatsapp: A plea for responsible and contextualized reporting on user security. Retrieved from http:\/\/technosociology.org\/?page_id=1687. Accessed: 15-09-2019."},{"key":"e_1_3_2_124_2","article-title":"Best video conferencing software in 2020","author":"Turner Nate Drake; Brian","year":"2020","unstructured":"Nate Drake; Brian Turner. 2020. Best video conferencing software in 2020. Techradar. Retrieved from https:\/\/www.techradar.com\/best\/best-video-conferencing-software. Accessed: 26-09-2020.","journal-title":"Techradar"},{"key":"e_1_3_2_125_2","article-title":"WebRTC IP address handling requirements","author":"Uberti J.","year":"2019","unstructured":"J. Uberti. 2019. WebRTC IP address handling requirements. IETF. Retrieved from https:\/\/tools.ietf.org\/html\/draft-ietf-rtcweb-ip-handling-12. Accessed: 29-12-2020.","journal-title":"IETF"},{"key":"e_1_3_2_126_2","unstructured":"University of Waterloo department Cryptography Security and Privacy (CrySP). 2018. Wire. Retrieved from https:\/\/crysp.uwaterloo.ca\/opinion\/wire\/. Accessed: 04-08-2020."},{"key":"e_1_3_2_127_2","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-030-31500-9_5"},{"key":"e_1_3_2_128_2","article-title":"Zoom took over the world. This is what will happen next","author":"Turk Vicki","year":"2020","unstructured":"Vicki Turk. 2020. Zoom took over the world. This is what will happen next. Wired. Retrieved from https:\/\/www.wired.co.uk\/article\/future-of-zoom. Accessed: 20-10-2020.","journal-title":"Wired"},{"key":"e_1_3_2_129_2","doi-asserted-by":"publisher","DOI":"10.1017\/9781108946940"},{"key":"e_1_3_2_130_2","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-030-00305-0_17"},{"key":"e_1_3_2_131_2","doi-asserted-by":"publisher","DOI":"10.5555\/1337689.1338249"},{"key":"e_1_3_2_132_2","unstructured":"WhatsApp. 2017. Whatsapp encryption overview. Retrieved from https:\/\/www.whatsapp.com\/security\/WhatsApp-Security-Whitepaper.pdf. Accessed: 07-05-2019."},{"key":"e_1_3_2_133_2","unstructured":"WhatsApp. 2021. Whatsapp privacy policy. Retrieved from https:\/\/www.whatsapp.com\/legal\/updates\/privacy-policy\/?lang=en. Accessed: 11-01-2021."},{"key":"e_1_3_2_134_2","unstructured":"WhatsApp FAQ. [n.d.]. How we work with the facebook companies. Retrieved from https:\/\/faq.whatsapp.com\/general\/26000112\/?eea=1. Accessed: 15-09-2019."},{"key":"e_1_3_2_135_2","unstructured":"Whonix.org. [n.d.]. whonix.org. Retrieved from https:\/\/www.whonix.org\/. Accessed: 12-08-2021."},{"key":"e_1_3_2_136_2","unstructured":"Wire Swiss GmbH. [n.d.]. About wire. Retrieved from https:\/\/wire.com\/en\/about\/. Accessed: 23-07-2020."},{"key":"e_1_3_2_137_2","unstructured":"Wire Swiss GmbH. [n.d.]. Proteus. Retrieved from https:\/\/github.com\/wireapp\/proteus. Accessed: 13-06-2020."},{"key":"e_1_3_2_138_2","unstructured":"Wire Swiss GmbH. [n.d.]. Wire audits. Retrieved from https:\/\/wire.com\/en\/security\/#audits. Accessed: 23-07-2020."},{"key":"e_1_3_2_139_2","unstructured":"Wire Swiss GmbH. 2018. Wire privacy whitepaper. Retrieved from https:\/\/wire-docs.wire.com\/download\/WirePrivacyWhitepaper.pdf. Accessed: 19-05-2020."},{"key":"e_1_3_2_140_2","unstructured":"Wire Swiss GmbH. 2018. Wire security whitepaper. Retrieved from https:\/\/wire-docs.wire.com\/download\/WireSecurityWhitepaper.pdf. Accessed: 19-05-2020."},{"key":"e_1_3_2_141_2","article-title":"phone porting: How hackers can hijack your mobile phone number","author":"Wood Gabriel","year":"2018","unstructured":"Gabriel Wood. 2018. phone porting: How hackers can hijack your mobile phone number. NextAdvisor. Retrieved from https:\/\/www.nextadvisor.com\/phone-porting-how-hackers-can-hijack-your-mobile-phone-number\/. Accessed: 03-11-2019.","journal-title":"NextAdvisor"},{"key":"e_1_3_2_142_2","unstructured":"Eric Yuan. 2020. A message to our users. Retrieved from https:\/\/blog.zoom.us\/wordpress\/2020\/04\/01\/a-message-to-our-users\/. Accessed: 11-05-2020."},{"key":"e_1_3_2_143_2","unstructured":"Eric Yuan. 2020. Zoom\u2019s use of facebook\u2019s SDK in iOS client. Retrieved from https:\/\/blog.zoom.us\/wordpress\/2020\/03\/27\/zoom-use-of-facebook-sdk-in-ios-client\/. Accessed: 11-05-2020."},{"key":"e_1_3_2_144_2","unstructured":"Ali Zafar. 2018. Countries where whatsapp is banned. Retrieved from https:\/\/www.privacyend.com\/countries-where-whatsapp-banned\/. Accessed: 21-05-2019."},{"key":"e_1_3_2_145_2","unstructured":"Zoom. 2020. 90-Day security plan: Key updates. Retrieved from https:\/\/blog.zoom.us\/wp-content\/uploads\/2020\/07\/Security-90-day-Plan-Key-Updates.pdf. Accessed: 13-12-2020."},{"key":"e_1_3_2_146_2","unstructured":"Zoom. 2020. Privacy policy. Retrieved from https:\/\/zoom.us\/privacyAccessed: 11-05-2020."},{"key":"e_1_3_2_147_2","unstructured":"Zoom. 2020. Security guide. Retrieved from https:\/\/zoom.us\/docs\/doc\/Zoom-Security-White-Paper.pdf. Accessed: 15-07-2020."},{"key":"e_1_3_2_148_2","unstructured":"Zoom. 2020. Zoom encryption. Retrieved from https:\/\/zoom.us\/docs\/doc\/ZoomEncryptionWhitepaper.pdf. Accessed: 11-05-2020."},{"key":"e_1_3_2_149_2","unstructured":"Zoom. 2021. government requests guide. Retrieved from https:\/\/zoom.us\/docs\/en-us\/government-requests-guide.html. Accessed: 18-08-2021."}],"container-title":["ACM Computing Surveys"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3498335","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3498335","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,17]],"date-time":"2025-06-17T19:30:05Z","timestamp":1750188605000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3498335"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2022,2,3]]},"references-count":148,"journal-issue":{"issue":"3","published-print":{"date-parts":[[2023,3,31]]}},"alternative-id":["10.1145\/3498335"],"URL":"https:\/\/doi.org\/10.1145\/3498335","relation":{},"ISSN":["0360-0300","1557-7341"],"issn-type":[{"value":"0360-0300","type":"print"},{"value":"1557-7341","type":"electronic"}],"subject":[],"published":{"date-parts":[[2022,2,3]]},"assertion":[{"value":"2021-02-01","order":0,"name":"received","label":"Received","group":{"name":"publication_history","label":"Publication History"}},{"value":"2021-11-01","order":1,"name":"accepted","label":"Accepted","group":{"name":"publication_history","label":"Publication History"}},{"value":"2022-02-03","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}