{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,7,2]],"date-time":"2026-07-02T13:30:31Z","timestamp":1782999031367,"version":"3.54.5"},"publisher-location":"New York, NY, USA","reference-count":39,"publisher":"ACM","license":[{"start":{"date-parts":[[2022,6,23]],"date-time":"2022-06-23T00:00:00Z","timestamp":1655942400000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by-nc-nd\/4.0\/"}],"funder":[{"DOI":"10.13039\/501100006360","name":"Bundesministerium f\u00fcr Wirtschaft und Energie","doi-asserted-by":"publisher","award":["1501589A"],"award-info":[{"award-number":["1501589A"]}],"id":[{"id":"10.13039\/501100006360","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2022,6,23]]},"DOI":"10.1145\/3531536.3532947","type":"proceedings-article","created":{"date-parts":[[2022,6,23]],"date-time":"2022-06-23T22:18:44Z","timestamp":1656022724000},"page":"69-79","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":6,"title":["Covert Channels in Network Time Security"],"prefix":"10.1145","author":[{"given":"Kevin","family":"Lamsh\u00f6ft","sequence":"first","affiliation":[{"name":"Otto-von-Guericke University Magdeburg, Magdeburg, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Jana","family":"Dittmann","sequence":"additional","affiliation":[{"name":"Otto-von-Guericke University Magdeburg, Magdeburg, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2022,6,23]]},"reference":[{"key":"e_1_3_2_1_1_1","first-page":"53","article-title":"Testing randomness in ciphertext of block-ciphers using DieHard tests","volume":"10","author":"Alani Mohammed M","year":"2010","unstructured":"Mohammed M Alani . 2010 . Testing randomness in ciphertext of block-ciphers using DieHard tests . Int. J. Comput. Sci. Netw. Secur , Vol. 10 , 4 (2010), 53 -- 57 . Mohammed M Alani. 2010. Testing randomness in ciphertext of block-ciphers using DieHard tests. Int. J. Comput. Sci. Netw. Secur, Vol. 10, 4 (2010), 53--57.","journal-title":"Int. J. Comput. Sci. Netw. Secur"},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1145\/3058060.3058082"},{"key":"e_1_3_2_1_3_1","volume-title":"NC","author":"Brown Robert G","year":"2018","unstructured":"Robert G Brown , Dirk Eddelbuettel , and David Bauer . 2018. Dieharder. Duke University Physics Department Durham , NC ( 2018 ), 27708--0305. Robert G Brown, Dirk Eddelbuettel, and David Bauer. 2018. Dieharder. Duke University Physics Department Durham, NC (2018), 27708--0305."},{"key":"e_1_3_2_1_4_1","volume-title":"Packet Timing: Network Time Protocol","author":"Chowdhury Dhiman Deb","year":"2021","unstructured":"Dhiman Deb Chowdhury . 2021 . Packet Timing: Network Time Protocol . Springer International Publishing , Cham , 103--116. https:\/\/doi.org\/10.1007\/978--3-030--71179--5_7 10.1007\/978--3-030--71179--5_7 Dhiman Deb Chowdhury. 2021. Packet Timing: Network Time Protocol .Springer International Publishing, Cham, 103--116. https:\/\/doi.org\/10.1007\/978--3-030--71179--5_7"},{"key":"#cr-split#-e_1_3_2_1_6_1.1","doi-asserted-by":"crossref","unstructured":"Daniel Fox Franke Dieter Sibold Kristof Teichel Marcus Dansarie and Ragnar Sundblad. 2020. Network Time Security for the Network Time Protocol. RFC 8915. https:\/\/doi.org\/10.17487\/RFC8915 10.17487\/RFC8915","DOI":"10.17487\/RFC8915"},{"key":"#cr-split#-e_1_3_2_1_6_1.2","doi-asserted-by":"crossref","unstructured":"Daniel Fox Franke Dieter Sibold Kristof Teichel Marcus Dansarie and Ragnar Sundblad. 2020. Network Time Security for the Network Time Protocol. RFC 8915. https:\/\/doi.org\/10.17487\/RFC8915","DOI":"10.17487\/RFC8915"},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.1145\/3465481.3470075"},{"key":"e_1_3_2_1_8_1","first-page":"80","article-title":"Intelligence-Driven Computer Network Defense Informed by Analysis of Adversary Campaigns and Intrusion Kill Chains","volume":"1","author":"Hutchins Eric M.","year":"2011","unstructured":"Eric M. Hutchins , Michael J. Cloppert , and Rohan M. Amin . 2011 . Intelligence-Driven Computer Network Defense Informed by Analysis of Adversary Campaigns and Intrusion Kill Chains . Leading Issues in Information Warfare & Security Research , Vol. 1 , 1 (2011), 80 . Eric M. Hutchins, Michael J. Cloppert, and Rohan M. Amin. 2011. Intelligence-Driven Computer Network Defense Informed by Analysis of Adversary Campaigns and Intrusion Kill Chains. Leading Issues in Information Warfare & Security Research, Vol. 1, 1 (2011), 80.","journal-title":"Leading Issues in Information Warfare & Security Research"},{"key":"e_1_3_2_1_9_1","volume-title":"2022 a. The Threat of Covert Channels in Network Time Synchronisation Protocols. Journal of Cyber Security and Mobility","author":"Lamsh\u00f6ft Kevin","year":"2022","unstructured":"Kevin Lamsh\u00f6ft , Jonas Hielscher , Christian Kratzer , and Jana Dittmann . 2022 a. The Threat of Covert Channels in Network Time Synchronisation Protocols. Journal of Cyber Security and Mobility ( 2022 ), 165--204. https:\/\/doi.org\/10.13052\/jcsm2245--1439.1123 10.13052\/jcsm2245--1439.1123 Kevin Lamsh\u00f6ft, Jonas Hielscher, Christian Kratzer, and Jana Dittmann. 2022 a. The Threat of Covert Channels in Network Time Synchronisation Protocols. Journal of Cyber Security and Mobility (2022), 165--204. https:\/\/doi.org\/10.13052\/jcsm2245--1439.1123"},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.1016\/j.fsidi.2022.301335"},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"publisher","DOI":"10.1016\/j.ifacol.2020.12.258"},{"key":"e_1_3_2_1_12_1","doi-asserted-by":"publisher","DOI":"10.1145\/1268776.1268777"},{"key":"e_1_3_2_1_13_1","volume-title":"International Workshop on Privacy Enhancing Technologies. Springer, 147--166","author":"Lucena Norka B","year":"2005","unstructured":"Norka B Lucena , Grzegorz Lewandowski , and Steve J Chapin . 2005 . Covert channels in IPv6 . In International Workshop on Privacy Enhancing Technologies. Springer, 147--166 . Norka B Lucena, Grzegorz Lewandowski, and Steve J Chapin. 2005. Covert channels in IPv6. In International Workshop on Privacy Enhancing Technologies. Springer, 147--166."},{"key":"e_1_3_2_1_14_1","volume-title":"Attacking the network time protocol. Cryptology ePrint Archive","author":"Malhotra Aanchal","year":"2015","unstructured":"Aanchal Malhotra , Isaac E Cohen , Erik Brakke , and Sharon Goldberg . 2015. Attacking the network time protocol. Cryptology ePrint Archive ( 2015 ). Aanchal Malhotra, Isaac E Cohen, Erik Brakke, and Sharon Goldberg. 2015. Attacking the network time protocol. Cryptology ePrint Archive (2015)."},{"key":"#cr-split#-e_1_3_2_1_15_1.1","doi-asserted-by":"crossref","unstructured":"Jim Martin Jack Burbank William Kasch and Professor David L. Mills. 2010. Network Time Protocol Version 4: Protocol and Algorithms Specification. RFC 5905. https:\/\/doi.org\/10.17487\/RFC5905 10.17487\/RFC5905","DOI":"10.17487\/rfc5905"},{"key":"#cr-split#-e_1_3_2_1_15_1.2","doi-asserted-by":"crossref","unstructured":"Jim Martin Jack Burbank William Kasch and Professor David L. Mills. 2010. Network Time Protocol Version 4: Protocol and Algorithms Specification. RFC 5905. https:\/\/doi.org\/10.17487\/RFC5905","DOI":"10.17487\/rfc5905"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.1145\/3360664.3360674"},{"key":"#cr-split#-e_1_3_2_1_17_1.1","doi-asserted-by":"crossref","unstructured":"David McGrew. 2008. An Interface and Algorithms for Authenticated Encryption. RFC 5116. https:\/\/doi.org\/10.17487\/RFC5116 10.17487\/RFC5116","DOI":"10.17487\/rfc5116"},{"key":"#cr-split#-e_1_3_2_1_17_1.2","doi-asserted-by":"crossref","unstructured":"David McGrew. 2008. An Interface and Algorithms for Authenticated Encryption. RFC 5116. https:\/\/doi.org\/10.17487\/RFC5116","DOI":"10.17487\/rfc5116"},{"key":"e_1_3_2_1_18_1","volume-title":"Comprehensive analysis of MQTT 5.0 susceptibility to network covert channels. Computers & security","author":"Mileva Aleksandra","year":"2021","unstructured":"Aleksandra Mileva , Aleksandar Velinov , Laura Hartmann , Steffen Wendzel , and Wojciech Mazurczyk . 2021. Comprehensive analysis of MQTT 5.0 susceptibility to network covert channels. Computers & security , Vol. 104 ( 2021 ), 102207. Aleksandra Mileva, Aleksandar Velinov, Laura Hartmann, Steffen Wendzel, and Wojciech Mazurczyk. 2021. Comprehensive analysis of MQTT 5.0 susceptibility to network covert channels. Computers & security, Vol. 104 (2021), 102207."},{"key":"#cr-split#-e_1_3_2_1_19_1.1","doi-asserted-by":"crossref","unstructured":"David L. Mills. 1992. Network Time Protocol (Version 3) Specification Implementation and Analysis. RFC 1305. https:\/\/doi.org\/10.17487\/RFC1305 10.17487\/RFC1305","DOI":"10.17487\/rfc1305"},{"key":"#cr-split#-e_1_3_2_1_19_1.2","doi-asserted-by":"crossref","unstructured":"David L. Mills. 1992. Network Time Protocol (Version 3) Specification Implementation and Analysis. RFC 1305. https:\/\/doi.org\/10.17487\/RFC1305","DOI":"10.17487\/rfc1305"},{"key":"e_1_3_2_1_20_1","volume-title":"Mills and Brian Haberman","author":"Professor David","year":"2010","unstructured":"Professor David L. Mills and Brian Haberman . 2010 . Network Time Protocol Version 4: Autokey Specification. RFC 5906. https:\/\/doi.org\/10.17487\/RFC5906 10.17487\/RFC5906 Professor David L. Mills and Brian Haberman. 2010. Network Time Protocol Version 4: Autokey Specification. RFC 5906. https:\/\/doi.org\/10.17487\/RFC5906"},{"key":"e_1_3_2_1_21_1","unstructured":"Netnod. 2020. How does NTS wok and why is it important. (2020). https:\/\/www.netnod.se\/time-and-frequency\/white-paper-how-does-nts-work-and-why-is-it-important  Netnod. 2020. How does NTS wok and why is it important. (2020). https:\/\/www.netnod.se\/time-and-frequency\/white-paper-how-does-nts-work-and-why-is-it-important"},{"key":"e_1_3_2_1_22_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-01244-0_5"},{"key":"#cr-split#-e_1_3_2_1_23_1.1","doi-asserted-by":"crossref","unstructured":"Denis Reilly Harlan Stenn and Dieter Sibold. 2019. Network Time Protocol Best Current Practices. RFC 8633. https:\/\/doi.org\/10.17487\/RFC8633 10.17487\/RFC8633","DOI":"10.17487\/RFC8633"},{"key":"#cr-split#-e_1_3_2_1_23_1.2","doi-asserted-by":"crossref","unstructured":"Denis Reilly Harlan Stenn and Dieter Sibold. 2019. Network Time Protocol Best Current Practices. RFC 8633. https:\/\/doi.org\/10.17487\/RFC8633","DOI":"10.17487\/RFC8633"},{"key":"#cr-split#-e_1_3_2_1_24_1.1","doi-asserted-by":"crossref","unstructured":"Eric Rescorla. 2010. Keying Material Exporters for Transport Layer Security (TLS). RFC 5705. https:\/\/doi.org\/10.17487\/RFC5705 10.17487\/RFC5705","DOI":"10.17487\/rfc5705"},{"key":"#cr-split#-e_1_3_2_1_24_1.2","doi-asserted-by":"crossref","unstructured":"Eric Rescorla. 2010. Keying Material Exporters for Transport Layer Security (TLS). RFC 5705. https:\/\/doi.org\/10.17487\/RFC5705","DOI":"10.17487\/rfc5705"},{"key":"#cr-split#-e_1_3_2_1_25_1.1","doi-asserted-by":"crossref","unstructured":"Eric Rescorla. 2018. The Transport Layer Security (TLS) Protocol Version 1.3. RFC 8446. https:\/\/doi.org\/10.17487\/RFC8446 10.17487\/RFC8446","DOI":"10.17487\/RFC8446"},{"key":"#cr-split#-e_1_3_2_1_25_1.2","doi-asserted-by":"crossref","unstructured":"Eric Rescorla. 2018. The Transport Layer Security (TLS) Protocol Version 1.3. RFC 8446. https:\/\/doi.org\/10.17487\/RFC8446","DOI":"10.17487\/RFC8446"},{"key":"e_1_3_2_1_26_1","doi-asserted-by":"publisher","DOI":"10.1145\/3407023.3409207"},{"key":"#cr-split#-e_1_3_2_1_27_1.1","doi-asserted-by":"crossref","unstructured":"Vinay Shankarkumar Laurent Montini Tim Frost and Greg Dowd. 2017. Precision Time Protocol Version 2 (PTPv2) Management Information Base. RFC 8173. https:\/\/doi.org\/10.17487\/RFC8173 10.17487\/RFC8173","DOI":"10.17487\/RFC8173"},{"key":"#cr-split#-e_1_3_2_1_27_1.2","doi-asserted-by":"crossref","unstructured":"Vinay Shankarkumar Laurent Montini Tim Frost and Greg Dowd. 2017. Precision Time Protocol Version 2 (PTPv2) Management Information Base. RFC 8173. https:\/\/doi.org\/10.17487\/RFC8173","DOI":"10.17487\/RFC8173"},{"key":"e_1_3_2_1_28_1","volume-title":"Thomas","author":"Strom Blake E.","year":"2018","unstructured":"Blake E. Strom , Andy Applebaum , Douglas P. Miller , Kathryn C. Nickels , Adam G. Pennington , and Cody B . Thomas . 2018 . MITRE ATT&CK #8482; : Design and Philosophy . (July 2018). Blake E. Strom, Andy Applebaum, Douglas P. Miller, Kathryn C. Nickels, Adam G. Pennington, and Cody B. Thomas. 2018. MITRE ATT&CK #8482; : Design and Philosophy. (July 2018)."},{"key":"e_1_3_2_1_29_1","volume-title":"Security Standardisation Research, Liqun Chen and Shin'ichiro Matsuo (Eds.)","author":"Teichel Kristof","unstructured":"Kristof Teichel , Dieter Sibold , and Stefan Milius . 2015. First Results of a Formal Analysis of the Network Time Security Specification . In Security Standardisation Research, Liqun Chen and Shin'ichiro Matsuo (Eds.) . Springer International Publishing , Cham , 218--245. Kristof Teichel, Dieter Sibold, and Stefan Milius. 2015. First Results of a Formal Analysis of the Network Time Security Specification. In Security Standardisation Research, Liqun Chen and Shin'ichiro Matsuo (Eds.). Springer International Publishing, Cham, 218--245."},{"key":"e_1_3_2_1_30_1","volume-title":"Alternative communication channel over NTP. Virus Bulletin (April","author":"Tsapakis Nikolaos","year":"2019","unstructured":"Nikolaos Tsapakis . 2019. Alternative communication channel over NTP. Virus Bulletin (April 2019 ). https:\/\/www.virusbulletin.com\/virusbulletin\/2019\/04\/alternative-communication-channel-over-ntp\/. Nikolaos Tsapakis. 2019. Alternative communication channel over NTP. Virus Bulletin (April 2019). https:\/\/www.virusbulletin.com\/virusbulletin\/2019\/04\/alternative-communication-channel-over-ntp\/."},{"key":"e_1_3_2_1_31_1","doi-asserted-by":"publisher","DOI":"10.1145\/3465481.3470069"},{"key":"e_1_3_2_1_32_1","doi-asserted-by":"publisher","DOI":"10.1145\/2684195"}],"event":{"name":"IH&MMSec '22: ACM Workshop on Information Hiding and Multimedia Security","location":"Santa Barbara CA USA","acronym":"IH&MMSec '22","sponsor":["SIGMM ACM Special Interest Group on Multimedia"]},"container-title":["Proceedings of the 2022 ACM Workshop on Information Hiding and Multimedia Security"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3531536.3532947","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3531536.3532947","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,17]],"date-time":"2025-06-17T18:09:22Z","timestamp":1750183762000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3531536.3532947"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2022,6,23]]},"references-count":39,"alternative-id":["10.1145\/3531536.3532947","10.1145\/3531536"],"URL":"https:\/\/doi.org\/10.1145\/3531536.3532947","relation":{},"subject":[],"published":{"date-parts":[[2022,6,23]]},"assertion":[{"value":"2022-06-23","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}