{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,2,25]],"date-time":"2026-02-25T17:12:16Z","timestamp":1772039536677,"version":"3.50.1"},"publisher-location":"New York, NY, USA","reference-count":53,"publisher":"ACM","license":[{"start":{"date-parts":[[2023,7,10]],"date-time":"2023-07-10T00:00:00Z","timestamp":1688947200000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0\/"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2023,7,10]]},"DOI":"10.1145\/3579856.3582811","type":"proceedings-article","created":{"date-parts":[[2023,7,5]],"date-time":"2023-07-05T14:52:13Z","timestamp":1688568733000},"page":"328-341","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":5,"title":["On the Cryptographic Fragility of the Telegram Ecosystem"],"prefix":"10.1145","author":[{"ORCID":"https:\/\/orcid.org\/0000-0003-3641-8516","authenticated-orcid":false,"given":"Theo","family":"von Arx","sequence":"first","affiliation":[{"name":"ETH Zurich, Switzerland"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-5145-4489","authenticated-orcid":false,"given":"Kenneth G.","family":"Paterson","sequence":"additional","affiliation":[{"name":"ETH Zurich, Switzerland"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"320","published-online":{"date-parts":[[2023,7,10]]},"reference":[{"key":"e_1_3_2_1_1_1","unstructured":"2022. Security Vulnerability: Replay Attack Against Telethon \u00b7 Issue #3753. https:\/\/github.com\/LonamiWebs\/Telethon\/issues\/3753  2022. Security Vulnerability: Replay Attack Against Telethon \u00b7 Issue #3753. https:\/\/github.com\/LonamiWebs\/Telethon\/issues\/3753"},{"key":"e_1_3_2_1_2_1","unstructured":"Siddiqui Affan and Rashid Pathiyil. 2021. WhatsGram. Yet another userbot for Whatsapp. https:\/\/github.com\/WhatsGram\/WhatsGram.  Siddiqui Affan and Rashid Pathiyil. 2021. WhatsGram. Yet another userbot for Whatsapp. https:\/\/github.com\/WhatsGram\/WhatsGram."},{"key":"e_1_3_2_1_3_1","volume-title":"Lucky Thirteen: Breaking the TLS and DTLS Record Protocols","author":"Al\u00a0Fardan J.","year":"2013","unstructured":"Nadhem\u00a0 J. Al\u00a0Fardan and Kenneth\u00a0 G. Paterson . 2013 . Lucky Thirteen: Breaking the TLS and DTLS Record Protocols . In IEEE S &P 2013. Nadhem\u00a0J. Al\u00a0Fardan and Kenneth\u00a0G. Paterson. 2013. Lucky Thirteen: Breaking the TLS and DTLS Record Protocols. In IEEE S&P 2013."},{"key":"e_1_3_2_1_4_1","volume-title":"USENIX Security","author":"Albrecht R.","year":"2021","unstructured":"Martin\u00a0 R. Albrecht , Jorge Blasco , Rikke\u00a0Bjerg Jensen , and Lenka Marekov\u00e1 . 2021. Collective Information Security in Large-Scale Urban Protests: the Case of Hong Kong . In USENIX Security 2021 . Martin\u00a0R. Albrecht, Jorge Blasco, Rikke\u00a0Bjerg Jensen, and Lenka Marekov\u00e1. 2021. Collective Information Security in Large-Scale Urban Protests: the Case of Hong Kong. In USENIX Security 2021."},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP46214.2022.9833666"},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"publisher","DOI":"10.1145\/3243734.3243787"},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2009.5"},{"key":"e_1_3_2_1_8_1","unstructured":"Steven Almeroth. 2021. telegram-signals. https:\/\/github.com\/stav\/telegram-signals.  Steven Almeroth. 2021. telegram-signals. https:\/\/github.com\/stav\/telegram-signals."},{"key":"e_1_3_2_1_9_1","volume-title":"Patch Release Behavior: Impact of Vulnerability Disclosure. Information Systems Research","author":"Arora Ashish","year":"2010","unstructured":"Ashish Arora , Ramayya Krishnan , Rahul Telang , and Yubao Yang . 2010. An Empirical Analysis of Software Vendors \u2019 Patch Release Behavior: Impact of Vulnerability Disclosure. Information Systems Research ( 2010 ). Ashish Arora, Ramayya Krishnan, Rahul Telang, and Yubao Yang. 2010. An Empirical Analysis of Software Vendors \u2019 Patch Release Behavior: Impact of Vulnerability Disclosure. Information Systems Research (2010)."},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.5555\/647096.716997"},{"key":"e_1_3_2_1_11_1","volume-title":"A Messy State of the Union: Taming the Composite State Machines of TLS","author":"Beurdouche Benjamin","year":"2015","unstructured":"Benjamin Beurdouche , Karthikeyan Bhargavan , Antoine Delignat-Lavaud , C\u00e9dric Fournet , Markulf Kohlweiss , Alfredo Pironti , Pierre-Yves Strub , and Jean\u00a0Karim Zinzindohoue . 2015. A Messy State of the Union: Taming the Composite State Machines of TLS . In IEEE S &P 2015 . Benjamin Beurdouche, Karthikeyan Bhargavan, Antoine Delignat-Lavaud, C\u00e9dric Fournet, Markulf Kohlweiss, Alfredo Pironti, Pierre-Yves Strub, and Jean\u00a0Karim Zinzindohoue. 2015. A Messy State of the Union: Taming the Composite State Machines of TLS. In IEEE S&P 2015."},{"key":"e_1_3_2_1_12_1","unstructured":"Aldo Cortesi Maximilian Hils Thomas Kriechbaumer and contributors. 2010\u2013. mitmproxy. https:\/\/mitmproxy.org\/  Aldo Cortesi Maximilian Hils Thomas Kriechbaumer and contributors. 2010\u2013. mitmproxy. https:\/\/mitmproxy.org\/"},{"key":"e_1_3_2_1_13_1","unstructured":"Dan \"delivrance\". 2017\u2013. Pyrogram. Telegram MTProto API Framework for Python. https:\/\/github.com\/pyrogram\/pyrogram.  Dan \"delivrance\". 2017\u2013. Pyrogram. Telegram MTProto API Framework for Python. https:\/\/github.com\/pyrogram\/pyrogram."},{"key":"e_1_3_2_1_14_1","volume-title":"mtproto.py. https:\/\/github.com\/pyrogram\/pyrogram\/blob\/34b6002c689273d7233ca1a0976da009a3aafe09\/pyrogram\/crypto\/mtproto.py#L52","author":"Dan","unstructured":"Dan \"delivrance\". 2021. mtproto.py. https:\/\/github.com\/pyrogram\/pyrogram\/blob\/34b6002c689273d7233ca1a0976da009a3aafe09\/pyrogram\/crypto\/mtproto.py#L52 . Dan \"delivrance\". 2021. mtproto.py. https:\/\/github.com\/pyrogram\/pyrogram\/blob\/34b6002c689273d7233ca1a0976da009a3aafe09\/pyrogram\/crypto\/mtproto.py#L52."},{"key":"e_1_3_2_1_15_1","unstructured":"Pavel Durov. 2017. Why Isn\u2019t Telegram End-to-End Encrypted by Default?Telegraph. https:\/\/web.archive.org\/web\/20220310005110\/https:\/\/telegra.ph\/Why-Isnt-Telegram-End-to-End-Encrypted-by-Default-08-14  Pavel Durov. 2017. Why Isn\u2019t Telegram End-to-End Encrypted by Default?Telegraph. https:\/\/web.archive.org\/web\/20220310005110\/https:\/\/telegra.ph\/Why-Isnt-Telegram-End-to-End-Encrypted-by-Default-08-14"},{"key":"e_1_3_2_1_16_1","unstructured":"Pavel Durov. 2021. 500 million users. https:\/\/t.me\/durov\/147.  Pavel Durov. 2021. 500 million users. https:\/\/t.me\/durov\/147."},{"key":"e_1_3_2_1_17_1","unstructured":"Morris Dworkin Elaine Barker James Nechvatal James Foti Lawrence Bassham E. Roback and James Dray. 2001. Advanced Encryption Standard (AES).  Morris Dworkin Elaine Barker James Nechvatal James Foti Lawrence Bassham E. Roback and James Dray. 2001. Advanced Encryption Standard (AES)."},{"key":"e_1_3_2_1_18_1","unstructured":"\u201cLonamiWebs\u201d. 2016\u2013. Telethon. https:\/\/github.com\/LonamiWebs\/Telethon.  \u201cLonamiWebs\u201d. 2016\u2013. Telethon. https:\/\/github.com\/LonamiWebs\/Telethon."},{"key":"e_1_3_2_1_19_1","unstructured":"\u201cLonamiWebs\u201d. 2021. mtprotostate.py. https:\/\/github.com\/LonamiWebs\/Telethon\/blob\/f9643bf7376a5953da2050a5361c9b465f7ee7d9\/telethon\/network\/mtprotostate.py#L133.  \u201cLonamiWebs\u201d. 2021. mtprotostate.py. https:\/\/github.com\/LonamiWebs\/Telethon\/blob\/f9643bf7376a5953da2050a5361c9b465f7ee7d9\/telethon\/network\/mtprotostate.py#L133."},{"key":"e_1_3_2_1_20_1","unstructured":"Daniil Gentili. 2020. MadelineProto \u2013 ReadLoop.php. https:\/\/github.com\/danog\/MadelineProto\/blob\/1389b24751fa3f06ba783888c4eee7b1c42dea84\/src\/danog\/MadelineProto\/Loop\/Connection\/ReadLoop.php#L106.  Daniil Gentili. 2020. MadelineProto \u2013 ReadLoop.php. https:\/\/github.com\/danog\/MadelineProto\/blob\/1389b24751fa3f06ba783888c4eee7b1c42dea84\/src\/danog\/MadelineProto\/Loop\/Connection\/ReadLoop.php#L106."},{"key":"e_1_3_2_1_21_1","unstructured":"Daniil Gentili. 2021. MadelineProto. https:\/\/github.com\/danog\/MadelineProto\/blob\/5969ebe783692c8c7aa1b38d380489954a540f66\/README.md.  Daniil Gentili. 2021. MadelineProto. https:\/\/github.com\/danog\/MadelineProto\/blob\/5969ebe783692c8c7aa1b38d380489954a540f66\/README.md."},{"key":"e_1_3_2_1_22_1","volume-title":"https:\/\/github.com\/danog\/MadelineProto\/blob\/1389b24751fa3f06ba783888c4eee7b1c42dea84\/src\/danog\/MadelineProto\/MTProtoSession\/MsgIdHandler\/MsgIdHandler64.php#L50","author":"Gentili Daniil","unstructured":"Daniil Gentili . 2021. MsgIdHandler64.php. https:\/\/github.com\/danog\/MadelineProto\/blob\/1389b24751fa3f06ba783888c4eee7b1c42dea84\/src\/danog\/MadelineProto\/MTProtoSession\/MsgIdHandler\/MsgIdHandler64.php#L50 . Daniil Gentili. 2021. MsgIdHandler64.php. https:\/\/github.com\/danog\/MadelineProto\/blob\/1389b24751fa3f06ba783888c4eee7b1c42dea84\/src\/danog\/MadelineProto\/MTProtoSession\/MsgIdHandler\/MsgIdHandler64.php#L50."},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"publisher","DOI":"10.1145\/2382196.2382204"},{"key":"e_1_3_2_1_24_1","unstructured":"GramJS. 2019\u2013. GramJS. NodeJS\/Browser MTProto API Telegram client library. https:\/\/github.com\/gram-js\/gramjs.  GramJS. 2019\u2013. GramJS. NodeJS\/Browser MTProto API Telegram client library. https:\/\/github.com\/gram-js\/gramjs."},{"key":"e_1_3_2_1_25_1","unstructured":"GramJS. 2021. MTProtoState.ts. https:\/\/github.com\/gram-js\/gramjs\/blob\/7474e57e1f5e392ce9750871db1ca78bf3fcc453\/gramjs\/network\/MTProtoState.ts#L190.  GramJS. 2021. MTProtoState.ts. https:\/\/github.com\/gram-js\/gramjs\/blob\/7474e57e1f5e392ce9750871db1ca78bf3fcc453\/gramjs\/network\/MTProtoState.ts#L190."},{"key":"e_1_3_2_1_26_1","unstructured":"Nasif Imtiaz Aniqa Khanom and Laurie Williams. 2021. Open or Sneaky? Fast or Slow? Light or Heavy?: Investigating Security Releases of Open Source Packages. (2021). arxiv:2112.06804  Nasif Imtiaz Aniqa Khanom and Laurie Williams. 2021. Open or Sneaky? Fast or Slow? Light or Heavy?: Investigating Security Releases of Open Source Packages. (2021). arxiv:2112.06804"},{"key":"e_1_3_2_1_27_1","unstructured":"Mohammadreza Jafari. 2021. telminal. A Terminal in Telegram!https:\/\/github.com\/fristhon\/telminal.  Mohammadreza Jafari. 2021. telminal. A Terminal in Telegram!https:\/\/github.com\/fristhon\/telminal."},{"key":"e_1_3_2_1_28_1","unstructured":"Stephen Kent. 2020. IP Authentication Header. RFC 4302.  Stephen Kent. 2020. IP Authentication Header. RFC 4302."},{"key":"e_1_3_2_1_29_1","unstructured":"Nadim Kobeissi. 2018. Formal Verification for Real-World Cryptographic Protocols and Implementations. Ph.\u00a0D. Dissertation.  Nadim Kobeissi. 2018. Formal Verification for Real-World Cryptographic Protocols and Implementations. Ph.\u00a0D. Dissertation."},{"key":"e_1_3_2_1_30_1","doi-asserted-by":"publisher","DOI":"10.1109\/TIFS.2017.2768018"},{"key":"e_1_3_2_1_31_1","volume-title":"To disclose or not? An analysis of software user behavior. Information Economics and Policy","author":"Nizovtsev Dmitri","year":"2007","unstructured":"Dmitri Nizovtsev and Marie Thursby . 2007. To disclose or not? An analysis of software user behavior. Information Economics and Policy ( 2007 ). Dmitri Nizovtsev and Marie Thursby. 2007. To disclose or not? An analysis of software user behavior. Information Economics and Policy (2007)."},{"key":"e_1_3_2_1_32_1","unstructured":"Fayas Noushad Nikhil Eashy and \u201cMrBotDeveloper\u201d. 2021. BroadcastBot. https:\/\/github.com\/nacbots\/BroadcastBot.  Fayas Noushad Nikhil Eashy and \u201cMrBotDeveloper\u201d. 2021. BroadcastBot. https:\/\/github.com\/nacbots\/BroadcastBot."},{"key":"e_1_3_2_1_33_1","volume-title":"USENIX Security","author":"Oltrogge Marten","year":"2021","unstructured":"Marten Oltrogge , Nicolas Huaman , Sabrina Amft , Yasemin Acar , Michael Backes , and Sascha Fahl . 2021. Why Eve and Mallory Still Love Android: Revisiting TLS (In)Security in Android Applications . In USENIX Security 2021 . Marten Oltrogge, Nicolas Huaman, Sabrina Amft, Yasemin Acar, Michael Backes, and Sascha Fahl. 2021. Why Eve and Mallory Still Love Android: Revisiting TLS (In)Security in Android Applications. In USENIX Security 2021."},{"key":"e_1_3_2_1_34_1","volume-title":"\u00a0B. Butler","author":"Reaves Bradley","year":"2017","unstructured":"Bradley Reaves , Jasmine Bowers , Nolen Scaife , Adam Bates , Arnav Bhartiya , Patrick Traynor , and Kevin R . \u00a0B. Butler . 2017 . Mo(bile) Money, Mo(bile) Problems : Analysis of Branchless Banking Applications. ACM Transactions on Privacy and Security ( 2017). Bradley Reaves, Jasmine Bowers, Nolen Scaife, Adam Bates, Arnav Bhartiya, Patrick Traynor, and Kevin R.\u00a0B. Butler. 2017. Mo(bile) Money, Mo(bile) Problems: Analysis of Branchless Banking Applications. ACM Transactions on Privacy and Security (2017)."},{"key":"e_1_3_2_1_35_1","doi-asserted-by":"crossref","unstructured":"E. Rescorla. 2018. The Transport Layer Security (TLS) Protocol Version 1.3. RFC 8446.  E. Rescorla. 2018. The Transport Layer Security (TLS) Protocol Version 1.3. RFC 8446.","DOI":"10.17487\/RFC8446"},{"key":"e_1_3_2_1_36_1","doi-asserted-by":"crossref","unstructured":"E. Rescorla H. Tschofenig and N. Modadugu. 2022. The Datagram Transport Layer Security (DTLS) Protocol Version 1.3. RFC 9147.  E. Rescorla H. Tschofenig and N. Modadugu. 2022. The Datagram Transport Layer Security (DTLS) Protocol Version 1.3. RFC 9147.","DOI":"10.17487\/RFC9147"},{"key":"e_1_3_2_1_37_1","volume-title":"Pseudo Constant Time Implementations of TLS Are Only Pseudo Secure. In ACM CCS","author":"Ronen Eyal","year":"2018","unstructured":"Eyal Ronen , Kenneth\u00a0 G. Paterson , and Adi Shamir . 2018 . Pseudo Constant Time Implementations of TLS Are Only Pseudo Secure. In ACM CCS 2018. Eyal Ronen, Kenneth\u00a0G. Paterson, and Adi Shamir. 2018. Pseudo Constant Time Implementations of TLS Are Only Pseudo Secure. In ACM CCS 2018."},{"key":"e_1_3_2_1_38_1","doi-asserted-by":"publisher","DOI":"10.1145\/3046055.3046058"},{"key":"e_1_3_2_1_39_1","volume-title":"Most popular global mobile messenger apps as of","year":"2021","unstructured":"Statista. 2021. Most popular global mobile messenger apps as of October 2021 , based on number of monthly active users. https:\/\/www.statista.com\/statistics\/258749\/most-popular-global-mobile-messenger-apps\/. Statista. 2021. Most popular global mobile messenger apps as of October 2021, based on number of monthly active users. https:\/\/www.statista.com\/statistics\/258749\/most-popular-global-mobile-messenger-apps\/."},{"key":"e_1_3_2_1_40_1","doi-asserted-by":"crossref","unstructured":"Tom\u00e1\u0161 Su\u0161\u00e1nka and Josef Koke\u0161. 2017. Security Analysis of the Telegram IM. In ACM ROOTS.  Tom\u00e1\u0161 Su\u0161\u00e1nka and Josef Koke\u0161. 2017. Security Analysis of the Telegram IM. In ACM ROOTS.","DOI":"10.1145\/3150376.3150382"},{"key":"e_1_3_2_1_41_1","unstructured":"Telegram. 2018. TDLib \u2013 Build Your Own Telegram. https:\/\/telegram.org\/blog\/tdlib.  Telegram. 2018. TDLib \u2013 Build Your Own Telegram. https:\/\/telegram.org\/blog\/tdlib."},{"key":"e_1_3_2_1_42_1","unstructured":"Telegram. 2021. API. https:\/\/web.archive.org\/web\/20211127010953\/https:\/\/core.telegram.org\/api.  Telegram. 2021. API. https:\/\/web.archive.org\/web\/20211127010953\/https:\/\/core.telegram.org\/api."},{"key":"e_1_3_2_1_43_1","unstructured":"Telegram. 2021. FAQ for the Technically Inclined. https:\/\/web.archive.org\/web\/20211115225615\/https:\/\/core.telegram.org\/techfaq.  Telegram. 2021. FAQ for the Technically Inclined. https:\/\/web.archive.org\/web\/20211115225615\/https:\/\/core.telegram.org\/techfaq."},{"key":"e_1_3_2_1_44_1","volume-title":"Mobile Protocol: Detailed Description. https:\/\/web.archive.org\/web\/20211016013637\/https:\/\/core.telegram.org\/mtproto\/description\/.","year":"2021","unstructured":"Telegram. 2021 . Mobile Protocol: Detailed Description. https:\/\/web.archive.org\/web\/20211016013637\/https:\/\/core.telegram.org\/mtproto\/description\/. Telegram. 2021. Mobile Protocol: Detailed Description. https:\/\/web.archive.org\/web\/20211016013637\/https:\/\/core.telegram.org\/mtproto\/description\/."},{"key":"e_1_3_2_1_45_1","unstructured":"Telegram. 2021. MTProto Mobile Protocol. https:\/\/web.archive.org\/web\/20211213201047\/https:\/\/core.telegram.org\/mtproto.  Telegram. 2021. MTProto Mobile Protocol. https:\/\/web.archive.org\/web\/20211213201047\/https:\/\/core.telegram.org\/mtproto."},{"key":"e_1_3_2_1_46_1","unstructured":"Telegram. 2021. Security Guidelines for Client Developers. https:\/\/web.archive.org\/web\/20211028151304\/https:\/\/core.telegram.org\/mtproto\/security_guidelines.  Telegram. 2021. Security Guidelines for Client Developers. https:\/\/web.archive.org\/web\/20211028151304\/https:\/\/core.telegram.org\/mtproto\/security_guidelines."},{"key":"e_1_3_2_1_47_1","volume-title":"mtproto_received_ids_manager.h. https:\/\/github.com\/telegramdesktop\/tdesktop\/blob\/dev\/Telegram\/SourceFiles\/mtproto\/details\/mtproto_received_ids_manager.h#L15","unstructured":"Telegram. 2021. TDLib , mtproto_received_ids_manager.h. https:\/\/github.com\/telegramdesktop\/tdesktop\/blob\/dev\/Telegram\/SourceFiles\/mtproto\/details\/mtproto_received_ids_manager.h#L15 . Telegram. 2021. TDLib, mtproto_received_ids_manager.h. https:\/\/github.com\/telegramdesktop\/tdesktop\/blob\/dev\/Telegram\/SourceFiles\/mtproto\/details\/mtproto_received_ids_manager.h#L15."},{"key":"e_1_3_2_1_48_1","unstructured":"Telegram. 2021. Telegram Applications. https:\/\/web.archive.org\/web\/20211201125716\/https:\/\/telegram.org\/apps.  Telegram. 2021. Telegram Applications. https:\/\/web.archive.org\/web\/20211201125716\/https:\/\/telegram.org\/apps."},{"key":"e_1_3_2_1_49_1","unstructured":"Telegram. 2022. TDLib AuthData.cpp. https:\/\/github.com\/tdlib\/td\/blob\/fa8feefed70d64271945e9d5fd010b957d93c8cd\/td\/mtproto\/AuthData.cpp  Telegram. 2022. TDLib AuthData.cpp. https:\/\/github.com\/tdlib\/td\/blob\/fa8feefed70d64271945e9d5fd010b957d93c8cd\/td\/mtproto\/AuthData.cpp"},{"key":"e_1_3_2_1_50_1","unstructured":"Telegram. 2022. Telegram Schema. https:\/\/telegram.org\/schema.  Telegram. 2022. Telegram Schema. https:\/\/telegram.org\/schema."},{"key":"e_1_3_2_1_51_1","volume-title":"mtproto_received_ids_manager.h. https:\/\/github.com\/telegramdesktop\/tdesktop\/blob\/9308615361c77d983bac458e48196646b0660c3b\/Telegram\/SourceFiles\/mtproto\/details\/mtproto_received_ids_manager.h#L15","author":"Desktop Telegram","unstructured":"Telegram Desktop . 2019. mtproto_received_ids_manager.h. https:\/\/github.com\/telegramdesktop\/tdesktop\/blob\/9308615361c77d983bac458e48196646b0660c3b\/Telegram\/SourceFiles\/mtproto\/details\/mtproto_received_ids_manager.h#L15 . Telegram Desktop. 2019. mtproto_received_ids_manager.h. https:\/\/github.com\/telegramdesktop\/tdesktop\/blob\/9308615361c77d983bac458e48196646b0660c3b\/Telegram\/SourceFiles\/mtproto\/details\/mtproto_received_ids_manager.h#L15."},{"key":"e_1_3_2_1_52_1","unstructured":"Telegram Support Force. 2022. End-to-End Encryption FAQ. https:\/\/web.archive.org\/web\/20220315180848\/https:\/\/tsf.telegram.org\/manuals\/e2ee-simple  Telegram Support Force. 2022. End-to-End Encryption FAQ. https:\/\/web.archive.org\/web\/20220315180848\/https:\/\/tsf.telegram.org\/manuals\/e2ee-simple"},{"key":"e_1_3_2_1_53_1","unstructured":"Alexander Zinchuk. 2021. Telegram Web Z. https:\/\/github.com\/Ajaxy\/telegram-tt.  Alexander Zinchuk. 2021. Telegram Web Z. https:\/\/github.com\/Ajaxy\/telegram-tt."}],"event":{"name":"ASIA CCS '23: ACM ASIA Conference on Computer and Communications Security","location":"Melbourne VIC Australia","acronym":"ASIA CCS '23","sponsor":["SIGSAC ACM Special Interest Group on Security, Audit, and Control"]},"container-title":["Proceedings of the ACM Asia Conference on Computer and Communications Security"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3579856.3582811","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"}],"deposited":{"date-parts":[[2025,6,17]],"date-time":"2025-06-17T17:51:27Z","timestamp":1750182687000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3579856.3582811"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2023,7,10]]},"references-count":53,"alternative-id":["10.1145\/3579856.3582811","10.1145\/3579856"],"URL":"https:\/\/doi.org\/10.1145\/3579856.3582811","relation":{},"subject":[],"published":{"date-parts":[[2023,7,10]]},"assertion":[{"value":"2023-07-10","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}