{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,7,23]],"date-time":"2026-07-23T18:19:25Z","timestamp":1784830765706,"version":"3.55.0"},"publisher-location":"New York, NY, USA","reference-count":21,"publisher":"ACM","license":[{"start":{"date-parts":[[2023,7,12]],"date-time":"2023-07-12T00:00:00Z","timestamp":1689120000000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by-nc-sa\/4.0\/"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2023,7,12]]},"DOI":"10.1145\/3597926.3604922","type":"proceedings-article","created":{"date-parts":[[2023,7,13]],"date-time":"2023-07-13T20:12:53Z","timestamp":1689279173000},"page":"1495-1498","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":12,"title":["EDHOC-Fuzzer: An EDHOC Protocol State Fuzzer"],"prefix":"10.1145","author":[{"given":"Konstantinos","family":"Sagonas","sequence":"first","affiliation":[{"name":"Uppsala University, Sweden \/ National Technical University of Athens, Greece"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Thanasis","family":"Typaldos","sequence":"additional","affiliation":[{"name":"National Technical University of Athens, Greece"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2023,7,13]]},"reference":[{"key":"e_1_3_2_1_1_1","doi-asserted-by":"publisher","DOI":"10.4204\/EPTCS.371.1"},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1016\/0890-5401(87)90052-6"},{"key":"e_1_3_2_1_3_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8949"},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.1109\/EuroSPW.2018.00009"},{"key":"e_1_3_2_1_5_1","volume-title":"Protocol State Fuzzing of TLS Implementations. In 24th USENIX Security Symposium. USENIX Association, 193\u2013206","author":"de Ruiter Joeri","year":"2015","unstructured":"Joeri de Ruiter and Erik Poll . 2015 . Protocol State Fuzzing of TLS Implementations. In 24th USENIX Security Symposium. USENIX Association, 193\u2013206 . https:\/\/www.usenix.org\/conference\/usenixsecurity15\/technical-sessions\/presentation\/de-ruiter Joeri de Ruiter and Erik Poll. 2015. Protocol State Fuzzing of TLS Implementations. In 24th USENIX Security Symposium. USENIX Association, 193\u2013206. https:\/\/www.usenix.org\/conference\/usenixsecurity15\/technical-sessions\/presentation\/de-ruiter"},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"publisher","DOI":"10.1145\/3452296.3472938"},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICST53961.2022.00051"},{"key":"e_1_3_2_1_8_1","volume-title":"Automata-Based Automated Detection of State Machine Bugs in Protocol Implementations. In Network and Distributed System Security Symposium (NDSS 2023","author":"Fiterau-Brostean Paul","year":"2023","unstructured":"Paul Fiterau-Brostean , Bengt Jonsson , Konstantinos Sagonas , and Fredrik T\u00e5quist . 2023 . Automata-Based Automated Detection of State Machine Bugs in Protocol Implementations. In Network and Distributed System Security Symposium (NDSS 2023 ). The Internet Society. https:\/\/www.ndss-symposium.org\/wp-content\/uploads\/ 2023\/02\/ndss2023_s68_paper.pdf Paul Fiterau-Brostean, Bengt Jonsson, Konstantinos Sagonas, and Fredrik T\u00e5quist. 2023. Automata-Based Automated Detection of State Machine Bugs in Protocol Implementations. In Network and Distributed System Security Symposium (NDSS 2023). The Internet Society. https:\/\/www.ndss-symposium.org\/wp-content\/uploads\/2023\/02\/ndss2023_s68_paper.pdf"},{"key":"e_1_3_2_1_9_1","volume-title":"Analysis of DTLS Implementations Using Protocol State Fuzzing. In 29th USENIX Security Symposium (USENIX Security 20)","author":"Fiter\u0103u-Bro\u015ftean Paul","year":"2020","unstructured":"Paul Fiter\u0103u-Bro\u015ftean , Bengt Jonsson , Robert Merget , Joeri de Ruiter , Konstantinos Sagonas , and Juraj Somorovsky . 2020 . Analysis of DTLS Implementations Using Protocol State Fuzzing. In 29th USENIX Security Symposium (USENIX Security 20) . USENIX Association, 2523\u20132540. https:\/\/www.usenix.org\/conference\/usenixsecurity20\/presentation\/fiterau-brostean Paul Fiter\u0103u-Bro\u015ftean, Bengt Jonsson, Robert Merget, Joeri de Ruiter, Konstantinos Sagonas, and Juraj Somorovsky. 2020. Analysis of DTLS Implementations Using Protocol State Fuzzing. In 29th USENIX Security Symposium (USENIX Security 20). USENIX Association, 2523\u20132540. https:\/\/www.usenix.org\/conference\/usenixsecurity20\/presentation\/fiterau-brostean"},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-319-28865-9_18"},{"key":"e_1_3_2_1_11_1","first-page":"239","article-title":"AutoFuzz: Automated Network Protocol Fuzzing Framework","volume":"10","author":"Gorbunov Serge","year":"2010","unstructured":"Serge Gorbunov and Arnold Rosenbloom . 2010 . AutoFuzz: Automated Network Protocol Fuzzing Framework . International Journal of Computer Science and Network Security (IJCSNS) , 10 , 8 (2010), Aug. , 239 \u2013 245 . Serge Gorbunov and Arnold Rosenbloom. 2010. AutoFuzz: Automated Network Protocol Fuzzing Framework. International Journal of Computer Science and Network Security (IJCSNS), 10, 8 (2010), Aug., 239\u2013245.","journal-title":"International Journal of Computer Science and Network Security (IJCSNS)"},{"key":"e_1_3_2_1_12_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-319-21690-4_32"},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.1007\/s10664-022-10233-3"},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICST46399.2020.00062"},{"key":"e_1_3_2_1_15_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC9052"},{"key":"e_1_3_2_1_16_1","volume-title":"John Preu\u00df Mattsson, and Francesca Palombini","author":"Selander G\u00f6ran","year":"2022","unstructured":"G\u00f6ran Selander , John Preu\u00df Mattsson, and Francesca Palombini . 2022 . Ephemeral Diffie-Hellman Over COSE (EDHOC) . draft-ietf-lake-edhoc-18. 99 pages. https:\/\/datatracker.ietf.org\/doc\/draft-ietf-lake-edhoc\/18\/ G\u00f6ran Selander, John Preu\u00df Mattsson, and Francesca Palombini. 2022. Ephemeral Diffie-Hellman Over COSE (EDHOC). draft-ietf-lake-edhoc-18. 99 pages. https:\/\/datatracker.ietf.org\/doc\/draft-ietf-lake-edhoc\/18\/"},{"key":"e_1_3_2_1_17_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC8613"},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC7252"},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1145\/2976749.2978411"},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-642-21455-4_8"},{"key":"e_1_3_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.1145\/2967606"}],"event":{"name":"ISSTA '23: 32nd ACM SIGSOFT International Symposium on Software Testing and Analysis","location":"Seattle WA USA","acronym":"ISSTA '23","sponsor":["SIGSOFT ACM Special Interest Group on Software Engineering","AITO"]},"container-title":["Proceedings of the 32nd ACM SIGSOFT International Symposium on Software Testing and Analysis"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3597926.3604922","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3597926.3604922","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,17]],"date-time":"2025-06-17T16:37:59Z","timestamp":1750178279000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3597926.3604922"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2023,7,12]]},"references-count":21,"alternative-id":["10.1145\/3597926.3604922","10.1145\/3597926"],"URL":"https:\/\/doi.org\/10.1145\/3597926.3604922","relation":{},"subject":[],"published":{"date-parts":[[2023,7,12]]},"assertion":[{"value":"2023-07-13","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}