{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,21]],"date-time":"2026-10-21T03:46:16Z","timestamp":1792554376504,"version":"4.5.0"},"publisher-location":"New York, NY, USA","reference-count":40,"publisher":"ACM","license":[{"start":{"date-parts":[[2024,1,4]],"date-time":"2024-01-04T00:00:00Z","timestamp":1704326400000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0\/"}],"funder":[{"name":"Engineering and Physical Sciences Research Council","award":["EP\/T022493\/1, EP\/R03351X\/1, EP\/X040518\/1, EP\/Y019229\/1"],"award-info":[{"award-number":["EP\/T022493\/1, EP\/R03351X\/1, EP\/X040518\/1, EP\/Y019229\/1"]}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2024,1,4]]},"DOI":"10.1145\/3631461.3631549","type":"proceedings-article","created":{"date-parts":[[2024,1,22]],"date-time":"2024-01-22T18:08:30Z","timestamp":1705946910000},"page":"164-173","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":16,"title":["Mitigating IoT Botnet DDoS Attacks through MUD and eBPF based Traffic Filtering"],"prefix":"10.1145","author":[{"ORCID":"https:\/\/orcid.org\/0000-0002-9727-0861","authenticated-orcid":false,"given":"Angelo","family":"Feraudo","sequence":"first","affiliation":[{"name":"University of Bologna, Italy"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-2435-9603","authenticated-orcid":false,"given":"Diana Andreea","family":"Popescu","sequence":"additional","affiliation":[{"name":"University of Cambridge, United Kingdom"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0003-0169-0704","authenticated-orcid":false,"given":"Poonam","family":"Yadav","sequence":"additional","affiliation":[{"name":"University of York, United Kingdom"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-5205-5992","authenticated-orcid":false,"given":"Richard","family":"Mortier","sequence":"additional","affiliation":[{"name":"University of Cambridge, United Kingdom"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0003-0992-7948","authenticated-orcid":false,"given":"Paolo","family":"Bellavista","sequence":"additional","affiliation":[{"name":"University of Bologna, Italy"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2024,1,22]]},"reference":[{"key":"e_1_3_2_1_1_1","doi-asserted-by":"publisher","DOI":"10.1109\/NFV-SDN53031.2021.9665095"},{"key":"e_1_3_2_1_2_1","volume-title":"2nd USENIX Workshop on Hot Topics in Edge Computing (HotEdge 19)","author":"Andalibi Vafa","year":"2019","unstructured":"Vafa Andalibi, DongInn Kim, and L.\u00a0Jean Camp. 2019. Throwing MUD into the FOG: Defending IoT and Fog by expanding MUD to Fog network. In 2nd USENIX Workshop on Hot Topics in Edge Computing (HotEdge 19). USENIX Association, Renton, WA. https:\/\/www.usenix.org\/conference\/hotedge19\/presentation\/andalibi"},{"key":"e_1_3_2_1_3_1","doi-asserted-by":"crossref","unstructured":"Vafa Andalibi Eliot Lear DongInn Kim and L.\u00a0Jean Camp. 2021. On the Analysis of MUD-Files\u2019 Interactions Conflicts and Configuration Requirements Before Deployment. arxiv:2107.06372\u00a0[cs.CR]","DOI":"10.1007\/978-3-030-94285-4_9"},{"key":"e_1_3_2_1_4_1","volume-title":"Understanding the Mirai Botnet. In 26th USENIX Security Symposium (USENIX Security 17)","author":"Antonakakis Manos","year":"2017","unstructured":"Manos Antonakakis, Tim April, Michael Bailey, Matt Bernhard, Elie Bursztein, Jaime Cochran, Zakir Durumeric, J.\u00a0Alex Halderman, Luca Invernizzi, Michalis Kallitsis, Deepak Kumar, Chaz Lever, Zane Ma, Joshua Mason, Damian Menscher, Chad Seaman, Nick Sullivan, Kurt Thomas, and Yi Zhou. 2017. Understanding the Mirai Botnet. In 26th USENIX Security Symposium (USENIX Security 17). USENIX Association, Vancouver, BC, 1093\u20131110. https:\/\/www.usenix.org\/conference\/usenixsecurity17\/technical-sessions\/presentation\/antonakakis"},{"key":"e_1_3_2_1_5_1","unstructured":"Gilberto Bertin. 2017. XDP in practice:integrating XDP into our DDoS mitigation pipeline. https:\/\/legacy.netdevconf.info\/2.1\/papers\/Gilberto_Bertin_XDP_in_practice.pdf."},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"publisher","DOI":"10.1109\/NOMS54207.2022.9789828"},{"key":"e_1_3_2_1_7_1","unstructured":"Gabriel Brown. 2019. Regulation of IoT Device Communications Using MUD Files and IPTables. https:\/\/gitlab.com\/columbia.irt\/riot\/tree\/master\/Fall2019\/CombineRouter"},{"key":"e_1_3_2_1_8_1","volume-title":"SoK: Beyond IoT MUD Deployments - Challenges and Future Directions. CoRR abs\/2004.08003","author":"Feraudo Angelo","year":"2020","unstructured":"Angelo Feraudo, Poonam Yadav, Richard Mortier, Paolo Bellavista, and Jon Crowcroft. 2020. SoK: Beyond IoT MUD Deployments - Challenges and Future Directions. CoRR abs\/2004.08003 (2020). arXiv:2004.08003https:\/\/arxiv.org\/abs\/2004.08003"},{"key":"e_1_3_2_1_9_1","doi-asserted-by":"publisher","DOI":"10.1145\/3378679.3394528"},{"key":"e_1_3_2_1_10_1","unstructured":"Matt Fleming. 2020. A thorough introduction to eBPF. https:\/\/lwn.net\/Articles\/740157\/."},{"key":"e_1_3_2_1_11_1","unstructured":"Matt Fleming. 2021. A thorough introduction to eBPF. https:\/\/lwn.net\/Articles\/740157\/."},{"key":"e_1_3_2_1_12_1","unstructured":"OSMUD Group. 2018. Open Source Manufacturer Usage Specification. https:\/\/osmud.org."},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.1109\/JIOT.2017.2704093"},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"publisher","DOI":"10.1145\/3314148.3314352"},{"key":"e_1_3_2_1_15_1","doi-asserted-by":"publisher","DOI":"10.1145\/3229565.3229566"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.1109\/NOMS56928.2023.10154376"},{"key":"e_1_3_2_1_17_1","doi-asserted-by":"publisher","DOI":"10.1109\/ACCESS.2021.3111477"},{"key":"e_1_3_2_1_18_1","unstructured":"Hewlett-Packard. 2022. Netperf. https:\/\/hewlettpackard.github.io\/netperf\/."},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1145\/3281411.3281443"},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","unstructured":"Mahesh Jethanandani Sonal Agarwal Lisa Huang and Dana Blair. 2019. YANG Data Model for Network Access Control Lists (ACLs). RFC 8519. https:\/\/doi.org\/10.17487\/RFC8519","DOI":"10.17487\/RFC8519"},{"key":"e_1_3_2_1_21_1","volume-title":"Revisiting IoT Device Identification. TMA\u201921 abs\/2107.07818","author":"Kolcun Roman","year":"2021","unstructured":"Roman Kolcun, Diana\u00a0Andreea Popescu, Vadim Safronov, Poonam Yadav, Anna\u00a0Maria Mandalari, Richard Mortier, and Hamed Haddadi. 2021. Revisiting IoT Device Identification. TMA\u201921 abs\/2107.07818 (2021). arXiv:2107.07818https:\/\/arxiv.org\/abs\/2107.07818"},{"key":"e_1_3_2_1_22_1","doi-asserted-by":"publisher","DOI":"10.1109\/MC.2017.201"},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"publisher","DOI":"10.1109\/JIOT.2021.3113577"},{"key":"e_1_3_2_1_24_1","doi-asserted-by":"publisher","unstructured":"Eliot Lear Ralph Droms and Dan Romascanu. 2019. Manufacturer Usage Description Specification. RFC 8520. https:\/\/doi.org\/10.17487\/RFC8520","DOI":"10.17487\/RFC8520"},{"key":"e_1_3_2_1_25_1","unstructured":"Lear E and Henry J. 2020. Bandwidth Profiling Extensions for MUD. https:\/\/tools.ietf.org\/html\/draft-lear-opsawg-mud-bw-profile-01"},{"key":"e_1_3_2_1_26_1","doi-asserted-by":"publisher","unstructured":"Ladislav Lhotka. 2016. JSON Encoding of Data Modeled with YANG. RFC 7951. https:\/\/doi.org\/10.17487\/RFC7951","DOI":"10.17487\/RFC7951"},{"key":"e_1_3_2_1_27_1","doi-asserted-by":"publisher","DOI":"10.1145\/3139937.3139938"},{"key":"e_1_3_2_1_28_1","doi-asserted-by":"publisher","DOI":"10.2478\/popets-2021-0075"},{"key":"e_1_3_2_1_29_1","doi-asserted-by":"publisher","DOI":"10.18420\/ois2020_12"},{"key":"e_1_3_2_1_30_1","doi-asserted-by":"publisher","DOI":"10.1109\/ACCESS.2019.2933491"},{"key":"e_1_3_2_1_31_1","doi-asserted-by":"publisher","DOI":"10.1016\/j.scs.2021.102994"},{"key":"e_1_3_2_1_32_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICED.2016.7804660"},{"key":"e_1_3_2_1_33_1","first-page":"1800","article-title":"Securing Small-Business and Home Internet of Things Devices","author":"NIST.","year":"2019","unstructured":"NIST. 2019. Securing Small-Business and Home Internet of Things Devices: NIST SP 1800-15.","journal-title":"NIST SP"},{"key":"e_1_3_2_1_34_1","unstructured":"Mudumbai Ranganathan Douglas Montgomery and Omar\u00a0El Mimouni. 2019. Soft MUD: Implementing Manufacturer Usage Descriptions on OpenFlow SDN Switches. ThinkMind Valencia ES. https:\/\/tsapps.nist.gov\/publication\/get_pdf.cfm?pub_id=927289"},{"key":"e_1_3_2_1_35_1","doi-asserted-by":"publisher","DOI":"10.1145\/3355369.3355577"},{"key":"e_1_3_2_1_36_1","doi-asserted-by":"publisher","DOI":"10.1109\/ITC30.2018.00039"},{"key":"e_1_3_2_1_37_1","doi-asserted-by":"publisher","DOI":"10.1109\/TMC.2018.2866249"},{"key":"e_1_3_2_1_38_1","unstructured":"Turner Aaron and Klassen Fred. 2021. Tcpreplay. https:\/\/tcpreplay.appneta.com\/wiki\/tcpreplay.html"},{"key":"e_1_3_2_1_39_1","doi-asserted-by":"publisher","DOI":"10.1145\/3371038"},{"key":"e_1_3_2_1_40_1","doi-asserted-by":"publisher","DOI":"10.1145\/3417313.3429384"}],"event":{"name":"ICDCN '24: International Conference on Distributed Computing and Networking","location":"Chennai India","acronym":"ICDCN '24"},"container-title":["Proceedings of the 25th International Conference on Distributed Computing and Networking"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3631461.3631549","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3631461.3631549","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,8,23]],"date-time":"2025-08-23T00:39:23Z","timestamp":1755909563000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3631461.3631549"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2024,1,4]]},"references-count":40,"alternative-id":["10.1145\/3631461.3631549","10.1145\/3631461"],"URL":"https:\/\/doi.org\/10.1145\/3631461.3631549","relation":{},"subject":[],"published":{"date-parts":[[2024,1,4]]},"assertion":[{"value":"2024-01-22","order":3,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}