{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,26]],"date-time":"2026-10-26T03:34:39Z","timestamp":1792985679229,"version":"4.5.0"},"publisher-location":"New York, NY, USA","reference-count":53,"publisher":"ACM","license":[{"start":{"date-parts":[[2024,7,1]],"date-time":"2024-07-01T00:00:00Z","timestamp":1719792000000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0\/"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2024,7]]},"DOI":"10.1145\/3634737.3637675","type":"proceedings-article","created":{"date-parts":[[2024,6,28]],"date-time":"2024-06-28T11:51:38Z","timestamp":1719575498000},"page":"1617-1629","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":12,"title":["MultiTEE: Distributing Trusted Execution Environments"],"prefix":"10.1145","author":[{"ORCID":"https:\/\/orcid.org\/0000-0002-9415-3969","authenticated-orcid":false,"given":"Simon","family":"Ott","sequence":"first","affiliation":[{"name":"Fraunhofer AISEC, Garching near Munich, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0009-0008-3836-1844","authenticated-orcid":false,"given":"Benjamin","family":"Orthen","sequence":"additional","affiliation":[{"name":"Fraunhofer AISEC, Garching near Munich, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0009-0007-8590-0620","authenticated-orcid":false,"given":"Alexander","family":"Weidinger","sequence":"additional","affiliation":[{"name":"Fraunhofer AISEC, Garching near Munich, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-9018-7048","authenticated-orcid":false,"given":"Julian","family":"Horsch","sequence":"additional","affiliation":[{"name":"Fraunhofer AISEC, Garching near Munich, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0009-0005-8540-6556","authenticated-orcid":false,"given":"Vijayanand","family":"Nayani","sequence":"additional","affiliation":[{"name":"Huawei Technologies, Helsinki, Finland"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0009-0007-5432-6128","authenticated-orcid":false,"given":"Jan-Erik","family":"Ekberg","sequence":"additional","affiliation":[{"name":"Huawei Technologies, Helsinki, Finland"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2024,7]]},"reference":[{"key":"e_1_3_2_1_1_1","volume-title":"Retrieved","author":"Source Android Open","year":"2023","unstructured":"Android Open Source Project (AOSP). 2023. Trusty TEE. Retrieved March 23, 2023 from https:\/\/source.android.com\/docs\/security\/features\/trusty"},{"key":"e_1_3_2_1_2_1","unstructured":"ARM. 2018. Trusted Board Boot Requirements CLIENT (TBBR-CLIENT) Armv8-A."},{"key":"e_1_3_2_1_3_1","unstructured":"ARM Limited. 2017. TrustZone technology for the ARMv8-M architecture."},{"key":"e_1_3_2_1_4_1","unstructured":"Arm Limited. 2019. Arm TrustZone Technology. https:\/\/developer.arm.com\/ip-products\/security-ip\/trustzone."},{"key":"e_1_3_2_1_5_1","volume-title":"USENIX Annual Technical Conference. The Usenix Association, Virtual Conference, 65--79","author":"Bailleu Maurice","year":"2021","unstructured":"Maurice Bailleu, Dimitra Giantsidi, Vasilis Gavrielatos, Do Le Quoc, Vijay Nagarajan, and Pramod Bhatotia. 2021. Avocado: A Secure In-Memory Distributed Storage System.. In USENIX Annual Technical Conference. The Usenix Association, Virtual Conference, 65--79."},{"key":"e_1_3_2_1_6_1","volume-title":"Vehicular Ad-hoc Networks for Smart Cities","author":"Boos Philippe","unstructured":"Philippe Boos and Marc Lacoste. 2020. Networks of trusted execution environments for data protection in cooperative vehicular systems. In Vehicular Ad-hoc Networks for Smart Cities. Springer, 99--109."},{"key":"e_1_3_2_1_7_1","volume-title":"Blockchain and trusted computing: Problems, pitfalls, and a solution for hyperledger fabric. arXiv preprint arXiv:1805.08541","author":"Brandenburger Marcus","year":"2018","unstructured":"Marcus Brandenburger, Christian Cachin, R\u00fcdiger Kapitza, and Alessandro Sorniotti. 2018. Blockchain and trusted computing: Problems, pitfalls, and a solution for hyperledger fabric. arXiv preprint arXiv:1805.08541 (2018)."},{"key":"e_1_3_2_1_8_1","volume-title":"2019 38th Symposium on Reliable Distributed Systems (SRDS). IEEE","author":"Brandenburger Marcus","year":"2019","unstructured":"Marcus Brandenburger, Christian Cachin, R\u00fcdiger Kapitza, and Alessandro Sorniotti. 2019. Trusted computing meets blockchain: Rollback attacks and a solution for hyperledger fabric. In 2019 38th Symposium on Reliable Distributed Systems (SRDS). IEEE, Lyon, France, 324--32409."},{"key":"e_1_3_2_1_9_1","volume-title":"Digital Identity for all Europeans. Retrieved","author":"European Commission","year":"2023","unstructured":"European Commission. 2021. Digital Identity for all Europeans. Retrieved May 4, 2023 from https:\/\/commission.europa.eu\/strategy-and-policy\/priorities-2019-2024\/europe-fit-digital-age\/european-digital-identity_en"},{"key":"e_1_3_2_1_10_1","volume-title":"Retrieved","author":"Web World Wide","year":"2023","unstructured":"World Wide Web Consortium et al. 2019. Verifiable credentials data model 1.0: expressing verifiable information on the web. Retrieved May 11, 2023 from https:\/\/www.w3.org\/TR\/vc-data-model\/?#core-data-model"},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"publisher","DOI":"10.1109\/TIT.1983.1056650"},{"key":"e_1_3_2_1_12_1","volume-title":"NDSS.","author":"Donenfeld Jason A","unstructured":"Jason A Donenfeld. 2017. Wireguard: next generation kernel network tunnel.. In NDSS. San Diego, CA, USA, 1--12."},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.1109\/MSP.2014.38"},{"key":"e_1_3_2_1_14_1","volume-title":"Retrieved","author":"Foundation Linux","year":"2023","unstructured":"Linux Foundation. 2023. Yocto Project. Retrieved May 15, 2023 from https:\/\/www.yoctoproject.org\/"},{"key":"e_1_3_2_1_15_1","volume-title":"Retrieved","author":"Foundation Linux","year":"2023","unstructured":"Linux Foundation. 2023. Zephyr Project. Retrieved May 15, 2023 from https:\/\/zephyrproject.org\/"},{"key":"e_1_3_2_1_16_1","volume-title":"Treaty: Secure Distributed Transactions. In 2022 52nd Annual IEEE\/IFIP International Conference on Dependable Systems and Networks (DSN). IEEE, IEEE\/IFIP","author":"Giantsidi Dimitra","year":"2022","unstructured":"Dimitra Giantsidi, Maurice Bailleu, Natacha Crooks, and Pramod Bhatotia. 2022. Treaty: Secure Distributed Transactions. In 2022 52nd Annual IEEE\/IFIP International Conference on Dependable Systems and Networks (DSN). IEEE, IEEE\/IFIP, Maryland, MD, USA, 14--27."},{"issue":"2","key":"e_1_3_2_1_17_1","first-page":"1","article-title":"TEE Internal Core API Specification","volume":"1","year":"2019","unstructured":"GlobalPlatform. 2019. TEE Internal Core API Specification, Version 1.2.1. https:\/\/globalplatform.org\/specs-library\/tee-internal-core-api-specification-v1-2\/","journal-title":"Version"},{"key":"e_1_3_2_1_18_1","unstructured":"GlobalPlatform. 2020. TEE Protection Profile v1.3 | GPD_SPE_021. https:\/\/globalplatform.org\/specs-library\/tee-protection-profile-v1-3\/."},{"key":"e_1_3_2_1_19_1","unstructured":"GlobalPlatform. 2022. TEE System Architecture v1.3 | GPD_SPE_009. https:\/\/globalplatform.org\/specs-library\/tee-system-architecture\/."},{"key":"e_1_3_2_1_20_1","unstructured":"Trusted Computing Group. 2019. Trusted Platform Module 2.0: A Brief Introduction."},{"key":"e_1_3_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC6234"},{"key":"e_1_3_2_1_22_1","unstructured":"ARM Holding. 2009. ARM Security Technology Building a Secure System using TrustZone Technology."},{"key":"e_1_3_2_1_23_1","unstructured":"International Data Corporation (IDC). 2021. Worldwide Quarterly Wearable Device Tracker."},{"key":"e_1_3_2_1_24_1","volume-title":"Securing a communication channel for the trusted execution environment. computers & security 83","author":"Jang Jinsoo","year":"2019","unstructured":"Jinsoo Jang and Brent Byunghoon Kang. 2019. Securing a communication channel for the trusted execution environment. computers & security 83 (2019), 79--92."},{"key":"e_1_3_2_1_25_1","volume-title":"Secret: Secure channel between rich execution environment and trusted execution environment.. In NDSS. 1--15.","author":"Jang Jin Soo","year":"2015","unstructured":"Jin Soo Jang, Sunjune Kong, Minsu Kim, Daegyeong Kim, and Brent Byunghoon Kang. 2015. Secret: Secure channel between rich execution environment and trusted execution environment.. In NDSS. 1--15."},{"key":"e_1_3_2_1_26_1","volume-title":"Noise Explorer: Fully Automated Modeling and Verification for Arbitrary Noise Protocols. Cryptology ePrint Archive, Paper 2018\/766. https:\/\/eprint.iacr.org\/2018\/766 https:\/\/eprint.iacr.org\/2018\/766.","author":"Kobeissi Nadim","year":"2018","unstructured":"Nadim Kobeissi, Georgio Nicolas, and Karthikeyan Bhargavan. 2018. Noise Explorer: Fully Automated Modeling and Verification for Arbitrary Noise Protocols. Cryptology ePrint Archive, Paper 2018\/766. https:\/\/eprint.iacr.org\/2018\/766 https:\/\/eprint.iacr.org\/2018\/766."},{"key":"e_1_3_2_1_27_1","doi-asserted-by":"publisher","DOI":"10.1109\/EuroSP.2019.00034"},{"key":"e_1_3_2_1_28_1","doi-asserted-by":"publisher","unstructured":"Adam Langley Mike Hamburg and Sean Turner. 2016. Elliptic Curves for Security. RFC 7748. 10.17487\/RFC7748","DOI":"10.17487\/RFC7748"},{"key":"e_1_3_2_1_29_1","volume-title":"Retrieved","author":"Limited Arm","year":"2023","unstructured":"Arm Limited. 2023. Trusted Firmware-A. Retrieved May 15, 2023 from https:\/\/github.com\/ARM-software\/arm-trusted-firmware"},{"key":"e_1_3_2_1_30_1","volume-title":"Retrieved","author":"Limited Arm","year":"2023","unstructured":"Arm Limited. 2023. Trusted Firmware-M. Retrieved May 15, 2023 from https:\/\/git.trustedfirmware.org\/TF-M\/trusted-firmware-m.git\/"},{"key":"e_1_3_2_1_31_1","volume-title":"Teechan: Payment channels using trusted execution environments. arXiv preprint arXiv:1612.07766","author":"Lind Joshua","year":"2016","unstructured":"Joshua Lind, Ittay Eyal, Peter Pietzuch, and Emin G\u00fcn Sirer. 2016. Teechan: Payment channels using trusted execution environments. arXiv preprint arXiv:1612.07766 (2016), 1--14."},{"key":"e_1_3_2_1_32_1","doi-asserted-by":"publisher","DOI":"10.1145\/2692956.2663188"},{"key":"e_1_3_2_1_33_1","volume-title":"Retrieved","year":"2023","unstructured":"mcu tools. 2023. MCUBoot boodloader. Retrieved May 15, 2023 from https:\/\/github.com\/mcu-tools\/mcuboot"},{"key":"e_1_3_2_1_34_1","doi-asserted-by":"publisher","DOI":"10.1016\/j.cose.2023.103180"},{"key":"e_1_3_2_1_35_1","volume-title":"Nordic Conference on Secure IT Systems. Springer, Springer, 175--191","author":"Niemi Arto","year":"2021","unstructured":"Arto Niemi, Vasile Adrian Bogdan Pop, and Jan-Erik Ekberg. 2021. Trusted Sockets Layer: A TLS 1.3 based trusted channel protocol. In Nordic Conference on Secure IT Systems. Springer, Springer, 175--191."},{"key":"e_1_3_2_1_36_1","doi-asserted-by":"publisher","unstructured":"Yoav Nir. 2015. ChaCha20 Poly1305 and Their Use in the Internet Key Exchange Protocol (IKE) and IPsec. RFC 7634. 10.17487\/RFC7634","DOI":"10.17487\/RFC7634"},{"key":"e_1_3_2_1_37_1","doi-asserted-by":"publisher","unstructured":"Yoav Nir and Simon Josefsson. 2016. Curve25519 and Curve448 for the Internet Key Exchange Protocol Version 2 (IKEv2) Key Agreement. RFC 8031. 10.17487\/RFC8031","DOI":"10.17487\/RFC8031"},{"key":"e_1_3_2_1_38_1","doi-asserted-by":"publisher","unstructured":"Yoav Nir and Adam Langley. 2015. ChaCha20 and Poly1305 for IETF Protocols. RFC 7539. 10.17487\/RFC7539","DOI":"10.17487\/RFC7539"},{"key":"e_1_3_2_1_39_1","doi-asserted-by":"publisher","DOI":"10.1145\/3600160.3600171"},{"key":"e_1_3_2_1_40_1","volume-title":"The german eID as an authentication token on android devices. arXiv preprint arXiv:1701.04013","author":"Otterbein Florian","year":"2017","unstructured":"Florian Otterbein, Tim Ohlendorf, and Marian Margraf. 2017. The german eID as an authentication token on android devices. arXiv preprint arXiv:1701.04013 (2017)."},{"key":"e_1_3_2_1_41_1","unstructured":"Trevor Perrin. 2018. The Noise Protocol Framework. https:\/\/noiseprotocol.org\/noise.html"},{"key":"e_1_3_2_1_42_1","doi-asserted-by":"publisher","DOI":"10.1145\/3291047"},{"key":"e_1_3_2_1_43_1","doi-asserted-by":"publisher","unstructured":"Eric Rescorla. 2018. The Transport Layer Security (TLS) Protocol Version 1.3. RFC 8446. 10.17487\/RFC8446","DOI":"10.17487\/RFC8446"},{"key":"e_1_3_2_1_44_1","volume-title":"And Segment Forecasts, 2023","author":"Research Grand View","year":"2022","unstructured":"Grand View Research. 2022. Wearable Technology Market Size, Share & Trends Analysis Report By Product (Head & Eyewear, Wristwear), By Application (Consumer Electronics, Healthcare), By Region (Asia Pacific, Europe), And Segment Forecasts, 2023 - 2030."},{"key":"e_1_3_2_1_45_1","volume-title":"Retrieved","author":"Research Microsoft","year":"2023","unstructured":"Microsoft Research. 2023. Firmware Trusted Platform Module (fTPM). Retrieved Jul 28, 2023 from https:\/\/github.com\/microsoft\/MSRSec\/blob\/master\/TAs\/optee_ta\/fTPM\/README.md"},{"key":"e_1_3_2_1_46_1","volume-title":"Android security maximized by Samsung KNOX. Retrieved","year":"2023","unstructured":"Samsung. 2015. Android security maximized by Samsung KNOX. Retrieved December 6, 2023 from https:\/\/kp-cdn.samsungknox.com\/2f2fff7938aaf9a7dcf7a9e7ccd0446f.pdf"},{"key":"e_1_3_2_1_47_1","doi-asserted-by":"publisher","DOI":"10.1145\/3098954.3098971"},{"key":"e_1_3_2_1_48_1","volume-title":"Trusted Systems: Second International Conference, INTRUST 2010","author":"Tamrakar Sandeep","year":"2011","unstructured":"Sandeep Tamrakar, Jan-Erik Ekberg, Pekka Laitinen, N Asokan, and Tuomas Aura. 2011. Can hand-held computers still be better smart cards?. In Trusted Systems: Second International Conference, INTRUST 2010, Beijing, China, December 13-15, 2010, Revised Selected Papers 2. Springer, 200--218."},{"key":"e_1_3_2_1_49_1","unstructured":"Trusted Computing Group. 2018. Implicit Identity Based Device Attestation."},{"key":"e_1_3_2_1_50_1","unstructured":"Trusted Computing Group. 2019. Trusted Platform Module Library."},{"key":"e_1_3_2_1_51_1","volume-title":"Retrieved","year":"2023","unstructured":"TrustedFirmware.org. 2023. OP-TEE Trusted OS. Retrieved May 15, 2023 from https:\/\/github.com\/OP-TEE\/optee_os"},{"key":"e_1_3_2_1_52_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-030-59817-4_5"},{"key":"e_1_3_2_1_53_1","volume-title":"Retrieved","author":"Software Engineering Wolfgang Denk DENX","year":"2023","unstructured":"DENX Software Engineering Wolfgang Denk. 2023. U-Boot bootloader. Retrieved May 15, 2023 from https:\/\/github.com\/u-boot\/u-boot"}],"event":{"name":"ASIA CCS '24: 19th ACM Asia Conference on Computer and Communications Security","location":"Singapore Singapore","acronym":"ASIA CCS '24","sponsor":["SIGSAC ACM Special Interest Group on Security, Audit, and Control"]},"container-title":["Proceedings of the 19th ACM Asia Conference on Computer and Communications Security"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3634737.3637675","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T23:44:06Z","timestamp":1750290246000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3634737.3637675"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2024,7]]},"references-count":53,"alternative-id":["10.1145\/3634737.3637675","10.1145\/3634737"],"URL":"https:\/\/doi.org\/10.1145\/3634737.3637675","relation":{},"subject":[],"published":{"date-parts":[[2024,7]]},"assertion":[{"value":"2024-07-01","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}