{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,8,27]],"date-time":"2026-08-27T15:23:38Z","timestamp":1787844218672,"version":"build-2784847793"},"publisher-location":"New York, NY, USA","reference-count":46,"publisher":"ACM","license":[{"start":{"date-parts":[[2024,8,4]],"date-time":"2024-08-04T00:00:00Z","timestamp":1722729600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0\/"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2024,8,4]]},"DOI":"10.1145\/3651890.3672259","type":"proceedings-article","created":{"date-parts":[[2024,7,31]],"date-time":"2024-07-31T13:11:43Z","timestamp":1722431503000},"page":"311-326","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":3,"title":["Bad Packets Come Back, Worse Ones Don't"],"prefix":"10.1145","author":[{"ORCID":"https:\/\/orcid.org\/0000-0002-2076-6287","authenticated-orcid":false,"given":"Petros","family":"Gigis","sequence":"first","affiliation":[{"name":"Computer Science, University College London, London, United Kingdom"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-8509-2001","authenticated-orcid":false,"given":"Mark James","family":"Handley","sequence":"additional","affiliation":[{"name":"Computer Science, University College London, London, United Kingdom"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0003-3699-8127","authenticated-orcid":false,"given":"Stefano","family":"Vissicchio","sequence":"additional","affiliation":[{"name":"Computer Science, University College London, London, United Kingdom"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2024,8,4]]},"reference":[{"key":"e_1_3_2_1_1_1","doi-asserted-by":"publisher","DOI":"10.1145\/1052812.1052823"},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1145\/3232755.3232783"},{"key":"e_1_3_2_1_3_1","doi-asserted-by":"crossref","unstructured":"Fred Baker and Pekka Savola. 2004. BCP38 - Ingress Filtering for Multihomed Networks. https:\/\/tools.ietf.org\/html\/bcp84.","DOI":"10.17487\/rfc3704"},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.23919\/CNSM55787.2022.9964817"},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"crossref","unstructured":"Jun Bi Jianping Wu Guang Yao and Fred Baker. 2015. RFC7513 - Source Address Validation Improvement (SAVI) Solution for DHCP. https:\/\/tools.ietf.org\/html\/rfc7513. https:\/\/tools.ietf.org\/html\/rfc7513","DOI":"10.17487\/RFC7513"},{"key":"e_1_3_2_1_6_1","volume-title":"Enhancing Global Network Monitoring with Magnifier. In 20th USENIX Symposium on Networked Systems Design and Implementation (NSDI 23)","author":"B\u00fchler Tobias","year":"2023","unstructured":"Tobias B\u00fchler, Romain Jacob, Ingmar Poese, and Laurent Vanbever. 2023. Enhancing Global Network Monitoring with Magnifier. In 20th USENIX Symposium on Networked Systems Design and Implementation (NSDI 23). USENIX Association, Boston, MA, 1521--1539."},{"key":"e_1_3_2_1_7_1","unstructured":"CAIDA. 2019. Anonymized Internet Traces. https:\/\/catalog.caida.org\/dataset\/passive_merged_pcap."},{"key":"e_1_3_2_1_8_1","doi-asserted-by":"publisher","DOI":"10.1145\/3012426.3022184"},{"key":"e_1_3_2_1_9_1","volume-title":"Martin Lee Schoffstall, and James Davin","author":"Case Jeffrey D","year":"1990","unstructured":"Jeffrey D Case, Mark Fedor, Martin Lee Schoffstall, and James Davin. 1990. A Simple Network Management Protocol (SNMP). https:\/\/tools.ietf.org\/html\/rfc1157"},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.1145\/2716281.2836125"},{"key":"e_1_3_2_1_11_1","unstructured":"Cisco. 2023. Policy-Based Routing. https:\/\/www.cisco.com\/c\/en\/us\/td\/docs\/ios-xml\/ios\/iproute_pi\/configuration\/xe-3e\/iri-xe-3e-book\/iri-pbr.pdf."},{"key":"e_1_3_2_1_12_1","unstructured":"Cisco. 2023. Route Maps. https:\/\/www.cisco.com\/c\/en\/us\/td\/docs\/security\/asa\/asa92\/configuration\/general\/asa-general-cli\/route-maps.pdf."},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"crossref","unstructured":"Beno\u00eet Claise. 2004. Cisco Systems NetFlow Services Export Version 9. RFC 3954. https:\/\/tools.ietf.org\/html\/rfc3954","DOI":"10.17487\/rfc3954"},{"key":"e_1_3_2_1_14_1","unstructured":"HE Hurricane Electric. 2023. Hurricane Electric BGP Toolkit. https:\/\/bgp.he.net."},{"key":"e_1_3_2_1_15_1","doi-asserted-by":"crossref","unstructured":"Roni Even and Jonathan Lennox. 2021. Mapping RTP Streams to Controlling Multiple Streams for Telepresence (CLUE) Media Captures. RFC 8849. https:\/\/tools.ietf.org\/html\/rfc8849","DOI":"10.17487\/RFC8849"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"crossref","unstructured":"Paul Ferguson and Daniel Senie. 2000. BCP38 - Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address Spoofing. https:\/\/tools.ietf.org\/html\/bcp38.","DOI":"10.17487\/rfc2827"},{"key":"e_1_3_2_1_17_1","doi-asserted-by":"publisher","DOI":"10.1145\/3050220.3050228"},{"key":"e_1_3_2_1_18_1","volume-title":"Worse Ones Don't","author":"Gigis Petros","year":"2024","unstructured":"Petros Gigis. 2024. Bad Packets Come Back, Worse Ones Don't, Artifacts: Project Repository. https:\/\/github.com\/pgigis\/sigcomm2024-penny."},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1145\/964725.633028"},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1145\/1400097.1400105"},{"key":"e_1_3_2_1_21_1","unstructured":"Tom Henderson and Sally Floyd. 1999. The NewReno Modification to TCP's Fast Recovery Algorithm. RFC 2582. https:\/\/tools.ietf.org\/html\/rfc2582"},{"key":"e_1_3_2_1_22_1","volume-title":"Blink: Fast Connectivity Recovery Entirely in the Data Plane. In 16th USENIX Symposium on Networked Systems Design and Implementation (NSDI 19)","author":"Holterbach Thomas","year":"2019","unstructured":"Thomas Holterbach, Edgar Costa Molero, Maria Apostolaki, Alberto Dainotti, Stefano Vissicchio, and Laurent Vanbever. 2019. Blink: Fast Connectivity Recovery Entirely in the Data Plane. In 16th USENIX Symposium on Networked Systems Design and Implementation (NSDI 19). USENIX Association, Boston, MA, 161--176."},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC9000"},{"key":"e_1_3_2_1_24_1","doi-asserted-by":"publisher","DOI":"10.1145\/3131365.3131383"},{"key":"e_1_3_2_1_25_1","volume-title":"Passive and Active Measurement: 21st International Conference, PAM 2020, Eugene, Oregon, USA, March 30--31, 2020, Proceedings 21","author":"Korczy\u0144ski Maciej","year":"2020","unstructured":"Maciej Korczy\u0144ski, Yevheniya Nosyk, Qasim Lone, Marcin Skwarek, Baptiste Jonglez, and Andrzej Duda. 2020. Don't forget to lock the front door! inferring the deployment of source address validation of inbound traffic. In Passive and Active Measurement: 21st International Conference, PAM 2020, Eugene, Oregon, USA, March 30--31, 2020, Proceedings 21. Springer, 107--121."},{"key":"e_1_3_2_1_26_1","volume-title":"23rd USENIX security symposium (USENIX security 14). 111--125.","author":"K\u00fchrer Marc","unstructured":"Marc K\u00fchrer, Thomas Hupperich, Christian Rossow, and Thorsten Holz. 2014. Exit from Hell? Reducing the Impact of Amplification DDoS Attacks. In 23rd USENIX security symposium (USENIX security 14). 111--125."},{"key":"e_1_3_2_1_27_1","doi-asserted-by":"crossref","unstructured":"Mirja K\u00fchlewind and Brian Trammell. 2022. Manageability of the QUIC Transport Protocol. RFC 9312. https:\/\/tools.ietf.org\/html\/rfc9312","DOI":"10.17487\/RFC9312"},{"key":"e_1_3_2_1_28_1","doi-asserted-by":"publisher","DOI":"10.1145\/3131365.3131367"},{"key":"e_1_3_2_1_29_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-319-54328-4_17"},{"key":"e_1_3_2_1_30_1","doi-asserted-by":"publisher","DOI":"10.1145\/3544216.3544234"},{"key":"e_1_3_2_1_31_1","doi-asserted-by":"publisher","DOI":"10.1145\/2619239.2626291"},{"key":"e_1_3_2_1_32_1","doi-asserted-by":"crossref","unstructured":"John Nagle. 1984. Congestion Control in IP\/TCP Internetworks. RFC 896. https:\/\/tools.ietf.org\/html\/rfc896","DOI":"10.17487\/rfc0896"},{"key":"e_1_3_2_1_33_1","doi-asserted-by":"publisher","DOI":"10.1145\/3098822.3098829"},{"key":"e_1_3_2_1_34_1","unstructured":"RIPE NCC. 2023. Routing Information Service (RIS). https:\/\/www.ripe.net\/analyse\/internet-measurements\/routing-information-service-ris."},{"key":"e_1_3_2_1_35_1","unstructured":"University of Oregon. 2023. RouteViews Project. http:\/\/www.routeviews.org\/."},{"key":"e_1_3_2_1_36_1","doi-asserted-by":"publisher","DOI":"10.1145\/285237.285291"},{"key":"e_1_3_2_1_37_1","unstructured":"Sonia Panchen Neil McKee and Peter Phaal. 2001. InMon Corporation's sFlow: A Method for Monitoring Traffic in Switched and Routed Networks. RFC 3176. https:\/\/tools.ietf.org\/html\/rfc3176"},{"key":"e_1_3_2_1_38_1","unstructured":"Peter Phaal and Marc Lavine. 2004. sFlow Version 5. https:\/\/sflow.org\/sflow_version_5.txt"},{"key":"e_1_3_2_1_39_1","doi-asserted-by":"publisher","DOI":"10.1145\/2619239.2626310"},{"key":"e_1_3_2_1_40_1","volume-title":"Modeling and tools for network simulation","author":"Riley George F","unstructured":"George F Riley and Thomas R Henderson. 2010. The ns-3 network simulator. In Modeling and tools for network simulation. Springer, 15--34."},{"key":"e_1_3_2_1_41_1","doi-asserted-by":"publisher","DOI":"10.1109\/TNSM.2020.3034278"},{"key":"e_1_3_2_1_42_1","unstructured":"The Chromium Projects. 2021. Parsing QUIC Client Hellos. https:\/\/www.chromium.org\/quic\/parse-client-hello\/."},{"key":"e_1_3_2_1_43_1","volume-title":"15th USENIX Symposium on Networked Systems Design and Implementation (NSDI 18)","author":"Tilmans Olivier","year":"2018","unstructured":"Olivier Tilmans, Tobias B\u00fchler, Ingmar Poese, Stefano Vissicchio, and Laurent Vanbever. 2018. Stroboscope: Declarative Network Monitoring on a Budget. In 15th USENIX Symposium on Networked Systems Design and Implementation (NSDI 18). USENIX Association, Renton, WA, 467--482."},{"key":"e_1_3_2_1_44_1","doi-asserted-by":"publisher","DOI":"10.1145\/3517745.3561422"},{"key":"e_1_3_2_1_45_1","doi-asserted-by":"publisher","DOI":"10.1145\/3098822.3098854"},{"key":"e_1_3_2_1_46_1","doi-asserted-by":"publisher","DOI":"10.1145\/2785956.2787483"}],"event":{"name":"ACM SIGCOMM '24: ACM SIGCOMM 2024 Conference","location":"Sydney NSW Australia","acronym":"ACM SIGCOMM '24","sponsor":["SIGCOMM ACM Special Interest Group on Data Communication"]},"container-title":["Proceedings of the ACM SIGCOMM 2024 Conference"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3651890.3672259","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3651890.3672259","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T17:49:13Z","timestamp":1750268953000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3651890.3672259"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2024,8,4]]},"references-count":46,"alternative-id":["10.1145\/3651890.3672259","10.1145\/3651890"],"URL":"https:\/\/doi.org\/10.1145\/3651890.3672259","relation":{},"subject":[],"published":{"date-parts":[[2024,8,4]]},"assertion":[{"value":"2024-08-04","order":3,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}