{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,8,3]],"date-time":"2026-08-03T11:18:02Z","timestamp":1785755882284,"version":"3.56.0"},"publisher-location":"New York, NY, USA","reference-count":54,"publisher":"ACM","license":[{"start":{"date-parts":[[2024,12,2]],"date-time":"2024-12-02T00:00:00Z","timestamp":1733097600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"funder":[{"name":"German Federal Ministry of Education and Research"},{"name":"Hessen State Ministry for Higher Education, Research and Arts"},{"DOI":"10.13039\/501100006374","name":"Deutsche Forschungsgemeinschaft","doi-asserted-by":"publisher","award":["SFB1119"],"award-info":[{"award-number":["SFB1119"]}],"id":[{"id":"10.13039\/501100006374","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2024,12,2]]},"DOI":"10.1145\/3658644.3690368","type":"proceedings-article","created":{"date-parts":[[2024,12,9]],"date-time":"2024-12-09T12:19:20Z","timestamp":1733746760000},"page":"49-63","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":4,"title":["Byzantine-Secure Relying Party for Resilient RPKI"],"prefix":"10.1145","author":[{"ORCID":"https:\/\/orcid.org\/0000-0001-7809-3647","authenticated-orcid":false,"given":"Jens","family":"Frie\u00df","sequence":"first","affiliation":[{"name":"TU Darmstadt &amp; ATHENE, Darmstadt, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-6924-4802","authenticated-orcid":false,"given":"Donika","family":"Mirdita","sequence":"additional","affiliation":[{"name":"TU Darmstadt &amp; ATHENE, Darmstadt, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-8130-0472","authenticated-orcid":false,"given":"Haya","family":"Schulmann","sequence":"additional","affiliation":[{"name":"Goethe-Univ. Frankfurt &amp; ATHENE, Frankfurt, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-7919-9961","authenticated-orcid":false,"given":"Michael","family":"Waidner","sequence":"additional","affiliation":[{"name":"TU Darmstadt &amp; ATHENE, Darmstadt, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2024,12,9]]},"reference":[{"key":"e_1_3_2_1_1_1","doi-asserted-by":"publisher","DOI":"10.1145\/2946802"},{"key":"e_1_3_2_1_2_1","volume-title":"Proceedings of the 21st USENIX Symposium on Networked Systems Design and Implementation.","author":"Antunes Diogo S.","year":"2024","unstructured":"Diogo S. Antunes, Afonso N. Oliveira, Andr\u00e9 Breda, Matheus Guilherme Franco, Henrique Moniz, and Rodrigo Rodrigues. 2024. Alea-BFT: Practical Asynchronous Byzantine Fault Tolerance. In Proceedings of the 21st USENIX Symposium on Networked Systems Design and Implementation."},{"key":"e_1_3_2_1_3_1","unstructured":"Arstechnica. 2019. BGP event sends European mobile traffic through China Telecom for 2 hours. https:\/\/arstechnica.com\/informationtechnology\/2019\/06\/bgp-mishap-sends-europeanmobile-traffic-through\u00adchina-telecom -for-2-hours. (2019)."},{"key":"e_1_3_2_1_4_1","unstructured":"A. Azimov E. Bogomazov R. Bush K. Patel and J. Snijders. November 2020. Verification of AS_PATH Using the Resource Certificate Public Key Infrastructure and Autonomous System Provider Authorization. ( November 2020). https:\/\/datatracker.ietf.org\/doc\/html\/draft-ietf-sidrops-aspa-verification-06."},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"publisher","DOI":"10.1145\/1282380.1282411"},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"crossref","unstructured":"R. Bush and R. Austein. 2013. The Resource Public Key Infrastructure (RPKI) to Router Protocol. RFC 6810. IETF. http:\/\/tools.ietf.org\/rfc\/rfc6810.txt","DOI":"10.17487\/rfc6810"},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.5555\/296806.296824"},{"key":"e_1_3_2_1_8_1","unstructured":"CloudFlare Inc. 2024. CloudFlare Advanced DDoS Protection. https:\/\/www.cloudflare.com\/ddos. (2024)."},{"key":"e_1_3_2_1_9_1","doi-asserted-by":"publisher","DOI":"10.1145\/2834050.2834078"},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.1145\/2934872.2934883"},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"publisher","DOI":"10.1145\/5925.5931"},{"key":"e_1_3_2_1_12_1","unstructured":"Federal Communication Commission. 2024. FCC FACT SHEET * Reporting on Border Gateway Protocol Risk Mitigation Progress. https:\/\/docs.fcc.gov\/public\/attachments\/DOC-402609A1.pdf\/. (2024)."},{"key":"e_1_3_2_1_13_1","volume-title":"Proceedings of the 2022 ACM SIGSAC Conference on Computer and Communications Security. 2007--2015","author":"Gelashvili Rachid","year":"2022","unstructured":"Rachid Gelashvili, Lefteris Kokoris-Kogias, Alberto Sonnino, Alexander Spiegelman, and Zhuolun Xiang. 2022. The Honey Badger of BFT Protocols. In Proceedings of the 2022 ACM SIGSAC Conference on Computer and Communications Security. 2007--2015."},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"crossref","unstructured":"Yossi Gilad Avichai Cohen Amir Herzberg Michael Schapira and Haya Shulman. 2017. Are We There Yet? On RPKI's Deployment and Security. In NDSS.","DOI":"10.14722\/ndss.2017.23123"},{"key":"e_1_3_2_1_15_1","doi-asserted-by":"publisher","DOI":"10.1145\/3286062.3286071"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.1145\/3366625.3369437"},{"key":"e_1_3_2_1_17_1","doi-asserted-by":"publisher","DOI":"10.14722\/ndss.2020.24355"},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.1109\/DSN.2018.00070"},{"key":"e_1_3_2_1_19_1","volume-title":"Stalloris: RPKI Downgrade Attack. In 31st USENIX Security Symposium, USENIX Security 2022","author":"Hlavacek Tomas","year":"2022","unstructured":"Tomas Hlavacek, Philipp Jeitner, Donika Mirdita, Haya Schulmann, and Michael Waidner. 2022. Stalloris: RPKI Downgrade Attack. In 31st USENIX Security Symposium, USENIX Security 2022, Boston, MA, USA, August 10--12, 2022, Kevin R. B. Butler and Kurt Thomas (Eds.). USENIX Association, 4455--4471."},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1145\/3603269.3604861"},{"key":"e_1_3_2_1_21_1","volume-title":"32nd USENIX Security Symposium. 4841--4858","author":"Hlavacek Tomas","year":"2023","unstructured":"Tomas Hlavacek, Haya Shulman, Niklas Vogel, and Michael Waidner. 2023. Keep Your Friends Close, but Your Routeservers Closer: Insights into RPKI Validation in the Internet. In 32nd USENIX Security Symposium. 4841--4858."},{"key":"e_1_3_2_1_22_1","unstructured":"Geoff Huston. 2021. Measuring ROAs and ROV. (2021). https:\/\/stats.labs.apnic.net\/rpki"},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"crossref","unstructured":"G. Huston R. Loomans and G. Michaelson. 2012. A Profile for Resource Certificate Repository Structure. RFC 6481. IETF. http:\/\/tools.ietf.org\/rfc\/rfc6481.txt","DOI":"10.17487\/rfc6481"},{"key":"e_1_3_2_1_24_1","doi-asserted-by":"crossref","unstructured":"G. Huston S. Weiler G. Michaelson and S. Kent. 2012. Resource Public Key Infrastructure (RPKI) Trust Anchor Locator. RFC 6490. IETF. http:\/\/tools.ietf.org\/rfc\/rfc6490.txt","DOI":"10.17487\/rfc6490"},{"key":"e_1_3_2_1_25_1","unstructured":"Santosh Janardhan. 2021. More details about the October 4 outage. https:\/\/engineering.fb.com\/2021\/10\/05\/networking-traffic\/outage-details\/. (2021)."},{"key":"e_1_3_2_1_26_1","volume-title":"USENIX Security symposium","volume":"1","author":"Lad Mohit","year":"2006","unstructured":"Mohit Lad, Daniel Massey, Dan Pei, Yiguo Wu, Beichuan Zhang, and Lixia Zhang. 2006. PHAS: A Prefix Hijack Alert System.. In USENIX Security symposium, Vol. 1. 3."},{"key":"e_1_3_2_1_27_1","first-page":"51","article-title":"Paxos Made Simple","volume":"32","author":"Lamport Leslie","year":"2001","unstructured":"Leslie Lamport. 2001. Paxos Made Simple. ACM SIGACT News (Distributed Computing Column), Vol. 32 (2001), 51--58.","journal-title":"ACM SIGACT News (Distributed Computing Column)"},{"key":"e_1_3_2_1_28_1","doi-asserted-by":"crossref","unstructured":"M. Lepinski and S. Kent. 2012. An Infrastructure to Support Secure Internet Routing. RFC 6480. IETF. http:\/\/tools.ietf.org\/rfc\/rfc6480.txt","DOI":"10.17487\/rfc6480"},{"key":"e_1_3_2_1_29_1","doi-asserted-by":"crossref","unstructured":"M. Lepinski and K. Sriram. 2017. BGPsec Protocol Specification. RFC 8205. IETF. http:\/\/tools.ietf.org\/rfc\/rfc8205.txt","DOI":"10.17487\/RFC8205"},{"key":"e_1_3_2_1_30_1","doi-asserted-by":"publisher","DOI":"10.1145\/3618257.3624806"},{"key":"e_1_3_2_1_31_1","unstructured":"Patrick Maigron. 2023. Regional Internet Registries Statistics. (2023). https:\/\/www-public.imtbs-tsp.eu\/ maigron\/rir-stats\/rir-delegations\/world\/world-asn-by-number.html"},{"key":"e_1_3_2_1_32_1","volume-title":"Poster: Smart BGP Hijacks that Evade Public Route Collectors.","author":"Milolidakis Alexandros","year":"2021","unstructured":"Alexandros Milolidakis. 2021. Poster: Smart BGP Hijacks that Evade Public Route Collectors. (2021)."},{"key":"e_1_3_2_1_33_1","doi-asserted-by":"publisher","DOI":"10.14722\/ndss.2024.241093"},{"key":"e_1_3_2_1_34_1","doi-asserted-by":"publisher","DOI":"10.1145\/3548606.3563536"},{"key":"e_1_3_2_1_35_1","volume-title":"ROV: Improved deployable defense against BGP hijacking.","author":"Morillo Reynaldo","year":"2021","unstructured":"Reynaldo Morillo, Justin Furuness, Amir Herzberg, Cameron Morris, Bing Wang, and James Breslin. 2021. ROV: Improved deployable defense against BGP hijacking. (2021)."},{"key":"e_1_3_2_1_36_1","doi-asserted-by":"publisher","DOI":"10.1145\/3639041"},{"key":"e_1_3_2_1_37_1","unstructured":"Dataplane.org NFP. 2024. RPKI Measurements @ Dataplane.org. (2024). https:\/\/dataplane.org\/rpki.html"},{"key":"e_1_3_2_1_38_1","volume-title":"Diep N Nguyen, Dusit Niyato, Huynh Tuong Nguyen, and Eryk Dutkiewicz.","author":"Nguyen Cong T","year":"2019","unstructured":"Cong T Nguyen, Dinh Thai Hoang, Diep N Nguyen, Dusit Niyato, Huynh Tuong Nguyen, and Eryk Dutkiewicz. 2019. Proof-of-stake consensus mechanisms for future blockchain networks: fundamentals, applications and opportunities. IEEE access, Vol. 7 (2019), 85727--85745."},{"key":"e_1_3_2_1_39_1","doi-asserted-by":"publisher","DOI":"10.5555\/2643634.2643666"},{"key":"e_1_3_2_1_40_1","unstructured":"Lancheng Qin Li Chen Dan Li Honglin Ye and Yutian Wang. 2024. Understanding Route Origin Validation (ROV) Deployment in the Real World and Why MANRS Action 1 Is Not Followed. (2024)."},{"key":"e_1_3_2_1_41_1","unstructured":"Renesys. 2013. The New Threat: Targeted Internet Traffic Misdirection. http:\/\/www.renesys.com\/2013\/11\/mitm-internet-hijacking\/. (2013)."},{"key":"e_1_3_2_1_42_1","volume-title":"YouTube Hijacking: A RIPE NCC RIS case study. (March","author":"RIPE NCC.","year":"2008","unstructured":"RIPE NCC. 2008. YouTube Hijacking: A RIPE NCC RIS case study. (March 2008)."},{"key":"e_1_3_2_1_43_1","doi-asserted-by":"publisher","DOI":"10.1108\/eb024706"},{"key":"e_1_3_2_1_44_1","doi-asserted-by":"publisher","DOI":"10.1109\/JSAC.2016.2558978"},{"key":"e_1_3_2_1_45_1","volume-title":"ARTEMIS: Neutralizing BGP hijacking within a minute","author":"Sermpezis Pavlos","year":"2018","unstructured":"Pavlos Sermpezis, Vasileios Kotronis, Petros Gigis, Xenofontas Dimitropoulos, Danilo Cicalese, Alistair King, and Alberto Dainotti. 2018. ARTEMIS: Neutralizing BGP hijacking within a minute. IEEE\/ACM transactions on networking, Vol. 26, 6 (2018), 2471--2486."},{"key":"e_1_3_2_1_46_1","volume-title":"Privacy Preserving and Resilient RPKI. In IEEE INFOCOM 2021-IEEE Conference on Computer Communications. IEEE, 1--10","author":"Shrishak Kris","year":"2021","unstructured":"Kris Shrishak and Haya Shulman. 2021. Privacy Preserving and Resilient RPKI. In IEEE INFOCOM 2021-IEEE Conference on Computer Communications. IEEE, 1--10."},{"key":"e_1_3_2_1_47_1","doi-asserted-by":"crossref","unstructured":"Su Yingying Li Dan Chen Li Li Qi and Ling Sitong. dRR: A Decentralized Scalable and Auditable Architecture for RPKI Repository. https:\/\/www.ndss-symposium.org\/wp-content\/uploads\/2024--368-paper.pdf. ( ????).","DOI":"10.14722\/ndss.2024.24368"},{"key":"e_1_3_2_1_48_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-030-44081-7_5"},{"key":"e_1_3_2_1_49_1","unstructured":"Andree Toonk. 2014. Hijack Event Today by Indosat. http:\/\/www.bgpmon.net\/hijack-event-today-by-indosat\/. (2014)."},{"key":"e_1_3_2_1_50_1","unstructured":"Andree Toonk. 2014. Turkey Hijacking IP Addresses for Popular Global DNS Providers. (2014). BGPMon."},{"key":"e_1_3_2_1_51_1","volume-title":"Rpkiller: Threat analysis from an RPKI relying party perspective. arXiv preprint arXiv:2203.00993","author":"van Hove Koen","year":"2022","unstructured":"Koen van Hove, Jeroen van der Ham, and Roland van Rijswijk-Deij. 2022. Rpkiller: Threat analysis from an RPKI relying party perspective. arXiv preprint arXiv:2203.00993 (2022)."},{"key":"e_1_3_2_1_52_1","doi-asserted-by":"crossref","unstructured":"Pierre-Antoine Vervier Olivier Thonnard and Marc Dacier. 2015. Mind Your Blocks: On the Stealthiness of Malicious BGP Hijacks. In NDSS.","DOI":"10.14722\/ndss.2015.23035"},{"key":"e_1_3_2_1_53_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICNP.2011.6089080"},{"key":"e_1_3_2_1_54_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2011.45"}],"event":{"name":"CCS '24: ACM SIGSAC Conference on Computer and Communications Security","location":"Salt Lake City UT USA","acronym":"CCS '24","sponsor":["SIGSAC ACM Special Interest Group on Security, Audit, and Control"]},"container-title":["Proceedings of the 2024 on ACM SIGSAC Conference on Computer and Communications Security"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3658644.3690368","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3658644.3690368","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,8,22]],"date-time":"2025-08-22T06:04:33Z","timestamp":1755842673000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3658644.3690368"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2024,12,2]]},"references-count":54,"alternative-id":["10.1145\/3658644.3690368","10.1145\/3658644"],"URL":"https:\/\/doi.org\/10.1145\/3658644.3690368","relation":{},"subject":[],"published":{"date-parts":[[2024,12,2]]},"assertion":[{"value":"2024-12-09","order":3,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}