{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,8]],"date-time":"2026-10-08T11:39:32Z","timestamp":1791459572257,"version":"4.3.4"},"publisher-location":"New York, NY, USA","reference-count":36,"publisher":"ACM","license":[{"start":{"date-parts":[[2024,7,30]],"date-time":"2024-07-30T00:00:00Z","timestamp":1722297600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0\/"}],"funder":[{"DOI":"10.13039\/501100006374","name":"Stiftelsen f\u00f6r\u00a0Strategisk Forskning","doi-asserted-by":"publisher","award":["RIT 08-0065"],"award-info":[{"award-number":["RIT 08-0065"]}],"id":[{"id":"10.13039\/501100006374","id-type":"DOI","asserted-by":"publisher"}]},{"DOI":"10.13039\/501100006374","name":"Vetenskapsr\u00e5det","doi-asserted-by":"publisher","award":["621-2023-05363"],"award-info":[{"award-number":["621-2023-05363"]}],"id":[{"id":"10.13039\/501100006374","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2024,7,30]]},"DOI":"10.1145\/3664476.3664521","type":"proceedings-article","created":{"date-parts":[[2024,7,25]],"date-time":"2024-07-25T12:35:50Z","timestamp":1721910950000},"page":"1-12","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":4,"title":["Monitor-based Testing of Network Protocol Implementations Using Symbolic Execution"],"prefix":"10.1145","author":[{"ORCID":"https:\/\/orcid.org\/0000-0003-0090-634X","authenticated-orcid":false,"given":"Hooman","family":"Asadian","sequence":"first","affiliation":[{"name":"Department of Information Technology, Uppsala University, Sweden"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-5185-0035","authenticated-orcid":false,"given":"Paul","family":"Fiterau-Brostean","sequence":"additional","affiliation":[{"name":"Department of Information Technology, Uppsala University, Sweden"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-7897-601X","authenticated-orcid":false,"given":"Bengt","family":"Jonsson","sequence":"additional","affiliation":[{"name":"Department of Information Technology, Uppsala University, Sweden"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-9657-0179","authenticated-orcid":false,"given":"Konstantinos","family":"Sagonas","sequence":"additional","affiliation":[{"name":"Department of Information Technology, Uppsala University, Sweden and School of Electrical and Computer Engineering, National Technical University of Athens, Greece"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2024,7,30]]},"reference":[{"key":"e_1_3_2_1_1_1","doi-asserted-by":"publisher","DOI":"10.1145\/3533767.3534376"},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1016\/j.tcs.2004.11.007"},{"key":"e_1_3_2_1_3_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICST53961.2022.00019"},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.5281\/zenodo.5929867"},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"publisher","unstructured":"Hooman Asadian Paul Fiter\u0103u-Bro\u015ftean Bengt Jonsson and Konstantinos Sagonas. 2024. Replication material for the ARES 2024 paper: Monitor-based Testing of Network Protocol Implementations Using Symbolic Execution. https:\/\/doi.org\/10.5281\/zenodo.11945614","DOI":"10.5281\/zenodo.11945614"},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"publisher","DOI":"10.1145\/2699444"},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.1145\/3023357"},{"key":"e_1_3_2_1_8_1","volume-title":"Proceedings of the 8th USENIX Conference on Operating Systems Design and Implementation","author":"Cadar Cristian","year":"2008","unstructured":"Cristian Cadar, Daniel Dunbar, and Dawson Engler. 2008. KLEE: Unassisted and Automatic Generation of High-Coverage Tests for Complex Systems Programs. In Proceedings of the 8th USENIX Conference on Operating Systems Design and Implementation (San Diego, California) (OSDI \u201908). USENIX Association, Berkeley, CA, USA, 209\u2013224. http:\/\/dl.acm.org\/citation.cfm?id=1855741.1855756"},{"key":"e_1_3_2_1_9_1","doi-asserted-by":"publisher","DOI":"10.1145\/2408776.2408795"},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.1109\/MSP.2014.66"},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"publisher","DOI":"10.4204\/EPTCS.254.2"},{"key":"e_1_3_2_1_12_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2017.40"},{"key":"e_1_3_2_1_13_1","doi-asserted-by":"publisher","DOI":"10.14722\/ndss.2019.23430"},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"publisher","DOI":"10.1145\/3180155.3180226"},{"key":"e_1_3_2_1_15_1","doi-asserted-by":"publisher","DOI":"10.1145\/2110356.2110358"},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"crossref","unstructured":"Tim Dierks and Eric Rescorla. 2008. The Transport Layer Security TLS Protocol Version 1.2. RFC 5246. http:\/\/www.rfc-editor.org\/rfc\/rfc5246.txt","DOI":"10.17487\/rfc5246"},{"key":"e_1_3_2_1_17_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-319-94111-0_2"},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC9000"},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1145\/360248.360252"},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1145\/3341302.3342087"},{"key":"e_1_3_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.1145\/3510003.3510082"},{"key":"e_1_3_2_1_22_1","unstructured":"Bodo M\u00f6ller Thai Duong and Krzysztof Kotowicz. 2014. This POODLE bites: exploiting the SSL 3.0 fallback. https:\/\/www.openssl.org\/\u00a0bodo\/ssl-poodle.pdf"},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"crossref","unstructured":"R. Moskowitz P. Nikander P. Jokela and T. Henderson. 2008. Host Identity Protocol. RFC 5201. https:\/\/www.ietd.org\/rfc\/rfc5201.txt updated by RFC 6253.","DOI":"10.17487\/rfc5201"},{"key":"e_1_3_2_1_24_1","volume-title":"Analyzing Protocol Implementations for Interoperability. In 12th USENIX Symposium on Networked Systems Design and Implementation","author":"Pedrosa Luis","year":"2015","unstructured":"Luis Pedrosa, Ari Fogel, Nupur Kothari, Ramesh Govindan, Ratul Mahajan, and Todd\u00a0D. Millstein. 2015. Analyzing Protocol Implementations for Interoperability. In 12th USENIX Symposium on Networked Systems Design and Implementation (Oakland, CA, USA) (NSDI 15). USENIX Association, 485\u2013498. https:\/\/www.usenix.org\/conference\/nsdi15\/technical-sessions\/presentation\/pedrosa"},{"key":"e_1_3_2_1_25_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICST46399.2020.00062"},{"key":"e_1_3_2_1_26_1","doi-asserted-by":"publisher","DOI":"10.1145\/3284850.3284853"},{"key":"e_1_3_2_1_27_1","doi-asserted-by":"crossref","unstructured":"Eric Rescorla and Nagendra Modadugu. 2012. Datagram Transport Layer Security Version 1.2. RFC 6347. 32\u00a0pages. http:\/\/www.rfc-editor.org\/rfc\/rfc6347.txt","DOI":"10.17487\/rfc6347"},{"key":"e_1_3_2_1_28_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICNP.2012.6459940"},{"key":"e_1_3_2_1_29_1","doi-asserted-by":"publisher","DOI":"10.1145\/1791212.1791235"},{"key":"e_1_3_2_1_30_1","doi-asserted-by":"publisher","DOI":"10.1145\/1460412.1460485"},{"key":"e_1_3_2_1_31_1","doi-asserted-by":"publisher","DOI":"10.1145\/353323.353382"},{"key":"e_1_3_2_1_32_1","doi-asserted-by":"publisher","DOI":"10.1109\/TSE.2014.2323977"},{"key":"e_1_3_2_1_33_1","volume-title":"Unix network programming","author":"Stevens Richard","unstructured":"W.\u00a0Richard Stevens. 1990. Unix network programming. Prentice Hall."},{"key":"e_1_3_2_1_34_1","doi-asserted-by":"publisher","DOI":"10.1109\/JIOT.2023.3236694"},{"key":"e_1_3_2_1_35_1","doi-asserted-by":"publisher","DOI":"10.1371\/journal.pone.0188229"},{"key":"e_1_3_2_1_36_1","unstructured":"Micha\u0142 Zalewski. 2013. American Fuzzy Lop. http:\/\/lcamtuf.coredump.cx\/afl\/."}],"event":{"name":"ARES 2024: The 19th International Conference on Availability, Reliability and Security","location":"Vienna Austria","acronym":"ARES 2024"},"container-title":["Proceedings of the 19th International Conference on Availability, Reliability and Security"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3664476.3664521","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3664476.3664521","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,8,22]],"date-time":"2025-08-22T16:51:44Z","timestamp":1755881504000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3664476.3664521"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2024,7,30]]},"references-count":36,"alternative-id":["10.1145\/3664476.3664521","10.1145\/3664476"],"URL":"https:\/\/doi.org\/10.1145\/3664476.3664521","relation":{},"subject":[],"published":{"date-parts":[[2024,7,30]]},"assertion":[{"value":"2024-07-30","order":3,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}