{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,9,29]],"date-time":"2026-09-29T13:50:53Z","timestamp":1790689853122,"version":"4.1.0"},"publisher-location":"New York, NY, USA","reference-count":39,"publisher":"ACM","funder":[{"DOI":"10.13039\/501100006374","name":"H2020 Marie Sk\u0142odowska-Curie Actions","doi-asserted-by":"publisher","award":["101008233"],"award-info":[{"award-number":["101008233"]}],"id":[{"id":"10.13039\/501100006374","id-type":"DOI","asserted-by":"publisher"}]}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2025,7,22]]},"DOI":"10.1145\/3744200.3744758","type":"proceedings-article","created":{"date-parts":[[2025,7,14]],"date-time":"2025-07-14T13:43:41Z","timestamp":1752500621000},"page":"39-46","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":6,"title":["PhantomLink: Emulating Virtual End-to-End Links on Ground and in Orbit"],"prefix":"10.1145","author":[{"ORCID":"https:\/\/orcid.org\/0009-0002-1436-6196","authenticated-orcid":false,"given":"Robin","family":"Ohs","sequence":"first","affiliation":[{"name":"Saarland University, Saarbr\u00fccken, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-5170-2019","authenticated-orcid":false,"given":"Gregory F.","family":"Stock","sequence":"additional","affiliation":[{"name":"Saarland University, Saarbr\u00fccken, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-9816-6989","authenticated-orcid":false,"given":"Juan A.","family":"Fraire","sequence":"additional","affiliation":[{"name":"Saarland University, Saarbr\u00fccken, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-2766-9615","authenticated-orcid":false,"given":"Holger","family":"Hermanns","sequence":"additional","affiliation":[{"name":"Saarland University, Saarbr\u00fccken, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-7113-7376","authenticated-orcid":false,"given":"Andreas","family":"Schmidt","sequence":"additional","affiliation":[{"name":"Saarland University, Saarbr\u00fccken, Germany"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2025,7,22]]},"reference":[{"key":"e_1_3_2_1_1_1","unstructured":"ANSYS Inc. 2025. Systems tool kit (STK). Version 12.10.0. (2025). https:\/\/www.ansys.com\/products\/missions\/ansys-stk."},{"key":"e_1_3_2_1_2_1","doi-asserted-by":"publisher","DOI":"10.1145\/3614204.3616103"},{"key":"e_1_3_2_1_3_1","doi-asserted-by":"publisher","DOI":"10.1145\/3359989.3365407"},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-3-031-28486-1_14"},{"key":"e_1_3_2_1_5_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC5681"},{"key":"e_1_3_2_1_6_1","unstructured":"Alex Butler. 2025. spin_sleep: accurate sleeping. Version 1.3.1. (2025). https:\/\/github.com\/alexheretic\/spin-sleep."},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.1145\/3009824"},{"key":"e_1_3_2_1_8_1","volume-title":"Retrieved","author":"Centre","year":"2022","unstructured":"Centre national d'\u00e9tudes spatiales (CNES). 2022. OpenSAND - open satellite network demonstrator. Retrieved Jan. 28, 2025 from https:\/\/github.com\/CNES\/opensand."},{"key":"e_1_3_2_1_9_1","doi-asserted-by":"publisher","DOI":"10.1109\/ASMS\/SPSC64465.2025.10946025"},{"key":"e_1_3_2_1_10_1","unstructured":"Robert Clipsham. 2024. pnet: cross-platform low level networking using the rust programming language. Version 0.35.0. (2024). https:\/\/github.com\/libpnet\/libpnet."},{"key":"e_1_3_2_1_11_1","volume-title":"Retrieved","author":"Inc.","year":"2024","unstructured":"Cloudflare, Inc. 2024. Year in Review 2024: SpaceX Starlink Traffic Trends. Retrieved Jan. 28, 2025 from https:\/\/radar.cloudflare.com\/year-in-review\/2024#starlink-traffic.trends."},{"key":"e_1_3_2_1_12_1","unstructured":"Alex Crichton. 2024. crossbeam: tools for concurrent programming. Version 0.8.4. (2024). https:\/\/github.com\/crossbeam-rs\/crossbeam."},{"key":"e_1_3_2_1_13_1","volume-title":"Proceedings of the 23rd Ka and Broadband Communications Conference, Kaconf 2017","author":"Dubois Emmanuel","year":"2017","unstructured":"Emmanuel Dubois, Nicolas Kuhn, Jean-Baptiste Dup\u00e9, Patrick G\u00e9lard, Fabrice Arnal, C\u00e9dric Baudoin, Aur\u00e9lien Delrieu, and David Pradas. 2017. OpenSAND: an open source SATCOM emulator. In Proceedings of the 23rd Ka and Broadband Communications Conference, Kaconf 2017. https:\/\/proceedings.kaconf.com\/papers\/2017\/ka13_2.pdf."},{"key":"e_1_3_2_1_14_1","volume-title":"Lawrence Berkeley National Laboratory","year":"2024","unstructured":"ESnet, Lawrence Berkeley National Laboratory. 2024. iperf3: a TCP, UDP, and SCTP network bandwidth measurement tool. Version 3.18. (2024). https:\/\/github.com\/esnet\/iperf."},{"key":"e_1_3_2_1_15_1","volume-title":"Retrieved","author":"European Space Agency (ESA).","year":"2022","unstructured":"European Space Agency (ESA). 2022. SCNE - satellite constellation network emulator. Retrieved Jan. 28, 2025 from https:\/\/connectivity.esa.int\/projects\/scne."},{"key":"e_1_3_2_1_16_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC2018"},{"key":"e_1_3_2_1_17_1","doi-asserted-by":"publisher","DOI":"10.1109\/WOWMOM54355.2022.00072"},{"key":"e_1_3_2_1_18_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC6582"},{"key":"e_1_3_2_1_19_1","doi-asserted-by":"publisher","DOI":"10.1145\/3286062.3286075"},{"key":"e_1_3_2_1_20_1","doi-asserted-by":"publisher","DOI":"10.1145\/3419394.3423635"},{"key":"e_1_3_2_1_21_1","volume-title":"Retrieved","author":"Kuznetsov Alexey N.","year":"2000","unstructured":"Alexey N. Kuznetsov. 2000. tc - show \/ manipulate traffic control settings. (2000). Retrieved Jan. 20, 2025 from https:\/\/man7.org\/linux\/man-pages\/man8\/tc.8.html."},{"key":"e_1_3_2_1_22_1","volume-title":"Retrieved","author":"Alexey","year":"2025","unstructured":"Alexey N. Kuznetsov and Stephen Hemminger. 2013. ip-netns -process network namespace management. (2013). Retrieved Jan. 20, 2025 from https:\/\/man7.org\/linux\/man-pages\/man8\/ip-netns.8.html."},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"publisher","DOI":"10.1145\/3696348.3696867"},{"key":"e_1_3_2_1_24_1","volume-title":"20th USENIX Symposium on Networked Systems Design and Implementation, NSDI 2023","author":"Zeqi","year":"2023","unstructured":"Zeqi Lai et al. 2023. StarryNet: empowering researchers to evaluate futuristic integrated space and terrestrial networks. In 20th USENIX Symposium on Networked Systems Design and Implementation, NSDI 2023, Boston, MA, April 17-19, 2023. Mahesh Balakrishnan and Manya Ghobadi, (Eds.) USENIX Association, 1309--1324. https:\/\/www.usemx.org\/conference\/nsdi23\/presentation\/lai-zeqi."},{"key":"e_1_3_2_1_25_1","doi-asserted-by":"publisher","DOI":"10.1145\/3663408.3663430"},{"key":"e_1_3_2_1_26_1","doi-asserted-by":"publisher","DOI":"10.1007\/978-981-10-7877-4_3"},{"key":"e_1_3_2_1_27_1","doi-asserted-by":"publisher","DOI":"10.1145\/2663171.2663188"},{"key":"e_1_3_2_1_28_1","volume-title":"Proceedings of the 2015 USENIX Annual Technical Conference, USENIX ATC 2015. Shan Lu and Erik Riedel, (Eds.) USENIX Association, 417--429","author":"Netravali Ravi","year":"2015","unstructured":"Ravi Netravali, Anirudh Sivaraman, Somak Das, Ameesh Goyal, Keith Winstein, James Mickens, and Hari Balakrishnan. 2015. Mahimahi: accurate record-and-replay for HTTP. In Proceedings of the 2015 USENIX Annual Technical Conference, USENIX ATC 2015. Shan Lu and Erik Riedel, (Eds.) USENIX Association, 417--429. https:\/\/www.usenix.org\/conference\/atc15\/technical-session\/presentation\/netravali."},{"key":"e_1_3_2_1_29_1","doi-asserted-by":"publisher","unstructured":"Robin Ohs Gregory F. Stock Juan A. Fraire Holger Hermanns and Andreas Schmidt. 2025. PhantomLink: Emulating virtual end-to-end links on ground and in orbit. Version 0.1.0. (2025). doi:10.5281\/zenodo.15680652.","DOI":"10.5281\/zenodo.15680652"},{"key":"e_1_3_2_1_30_1","doi-asserted-by":"publisher","DOI":"10.1109\/ASMS\/SPSC64465.2025.10946051"},{"key":"e_1_3_2_1_31_1","volume-title":"Retrieved","author":"Qatar Airways","year":"2024","unstructured":"Qatar Airways Company Q.C.S.C. 2024. Qatar Airways launches the world's first Boeing 777 Starlink-equipped flight. Retrieved Jan. 20, 2025 from https:\/\/www.qatarairways.com\/press-releases\/en-WW\/242734-qatar-airways-launches-the-world-s-first-boeing-777-starlink-equipped-flight-taking-the-future-of-in-flight-connectivity-to-new-height."},{"key":"e_1_3_2_1_32_1","volume-title":"Retrieved","author":"SES","year":"2020","unstructured":"SES S.A. 2020. Connected cruises - delivering a differentiated passenger experience with O3b mPOWER. Retrieved Jan. 21, 2025 from https:\/\/www.ses.com\/sites\/default\/files\/2020-01\/O3b_mPOWER_ExecutiveGuide_SES_Maritime_Connected_Cruises.pdf."},{"key":"e_1_3_2_1_33_1","unstructured":"Space Exploration Holdings LLC. 2019. SpaceX non-geostationary satellite system: attachment A. FCC IBFS SAT-MOD-20190830-00087. (2019)."},{"key":"e_1_3_2_1_34_1","doi-asserted-by":"publisher","DOI":"10.1109\/ICCWORKSHOPS59551.2024.10615714"},{"key":"e_1_3_2_1_35_1","doi-asserted-by":"publisher","unstructured":"Andr\u00e1s Varga. 2010. OMNeT++. In Modeling and Tools for Network Simulation. Klaus Wehrle Mesut G\u00fcnes and James Gross (Eds.) Springer 35--59. doi:10.1007\/978-3-642-12331-3_3.","DOI":"10.1007\/978-3-642-12331-3_3"},{"key":"e_1_3_2_1_36_1","doi-asserted-by":"publisher","DOI":"10.1109\/49.345883"},{"key":"e_1_3_2_1_37_1","unstructured":"Wireshark Foundation. 2025. Wireshark: network protocol analyzer. Version 4.4.7. (2025). https:\/\/www.wireshark.org\/."},{"key":"e_1_3_2_1_38_1","doi-asserted-by":"publisher","DOI":"10.17487\/RFC9438"},{"key":"e_1_3_2_1_39_1","doi-asserted-by":"publisher","DOI":"10.1145\/3697253.3697263"}],"event":{"name":"ANRW '25: ACM\/IRTF Applied Networking Research Workshop 2025","location":"Madrid Spain","acronym":"ANRW '25","sponsor":["Internet Society Internet Society","SIGCOMM ACM Special Interest Group on Data Communication","IRTF Internet Research Task Force"]},"container-title":["Proceedings of the Applied Networking Research Workshop on ZZZ"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/3744200.3744758","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,8,26]],"date-time":"2025-08-26T20:12:24Z","timestamp":1756239144000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/3744200.3744758"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2025,7,22]]},"references-count":39,"alternative-id":["10.1145\/3744200.3744758","10.1145\/3744200"],"URL":"https:\/\/doi.org\/10.1145\/3744200.3744758","relation":{},"subject":[],"published":{"date-parts":[[2025,7,22]]},"assertion":[{"value":"2025-07-22","order":3,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}