{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,10,5]],"date-time":"2026-10-05T20:06:03Z","timestamp":1791230763508,"version":"4.1.0"},"publisher-location":"New York, NY, USA","reference-count":42,"publisher":"ACM","license":[{"start":{"date-parts":[[2008,10,27]],"date-time":"2008-10-27T00:00:00Z","timestamp":1225065600000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/www.acm.org\/publications\/policies\/copyright_policy#Background"}],"content-domain":{"domain":["dl.acm.org"],"crossmark-restriction":true},"short-container-title":[],"published-print":{"date-parts":[[2008,10,27]]},"DOI":"10.1145\/1455770.1455820","type":"proceedings-article","created":{"date-parts":[[2008,11,6]],"date-time":"2008-11-06T13:49:50Z","timestamp":1225979390000},"page":"391-402","update-policy":"https:\/\/doi.org\/10.1145\/crossmark-policy","source":"Crossref","is-referenced-by-count":143,"title":["Tupni"],"prefix":"10.1145","author":[{"given":"Weidong","family":"Cui","sequence":"first","affiliation":[{"name":"Microsoft Research, Redmond, WA, USA"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Marcus","family":"Peinado","sequence":"additional","affiliation":[{"name":"Microsoft Corporation, Redmond, WA, USA"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Karl","family":"Chen","sequence":"additional","affiliation":[{"name":"University of California, Berkeley, CA, USA"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Helen J.","family":"Wang","sequence":"additional","affiliation":[{"name":"Microsoft Research, Redmond, WA, USA"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Luis","family":"Irun-Briz","sequence":"additional","affiliation":[{"name":"Microsoft Corporation, Redmond, WA, USA"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"320","published-online":{"date-parts":[[2008,10,27]]},"reference":[{"key":"e_1_3_2_1_1_1","unstructured":"International Telecommunication Union Recommendation T.81: JPEG Specification. http:\/\/www.w3.org\/Graphics\/JPEG\/itu-t81.pdf.  International Telecommunication Union Recommendation T.81: JPEG Specification. http:\/\/www.w3.org\/Graphics\/JPEG\/itu-t81.pdf."},{"key":"e_1_3_2_1_2_1","unstructured":"TIFF Revision 6.0. http:\/\/partners.adobe.com\/public\/developer\/en\/tiff\/TIFF6.pdf.  TIFF Revision 6.0. http:\/\/partners.adobe.com\/public\/developer\/en\/tiff\/TIFF6.pdf."},{"key":"e_1_3_2_1_3_1","volume-title":"Compilers: Principles, Techniques, and Tools","author":"Aho A.","year":"2007","unstructured":"A. Aho , M. Lam , R. Sethi , and J. Ullman . Compilers: Principles, Techniques, and Tools . Addison-Wesley , 2007 . A. Aho, M. Lam, R. Sethi, and J. Ullman. Compilers: Principles, Techniques, and Tools. Addison-Wesley, 2007."},{"key":"e_1_3_2_1_4_1","doi-asserted-by":"publisher","DOI":"10.1145\/1134760.1220164"},{"key":"e_1_3_2_1_5_1","volume-title":"Proceedings of the 14th Annual Network & Distributed System Security Symposium (NDSS)","author":"Borisov N.","year":"2007","unstructured":"N. Borisov , D. J. Brumley , H. J. Wang , J. Dunagan , P. Joshi , and C. Guo . A Generic Application-Level Protocol Analyzer and its Language . In Proceedings of the 14th Annual Network & Distributed System Security Symposium (NDSS) , March 2007 . N. Borisov, D. J. Brumley, H. J. Wang, J. Dunagan, P. Joshi, and C. Guo. A Generic Application-Level Protocol Analyzer and its Language. In Proceedings of the 14th Annual Network & Distributed System Security Symposium (NDSS), March 2007."},{"key":"e_1_3_2_1_6_1","doi-asserted-by":"publisher","DOI":"10.1145\/1315245.1315286"},{"key":"e_1_3_2_1_7_1","doi-asserted-by":"publisher","DOI":"10.1006\/jagm.2000.1155"},{"key":"e_1_3_2_1_8_1","doi-asserted-by":"publisher","DOI":"10.1145\/1108792.1108814"},{"key":"e_1_3_2_1_9_1","doi-asserted-by":"publisher","DOI":"10.1145\/1294261.1294274"},{"key":"e_1_3_2_1_10_1","doi-asserted-by":"publisher","DOI":"10.1145\/1095810.1095824"},{"key":"e_1_3_2_1_11_1","doi-asserted-by":"publisher","DOI":"10.1109\/MICRO.2004.26"},{"key":"e_1_3_2_1_12_1","volume-title":"Proceedings of the 16th USENIX Security Symposium","author":"Cui W.","year":"2007","unstructured":"W. Cui , J. Kannan , and H. J. Wang . Discoverer: Automatic Protocol Reverse Engineering from Network Traces . In Proceedings of the 16th USENIX Security Symposium , Boston, MA , August 2007 . W. Cui, J. Kannan, and H. J. Wang. Discoverer: Automatic Protocol Reverse Engineering from Network Traces. In Proceedings of the 16th USENIX Security Symposium, Boston, MA, August 2007."},{"key":"e_1_3_2_1_13_1","volume-title":"Proceedings of the 13th Symposium on Network and Distributed System Security (NDSS 2006)","author":"Cui W.","year":"2006","unstructured":"W. Cui , V. Paxson , N. C. Weaver , and R. H. Katz . Protocol-Independent Adatpive Replay of Application Dialog . In Proceedings of the 13th Symposium on Network and Distributed System Security (NDSS 2006) , February 2006 . W. Cui, V. Paxson, N. C. Weaver, and R. H. Katz. Protocol-Independent Adatpive Replay of Application Dialog. In Proceedings of the 13th Symposium on Network and Distributed System Security (NDSS 2006), February 2006."},{"key":"e_1_3_2_1_14_1","doi-asserted-by":"publisher","DOI":"10.1109\/SP.2007.34"},{"key":"e_1_3_2_1_15_1","volume-title":"The Daikon System for Dynamic Detection of Likely Invariants","author":"Ernst M. D.","year":"2007","unstructured":"M. D. Ernst , J. H. Perkins , P. J. Guo , S. McCamant , C. Pacheco , M. S. Tschantz , and C. Xiao . The Daikon System for Dynamic Detection of Likely Invariants . 2007 . M. D. Ernst, J. H. Perkins, P. J. Guo, S. McCamant, C. Pacheco, M. S. Tschantz, and C. Xiao. The Daikon System for Dynamic Detection of Likely Invariants. 2007."},{"key":"e_1_3_2_1_16_1","unstructured":"R. Fielding J. Gettys J. Mogul H. Frystyk L. Masinter P. Leach and T. Berners-Lee. RFC 2616: Hypertext Transfer Protocol -- HTTP\/1.1. http:\/\/www.w3.org\/Protocols\/rfc2616\/rfc2616.html.   R. Fielding J. Gettys J. Mogul H. Frystyk L. Masinter P. Leach and T. Berners-Lee. RFC 2616: Hypertext Transfer Protocol -- HTTP\/1.1. http:\/\/www.w3.org\/Protocols\/rfc2616\/rfc2616.html."},{"key":"e_1_3_2_1_17_1","doi-asserted-by":"publisher","DOI":"10.1145\/1328438.1328488"},{"key":"e_1_3_2_1_18_1","unstructured":"Gaim Instant Messaging Client. http:\/\/gaim.sourceforge.net.  Gaim Instant Messaging Client. http:\/\/gaim.sourceforge.net."},{"key":"e_1_3_2_1_19_1","volume-title":"Proceedings of the 15th Annual Network and Distributed System Security Symposium (NDSS)","author":"Godefroid P.","year":"2008","unstructured":"P. Godefroid , M. Levin , and D. Molnar . Automated Whitebox Fuzz Testing . In Proceedings of the 15th Annual Network and Distributed System Security Symposium (NDSS) , February 2008 . P. Godefroid, M. Levin, and D. Molnar. Automated Whitebox Fuzz Testing. In Proceedings of the 15th Annual Network and Distributed System Security Symposium (NDSS), February 2008."},{"key":"e_1_3_2_1_20_1","unstructured":"T. O. Group. Dce 1.1: Remote procedure call. http:\/\/www.opengroup.org\/onlinepubs\/9629399\/toc.htm.  T. O. Group. Dce 1.1: Remote procedure call. http:\/\/www.opengroup.org\/onlinepubs\/9629399\/toc.htm."},{"key":"e_1_3_2_1_21_1","doi-asserted-by":"publisher","DOI":"10.1007\/s00037-006-0205-6"},{"key":"e_1_3_2_1_22_1","doi-asserted-by":"publisher","DOI":"10.1145\/1177080.1177096"},{"key":"e_1_3_2_1_23_1","doi-asserted-by":"publisher","DOI":"10.1007\/11856214_10"},{"key":"e_1_3_2_1_24_1","doi-asserted-by":"publisher","DOI":"10.1109\/CSAC.2005.49"},{"key":"e_1_3_2_1_25_1","doi-asserted-by":"publisher","DOI":"10.1109\/WCRE.2006.29"},{"key":"e_1_3_2_1_26_1","volume-title":"Proceedings of NDSS'2008","author":"Lin Z.","year":"2008","unstructured":"Z. Lin , X. Jiang , D. Xu , and X. Zhang . Automatic Protocol Format Reverse Engineering through Context-Aware Monitored Execution . In Proceedings of NDSS'2008 , 2008 . Z. Lin, X. Jiang, D. Xu, and X. Zhang. Automatic Protocol Format Reverse Engineering through Context-Aware Monitored Execution. In Proceedings of NDSS'2008, 2008."},{"key":"e_1_3_2_1_27_1","doi-asserted-by":"publisher","DOI":"10.1145\/1453101.1453114"},{"key":"e_1_3_2_1_28_1","unstructured":"P. Mockapetris. RFC 1035: Domain Names -- Implementation and Specification. http:\/\/www.faqs.org\/rfcs\/rfc1035.html.   P. Mockapetris. RFC 1035: Domain Names -- Implementation and Specification. http:\/\/www.faqs.org\/rfcs\/rfc1035.html."},{"key":"e_1_3_2_1_29_1","doi-asserted-by":"publisher","DOI":"10.1145\/1180405.1180444"},{"key":"e_1_3_2_1_30_1","volume-title":"Proceeding of the Network and Distributed System Security Symposium (NDSS)","author":"Newsome J.","year":"2006","unstructured":"J. Newsome , D. Brumley , and D. Song . Vulnerability-specific execution filtering for exploit prevention on commodity software . In Proceeding of the Network and Distributed System Security Symposium (NDSS) , 2006 . J. Newsome, D. Brumley, and D. Song. Vulnerability-specific execution filtering for exploit prevention on commodity software. In Proceeding of the Network and Distributed System Security Symposium (NDSS), 2006."},{"key":"e_1_3_2_1_31_1","volume-title":"Proceedings of the 12th Symposium on Network and Distributed System Security (NDSS)","author":"Newsome J.","year":"2005","unstructured":"J. Newsome and D. Song . Dynamic Taint Analysis for Automatic Detection, Analysis, and Signature Generation of Exploits on Commodity Software . In Proceedings of the 12th Symposium on Network and Distributed System Security (NDSS) , February 2005 . J. Newsome and D. Song. Dynamic Taint Analysis for Automatic Detection, Analysis, and Signature Generation of Exploits on Commodity Software. In Proceedings of the 12th Symposium on Network and Distributed System Security (NDSS), February 2005."},{"key":"e_1_3_2_1_32_1","doi-asserted-by":"publisher","DOI":"10.1145\/1177080.1177119"},{"key":"e_1_3_2_1_33_1","doi-asserted-by":"publisher","DOI":"10.1016\/S1389-1286(99)00112-7"},{"key":"e_1_3_2_1_34_1","unstructured":"J. Postel and J. Reynolds. Rfc 959: File transfer protocol (ftp). http:\/\/www.faqs.org\/rfcs\/rfc959.html.   J. Postel and J. Reynolds. Rfc 959: File transfer protocol (ftp). http:\/\/www.faqs.org\/rfcs\/rfc959.html."},{"key":"e_1_3_2_1_35_1","unstructured":"The Protocol Informatics Project. http:\/\/www.baselineresearch.net\/PI\/.  The Protocol Informatics Project. http:\/\/www.baselineresearch.net\/PI\/."},{"key":"e_1_3_2_1_36_1","unstructured":"How Samba Was Written. http:\/\/samba.org\/ftp\/tridge\/misc\/french_cafe.txt.  How Samba Was Written. http:\/\/samba.org\/ftp\/tridge\/misc\/french_cafe.txt."},{"key":"e_1_3_2_1_37_1","unstructured":"K. Sollins. Rfc 1350: The tftp protocol (revision 2). http:\/\/www.faqs.org\/rfcs\/rfc1350.html.   K. Sollins. Rfc 1350: The tftp protocol (revision 2). http:\/\/www.faqs.org\/rfcs\/rfc1350.html."},{"key":"e_1_3_2_1_38_1","doi-asserted-by":"publisher","DOI":"10.1145\/1024393.1024404"},{"key":"e_1_3_2_1_39_1","doi-asserted-by":"publisher","DOI":"10.5555\/529343"},{"key":"e_1_3_2_1_40_1","volume-title":"RFC 2083: PNG (Portable Network Graphics) Specification. http:\/\/www.faqs.org\/rfcs\/rfc2083","author":"Boutell T.","unstructured":"T. Boutell , et. al. RFC 2083: PNG (Portable Network Graphics) Specification. http:\/\/www.faqs.org\/rfcs\/rfc2083 .html. T. Boutell, et. al. RFC 2083: PNG (Portable Network Graphics) Specification. http:\/\/www.faqs.org\/rfcs\/rfc2083.html."},{"key":"e_1_3_2_1_41_1","doi-asserted-by":"publisher","DOI":"10.1145\/1015467.1015489"},{"key":"e_1_3_2_1_42_1","volume-title":"Proceedings of the 15th Annual Network and Distributed System Security Symposium (NDSS)","author":"Wondracek G.","year":"2008","unstructured":"G. Wondracek , C. Kruegel , E. Kirda , and P. Milani . Automatic Network Protocol Analysis . In Proceedings of the 15th Annual Network and Distributed System Security Symposium (NDSS) , February 2008 . G. Wondracek, C. Kruegel, E. Kirda, and P. Milani. Automatic Network Protocol Analysis. In Proceedings of the 15th Annual Network and Distributed System Security Symposium (NDSS), February 2008."}],"event":{"name":"CCS08: 15th ACM Conference on Computer and Communications Security 2008","location":"Alexandria Virginia USA","acronym":"CCS08","sponsor":["SIGSAC ACM Special Interest Group on Security, Audit, and Control","ACM Association for Computing Machinery"]},"container-title":["Proceedings of the 15th ACM conference on Computer and communications security"],"original-title":[],"link":[{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1455770.1455820","content-type":"unspecified","content-version":"vor","intended-application":"text-mining"},{"URL":"https:\/\/dl.acm.org\/doi\/pdf\/10.1145\/1455770.1455820","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,6,18]],"date-time":"2025-06-18T22:54:14Z","timestamp":1750287254000},"score":1,"resource":{"primary":{"URL":"https:\/\/dl.acm.org\/doi\/10.1145\/1455770.1455820"}},"subtitle":["automatic reverse engineering of input formats"],"short-title":[],"issued":{"date-parts":[[2008,10,27]]},"references-count":42,"alternative-id":["10.1145\/1455770.1455820","10.1145\/1455770"],"URL":"https:\/\/doi.org\/10.1145\/1455770.1455820","relation":{},"subject":[],"published":{"date-parts":[[2008,10,27]]},"assertion":[{"value":"2008-10-27","order":2,"name":"published","label":"Published","group":{"name":"publication_history","label":"Publication History"}}]}}