{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,3,17]],"date-time":"2026-03-17T19:17:27Z","timestamp":1773775047612,"version":"3.50.1"},"reference-count":28,"publisher":"IEEE","license":[{"start":{"date-parts":[[2025,6,10]],"date-time":"2025-06-10T00:00:00Z","timestamp":1749513600000},"content-version":"stm-asf","delay-in-days":0,"URL":"https:\/\/doi.org\/10.15223\/policy-029"},{"start":{"date-parts":[[2025,6,10]],"date-time":"2025-06-10T00:00:00Z","timestamp":1749513600000},"content-version":"stm-asf","delay-in-days":0,"URL":"https:\/\/doi.org\/10.15223\/policy-037"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":[],"published-print":{"date-parts":[[2025,6,10]]},"DOI":"10.23919\/tma66427.2025.11097006","type":"proceedings-article","created":{"date-parts":[[2025,8,1]],"date-time":"2025-08-01T18:07:24Z","timestamp":1754071644000},"page":"1-4","source":"Crossref","is-referenced-by-count":1,"title":["Building Block for the Internet Digital Twin: Scalable and Automated Internetwork Emulator"],"prefix":"10.23919","author":[{"given":"Joshua","family":"Levett","sequence":"first","affiliation":[{"name":"University of York,Department of Computer Science"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Vassilios","family":"Vassilakis","sequence":"additional","affiliation":[{"name":"University of York,Department of Computer Science"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Poonam","family":"Yadav","sequence":"additional","affiliation":[{"name":"University of York,Department of Computer Science"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"263","reference":[{"key":"ref1","article-title":"Network Digital Twin: Concepts and Reference Architecture","author":"Zhou","year":"2024","journal-title":"Internet Engineering Task Force, Internet Draft draft-irtf-nmrg-network-digital-twin-arch-05"},{"key":"ref2","article-title":"A Border Gateway Protocol 4 (BGP-4)","author":"Rekhter","year":"1994","journal-title":"Internet Engineering Task Force, Request for Comments RFC 1654"},{"key":"ref3","doi-asserted-by":"publisher","DOI":"10.1109\/49.839934"},{"key":"ref4","article-title":"BGPsec Protocol Specification","author":"Lepinski","year":"2017","journal-title":"Internet Engineering Task Force, Request for Comments RFC 8205"},{"key":"ref5","doi-asserted-by":"publisher","DOI":"10.1109\/sp.2011.45"},{"key":"ref6","article-title":"The Resource Public Key Infrastructure (RPKI) to Router Protocol","author":"Bush","year":"2013","journal-title":"Internet Engineering Task Force, Request for Comments RFC 6810"},{"key":"ref7","doi-asserted-by":"publisher","DOI":"10.2139\/ssrn.4948317"},{"key":"ref8","volume-title":"Grave flaws in BGP error handling.","author":"Cartwright-Cox","year":"2023"},{"key":"ref9","volume-title":"How Verizon and a BGP optimizer knocked large parts of the Internet offline today","author":"Strickx","year":"2019"},{"key":"ref10","doi-asserted-by":"crossref","DOI":"10.1109\/ICNP49622.2020.9259355","article-title":"SCIONLab: A next-generation Internet testbed","volume-title":"Proceedings of the IEEE International Conference on Network Protocols (ICNP)","author":"Kwon","year":"2020"},{"key":"ref11","doi-asserted-by":"publisher","DOI":"10.1145\/3359989.3365414"},{"key":"ref12","doi-asserted-by":"publisher","DOI":"10.1145\/3575813.3595192"},{"key":"ref13","doi-asserted-by":"publisher","DOI":"10.1145\/2535372.2535378"},{"key":"ref14","first-page":"575","article-title":"xBGP: Faster innovation in routing protocols","volume-title":"20th USENIX Symposium on Networked Systems Design and Implementation (NSDI 23)","author":"Wirtgen"},{"key":"ref15","volume-title":"Software for Open Networking in the Cloud (SONiC)","author":"Foundation","year":"2023"},{"key":"ref16","doi-asserted-by":"publisher","DOI":"10.1145\/3132747.3132759"},{"key":"ref17","first-page":"1045","article-title":"Crescent: Emulating heterogeneous production network at scale","volume-title":"21st USENIX Symposium on Networked Systems Design and Implementation (NSDI 24)","author":"Gao"},{"key":"ref18","volume-title":"Unveiling internet censorship: Analysing the impact of nation states\u2018 content control efforts on internet architecture and routine patterns","author":"Levett","year":"2024"},{"key":"ref19","doi-asserted-by":"publisher","DOI":"10.1145\/3646547.3688444"},{"key":"ref20","doi-asserted-by":"publisher","DOI":"10.1145\/3517745.3561443"},{"key":"ref21","volume-title":"NetworkX","year":"2005"},{"key":"ref22","volume-title":"The CAIDA AS relationships dataset","year":"2025"},{"key":"ref23","volume-title":"The CAIDA UCSD PeeringDB dataset","year":"2025"},{"key":"ref24","volume-title":"Route Views prefix to AS mappings dataset for IPv4 and IPv6, jan 2025","year":"2025"},{"key":"ref25","article-title":"bgp.tools","year":"2018","journal-title":"Port 179 Ltd"},{"key":"ref26","doi-asserted-by":"publisher","DOI":"10.1109\/MNET.2014.6786612"},{"key":"ref27","volume-title":"Frrouting project.","author":"Foundation","year":"2017"},{"issue":"9","key":"ref28","doi-asserted-by":"crossref","DOI":"10.3390\/fi13090227","article-title":"Megalos: A scalable architecture for the virtualization of large network scenarios","volume":"13","author":"Scazzariello","year":"2021","journal-title":"Future Internet"}],"event":{"name":"2025 9th Network Traffic Measurement and Analysis Conference (TMA)","location":"Copenhagen, Denmark","start":{"date-parts":[[2025,6,10]]},"end":{"date-parts":[[2025,6,13]]}},"container-title":["2025 9th Network Traffic Measurement and Analysis Conference (TMA)"],"original-title":[],"link":[{"URL":"http:\/\/xplorestaging.ieee.org\/ielx8\/11096977\/11096962\/11097006.pdf?arnumber=11097006","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,8,2]],"date-time":"2025-08-02T04:22:45Z","timestamp":1754108565000},"score":1,"resource":{"primary":{"URL":"https:\/\/ieeexplore.ieee.org\/document\/11097006\/"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2025,6,10]]},"references-count":28,"URL":"https:\/\/doi.org\/10.23919\/tma66427.2025.11097006","relation":{},"subject":[],"published":{"date-parts":[[2025,6,10]]}}}