{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2025,10,12]],"date-time":"2025-10-12T04:08:15Z","timestamp":1760242095828,"version":"build-2065373602"},"reference-count":20,"publisher":"MDPI AG","issue":"12","license":[{"start":{"date-parts":[[2018,12,2]],"date-time":"2018-12-02T00:00:00Z","timestamp":1543708800000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0\/"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":["Sensors"],"abstract":"<jats:p>Nowadays, due to the widespread usage of mobile devices and wireless network technologies, we can use various ICT services almost anytime, anywhere even if we are changing our location at that moment. Therefore, mobility management technology have been attracting attention. This technology is to keep communication alive even when a mobile node (MN), which is communicating with the server or some nodes, moves to another network domain. Software Defined Networking (SDN) is used for mobility management to realize effective intra-domain routing that optimizes routes when an MN moves inside an SDN domain. However, many of the approaches mainly focus on intra-domain routing and it is difficult to optimize inter-domain route. In this paper, we focus on this routing optimization problem and propose an SDN based end-to-end routing mechanism specified for mobility management. The proposed routing mechanism can optimize an end-to-end route based on various parameters such as bandwidth, number of domains, and flow operations for mobility after an MN has moved across SDN domains. We carried out some simulational experimentations to evaluate the effect of proposal. It is shown that the proposed routing mechanism can reduce communication delay and enhance network performance. Thus, the proposed routing mechanism can realize effective ICT services.<\/jats:p>","DOI":"10.3390\/s18124228","type":"journal-article","created":{"date-parts":[[2018,12,3]],"date-time":"2018-12-03T06:02:09Z","timestamp":1543816929000},"page":"4228","update-policy":"https:\/\/doi.org\/10.3390\/mdpi_crossmark_policy","source":"Crossref","is-referenced-by-count":7,"title":["SDN Based End-to-End Inter-Domain Routing Mechanism for Mobility Management and Its Evaluation"],"prefix":"10.3390","volume":"18","author":[{"given":"Misumi","family":"Hata","sequence":"first","affiliation":[{"name":"Graduate School of Information Sciences, Tohoku University, Miyagi 980-8577, Japan"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"given":"Mustafa","family":"Soylu","sequence":"additional","affiliation":[{"name":"Electronics and Communication Engineering, Istanbul Technical University, 34467 Sar\u0131yer, Turkey"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"ORCID":"https:\/\/orcid.org\/0000-0001-9634-4227","authenticated-orcid":false,"given":"Satoru","family":"Izumi","sequence":"additional","affiliation":[{"name":"Graduate School of Information Sciences, Tohoku University, Miyagi 980-8577, Japan"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-3786-0122","authenticated-orcid":false,"given":"Toru","family":"Abe","sequence":"additional","affiliation":[{"name":"Graduate School of Information Sciences, Tohoku University, Miyagi 980-8577, Japan"},{"name":"Cyberscience Center, Tohoku University, Miyagi 980-8577, Japan"}],"role":[{"role":"author","vocabulary":"crossref"}]},{"ORCID":"https:\/\/orcid.org\/0000-0002-5798-5125","authenticated-orcid":false,"given":"Takuo","family":"Suganuma","sequence":"additional","affiliation":[{"name":"Graduate School of Information Sciences, Tohoku University, Miyagi 980-8577, Japan"},{"name":"Cyberscience Center, Tohoku University, Miyagi 980-8577, Japan"}],"role":[{"role":"author","vocabulary":"crossref"}]}],"member":"1968","published-online":{"date-parts":[[2018,12,2]]},"reference":[{"doi-asserted-by":"crossref","unstructured":"Giusto, D., Iera, A., Morabito, G., and Atzori, L. (2010). The Internet of Things, Springer.","key":"ref_1","DOI":"10.1007\/978-1-4419-1674-7"},{"key":"ref_2","doi-asserted-by":"crossref","first-page":"1645","DOI":"10.1016\/j.future.2013.01.010","article-title":"Internet of things (IoT): A vision, architectural elements, and future directions","volume":"29","author":"Gubbi","year":"2013","journal-title":"Future Gener. Comput. Syst."},{"unstructured":"(2018, October 12). IEEE P802.11\u2014TASK GROUP AI\u2014MEETING UPDATE. Available online: http:\/\/www.ieee802.org\/11\/Reports\/tgai_update.htm.","key":"ref_3"},{"unstructured":"Perkins, C.E. (2018, October 12). RFC 5944\u2014IP Mobility Support for IPv4. Available online: https:\/\/tools.ietf.org\/html\/rfc5944.","key":"ref_4"},{"unstructured":"Perkins, C.E., Johnson, D.B., and Arkko, J. (2018, October 12). RFC 6275\u2014Mobility Support for IPv6. Available online: https:\/\/tools.ietf.org\/html\/rfc6275.","key":"ref_5"},{"unstructured":"Gundavelli, S., Leung, K., Devarapalli, V., Chowdhury, K., and Patil, B. (2018, October 12). RFC 5213\u2014Proxy Mobile IPv6. Available online: https:\/\/tools.ietf.org\/html\/rfc5213.","key":"ref_6"},{"doi-asserted-by":"crossref","unstructured":"Wang, Y., and Bi, J. (2014, January 4\u20137). A solution for IP mobility support in software defined networks. Proceedings of the 23rd International Conference on Computer Communication and Networks, Shanghai, China.","key":"ref_7","DOI":"10.1109\/ICCCN.2014.6911783"},{"key":"ref_8","doi-asserted-by":"crossref","first-page":"40","DOI":"10.1007\/s11036-015-0579-2","article-title":"Design and implementation of a software-defined mobility architecture for IP networks","volume":"20","author":"Wang","year":"2015","journal-title":"Mob. Netw. Appl."},{"key":"ref_9","doi-asserted-by":"crossref","first-page":"922","DOI":"10.25046\/aj0203116","article-title":"A Design of SDN Based IP Mobility Management Considering Inter-Domain Handovers and Its Evaluation","volume":"2","author":"Hata","year":"2017","journal-title":"Adv. Sci. Technol. Eng. Syst. J."},{"key":"ref_10","first-page":"71","article-title":"SDN Based End-to-end Inter-domain Routing Mechanism for Mobility Management and Its Implementation","volume":"117","author":"Hata","year":"2017","journal-title":"IEICE Tech. Rep."},{"doi-asserted-by":"crossref","unstructured":"Idri, M. (2017, January 8\u201311). Mobility management based SDN-IPv6 Routing Header. Proceedings of the 4th International Conference on Software Defined Systems (SDS2017), Valencia, Spain.","key":"ref_11","DOI":"10.1109\/SDS.2017.7939156"},{"doi-asserted-by":"crossref","unstructured":"Shrivastava, P., and Kataoka, K. (2016, January 7\u20139). FastSplit: Fast and Dynamic IP Mobility Management in SDN. Proceedings of the 26th International Telecommunication Networks and Applications Conference (ITNAC2016), Dunedin, New Zealand.","key":"ref_12","DOI":"10.1109\/ATNAC.2016.7878803"},{"key":"ref_13","doi-asserted-by":"crossref","first-page":"421","DOI":"10.1109\/TNSM.2016.2580590","article-title":"Optimization of SDN Flow Operations in Multi-Failure Restoration Scenarios","volume":"13","author":"Astaneh","year":"2016","journal-title":"IEEE Trans. Netw. Serv. Manag."},{"unstructured":"Duan, Q. (2014, January 9\u201310). Network-as-a-Service in Software-Defined Networks for End-to-End QoS Provisioning. Proceedings of the 23rd IEEE Wireless and Optical Communication Conference (WOCC 2014), Newark, NJ, USA.","key":"ref_14"},{"doi-asserted-by":"crossref","unstructured":"Phemius, K., Bouet, M., and Leguay, J. (2014, January 5\u20139). DISCO: Distributed Muti-Domain SDN Controller. Proceedings of the 2014 IEEE Network Operation and Management Symposium (NOMS2014), Krakow, Poland.","key":"ref_15","DOI":"10.1109\/NOMS.2014.6838330"},{"doi-asserted-by":"crossref","unstructured":"Figueira, N., and Krishnan, R.R. (2015, January 16\u201319). SDN Multi-Domain Orchestration and Control: Challenges and Innovative Future Directions. Proceedings of the 2015 International Conference on Computing, Networking, and Communications (ICNC2015), Garden Grove, CA, USA.","key":"ref_16","DOI":"10.1109\/ICCNC.2015.7069378"},{"unstructured":"(2018, October 12). The OpenDaylight Platform. Available online: https:\/\/www.opendaylight.org\/.","key":"ref_17"},{"unstructured":"(2018, October 12). Open vSwitch. Available online: http:\/\/openvswitch.org\/.","key":"ref_18"},{"key":"ref_19","doi-asserted-by":"crossref","first-page":"69","DOI":"10.1145\/1355734.1355746","article-title":"OpenFlow: Enabling Innovation in Campus Networks","volume":"38","author":"McKeown","year":"2008","journal-title":"SIGCOMM Comput. Commun. Rev."},{"key":"ref_20","doi-asserted-by":"crossref","first-page":"663","DOI":"10.1109\/TNET.2003.815294","article-title":"Maximizable routing metrics","volume":"11","author":"Gouda","year":"2003","journal-title":"IEEE\/ACM Trans. Netw."}],"container-title":["Sensors"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/www.mdpi.com\/1424-8220\/18\/12\/4228\/pdf","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,10,11]],"date-time":"2025-10-11T15:33:59Z","timestamp":1760196839000},"score":1,"resource":{"primary":{"URL":"https:\/\/www.mdpi.com\/1424-8220\/18\/12\/4228"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2018,12,2]]},"references-count":20,"journal-issue":{"issue":"12","published-online":{"date-parts":[[2018,12]]}},"alternative-id":["s18124228"],"URL":"https:\/\/doi.org\/10.3390\/s18124228","relation":{},"ISSN":["1424-8220"],"issn-type":[{"type":"electronic","value":"1424-8220"}],"subject":[],"published":{"date-parts":[[2018,12,2]]}}}