{"status":"ok","message-type":"work","message-version":"1.0.0","message":{"indexed":{"date-parts":[[2026,8,18]],"date-time":"2026-08-18T05:08:33Z","timestamp":1787029713752,"version":"build-2736575974"},"reference-count":29,"publisher":"MDPI AG","issue":"4","license":[{"start":{"date-parts":[[2025,2,13]],"date-time":"2025-02-13T00:00:00Z","timestamp":1739404800000},"content-version":"vor","delay-in-days":0,"URL":"https:\/\/creativecommons.org\/licenses\/by\/4.0\/"}],"content-domain":{"domain":[],"crossmark-restriction":false},"short-container-title":["Sensors"],"abstract":"<jats:p>The integrated heterogeneous 7G\/8G networks may face multiple challenges for reliable data delivery such as link disruption, intermittent link availability, long latency and a highly lossy channel. Delay tolerant networking (DTN) was proposed as a highly reliable networking technology for space networks that will be part of future 7G\/8G networks. In this paper, an experimental evaluation of transmission control protocol (TCP)-based DTN (i.e., running TCP at the transport layer of DTN) for space-vehicle communications in the cislunar domain is presented. The impact of link disruption is also considered. The evaluation was conducted using the DTN protocol suites over a realistic experimental testbed. The study results show that TCP-based DTN works effectively for space-vehicle communications in cislunar domain in the presence of a link disruption event. However, a roughly exponential goodput decrease is observed with a linear increase in link delay from 1250 ms to 5 s.<\/jats:p>","DOI":"10.3390\/s25041136","type":"journal-article","created":{"date-parts":[[2025,2,13]],"date-time":"2025-02-13T04:03:35Z","timestamp":1739419415000},"page":"1136","update-policy":"https:\/\/doi.org\/10.3390\/mdpi_crossmark_policy","source":"Crossref","is-referenced-by-count":1,"title":["Transmission Control Protocol (TCP)-Based Delay Tolerant Networking for Space-Vehicle Communications in Cislunar Domain: An Experimental Approach"],"prefix":"10.3390","volume":"25","author":[{"given":"Ding","family":"Wang","sequence":"first","affiliation":[{"name":"School of Mathematics and Computer Science, Northwest Minzu University, Lanzhou 730030, China"}],"role":[{"vocabulary":"crossref","role":"author"}]},{"given":"Ruhai","family":"Wang","sequence":"additional","affiliation":[{"name":"Phillip M. Drayer Department of Electrical and Computer Engineering, Lamar University, Beaumont, TX 77710, USA"}],"role":[{"vocabulary":"crossref","role":"author"}]}],"member":"1968","published-online":{"date-parts":[[2025,2,13]]},"reference":[{"key":"ref_1","doi-asserted-by":"crossref","first-page":"1200","DOI":"10.1109\/TAES.2005.1561883","article-title":"Performance analysis of data transfer protocols over space communications","volume":"41","author":"Marchese","year":"2005","journal-title":"IEEE Trans. Aerosp. Electron. Syst."},{"key":"ref_2","doi-asserted-by":"crossref","first-page":"128","DOI":"10.1109\/MCOM.2003.1204759","article-title":"Delay-tolerant networking: An approach to inter-planetary Internet","volume":"41","author":"Burleigh","year":"2003","journal-title":"IEEE Commun. Mag."},{"key":"ref_3","unstructured":"Scott, K., and Burleigh, S. (2023, August 08). Bundle Protocol Specification, IETF Request for Comments RFC 5050, November 2007. Available online: https:\/\/www.ietf.org\/rfc\/rfc5050.txt."},{"key":"ref_4","doi-asserted-by":"crossref","unstructured":"Postel, J. (1981). Transmission Control Protocol\u2015Darpa Internet Program\u2015Protocol Specification, IETF. IETF Request for Comments RFC 793.","DOI":"10.17487\/rfc0793"},{"key":"ref_5","doi-asserted-by":"crossref","unstructured":"Postel, J. (1980). User Datagram Protocol, IETF. IETF Request for Comments RFC 768.","DOI":"10.17487\/rfc0768"},{"key":"ref_6","doi-asserted-by":"crossref","first-page":"38521","DOI":"10.1109\/JIOT.2024.3448538","article-title":"Semantic-Aware Spectrum Sharing in Internet of Vehicles Based on Deep Reinforcement Learning","volume":"11","author":"Shao","year":"2024","journal-title":"IEEE Internet Things J."},{"key":"ref_7","doi-asserted-by":"crossref","first-page":"1927","DOI":"10.1109\/JSYST.2024.3459926","article-title":"Vehicle Selection for C-V2X Mode 4 Based Federated Edge Learning Systems","volume":"18","author":"Wang","year":"2024","journal-title":"IEEE Syst. J."},{"key":"ref_8","doi-asserted-by":"crossref","unstructured":"Zhang, C., Zhang, W., Wu, Q., Fan, P., Fan, Q., Wang, J., and Letaief, K.B. (2024). Distributed Deep Reinforcement Learning Based Gradient Quantization for Federated Learning Enabled Vehicle Edge Computing. IEEE Internet Things J., 3447036.","DOI":"10.1109\/JIOT.2024.3447036"},{"key":"ref_9","doi-asserted-by":"crossref","first-page":"4179","DOI":"10.1109\/TNSM.2024.3403842","article-title":"Cooperative Edge Caching Based on Elastic Federated and Multi-Agent Deep Reinforcement Learning in Next-Generation Networks","volume":"21","author":"Wu","year":"2024","journal-title":"IEEE Trans. Netw. Serv. Manag."},{"key":"ref_10","unstructured":"Consultative Committee for Space Data Systems (2015). Bundle Protocol Specifications, CCSDS. CCSDS 734.2- B-1, Blue Book, Issue 1."},{"key":"ref_11","unstructured":"The Space Internetworking Strategy Group (SISG) (2024, June 10). Recommendations on a Strategy for Space Internetworking, Available online: https:\/\/cwe.ccsds.org\/sis\/docs\/SIS%20Area\/SOLAR%20SYSTEM%20INTERNET\/SISG%20Phase%20I%20report%20%E2%80%93%20final.pdf."},{"key":"ref_12","unstructured":"Demmer, M., and Ott, J. (2022, June 15). Delay Tolerant Networking TCP Convergence Layer Protocol. IETF DTNRG IRTF Research Group, draft-irtf-dtnrg-tcp-clayer-02.txt (Work in Progress), November 2008. Available online: https:\/\/www.ietf.org\/archive\/id\/draft-irtf-dtnrg-tcp-clayer-02.txt."},{"key":"ref_13","unstructured":"(2024, April 12). DTN Reference Implementation, October 2013 Release. Available online: https:\/\/github.com\/delay-tolerant-networking\/DTN2."},{"key":"ref_14","doi-asserted-by":"crossref","unstructured":"Ramadas, M., Burleigh, S., and Farrell, S. (2023, July 18). Licklider Transmission Protocol\u2015Specification. IETF Request for Comments RFC 5326, September 2008. Available online: https:\/\/www.ietf.org\/rfc\/rfc5326.txt?number=5326.","DOI":"10.17487\/rfc5326"},{"key":"ref_15","unstructured":"Kruse, H., and Ostermann, S. (2023, March 09). UDP Convergence Layers for the DTN Bundle and LTP Protocols. IETF DTNRG IRTF Research Group, draft-irtf-dtnrg-udp-clayer-00.txt (Work in Progress), November 2008. Available online: https:\/\/datatracker.ietf.org\/doc\/draft-irtf-dtnrg-udp-clayer."},{"key":"ref_16","doi-asserted-by":"crossref","first-page":"359","DOI":"10.1109\/TNET.2010.2060733","article-title":"Licklider Transmission Protocol (LTP)-based DTN for cislunar communications","volume":"19","author":"Wang","year":"2011","journal-title":"IEEE\/ACM Trans. Netw."},{"key":"ref_17","doi-asserted-by":"crossref","first-page":"518","DOI":"10.1109\/TCOMM.2018.2875717","article-title":"Analysis of the block delivery time of the Licklider transmission protocol","volume":"67","author":"Lent","year":"2019","journal-title":"IEEE Trans. Commun."},{"key":"ref_18","doi-asserted-by":"crossref","first-page":"2478","DOI":"10.1109\/TWC.2017.2665539","article-title":"Bundle Protocol over Highly Asymmetric Deep-Space Channels","volume":"16","author":"Sabbagh","year":"2017","journal-title":"IEEE Trans. Wirel. Commun."},{"key":"ref_19","doi-asserted-by":"crossref","first-page":"1897","DOI":"10.1109\/TAES.2013.6558026","article-title":"Delivery Time Estimation for Space Bundles","volume":"49","author":"Bezirgiannidis","year":"2013","journal-title":"IEEE Trans. Aerosp. Electron. Syst."},{"key":"ref_20","doi-asserted-by":"crossref","first-page":"2493","DOI":"10.1109\/TAES.2018.2820398","article-title":"Modeling Optimal Retransmission Timeout Interval for Bundle Protocol","volume":"54","author":"Yang","year":"2018","journal-title":"IEEE Trans. Aerosp. Electron. Syst."},{"key":"ref_21","doi-asserted-by":"crossref","first-page":"1086","DOI":"10.1109\/JSAC.2018.2832832","article-title":"Analytical Framework for Effect of Link Disruption on Bundle Protocol in Deep-Space Communications","volume":"36","author":"Sabbagh","year":"2018","journal-title":"IEEE J. Sel. Areas Commun. Spec. Issue Adv. Satell. Commun."},{"key":"ref_22","first-page":"3824","article-title":"A Study of Transmission Overhead of a Hybrid Bundle Retransmission Approach for Deep-Space Communications","volume":"58","author":"Zhou","year":"2022","journal-title":"IEEE Trans. Aerosp. Electron. Syst. Spec. Sect. Inf. Commun. Technol. (ICT) A New Space Vis."},{"key":"ref_23","first-page":"1344","article-title":"A Study of DTN for Reliable Data Delivery from Space Station to Ground Station","volume":"42","author":"Wang","year":"2024","journal-title":"IEEE J. Sel. Areas Commun. Spec. Issue Space Commun. New Front. Near Earth Deep Space"},{"key":"ref_24","unstructured":"Consultative Committee for Space Data Systems (2006). Cislunar Space Internetworking\u2015Architecture, Draft Informational Report, CCSDS 730.1-G-0, Draft Green Book."},{"key":"ref_25","unstructured":"Simpson, W. (2022, December 06). The Point-to-Point Protocol. IETF Request for Comments RFC 1661, July 1994. Available online: https:\/\/www.ietf.org\/rfc\/rfc1661.txt."},{"key":"ref_26","doi-asserted-by":"crossref","first-page":"2531","DOI":"10.1109\/18.720548","article-title":"Applications of Error-Control Coding","volume":"44","author":"Costello","year":"1998","journal-title":"IEEE Trans. Inf. Theory"},{"key":"ref_27","unstructured":"National Aeronautics and Space Administration (2012). Space Network Users\u2019 Guide (SNUG), Rev. 10."},{"key":"ref_28","unstructured":"(2023, February 07). TCP Connection Analysis Tool: TCPTRACE. Available online: https:\/\/www.tcptrace.org\/manual\/index.html."},{"key":"ref_29","unstructured":"Shepard, T. (1991). TCP Packet Trace Analysis. MIT-LCS-TR-494, MIT Laboratory for Computer Science, Massachusetts Institute of Technology. Available online: http:\/\/www.xplot.org."}],"container-title":["Sensors"],"original-title":[],"language":"en","link":[{"URL":"https:\/\/www.mdpi.com\/1424-8220\/25\/4\/1136\/pdf","content-type":"unspecified","content-version":"vor","intended-application":"similarity-checking"}],"deposited":{"date-parts":[[2025,10,9]],"date-time":"2025-10-09T16:32:42Z","timestamp":1760027562000},"score":1,"resource":{"primary":{"URL":"https:\/\/www.mdpi.com\/1424-8220\/25\/4\/1136"}},"subtitle":[],"short-title":[],"issued":{"date-parts":[[2025,2,13]]},"references-count":29,"journal-issue":{"issue":"4","published-online":{"date-parts":[[2025,2]]}},"alternative-id":["s25041136"],"URL":"https:\/\/doi.org\/10.3390\/s25041136","relation":{},"ISSN":["1424-8220"],"issn-type":[{"value":"1424-8220","type":"electronic"}],"subject":[],"published":{"date-parts":[[2025,2,13]]}}}